Sommaire

BONJOUR
Musique "Invention BWV784" J.S. BACH 1685-1750

Tutoriel et Help

Style & CSS


Accueil

Accueil CHM


Accueil

La page vide

Normal, dit comme ça,
vous ne risquez pas de comprendre.


Accueil

La page vide

J2M
J2M

JAVASCRIPT


Bienvenue

Bienvenue dans ce cours d'électronique !

    Vous allez trouver sur ce site un cours relatif aux bases de l'électronique analogique, découpé en 7 chapitres, accessibles chacun par un bouton :

Les outils de l'électronique (rappels d'électricité utiles en électronique)

Matière et conduction (notions de physique du solide)

La diode à jonction

Le transistor bipolaire

Le transistor à effet de champ

L'amplificateur opérationnel

Puissance et dissipation (mesures de puissances et calculs de radiateurs)

Un huitième bouton permet le retour à la case départ :
Retour sur ces pages d'aide.

    Un clic sur le bouton de chapitre (en haut à gauche) fait apparaître le sommaire dans le cadre situé en dessous : il ne reste plus qu'à cliquer dans le paragraphe désiré pour que son contenu s'affiche dans le cadre de droite (le temps de chargement peut être un peu long, le chapitre se charge en un seul bloc).

    Ce cours est celui que j'enseigne à l'IUT de Toulouse aux étudiants de première année en mesures physiques (cours du soir) : il est donc assez dépouillé. Il permet néanmoins de partir avec de bons rudiments si on veut connaître l'indispensable sur les composants de base.

    Contrairement à ce qu'on trouve dans beaucoup (trop ?) de livres, l'aspect mathématique a été volontairement négligé au profit d'une démarche inductive (comprendre comment assembler et calculer des éléments pour obtenir un résultat donné) et pratique.

    Si vous maîtrisez les bases de l'électronique, ce cours ne vous apportera pas grand chose. (Vous avez quand même le droit de le consulter et de donner votre avis !)


OUTILS.HTM

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/OUTILS/COURS.HTM#O02

LES DIPÔLES.

  1. DÉFINITIONS. CLASSIFICATION.

    2. Un dipôle est un système accessible par deux bornes dans lequel peut circuler un courant électrique.

    Pour qu'un courant puisse circuler dans un dipôle, il faut brancher celui-ci sur un autre dipôle.

    La classification actif / passif est difficile à faire, car quelle que soit la définition utilisée, on trouve toujours un contre exemple ! Par exemple, un critère énergétique (les actifs peuvent fournir de l'énergie, contrairement aux passifs) élimine les semi-conducteurs de la catégorie des actifs

    Les définitions proposées ne sont donc pas à prendre comme argent comptant. Elles donnent une tendance qui sera entachée d'exceptions !

    Nous allons étudier ici des dipôles de base . Dans la pratique, on trouvera ces dipôles tels quels, mais on pourra aussi en construire d'autres en associant en série et en parallèle ces dipôles de base. Pour que l'élément ainsi créé soit un dipôle, il doit répondre à la définition donnée ci-dessus.

    1. Dipôle passif.

      2. Si on branche ensemble deux dipôles identiques et qu'aucun courant permanent ne passe entre les deux dipôles quel que soit le sens du branchement, ces dipôles sont passifs. Ex : résistances, thermistances, selfs, condensateurs

      Il va circuler du courant dans un dipôle passif si on applique une différence de potentiel entre ses bornes.

      Réciproquement, si on fait circuler un courant dans ce dipôle, il va apparaître une tension à ses bornes.

    2. Dipôle actif.

      3. Si on branche un dipôle sur une résistance et qu'un courant permanent circule, alors ce dipôle est actif. ex : pile, accumulateur, alternateur

      Bien qu'ils ne répondent pas intrinsèquement à la définition ci-dessus, on classera également dans cette catégorie les semi-conducteurs et circuits intégrés ayant des caractéristiques de générateurs : diodes, zéners, transistors

      • Source de tension parfaite.

        • La représentation est la suivante :

        Fig. 1. Sources de tension parfaites.

        Une source de tension est un dipôle actif ; elle peut être continue ou alternative. Dans tous les cas, un dipôle est une source de tension s'il maintient la même tension entre ses bornes, et ce quel que soit le courant qu'il débite ou qu'il absorbe ; c'est une source de tension continue si cette tension est fixe dans le temps, et une source de tension alternative si la tension varie dans le temps de façon périodique.

      • Source de courant parfaite.

        • La définition est la même que pour la source de tension, sauf que la source de courant débite le même courant quel que soit la tension présente à ses bornes.

        Fig. 2. Sources de courant parfaites

      • Sources réelles.

        • Une source de tension réelle aura en réalité une impédance série non nulle, et une source de courant réelle une impédance parallèle non nulle. Les schémas deviennent :

        Fig. 3. Sources de tension et courant réelles.

    3. Dipôle linéaire.

      4. Un dipôle est linéaire si la relation entre la tension à ses bornes et le courant qui y circule est linéaire. Ex : résistance.

  2. CONVENTIONS DE SIGNE.

    3. Les conventions de signe communément admises pour représenter la tension aux bornes d'un dipôle et le courant y circulant font la différence entre générateurs et récepteurs.

    Il faut noter ici que le sens du courant ainsi défini est totalement arbitraire dans l'absolu , et ne représente qu'une convention. En pratique, physiquement, c'est la circulation des électrons qui forme le courant, et celle-ci se fait dans le sens opposé au sens de circulation conventionnel du courant !

    Lorsqu'on calcule les éléments d'un circuit électrique, on peut se fixer une convention différente , mais il faut garder la même pour tout le circuit électrique étudié.

    • Convention générateur.

      • Fig. 4. Dipôle générateur.

      Un dipôle est générateur lorsqu'il fournit de l'énergie (même de manière très temporaire) au circuit sur lequel il est connecté.

      Dans ce cas, le courant sort par le pôle positif du dipôle générateur. Les flèches représentant tension et courant sont dans le même sens.

    • Convention récepteur.

      • Un dipôle est un récepteur quand il consomme de l'énergie (fournie par le circuit sur lequel il est connecté).

      Dans ce cas, courant et tension sont orientés en sens inverse. Le pôle positif du dipôle est celui par lequel rentre le courant.

      Fig. 5. Dipôle récepteur

    • Attention à la méprise !

      • Actif n'est pas synonyme de générateur, pas plus que passif n'est synonyme de récepteur, même si c'est le cas le plus fréquent. Il y a de nombreuses exceptions.

      Certains dipôles passifs (dits réactifs : selfs, condensateurs) peuvent avoir temporairement un comportement de générateur et suivront cette convention de signe, alors que des dipôles actifs sont parfois utilisés comme récepteurs : on utilisera alors cette convention.

      Si dans un schéma, le calcul du courant circulant dans un dipôle actif et de la tension présente à ses bornes indiquent que le courant rentre par le pôle positif , alors ce dipôle est utilisé en récepteur.

      Exemple de composant passif utilisé comme générateur : le condensateur réservoir, très utilisé en électronique (filtrage des alimentations, découplage ).

      Exemple de composant actif utilisé comme récepteur : batterie en phase de charge.

  3. ASSOCIATION DE DIPÔLES.

    4. Quand on connecte deux dipôles ensemble, ils présentent la même tension à leurs bornes (!), et le courant entrant dans l'un est égal au courant sortant de l'autre (dans une boucle fermée sans connections avec l'extérieur, le courant circule dans un seul sens !)

    1. Association passif / actif.

      2. Fig. 6. Association passif/actif

      Ce cas justifie la différence de conventions entre générateur et récepteur : la tension aux bornes des deux dipôles étant la même, il y en aura forcément un avec le courant dans le même sens que la tension et l'autre avec le courant en sens inverse ! L'un délivre de l'énergie que l'autre absorbe.

    2. Association actif / actif.

      3. Dans le cas où l'on branche deux dipôles actifs ensemble, on ne peut pas toujours dire à priori si un des deux sera récepteur, et si oui, lequel. Dans ce cas, on fixe arbitrairement le sens du courant dans la boucle. Après le calcul, si le courant est positif, l'hypothèse était justifiée, sinon, le sens du courant réel est l'inverse de celui qui a été fixé.

      Fig. 7. Association actif/actif

      Le courant ainsi orienté sortira par le pôle positif du dipôle générateur. L'autre dipôle actif est utilisé en récepteur (courant entrant par le pôle positif).

  4. CARACTÉRISTIQUE STATIQUE D'UN DIPÔLE.

    1. Définition.

      2. La caractéristique statique permet de décrire tous les points de fonctionnement possibles en continu du dipôle : quand on applique une tension à ses bornes, le courant est défini, et vice versa. La représentation de la caractéristique est une courbe dans le plan (I, U).

    2. Quadrants.

      3. Le domaine (I, U) est partagé par les axes en quatre quadrants :

      Fig. 8. Les 4 quadrants d'une caractéristique.

      Par habitude ou pour simplifier, on ne représente souvent que le premier quadrant (I>0, U>0). En fait, la plupart des dipôles ont une caractéristique qui occupe au moins deux quadrants.

      Les conventions I>0 et U>0 indiquent que les sens des courants sont conformes aux normes générateur ou récepteur selon le dipôle.

      Pour certains dipôles, on est amenés à préciser la caractéristique complète : par exemple, certaines alimentations stabilisées réglables de laboratoire ont un domaine de fonctionnement spécifié dans un, deux ou quatre quadrants (on a des caractéristiques différentes en fonction du réglage) ; leur comportement en sera différent.

    3. Dipôle passif.

      • Résistance.

        • Fig. 9. Caractéristique de résistance.

        La relation I =f(U) est linéaire (loi d'Ohm). La pente de la droite est égale à 1/R.

      • Dipôle passif non linéaire.

        • Fig. 10. Caractéristique non linéaire.

        La relation I =f(U) est quelconque. Ex : varistance, certains capteurs utilisés en instrumentation

    4. Dipôle actif utilisé comme récepteur.

      5. Les composants actifs utilisés comme récepteurs sont très employés dans l'électronique analogique : on leur accordera une importance particulière.

      Les raisonnements qui suivent sont faits avec des sources continues. Le raisonnement est strictement le même avec des sources alternatives.

      • Source de tension continue parfaite.

        • Fig. 11. Source de tension continue parfaite.

        Une source de tension parfaite impose une tension constante aux bornes du dipôle sur lequel elle est branchée, et ce quel que soit le courant qu'elle absorbe. La caractéristique est verticale.

      • Source de tension avec résistance série.

        • La tension augmente quand le courant imposé au dipôle augmente. C'est la chute de tension créée aux bornes de R par le courant qui est responsable de cette augmentation.

        La pente de la courbe est égale à l'inverse de la résistance interne du générateur, soit 1 / R.

        Fig. 12. Source de tension quelconque.

        Il convient de noter que dans ce cas, la caractéristique est contenue dans un seul quadrant : si on prolongeait la caractéristique dans le quadrant I<0, la source serait génératrice, et plus réceptrice comme on en a fait l'hypothèse ! C'est vrai pour tous les cas du paragraphe I.D.4.

      • Source de courant continu parfaite.

        • Fig. 13. Source de courant parfaite.

        Un générateur de courant parfait impose un courant constant dans le dipôle sur lequel il est branché, quelle que soit la tension présente à ses bornes. La caractéristique obtenue est horizontale.

      • Source de courant avec résistance parallèle.

        • Lorsque la tension aux bornes de la source de courant augmente, le courant qu'elle absorbe augmente, avec une pente égale à 1 / R. En effet, la résistance interne en parallèle avec la source de courant absorbe un courant proportionnel à U qui vient s'ajouter à Io.

        Fig. 14. Source de courant quelconque.

  5. DROITE DE CHARGE D'UN GÉNÉRATEUR.

    6. Un générateur (dans le sens générateur d'énergie) est susceptible de faire circuler un courant dans un dipôle passif. Il peut être intéressant de voir quelle tension ou quel courant il va délivrer dans un dipôle passif lorsque l'impédance de celui-ci varie.

    Nous prendrons le cas général des générateurs avec résistances internes.

    • Générateur de tension continue.

      • Si on fait varier la résistance de charge Rch de 0 à l'infini, le courant dans la charge va passer du courant de court-circuit (valeur maxi égale à : Icc = Eg/Rg pour une tension U = 0) à une valeur nulle correspondant à la tension à vide Eg du générateur. La courbe reliant ces deux points est une droite de pente -1/Rg , Rg étant la résistance interne du générateur : c'est la droite de charge du générateur.

      Fig. 15. Droite de charge d'un générateur de tension.

    • Générateur de courant continu.

      • Fig. 16. Droite de charge d'un générateur de courant.

      Si on fait varier la résistance de charge Rch de 0 à l'infini, la tension aux bornes du générateur de courant va passer de 0 (avec un courant de court-circuit égal à Ig) à une valeur maxi U = RgIg pour un courant débité nul. La pente de la droite de charge reliant ces deux points est égale à -1/Rg.

    • Remarque.

      • Si on compare les deux figures précédentes, on remarque une étrange similitude des droites de charges du générateur de tension et de celui de courant ! En fait, à partir du moment où un générateur présente une impédance série interne non nulle ou une impédance parallèle non infinie, la notion de générateur de courant ou de tension s'estompe. Il existe d'ailleurs une transformation mathématique qui permet de faire la conversion générateur de tension / générateur de courant. Toutefois, en fonction de la valeur de la pente de la droite de charge, on parlera plutôt de générateur de courant ou bien de générateur de tension.

      Par exemple, une batterie d'automobile présente une impédance série interne tellement faible qu'il serait ridicule de parler de générateur de courant, et à fortiori, de faire des calculs avec ce formalisme.

  6. POINT DE POLARISATION.

    7. Si on associe un dipôle récepteur avec un dipôle générateur, on aura une tension et un courant bien déterminés dans ces dipôles. Ce point doit appartenir à la fois à la caractéristique du dipôle récepteur et à la droite de charge du dipôle générateur. C'est le point P d'intersection des deux courbes (Voir Fig. 17.).

    Fig. 17. Point de polarisation d'une résistance.

    Ce point de fonctionnement en continu est appelé point de polarisation du dipôle récepteur.

  7. DIPÔLES NON LINÉAIRES.

    1. NÉCESSITÉ DE LINÉARISER.

      2. Pour calculer les tensions et courants de circuits électriques simples composés de générateurs et de résistances, on applique la loi d'Ohm et on obtient un système d'équations linéaires permettant de trouver la solution.

      Les composants à semi-conducteurs ont, quant à eux, des caractéristiques non linéaires. Or, dans un circuit complexe, on trouvera souvent les valeurs de courants et tensions en résolvant un système de plusieurs équations à plusieurs inconnues. La résolution de tels problèmes est très difficile quand on a affaire à des équations non linéaires.

      Pour pallier cet inconvénient, on va s'arranger pour utiliser les composants non linéaires sur une très petite portion de leur caractéristique, et on va assimiler cette portion à une droite (droite qui sera la tangente à la caractéristique au niveau de la portion utilisée).

      On va ainsi définir des paramètres dynamiques (ou différentiels ) du composant non linéaire, ces paramètres étant utilisables uniquement sur la portion de caractéristique étudiée ; on pourra utiliser ces paramètres classiquement, et leur appliquer la loi d'ohm et les théorèmes classiques de l'électricité. Le système d'équations sera alors linéaire, donc simple à résoudre avec des outils classiques.

    2. RÉSISTANCE DIFFÉRENTIELLE.

      3. Très souvent, en électronique, on doit polariser le montage, et ensuite, on applique un signal alternatif à l'entrée de ce montage pour qu'il y soit traité.

      Pour ce qui suit, et conformément à ce qui a été dit précédemment, on va faire l'hypothèse que le signal alternatif est de faible amplitude comparé aux tensions de polarisation : on parle de régime des petits signaux.

      Supposons qu'au départ, on polarise le dipôle Zch avec un générateur de tension continu (Eg, Rg). Le point de polarisation Po correspond au courant Io et à la tension Eo (e = 0).

      Si on rajoute au générateur de polarisation (Eg, Rg) un générateur alternatif e avec e << Eg, on déplace la droite de charge qui correspond alors au générateur équivalent (Eg+e, Rg). A un instant donné, le nouveau point de polarisation est alors P(Eo+ [image] E, Io+ [image] I).

      Si [image] E est suffisamment petit, on peut considérer que P se déplace sur la tangente de la caractéristique en Po.

      A une petite variation [image] E de Eo va correspondre une petite variation [image] I de Io.

      Fig. 18. Résistance dynamique.

      Par définition, on pose :

      ro est la résistance dynamique (ou différentielle ) du dipôle au point de polarisation Po (Eo, Io). Ceci revient à assimiler localement la caractéristique à sa tangente.

      Pour des petites variations autour d'un point de polarisation donné, on linéarise le dipôle, et grâce à la notion de résistance dynamique, on a une loi d'Ohm simple. Ceci va permettre de simplifier grandement les calculs.

      ATTENTION : la résistance dynamique est une caractéristique du point de polarisation considéré. Si on modifie la polarisation, la résistance dynamique va varier. Cette notion n'a de sens que pour des petits signaux alternatifs (e << Eg).

      Ces notions de petits signaux et de paramètres différentiels sont absolument incontournables pour étudier un montage amplificateur en électronique.

  • LES QUADRIPÔLES.

    • Nous n'allons pas entrer ici dans les détails de cette théorie, mais juste indiquer ce qui nous sera utile pour l'étude des transistors.

    1. DÉFINITION.

      2. Un quadripôle est une boite noire à quatre bornes dans laquelle des courants électriques peuvent circuler ; cette boite comporte deux bornes d'entrée et deux bornes de sortie :

      Fig. 19. Représentation d'un quadripôle.

      La condition pour que cette boite noire soit un quadripôle est que le courant entrant par une des bornes d'entrée (resp. de sortie) soit égal au courant sortant par l'autre borne d'entrée (resp. de sortie).

      Quatre paramètres électriques caractérisent alors le quadripôle : tension et courant d'entrée ve et ie, et tension et courant de sortie vs et is.

      Deux de ces variables sont indépendantes. Les autre y sont liées par les paramètres du quadripôle.

    2. PARAMÈTRES HYBRIDES.

      3. Vu qu'on a quatre variables dont deux indépendantes, il y a plusieurs possibilités pour écrire les équations liant ces variables. Nous choisirons ici les équations faisant intervenir les paramètre hybrides, ce qui est le formalisme le plus simple pour décrire le fonctionnement des transistors.

      On démontre que l'on peut écrire :

      On peut mettre ce système sous la forme matricielle suivante :

      La matrice de transfert est appelée matrice hybride du quadripôle.

      La signification des paramètres est la suivante :

      h11 est l'impédance d'entrée du quadripôle avec la sortie en court-circuit.

      h12 est un coefficient adimensionnel quantifiant la réaction de la sortie sur l'entrée.

      h21 est le gain en courant avec sortie en court-circuit.

      h22 est l'admittance de sortie avec entrée à vide.

    3. SCHÉMA ÉQUIVALENT.

      4. A partir des paramètres définis précédemment, on peut donner un schéma électrique équivalent du quadripôle ; ce schéma ne fait intervenir que des composants classiques de l'électricité (voir Fig. 20).

      Ce schéma est typiquement celui qui sera utilisé pour représenter le transistor en petits signaux alternatifs.

      Fig. 20. Schéma équivalent d'un quadripôle.

  • LES INDISPENSABLES.

    • En électronique, il existe des conventions un peu différentes de ce qu'on trouve en électricité, et aussi des utilisations spécifiques de certains composants passifs . Nous allons étudier ces particularités dans ce paragraphe.

    1. MODÉLISATION.

      2. Les schémas électroniques font intervenir des composants ayant un comportement simple à décrire mathématiquement (R, L, C ), et d'autres ayant un comportement plus complexe. C'est le cas notamment des semi-conducteurs.

      De manière à pouvoir modéliser les circuits utilisant ces composants et prévoir leur fonctionnement, on est amenés à faire un schéma équivalent des composants complexes, ce schéma étant bâti à partir de composants simples : résistances, sources de tension, de courant (GIF 8ko)

      Par exemple, on pourra modéliser une diode zéner avec un générateur de tension parfait et une résistance série.

      Il faudra garder à l'esprit que ce n'est qu'un schéma équivalent, sous certaines hypothèses bien définies. Il ne saurait être question d'appliquer le résultat obtenu par le calcul hors de ces hypothèses !

      Exemple : bien qu'on puisse modéliser une diode zéner par un générateur de tension, si on branche une telle diode sur une ampoule, il ne se passera rien ! Ce composant n'est pas l'équivalent d'une pile ou d'un accumulateur.

      Cette remarque volontairement grossie reste valable pour la modélisation en général, quel que soit le domaine de la physique considéré.

    2. APPROXIMATIONS.

      3. Lorsqu'on fera des calculs sur un circuit électronique, on sera guidés en permanence par leur précision :

      les composants (résistances, condensateurs, transistors) font l'objet de dispersions (résistances à 5% par exemple ).

      les hypothèses de calcul conduisent à des simplifications (linéarisation, petits signaux )

      le résultat désiré le sera avec une précision plus ou moins élevée.

      Par conséquent, aussi savantes que puissent paraître les équations permettant de résoudre un circuit, on aura toujours présent à l'esprit que :

      elles sont fausses !

      elles sont inapplicables à des composants réels.

      Elles sont fausses car bâties sur des hypothèses représentant des approximations, et inutilisables telles quelles car il faudra tenir compte de la dispersion des composants et des valeurs normalisées (on ne trouve pas toutes les valeurs de résistances dans le commerce par exemple).

      Dans ce cas, dans la majeure partie des problèmes d'électronique, on se contentera de déterminer un ordre de grandeur des paramètres permettant de dimensionner les composants. On pourra dans ce cadre faire un maximum de simplifications. On adoptera souvent pour ce faire la règle du dixième : si deux paramètres s'ajoutent dans une équation, et que l'un soit plus de dix fois plus petit que l'autre, alors, on va le négliger. Exemple :

      En partant du constat qu'un calcul rigoureux est infaisable, et que de toutes façons, il ne servirait à rien, le meilleur calcul sera le plus simple !

    3. REPRÉSENTATION DES SCHÉMAS.

      4. En général, et contrairement à ce qui se pratique en électricité, on ne représentera pas toutes les connections entre les composants d'un schéma électronique. On omettra souvent les générateurs de tension continue, et de ce fait, le rebouclage des points où ils sont connectés avec la masse.

      De même, pour mieux comprendre le fonctionnement d'un montage, on tâchera (dans la mesure du possible) de bâtir le schéma en mettant le potentiel le plus élevé en haut de la feuille et de respecter une échelle des potentiels décroissants lorsqu'on dessinera les éléments du haut vers le bas de la feuille. En procédant ainsi, on aura les flèches de représentation des potentiels dans le même sens, et des courants descendants : la compréhension en sera largement accrue.

    4. MASSE.

      5. La masse est le potentiel de référence (fixé par convention à 0) du montage électronique : un potentiel n'est pas défini dans l'absolu, on parle toujours de différence de potentiel.

      Dans un montage électronique, quand on parlera du potentiel d'un point, il sera sous entendu que ce potentiel est référencé à la masse du montage.

      La masse sera en général le pôle moins de l'alimentation continue servant à polariser le montage. Cette règle est uniquement une coutume, elle ne sera pas systématiquement respectée sur les schémas rencontrés !

      Fig. 21. Représentations de la masse.

    5. TERRE.

      6. La terre est une connexion physique au sol (à la terre !). Contrairement aux croyances souvent énoncées, en aucun cas ce potentiel ne peut être considéré comme référence absolue, car il est différent d'un endroit de la Terre (la planète) à un autre. De plus, le câble de liaison du laboratoire au sol présente une impédance non nulle : si un courant parasite circule dans ce câble, il va y créer une chute de potentiel ; on aura une différence de potentiel entre la prise de terre du labo et le sol.

      La fonction d'une terre est la sécurité : elle permet de protéger les utilisateurs d'équipement sous tension , et aussi d'évacuer les courants induits par la foudre.

      Fig. 22. Représentations de la terre.

    6. INTERRUPTEURS.

      7. Ils permettent d'introduire une coupure dans un circuit électrique. Nous allons étudier ici le comportement d'un interrupteur parfait.

      1. Interrupteur ouvert.

        2. Lorsque l'interrupteur est ouvert, aucun courant ne circule dans la boucle, et toute la tension se retrouve sur l'interrupteur (U2 est nul, car le courant I est nul).

        Fig. 23. Interrupteur ouvert dans une boucle.

        La caractéristique de l'interrupteur ouvert se confond avec l'axe horizontal : le courant est nul quelle que soit la tension à ses bornes :

        Fig. 24. Caractéristique d'un interrupteur ouvert.

      2. Interrupteur fermé.

        3. Lorsque l'interrupteur est fermé, le courant peut circuler librement, la tension à ses bornes étant nulle ; on suppose celui-ci parfaitement conducteur, exempt de toute impédance parasite.

        Fig. 25. Interrupteur fermé dans une boucle.

        La caractéristique de l'interrupteur fermé se confond avec l'axe vertical : tension nulle quel que soit le courant qui circule à travers :

        Fig. 26. Caractéristique d'un interrupteur fermé.

    7. DIVISEUR DE TENSION.

      8. C'est le montage fondamental de l'électronique :

      Fig. 27. Diviseur de tension.

      Plutôt que d'appliquer la loi des mailles, on utilisera cette propriété au maximum ; les calculs en seront très souvent simplifiés.

      La formule donnant la tension de sortie Vs en fonction de la tension d'entrée du pont Ve est la suivante :

      En fait, on s'affranchit des courants dans la formulation, ce qui revient implicitement à diminuer le nombre d'inconnues, donc d'équations du problème. On arrive ainsi beaucoup plus vite et plus sûrement à le résoudre.

    8. ASSOCIATION DE RÉSISTANCES.

      1. En parallèle.

        2. Fig. 28. Résistances en parallèle.

      2. En série.

        3. Fig. 29. Résistances en série.

    9. CONDENSATEURS DE LIAISON.

      10. La plupart des montages électroniques à composants discrets nécessitent une polarisation (adjonction d'une tension continue) pour fonctionner correctement.

      À l'entrée du montage, sur ces tensions continues de polarisation, on va superposer un signal alternatif. Dans la plupart des cas, le générateur alternatif ne pourrait pas supporter qu'un courant continu le traverse ; de plus, si on ne veut pas modifier la polarisation du montage, ce générateur doit être neutre du point de vue du régime continu vis à vis du montage qu'il attaque.

      Pour satisfaire à toutes ces exigences, on relie le générateur alternatif à l'entrée du montage par l'intermédiaire d'un condensateur.

      Fig. 30. Condensateurs de liaison et découplage.

      Ce condensateur présente une impédance infinie au courant continu : il va ainsi empêcher qu'un tel courant ne traverse le générateur alternatif ; on ne modifiera pas la polarisation du montage.

      Ce condensateur est dit de liaison. On le choisira toujours pour que son impédance soit négligeable aux fréquences délivrées par le générateur alternatif :

      Pour le régime alternatif , et pour les fréquences des signaux utilisés, on l'assimilera à un court circuit.

      Pour le régime continu , on le considérera comme un circuit ouvert.

    10. CONDENSATEURS DE DÉCOUPLAGE.

      11. Les nécessités de la polarisation peuvent amener à introduire dans le montage des éléments (des résistances notamment) qui nuisent au bon fonctionnement du régime alternatif. Pour éviter ceci, on peut mettre en parallèle sur ces éléments un condensateur qui va se comporter comme un court circuit pour les signaux alternatifs. Comme pour les condensateurs de liaison, ils ne modifient en rien la polarisation du montage. (voir figure 30).

  • THÉORÈMES FONDAMENTAUX.

    1. LOIS DE KIRCHOFF.

      2. Les lois de Kirchoff sont les lois fondamentales qui régissent le fonctionnement de tout circuit électrique. Néanmoins, en pratique, elles sont peu appliquées telles quelles en électronique ; on leur préférera souvent les propriétés du diviseur de tension, et les théorèmes de thévenin et de superposition pour faire les calculs. A noter qu'on a besoin des lois de Kirchoff pour démontrer ces théorèmes.

      1. Loi des mailles.

        2. Une maille est une boucle fermée composée d'éléments réels ou virtuels (immatériels) présentant une différence de potentiel entre leurs bornes.

        La somme des tensions rencontrées lorsqu'on parcourt une boucle fermée est nulle.

        Cette loi est en quelque sorte la relation de Chasles de l'électricité.

        Pratiquement, on impose d'abord le sens des courant dans chaque élément de la maille. Ensuite, on représente les tensions par des flèches en respectant les règles suivantes :

        convention récepteur pour les dipôles passifs avec le sens du courant qu'on a imposé.

        respect de la polarité des générateurs (flèche au pôle positif). Attention : cette règle est absolue, même si le générateur est utilisé comme récepteur ! (Exception notable : les fcem).

        Une tension rencontrée sur la boucle peut correspondre à un élément immatériel (qui n'est ni un générateur, ni un composant passif : cas de la tension U dans l'exemple ci-dessous). Cette astuce permet de casser une boucle trop grande et de simplifier les calculs.

        Le sens et le début du parcours n'importent pas. On met un signe positif à toute tension rencontrée en direct (la flèche la représentant est orientée dans le sens de parcours de la boucle), sinon, le signe est négatif.

        boucle 1 :

        boucle 2

        Fig. 31. Circuit à deux mailles.

        Pour résoudre totalement le problème d'électricité posé, il va falloir déterminer autant d'équations indépendantes qu'on a d'inconnues (tensions et courants). La loi des mailles ne sera d'ailleurs pas suffisante pour définir toutes les équations nécessaires, il faudra aussi utiliser la loi des noeuds.

        Quand on a autant d'équations que d'inconnues, on peut résoudre le système. Il se peut alors qu'on obtienne des courants négatifs. Si le circuit ne comporte aucun élément appelé force contre électro-motrice (fcem) en électricité , le courant circule en fait dans le sens opposé à celui défini arbitrairement. Ceci ne remet pas en cause les résultats obtenus.

        Par contre, si le circuit contient des fcem, et que des courants négatifs apparaissent dans la solution, il faut impérativement retraiter tout le problème en modifiant le sens arbitraire des courants, et ceci jusqu'à ce que tous les courants soient positifs.

        En pratique, dans les problèmes d'électronique abordés dans le cadre de ce cours, il n'y aura jamais d'ambiguités : on n'aura que des composants passifs simples, et des sources de tension utilisées soit comme générateurs, soit comme récepteurs, mais dans tous les cas, leur polarité ne dépendra pas du sens du passage du courant.

        Par contre, la polarité des fcem dépend du sens du courant les traversant, ce qui fait que si on inverse celui-ci, le problème d'électricité à résoudre est différent !

        En électronique, on fera essentiellement attention aux inductances, qui ont un comportement de fcem.

        Nota : on trouvera dans la littérature une autre méthode de résolution de ces problèmes appelée résolution matricielle. Elle consiste à définir un courant de maille totalement fictif et n'ayant rien à voir avec la circulation réelle des courants (qui sont mesurables à l'aide d'un ampèremètre). On obtient les courants réels en sommant les courants fictifs communs aux différentes branches. Cette méthode est très efficace pour faire du calcul de circuits sur ordinateur (résolution de systèmes d'équations). Elle est déconseillée ici, car elle ne permet pas d'y voir clair dans un circuit électronique, ni surtout pas d'intuiter son fonctionnement !

      2. Loi des noeuds.

        3. Un noeud est la jonction d'au moins trois conducteurs.

        Fig. 32. Noeud de courant.

        La somme des courants entrant dans le noeud est égale à la somme des courants en sortant. Ici, on a :

    2. THÉORÈME DE SUPERPOSITION.

      1. Définition.

        2. Ce théorème est fondamental. Il va permettre d'étudier des circuits comportant plusieurs générateurs (de tension ou de courant) en considérant l'influence de chaque générateur indépendamment des autres, ce qui va beaucoup simplifier la plupart des problèmes.

        Une des grandes applications est le schéma alternatif petits signaux, qu'on utilise très souvent sans même penser qu'il découle du théorème de superposition !

        Dans un circuit comportant plusieurs générateurs, la solution du problème (les tensions et courants inconnus) est la somme des solutions trouvées en ne considérant qu'un générateur à la fois.

        Pour ce faire, on remplace chaque source de tension parfaite par un court circuit, et chaque source de courant par un circuit ouvert, à l'exception de la source dont on veut connaître l'influence.

        Fig. 33. Problème global.

        Dans l'exemple ci-dessus, on va commencer par supprimer E2 et faire le calcul de la tension U avec E1 seul. On a alors un diviseur de tension :

        Fig. 34. 1ère étape.

        Pour avoir la contribution de E2, on fait ensuite la même chose en supprimant E1 :

        Fig. 35. 2ème étape.

        La solution totale U est égale à la somme des deux solutions précédemment trouvées :

        On voit bien ici l'intérêt de ce théorème : on applique deux fois la formule du diviseur de tension et le tour est joué ! Il n'y a pas eu besoin de recourir aux équations lourdes de la loi des mailles.

        Tout comme pour le théorème de thévenin, on utilisera ce théorème avec une extrême prudence quand on aura affaire à des sources commandées

      2. Application au schéma équivalent alternatif petits signaux.

        3. En général, on conçoit un circuit électronique à éléments discrets en deux temps : on calcule d'abord les éléments nécessaires à sa bonne polarisation, et ensuite, on étudie son comportement en petits signaux alternatifs (la fonction principale du montage) indépendamment de la polarisation (qui est nécessaire au bon fonctionnement des semi conducteurs, mais ne constitue pas une fin en soi).

        Ce faisant, on utilise implicitement le théorème de superposition, car les tensions et courants du montage seront toujours la somme des tensions et courants de polarisation et des signaux alternatifs.

        Ainsi, dans un circuit, on pourra se focaliser sur l'effet d'un seul générateur. Il sera indépendant de la contribution du ou des autres générateurs du circuit.

        Pour construire un schéma équivalent en alternatif d'un montage, on appliquera les règles suivantes :

        On remplacera toutes les sources de tension continue parfaites par des court-circuits.

        On remplacera toutes les sources de courant continu parfaites par des circuits ouverts.

        On remplacera toutes les sources de tension continue et de courant continu ayant une résistance interne par leur résistance interne.

        Les condensateurs de découplage seront remplacés par des court-circuits.

        En général, on remplacera les condensateurs de liaison par des court-circuits.

        Tous les dipôles non linéaires seront préalablement linéarisés pour nous permettre d'appliquer simplement la loi d'Ohm.

        On obtient ainsi le schéma simplifié qui va permettre l'étude de la fonctionnalité du montage. Application pratique, mode d'emploi (GIF 26ko).

        ATTENTION !!! : il faudra toujours se souvenir des hypothèses de base qui ont servi à faire ce schéma, et notamment le fait que quand on a un courant (ou une tension) négatif dans le schéma alternatif, dans le montage, en réalité, il sera positif, mais inférieur au courant (ou à la tension) de polarisation.

        On pourra avoir des surprises de fonctionnement qui n'ont pas été prévues par l'étude du schéma alternatif équivalent, de par les simplifications faites.

        Un montage pourra avoir ainsi un fonctionnement dissymétrique sur les ondes positives et négatives du signal alternatif. Il faudra faire particulièrement attention au fonctionnement de ce montage sur charge capacitive (certains circuits présentent une impédance de sortie dissymétrique : par exemple, dans une diode ou un transistor, le courant ne peut circuler physiquement que dans un seul sens. Le montage ne pourra donc pas "absorber" un courant négatif, mais seulement fournir un courant positif inférieur au courant de polarisation).

        Ne pas oublier non plus qu'on est en régime de petits signaux, et que si on pousse le montage aux limites, cette hypothèse devient fausse, et le comportement observé n'est plus ce qui a été prévu !

        En cas de problèmes, il faudra rechercher la cause de dysfonctionnement en considérant le schéma global, et non plus le schéma équivalent en alternatif.

    3. THÉORÈME DE THÉVENIN.

      4. Il a été dit au début de ce chapitre qu'on pouvait associer des dipôles de base en série et en parallèle de manière à former des dipôles plus complexes. Le théorème de thévenin permet de remplacer un montage complexe par un générateur de tension équivalent avec sa résistance interne équivalente et de calculer ces éléments.

      On pourra ainsi considérer ce montage comme une source de tension réelle et étudier plus simplement son comportement lorsqu'on le connecte à un autre dipôle.

      On peut aussi grâce à ce théorème aborder un schéma compliqué en isolant des morceaux et en les transformant en générateurs de thévenin équivalents. Cela permet souvent d'y voir plus clair dans un schéma complexe, et de simplifier et bien faire ressortir des blocs clé du schéma.

      Dans l'exemple suivant, il pourrait être intéressant de réduire la partie gauche du schéma (en pointillés) à un seul générateur équivalent.

      Fig. 36. Dipôle complexe.

      Le théorème de thévenin va permettre de réduire cette partie à un générateur ETh et sa résistance interne RTh de la manière suivante :

      ETh est la tension à vide de la partie gauche du schéma : R3 est infinie.

      RTh est la résistance équivalente vue entre les points A et B lorsque les sources de tension non commandées sont éteintes et que R3 est infinie.

      La tension équivalente se calcule ici aisément par le théorème de superposition :

      Fig. 37. Générateur de tension équivalent.

      La résistance est obtenue en remplaçant les générateurs de tension par des court-circuits (s'il y avait eu des générateurs de courant, on les aurait remplacés par des circuits ouverts) :

      Fig. 38. Résistance équivalente.

      Le circuit équivalent est le suivant, avec les valeurs de ETh et RTh calculées précédemment.

      Si maintenant, on veut utiliser la même partie gauche du schéma avec une charge différente de R3, le générateur de thévenin reste identique : il n'y a pas besoin de refaire de laborieux calculs avec les lois de Kirchoff !

      Fig. 39. Générateur de thévenin équivalent.

      Il existe le théorème dual de celui de thévenin : c'est le théorème de norton. On raisonne alors en termes de source de courant. Il est plus rarement utilisé en électronique, et donc, nous ne l'étudierons pas ici (voir cours d'électricité).

    4. TRANSFORMATION NORTON / THÉVENIN.

      5. Il est parfois intéressant de passer d'une représentation de générateur de tension à celle de générateur de courant.

      Si on reprend les figures 15 et 16, on voit que la caractéristique de ces deux générateurs est similaire ; la pente de cette caractéristique est dans les deux cas égale à -1/Rg, où Rg est la résistance série du générateur de tension ou la résistance parallèle du générateur de courant.

      Il reste à déterminer la valeur de la tension duale du générateur de courant et vice versa.

      La solution est donnée par les figures 15 et 16 et dans le texte associé.

      Lorsqu'on transforme un générateur de courant (Ig, R) en générateur de tension (Eg, r), on a les relations :

      En effet, la tension à vide du générateur de courant est donnée lorsque tout le courant de la source est absorbé par la résistance parallèle interne R.

      Les résistances R et r sont égales (les pentes des caractéristiques sont les mêmes).

      Lorsqu'on transforme un générateur de tension (Eg, r) en générateur de courant (Ig, R), on a les relations :

      Ig est égal au courant de court-circuit de la source de tension (Eg, r).

      Fig. 40. Transformation norton / thévenin.

      Comme il a déjà été dit auparavant, ces calculs sont purement théoriques, et ils amènent à des valeurs de courant et tension équivalents irréalistes.

      Les calculs de tensions et courants dans un circuit comprenant des générateurs auxquels on aura appliqué la transformation thévenin/norton seront justes, mais le fonctionnement réel de ces sources sera très différent de celui décrit par le formalisme utilisé.

      Attention : Il ne faudra surtout pas faire de calculs de puissance dissipée à l'intérieur des sources avec le mauvais formalisme : par exemple, calculer des puissances dissipées à l'intérieur d'une batterie en utilisant le modèle du générateur de courant équivalent amènerait à des valeurs totalement erronées !

  • GÉNÉRALITÉS SUR L'AMPLIFICATION.

    1. INTRODUCTION

      2. Une des grandes fonctions de l'électronique analogique est l'amplification de signaux électriques. Cette fonction sera partout présente dans la mesure, et sera notamment cachée dans les appareils de mesure de laboratoire.

      Ces appareils seront assimilés à des boîtes noires, dont on ne connaît pas le contenu, mais dont le fabricant spécifie divers paramètres nous permettant de les interfacer avec d'autres éléments de la chaîne de mesure.

      La présentation de l'amplificateur qui va être faite ici indique les paramètres essentiels et à quoi ils se rapportent.

    2. REPRÉSENTATION D'UN AMPLIFICATEUR.

      3. Un amplificateur est un quadripôle, avec deux bornes d'entrée et deux bornes de sortie. Une des bornes sera généralement commune à l'entrée et à la sortie (Fig. 41.).

      On pourra représenter cet amplificateur par le schéma équivalent suivant :

      Fig. 41. Schéma équivalent d'un amplificateur.

      Dans ce schéma, on va distinguer trois séries de paramètres, relatifs à :

      l'entrée (comment se comporte l'ampli vis à vis de la source qui l'attaque).

      la relation qui lie l'entrée et la sortie (transfert).

      la sortie (de quelle manière la charge perturbe-t-elle l'ampli ?)

    3. PARAMÈTRES ESSENTIELS.

      1. les paramètres d'entrée.

        • Impédance d'entrée.

          • C'est tout simplement l'impédance vue de la source, à savoir le rapport :

          Cette impédance est en général élevée pour ne pas perturber la source qui l'attaque.

        • Sensibilité d'entrée.

          • C'est la tension Se appliquée à l'entrée pour laquelle l'ampli atteindra sa tension de sortie maximum admissible.

      2. les paramètres de transfert.

        • Gain en tension.

          • C'est le rapport de la tension de sortie sur la tension d'entrée. C'est le facteur multiplicatif de l'ampli :

          Le gain est adimensionnel. Il dépend de la fréquence du signal d'entrée tout en restant pratiquement constant dans la plage de fréquences constituant la bande passante.

        • Gain en décibels.

          • Très souvent, le gain sera exprimé en décibels (dB)

          Ce type de notation sera utilisé de façon très large en électronique : fondamental !

        • Bande passante.

          • C'est la plage de fréquence pour laquelle le gain en tension Av reste dans une fourchette comprise entre xdB autour d'une valeur nominale Avo. Généralement, x est égal à 3. On parle de bande passante à 3dB.

          Fig. 42. Bande passante d'un amplificateur.

      3. les paramètres de sortie.

        • Impédance de sortie.

          • C'est l'impédance vue de la charge, à savoir le rapport :

          Cette valeur sera en général faible.

        • Plage de sortie.

          • C'est la tension de sortie maximum que peut délivrer l'ampli. Il faudra faire attention (comme pour la sensibilité) au formalisme utilisé pour la définir : tension crête à crête, crête, ou efficace, les valeurs données variant alors dans un rapport de 1 à 2 [image] 2 !

        • Rapport signal sur bruit.

          • Les composants électroniques génèrent des bruits électriques d'origines diverses (agitation thermique entres autres), et les circuits sont sensibles aux perturbations extérieures (parasitages dus à des champs électromagnétiques, à des couplages ).

          En conséquence, la tension de sortie de l'amplificateur sera non nulle même avec une tension d'entrée nulle. Cette tension est aléatoire, et son niveau sera sensiblement constant quel que soit la tension présente à l'entrée de l'amplificateur.

          Le rapport signal sur bruit sera défini comme le rapport maxi du signal utile (la plage de sortie) sur le niveau de bruit :

          Ce rapport signal sur bruit sera la plupart du temps exprimé en dB.

          Cette notion est importante en instrumentation et déborde largement le cadre de l'amplification ; on la retrouvera aussi dans divers appareils de mesure et de traitement de signal.

    4. ADAPTATION D'IMPÉDANCE.

      5. Lorsqu'on veut connecter plusieurs étages amplificateurs en cascade, ou plus simplement, quand on désire relier un amplificateur à un générateur en amont et à une charge en aval, il faut faire attention aux impédances des divers constituants de la chaîne.

      La figure 43 représente un amplificateur d'impédance d'entrée Ze, d'impédance de sortie Zs, connecté à un générateur d'impédance interne Rg et à une charge Zu.

      Le générateur délivre une tension à vide Eg ; la tension à l'entrée de l'amplificateur est Ve, et celle sur la charge est Vs.

      Fig. 43. Connexion d'un amplificateur.

      Avec la représentation schématique de l'amplificateur, on distingue très nettement deux ponts diviseurs qui vont détériorer l'amplification.

      En entrée, on a :

      Et en sortie, on obtient :

      Au total, l'amplification réelle devient :

      Si on veut transmettre le maximum de tension entre le générateur et la charge (on parle ici d'adaptation en tension, mais on peut aussi réaliser une adaptation en courant ou en puissance), il faudra les deux conditions suivantes :

      En théorie, pour réaliser une bonne adaptation en tension en entrée et en sortie, un ampli idéal aura une impédance d'entrée infinie (en pratique, elle sera la plus grande possible, de l'ordre de quelques M [image]), et une impédance de sortie nulle (en pratique, elle sera de quelques à quelques m [image]).

      Cette notion d'adaptation d'impédance est fondamentale, et s'applique très largement, dès qu'on veut interconnecter des appareils électroniques entre eux, et en particulier, des instruments de mesure.


Cristal

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/CRISTAL/COURS.HTM#C01

INTRODUCTION

  1. AVERTISSEMENT.

    Ce cours n'a aucunement la prétention d'être un cours de cristallographie. Il ne sera donc ni exhaustif (et de très loin s'en faut !), ni franchement rigoureux.

    Son but est de permettre la compréhension des principaux phénomènes de conduction qui se produisent dans les semi-conducteurs, afin de pouvoir interpréter leur comportement.

    Cet exposé sera donc plus proche de la vulgarisation que du cours académique, mais compte tenu du but recherché, il sera largement suffisant pour comprendre les phénomènes sans rentrer dans les détails fort compliqués de la théorie de la conduction.

    Les personnes désireuses d'approfondir cette partie (tout en conservant une vue d'ensemble) pourront se référer (entres autres) à l'ouvrage Matériaux de l'électrotechnique de P. Robert édité chez Dunod (collection Traité d'électricité, d'électronique et d'électrotechnique ).

    A noter que des connaissances approfondies en cristallographie ne sont indispensables que pour l'électronicien désireux de se spécialiser en micro-électronique (conception de circuits intégrés). On peut donc parfaitement s'en passer si on se contente d'assembler des composants discrets !

    Dans l'optique de ce cours, elles vont nous permettre de comprendre l'essentiel du fonctionnement des composants utilisés sans avoir à parachuter trop de notions qui resteraient alors incomprises.

  2. LIEN AVEC LE COURS D'ÉLECTRONIQUE.

    Tout le secret de l'électricité réside dans la capacité de la matière à laisser circuler plus ou moins bien des charges électriques en son sein sous l'influence d'un champ électrique externe.

    Les composants électroniques obéissent aux lois générales de l'électricité (revoir le chapitre I), et donc répondent à la définition précédente.

    La différence avec les composants électriques traditionnels se situe dans le matériau conducteur utilisé, qui va autoriser un meilleur contrôle de la conduction électrique, et donc des fonctionnalités nouvelles.

    L'électronique va alors se distinguer de l'électricité par des composants dont on pourra moduler la conduction à l'aide de signaux électriques, chose impossible avec les composants simples de l'électricité.

    Il est par conséquent utile de rappeler en introduction que tout ce qu'on voit en électronique est totalement dépendant de la physique des solides, et qu'un aperçu de cette dernière est indispensable pour comprendre le fonctionnement des composants électriques et électroniques.

  • STRUCTURE DE LA MATIÈRE.

    1. RAPPEL DE LA DESCRIPTION SIMPLIFIÉE DE LA STRUCTURE DES ATOMES.

      Les atomes sont des particules de base constituées d'un noyau autour duquel gravitent des électrons.

      Le noyau est composé de protons, particules élémentaires chargées électriquement à la valeur +e, et de neutrons, sans charge.

      Les électrons sont des particules chargées électriquement à la valeur -e. Ils tournent autour du noyau sur des orbites définies et ont une masse négligeable vis à vis des neutrons et protons (qui ont eux environ la même masse).

      La charge électrique élémentaire vaut e = 1,6E-19 C (C pour Coulomb, unité de charge électrique).

      Les orbites des électrons ont des dimensions très grandes vis à vis de celle du noyau, et l'ensemble de l'atome est électriquement neutre, car il comprend autant de protons que d'électrons.

      Les électrons se répartissent sur des orbites différentes qui forment des couches. Les couches sont remplies par les électrons dans un ordre bien déterminé. Dans la mesure du possible, ceux-ci s'assemblent par paires. Quand ce n'est pas possible, ils restent célibataires .

      Quand l'atome possède plusieurs couches d'électrons, les couches profondes contiennent un nombre d'électrons indépendant de l'atome considéré. C'est la couche périphérique qui fait la différence.

      Fig. 1. Structure d'un atome (silicium).

    2. LES LIAISONS INTER-ATOMIQUES.

      Dans la matière, les atomes la constituant se combinent entre eux de manière à lui donner une certaine cohésion.

      Macroscopiquement, ces liaisons, appelées valences, vont donner la consistance du matériau : gaz, liquide, solide plus ou moins dur, structure cristalline

      Pour la suite de l'exposé, nous allons décrire seulement deux types de valences ; il en existe d'autres que nous n'aborderons pas.

      Ces deux liaisons sont :

      1. Les liaisons covalentes.

        Les atomes se lient entre eux en mettant en commun des électrons célibataires de la couche périphérique (électrons de valence). Ces électrons s'associent en paires et appartiennent en commun aux deux atomes participant à la liaison. De ce fait, les liaisons obtenues sont très robustes : il faut leur fournir une énergie importante pour les casser.

        Dans ce type de liaison, les électrons mis en commun restent très liés aux atomes qui les fournissent. Ils ne peuvent pas circuler facilement dans la matière.

      2. Les liaisons métalliques.

        Dans ce cas de liaison, ce ne sont pas deux atomes qui mettent en commun un ou plusieurs électrons pour se lier ; un grand nombre d'atomes mettent en commun des électrons célibataires.

        Les atomes ainsi dépouillés de leur(s) électrons(s) deviennent des particules non neutres du point de vue charge électrique (des ions).

        Ils forment un réseau cristallin et baignent dans un nuage d'électrons très mobiles appelés électrons libres.

    3. LA CONDUCTION ÉLECTRIQUE.

      1. Définition.

        Lorsqu'on applique un champ électrique extérieur sur un matériau, on a conduction si on observe la circulation d'un courant électrique dans le matériau.

        Ce courant est dû au déplacement de charges électriques dans le matériau.

        Fig. 2. Déplacement de charges dans un matériau.

        La figure 2 montre ce mécanisme : si on applique une différence de potentiel UAB entre deux points A et B d'un matériau distants d'une longueur L, on créé un champ électrique E dans le matériau :

        Ce champ va créer des forces sur les charges électriques présentes dans le matériau :

        Si la charge q est positive, la force et le champ sont de même sens, si elle est négative, ils sont de sens opposés.

        Pour que des charges se déplacent dans un champ électrique, encore faut-il que ces charges mobiles existent. Les paragraphes qui suivent vont faire le lien avec les types de liaisons atomiques vues précédemment.

      2. Les isolants.

        Dans le cas des matériaux isolants, on a affaire à des liaisons de type covalente : les électrons célibataires de la couche périphérique forment tous des liaisons avec leurs homologues issus d'autres atomes adjacents. Les liaisons sont robustes, et les charges potentiellement mobiles (les électrons) restent liées aux atomes auxquelles elles appartiennent.

        On a beau appliquer un champ électrique sur ces matériaux, aucun courant électrique ne circule, car il n'y a pas de charges mobiles.

        Il faut noter que les isolants sont aussi importants que les conducteurs en électricité et en électronique, car ce sont eux qui permettent de canaliser les courants électriques là où on le désire. Ils vont s'intercaler entre les conducteurs, et aussi assurer la protection des usagers (gaines isolantes, enrobages de câbles ).

      3. Les conducteurs.

        Les liaisons des atomes composant les matériaux conducteurs sont de type métallique. Nous avons vu précédemment que dans ce type de liaisons, chaque atome libère un électron qui peut circuler librement dans le cristal.

        En l'absence de champ électrique extérieur, ces électrons se déplacent dans un mouvement désordonné, et, statistiquement, la somme de tous les déplacements est nulle : il n'y a pas de courant électrique généré spontanément (ce qui serait l'équivalent du mouvement perpétuel en mécanique !).

        Par contre, dès qu'on applique un champ électrique extérieur au matériau conducteur, les électrons vont circuler dans un sens bien déterminé par le sens du champ électrique, créant un courant important.

      4. Interprétation de la loi d'Ohm.

        Tout le monde connaît la loi d'Ohm :

        Cette loi est interprétable au niveau atomique. Nous allons en donner les principales formulations ci-dessous.

        Certaines équations sont bien entendues parachutées, notamment celle qui paraît la plus simple, à savoir la mobilité des charges. Elle découle de la théorie du modèle boules de billard , qui assimile les particules en mouvement à des boules de billard qui se déplacent aléatoirement et qui s'entrechoquent. Nous n'entrerons pas dans cette théorie. On se reportera à l'ouvrage pré-cité (p.50) pour de plus amples renseignements.

        • Mobilité des charges.

          De tout ce qui a été dit précédemment, on se doute qu'un des principaux paramètres qui va décrire l'aptitude d'un matériau à conduire le courant électrique est la mobilité des charges électriques présentes dans ce matériau.

          On le définit dans la relation suivante :

          est la mobilité des charges exprimée en m2 /Vs, v la vitesse de déplacement de ces charges dans la matière, et E l'intensité du champ électrique appliqué sur le matériau (exprimé en V/m).

        • Courant.

          Le courant électrique est le débit de charges électriques circulant dans le conducteur d'une section S donnée, à savoir la quantité de charges électriques qui vont traverser cette section par unité de temps :

          où n est le nombre de charges traversant la section S de conducteur à la vitesse v. Chaque particule est chargée à la valeur élémentaire e = 1,6E-19C.

          Cette définition est tout à fait assimilable au débit d'eau dans une conduite.

          On voit ici que le courant dépend de la section du conducteur. Pour caractériser le matériau, on va utiliser une définition faisant abstraction de cette section : c'est la densité de courant.

        • Densité de courant.

          La densité de courant J est tout simplement le rapport de l'intensité à la section, soit :

          La densité est proportionnelle à la mobilité des charges, à leur nombre, et au champ électrique appliqué.

        • Conductivité et résistivité.

          Si on reprend l'équation [1] et la figure 2, on peut remplacer E par sa valeur dans l'équation [5], soit :

          C'est la loi d'Ohm. La résistance R du tronçon de matériau de section S et de longueur L est égale à :

          Par définition, on appelle la conductivité [image] la valeur :

          La résistivité [image] est l'inverse de la conductivité, à savoir :

          Une autre forme de la loi d'Ohm est dans ce cas :

          Exemples de valeurs de résistivité :

          = 1E12 [image] m pour le diamant (isolant)

          = 1,7E-8 [image] m pour le cuivre (conducteur)

      5. Influence de la température.

        La température, en augmentant, va accroître l'agitation des particules dans la matière, et ainsi gêner leur déplacement lors de l'application d'un champ électrique externe. La résistivité du matériau va augmenter.

        Cette augmentation de la résistivité avec la température est une loi linéaire, et peut se mettre sous la forme :

        a est la constante du matériau, [image] o la résistivité à To et [image] la résistivité à la température T.

        a vaut 4E-3K-1 pour le cuivre. Cela signifie que la résistance d'un conducteur de cuivre va varier de 1% tous les 2,5°C. On en tiendra compte lorsqu'on fera de telles mesures !

  • LES SEMI-CONDUCTEURS.

    1. INTRODUCTION.

      Nous venons de voir que les charges électriques sont plus ou moins libres de circuler dans la matière sous l'influence d'un champ électrique externe. Cette propriété nous a permis de distinguer les isolants (liaisons très robustes, charges électriques très peu mobiles) des conducteurs (liaisons fragiles, charges très mobiles).

      Les semi-conducteurs se situent entre ces deux extrêmes (d'ou leur nom !). On va aussi pouvoir obtenir les caractéristiques désirées en appliquant les transformations physico-chimiques adéquates. Il en résultera plusieurs sortes de semi-conducteurs que l'on pourra combiner pour obtenir des fonctionnements bien déterminés.

    2. GÉNÉRALITÉS SUR LES SEMI-CONDUCTEURS.

      1. Semi conducteurs intrinsèques.

        Un semi conducteur est constitué par un réseau cristallin de matériau très pur. On utilise soit des éléments du tableau périodique possédant chacun 4 électrons de valence, soit des combinaisons de matériaux qui possèdent 3 et 5 électrons de valence. Les atomes sont liés entre eux par des liaisons covalentes. Ces liaisons sont robustes, ce qui fait que pour arracher des électrons des atomes, il faut fournir une énergie assez importante (environ 1eV, contre 0,1 eV pour les conducteurs et 5eV pour les isolants).

        Fig. 3. liaisons dans un cristal de silicium.

        Les trois principaux semi conducteurs utilisés en électronique sont :

        le silicium (Si) : c'est le matériau le plus utilisé actuellement pour la fabrication des composants électroniques.

        le germanium (Ge) : il est délaissé (trop sensible en température : courants de fuite importants, température de fonctionnement limitée).

        l'arseniure de gallium (AsGa) : il est très utilisé dans la fabrication de composants opto électroniques, et permet aussi de fabriquer des composants plus rapides que ceux en silicium ; ces applications sont cependant relativement rares.

        Les semi conducteurs ont une résistivité électrique intermédiaire entre les isolants (1E14 à 1E22 [image] cm) et les bons conducteurs (1E-6 [image] cm) : elle est comprise entre 1E2 et 1E9 [image] cm.

        L'agitation thermique fait que certains électrons quittent leur liaison et deviennent des électrons libres. Ils créent alors un trou qui ne demande qu'à être rebouché par un autre électron libre, surtout si on applique un champ électrique sur le cristal : électrons et trous se déplacent en sens inverse, engendrant ainsi un courant électrique.

        Contrairement à ce qui se passe dans les conducteurs, la résistivité des semi conducteurs diminue quand la température augmente : en effet, plus la température est élevée, plus le nombre de trous et d'électrons libres augmente, et plus le courant produit est intense quand on branche un générateur sur le cristal.

      2. Semi conducteurs extrinsèques.

        Les semi conducteurs intrinsèques n'ont pas une grande utilité en tant que tels ; ils servent de base aux semi conducteurs dopés : on y rajoute des impuretés pour modifier leur comportement. Il existe deux types de semi conducteurs extrinsèques :

        • Le semi conducteur de type P. (GIF 17ko)

          On dope le cristal intrinsèque avec un élément possédant un nombre inférieur d'électrons de valence : on peut doper du silicium (4 électrons de valence) avec du Bore, de l'indium, du Gallium ou de l'Aluminium qui possèdent 3 électrons de valence (atome accepteur).

          Ces atomes vont prendre la place d'atomes de silicium dans le cristal. Comme ils possèdent 1 électron de valence en moins, il va se créer des trous dans le semi-conducteur. Les trous deviennent porteurs de charges mobiles majoritaires : le semi conducteur est de type P. Il subsistera quelques électrons libres dans le cristal (porteurs minoritaires).

          Les trous ainsi créés vont être susceptibles d'être bouchés par des électrons présents dans le cristal (par exemple, des électrons issus de paires électron-trou générés par l'agitation thermique).

        • Le semi conducteur de type N. (GIF 17ko)

          Le principe est le même que pour le semi conducteur de type P, sauf qu'on dope le cristal avec des éléments ayant un électron de valence de plus (atomes donneurs) : le phosphore, l'arsenic et l'antimoine, qui possèdent 5 électrons de valence pourront doper le silicium par exemple. 4 électrons vont faire des liaisons covalentes avec les atomes de silicium environnants, et le 5ème sera un électron libre ; tous ces électrons libres seront les porteurs majoritaires. Il existera encore quelques trous, mais en très faible quantité.

          Les électrons libres seront pratiquement aussi mobiles que dans le cas des conducteurs (liaisons métalliques).

          Anoter que dans ce cas, l'atome donneur devient ion positif, mais ceci ne créé pas un porteur trou comme dans le cas du silicium P, car cette charge positive ne peut pas se déplacer dans le cristal.

          A noter que dans les deux cas (types N et P), le cristal reste globalement électriquement neutre , car le noyau des atomes donneurs comporte un proton de plus que l'atome du cristal intrinsèque, et un de moins dans le cas des atomes accepteurs. Le dopage permet d'avoir beaucoup plus de porteurs d'une espèce donnée que de l'autre, et il a apporté une fragilité supplémentaire dans les liaisons atomiques : l'énergie nécessaire pour arracher un porteur majoritaire d'un atome est d'environ 0,1eV : il y aura plus de charges participant à la circulation du courant que dans un cristal intrinsèque.

    3. Conduction

      En pratique, seuls les électrons se déplacent. Au niveau mobilité des charges, on voit que pour le silicium N, les charges mobiles sont les électrons libres , dont l'énergie de liaison se situe dans la bande de conduction (il faut très peu d'énergie pour les arracher de leur atome donneur) : ils vont donc être très mobiles.

      Pour le silicium P, le déplacement de trous se fera en fait par déplacement d'électrons qui seront obligés de venir des autres liaisons covalentes (génération de paires électron-trou), donc de la bande de valence (il faut fournir une énergie relativement élevée pour créer ces paires de porteurs) : ils vont être beaucoup moins mobiles que les électrons libres du silicium N, ce qui explique que la conductivité du silicium P soit plus faible que celle du N.

      La conduction est le résultat de trois termes :

      Conduction par champ électrique : un champ externe va fournir suffisamment d'énergie aux électrons libres (N) ou au trous (P) : en fait, les électrons de valence voisins du trou) pour qu'ils se déplacent. On a une conduction dans un barreau de silicium monocristal (N ou P). La conduction est meilleure dans le N à cause de ce qui a été dit précédemment.

      Conduction par diffusion des porteurs : n'existe pas dans un cristal homogène. Ce phénomène est dû à l'hétérogénéïté du matériau (jonction, dopage non homogène ) : il y a un gradient de concentration des charges qui se déplacent pour se répartir de façon homogène dans le cristal à la manière des gaz.

      Conduction par création/recombinaison de charges : ceci concerne les charges libres minoritaires, qui peuvent être créées de diverses manières : émission photonique, avalanche, passage de la barrière de potentiel d'une jonction Ces charges en excès se recombinent avec les porteurs majoritaires selon une loi exponentielle de constante de temps égale à la durée de vie des porteurs.


COURS.HTM

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/DIODE/COURS.HTM#D20

INTRODUCTION.

La diode est le semi-conducteur de base : on ne peut pas combiner du silicium dopé plus simplement.

Son fonctionnement macroscopique est assimilable à celui d'un interrupteur commandé qui ne laisse passer le courant que dans un seul sens.

Cette propriété lui ouvre un champ d'applications assez vaste en électronique. C'est la diode qui va permettre de redresser le courant alternatif issu du secteur et autoriser la fabrication d'alimentations stabilisées qui sont obligatoires dans la plupart des montages électroniques. On conçoit donc que si ce composant est basique , ainsi que son fonctionnement, il n'en n'est pas moins fondamental !

Dans la catégorie des diodes, on trouve aussi des diodes de régulation, dites diodes zéner, qui ont un comportement de source de tension. Cette propriété va permettre d'élaborer autour de ce composant simple toute une série de montages délivrant une ou plusieurs tensions continues.

La fonction diode a existé bien avant l'arrivée du silicium : on utilisait alors des diodes à vide (les lampes ) dont le fonctionnement était basé sur l'effet thermoélectronique. Le silicium a apporté les avantages suivants : coût, fiabilité, encombrement, simplicité d'utilisation

PRINCIPE DE FONCTIONNEMENT.

  1. Si on dope une partie d'un semi conducteur intrinsèque avec des atomes à 5 électrons périphériques (le semi conducteur devient extrinsèque de type N) et l'autre avec des atomes à 3 électrons périphériques (extrinsèque de type P), on crée une jonction, qui est la limite de séparation entre les deux parties.

    Nous avons fabriqué une diode à jonction.

      Fig. 1. Équilibre au niveau de la jonction.

      Au voisinage de la jonction , les trous de la zone P vont neutraliser les électrons libres de la zone N (il y a diffusion des charges). Ce phénomène va s'arrêter quand le champ électrique Eint créé par les atomes donneurs ou accepteurs (qui vont devenir respectivement des charges + et -) va être suffisant pour contrarier le mouvement des charges mobiles. Ceci constitue une barrière de potentiel pour les porteurs majoritaires. Par contre, cette barrière de potentiel va favoriser le passage des porteurs minoritaires (conduction électrique).

      Les deux courants antagonistes (diffusion des majoritaires et conduction des minoritaires) s'équilibrent et leur somme est nulle en régime permanent et en l'absence de champ électrique extérieur.

      Avec un générateur en sens direct.

      La barrière de potentiel interne empêche donc toute circulation de courant. Si on applique un champ externe à l'aide d'un générateur en branchant le pôle + sur la zone P et le pôle - sur la zone N, on peut annuler les effets du champ interne et permettre au courant de circuler : le phénomène d'attraction des électrons libres de la partie N par les trous de la partie P (diffusion) n'est plus contrarié, et le générateur va pouvoir injecter des électrons dans la zone N et les repomper par la zone P.

      Le courant de conduction constitué par les porteurs minoritaires prend une valeur If indépendante du champ extérieur.

      Le courant total est la somme des deux courants, soit pratiquement le courant direct dû aux porteurs majoritaires dès que la tension atteint la centaine de mV.

      La diode est alors polarisée dans le sens direct, et un courant relativement intense peut circuler : de quelques dizaines de milliampères pour des diodes de signal à quelques ampères pour des diodes de redressement standard, voire à des centaines d'ampères pour des diodes industrielles de très forte puissance.

      Avec un générateur en sens inverse.

      Si on branche le générateur dans le sens inverse du cas précédent, on renforce le champ électrique interne, et on empêche le passage des porteurs majoritaires : les électrons libres sont repoussés dans la zone N et les trous dans la zone P ; on accentue la séparation des charges (zone de déplétion).

      Par contre, les porteurs minoritaires (trous pour la zone N et électrons libres pour la zone P) peuvent traverser la jonction et reboucler par le générateur : ils forment le courant inverse If qui dépend essentiellement de la température.

      Le champ extérieur repousse les charges qui vont se trouver à une distance sensiblement proportionnelle à |V|, créant ainsi une capacité proportionnelle à cette distance, donc à |V|.

      Cette capacité est inhérente à toute jonction de semi conducteurs, et va constituer la principale limitation (en régime linéaire tout du moins) au fonctionnement à haute fréquence des composants électroniques (diodes, transistors et circuits intégrés les employant).

    CARACTÉRISTIQUES ÉLECTRIQUES.

      Caractéristique courant/tension.
        <
        Caractéristique globale.
        On a vu précédemment que le courant était négligeable pour une tension Vd = Vp-Vn négative (ceci est vrai jusqu'à une tension Vc dite tension de claquage). Au dessus d'un certain seuil Vo de tension Vd positive, le courant direct croit très rapidement avec Vd.

        Le seuil Vo (barrière de potentiel) dépend du semi conducteur intrinsèque de base utilisé. Il est d'environ 0,2V pour le germanium et 0,6V pour le silicium.

        La caractéristique a la forme suivante :

        Fig. 2. Caractéristique complète.

        Caractéristique directe (Vd > 0)

        Fig. 3. Caractéristique directe d'une diode.

        Sur ce type de diode au silicium, le courant croit assez rapidement au delà de 0,7V. C'est une diode de redressement supportant 1A en direct et 600V en tension inverse.

        Autour de zéro.
        La caractéristique passe par l'origine. Pour Vd négatif, le courant tend rapidement vers la limite -If (courant de fuite) , car le courant de diffusion dû aux porteurs majoritaires va s'annuler.

        Caractéristique inverse (Vd < 0). Phénomène de claquage.
        Quand la tension appliquée dépasse la valeur spécifiée par le fabricant, le courant décroît (attention : il est déjà négatif !) très rapidement. S'il n'est pas limité par des éléments externes, il y a destruction rapide de la diode. Deux phénomènes sont à l'origine de ce résultat :

        phénomène d'avalanche : quand le champ électrique au niveau de la jonction devient trop intense, les électrons accélérés peuvent ioniser les atomes par chocs, ce qui libère d'autres électrons qui sont à leur tour accélérés Il y a divergence du phénomène, et le courant devient important.

        phénomène Zener : les électrons sont arrachés aux atomes directement par le champ électrique dans la zone de transition et créent un courant qui devient vite intense quand la tension Vd atteint une valeur Vz dite tension Zéner.

        Si on construit la diode pour que le phénomène Zéner l'emporte sur le phénomène d'avalanche (en s'arrangeant pour que la zone de transition soit étroite), on obtient une diode Zéner.

        On utilise alors cette diode en polarisation inverse. L'effet zéner n'est pas destructif dans ce cas. Ces diodes sont très utilisées pour la régulation de tension.

        Équation.

        Fig. 4. Linéarité de Log (I) fonction de V.

        la courbe Fig. 2. (à l'exception de la zone de claquage) répond assez bien à la formule suivante, expliquée par la thermodynamique statistique :

        où :

        If est le courant de fuite

        q la charge de l'électron = 1,6E-19C

        k constante de Boltzman = 1,38E-23 J/K

        T température absolue

        La loi logarithmique [1] est bien illustrée par les figures 3 et 4. La courbe expérimentale s'éloigne toutefois de la théorie aux forts courants, où le modèle n'a pas tenu compte d'autres phénomènes dont les chutes de tension ohmiques dans le semi conducteur.

        A noter que sur la figure 4, le courant maxi représenté est égal au 1/10ème admissible par cette diode.

        Effet de la température.
        Pour Vd positif, la diode a un coefficient de température négatif égal à -2mV/K. Cette dérive en température est suffisament stable pour qu'on puisse utiliser des diodes comme thermomètres.

        Pour Vd négatif, le courant de fuite If varie très rapidement avec la température. Il est plus important pour le germanium que pour le silicium, et croît plus vite, ce qui devient rapidement gênant. Dans le silicium, ce courant double tous les 6°C.

      Résistance différentielle (ou dynamique).

      Fig. 5. Résistance dynamique.

      La résistance dynamique étant l'inverse de la pente de la caractéristique en un point donné, on peut la déduire par dérivation de la formule [1] :

      C'est la résistance dynamique au point de fonctionnement (Vd , Id). Elle est fonction du courant de polarisation Id au point étudié.

      La figure 5 donne la valeur de rd en fonction de la tension de la diode : les variations sont très importantes.

      Schéma équivalent.
      La représentation de la diode par sa loi logarithmique est un peu complexe pour l'emploi de tous les jours. Plusieurs schémas équivalents simplifiés sont proposés :

        Diode idéale.
        Dans ce cas, on néglige la tension de seuil et la résistance interne de la diode. La caractéristique est alors celle de la figure 6.

        Ce schéma est utile pour des pré calculs, surtout si les diodes sont employées dans des circuits où les tensions sont élevées (plusieurs dizaines de volts) : la tension de coude est alors négligeable.

        Fig. 6. Caractéristique idéale.

        Diode avec seuil.
        On peut continuer à négliger la résistance interne, mais tenir compte du seuil de la diode. La caractéristique devient :

        Fig. 7. Caractéristique avec seuil.

        Ce schéma est le plus utilisé pour les calculs.

        Diode avec seuil et résistance.
        Ici, on prend en compte la résistance de la diode. Ceci peut être utile si on utilise la diode en petits signaux alternatifs et qu'on a besoin de sa résistance dynamique.

        Fig. 8. Caractéristique avec seuil et résistance.

        Attention : dans ce cas, on considère que la résistance dynamique est constante, ce qui n'est vrai que si la variation du signal alternatif est très petite autour du point de polarisation en continu.

UTILISATION.

Il existe divers types de diodes correspondant à des technologies différentes. Chaque technologie présente le meilleur compromis pour une utilisation donnée.

Nous allons balayer les applications des diodes en les classifiant par groupe technologique.

    Paramètres essentiels des diodes.
    En fonction de l'application considérée, on s'intéressera à certains paramètres des diodes plutôt qu'à d'autres. Certains paramètres ne sont pas spécifiés pour tous les types de diodes, sauf les suivants qui sont incontournables :

    VF : tension de coude de la diode spécifiée à un courant direct donné.

    IF : courant direct permanent admissible par la diode à la température maxi de fonctionnement.

    IFSM : courant temporaire de surcharge (régime impulsionnel). En général, pour un courant de surcharge donné, le constructeur spécifie l'amplitude des impulsions, leur durée, le rapport cyclique, et dans certains cas, le nombre maxi d'impulsions qu'on peut appliquer.

    VR : c'est la tension inverse maxi admissible par la diode (avant l'avalanche).

    IR : c'est le courant inverse de la diode. Il est spécifié à une tension inverse donnée, et pour plusieurs températures (généralement 25°C et Tmax). Ce courant n'est pas seulement celui dû aux porteurs minoritaires. Il provient aussi des courants parasites à la surface de la puce (le silicium est passivé par oxydation, et il peut subsister des impuretés qui vont permettre le passage de faibles courants). Le boitier d'encapsulation de la puce de silicium est aussi source de fuites.

    Ces symboles sont ceux généralement employés par les différents constructeurs, mais il peut y avoir des variantes, et il est toujours sage de se reporter à la documentation du constructeur pour savoir comment sont spécifiés les paramètres, et à quoi ils correspondent exactement.

    DIODES DE REDRESSEMENT.

    Une des principales applications de la diode est le redressement de la tension alternative du secteur pour faire des générateurs de tension continue destinés à alimenter les montages électroniques (entre autres).

    Il y a deux types principaux de diodes de redressement : les diodes standard pour le redressement secteur classique, et les diodes rapides pour les alimentations à découpage. Nous étudierons ces dernières ultérieurement.

      Caractéristiques physiques.
      Les diodes de redressement standard sont les moins sophistiquées, et ne font l'objet d'aucun traitement particulier, les conditions d'utilisations étant peu contraignantes.

      Elles ont des tensions VR comprises entre 50 et 1000V environ, et les courants IF vont de 1A à plusieurs centaines d'ampères.

      Avant le système de redressement, on a presque toujours un transformateur qui sert à abaisser la tension secteur (les montages électroniques fonctionnent souvent sous des tensions de polarisation allant de quelques volts à quelques dizaines de volts), et qui sert aussi à isoler les montages du secteur (220V, ça peut faire très mal !).

      Redressement simple alternance.
      C'est le redressement le plus simple qui soit : quand la tension aux bornes du transformateur Vt dépasse la tension de seuil de la diode, celle-ci conduit, laissant passer le courant direct dans la charge. La tension aux bornes de la charge Vr est alors égale à la tension aux bornes du transformateur moins la tension directe VF de la diode.

      Fig. 9. Redressement avec une diode.

      Quand la tension aux bornes du transformateur devient inférieure à la tension de seuil, la diode est bloquée ; il ne subsiste que le courant de fuite, qui est négligeable en comparaison du courant direct.

      La tension aux bornes de la diode est alors égale à celle aux bornes du transformateur : il faudra choisir une diode avec une tension VR au minimum égale à la tension crête du secondaire du transformateur.

      Redressement double alternance.
        Avec transfo double enroulement.

        Fig. 10. Redressement avec transfo double sortie.

        Le montage précédent présente l'inconvénient de ne laisser passer que la moitié du courant que peut délivrer le transformateur. Pour remédier à celà, on utilise un transformateur avec deux enroulements secondaires que l'on câble de manière à ce qu'ils délivrent des tensions en opposition de phase sur les diodes.

        On notera la chute de tension dans les diodes : elle devient non négligeable quand les tensions alternatives sont faibles (4V crête dans l'exemple ci-dessus).

        Dans ce cas, tout se passe comme si on avait deux montages identiques à celui de la Fig. 9 qui fonctionnent l'un pour l'alternance positive, l'autre pour l'alternance négative. On vérifie bien (Fig. 11 et 12) que le courant dans la charge est toujours orienté dans le même sens.

        Fig. 11. Alternance positive.

        Fig. 12. Alternance négative.

        Les diodes sont plus sollicitées que pour le montage simple alternance : en effet, la diode qui ne conduit pas devra supporter en plus de la tension aux bornes de son secondaire de transformateur, la tension aux bornes de la résistance. Au total, elle devra supporter une tension VR double de celle requise dans le montage à simple alternance, soit deux fois la tension crête présente sur chacun des secondaires.

        Avec pont de Grætz.

        Fig.13. Redressement avec pont de diodes.

        Il existe une autre manière de faire du redressement double alternance, ne nécessitant pas un transformateur à double enroulement : on utilise 4 diodes montées en pont. Des ponts tous faits sont disponibles dans le commerce, permettant de réduire le nombre de composants du montage.

        Lorsque la tension aux bornes du transformateur est positive, D1 et D4 conduisent, et quand elle est négative, D2 et D3 conduisent (Fig. 14 et 15).

        Fig. 14. Alternance positive.

        Fig.15. Alternance négative.

        Chaque diode n'a à supporter qu'une fois la tension crête du secondaire du transformateur (contre deux fois pour le montage précédent), mais en revanche, on a deux tensions directes de diode en série. La puissance totale dissipée dans les diodes est double par rapport à la solution précédente.

        Quelle solution choisir ?
        Quand on en aura la possibilité, on préfèrera la solution à transfo à point milieu, pour plusieurs raisons :

        le transfo n'est pas plus cher que celui à secondaire simple.

        avec un transfo à un seul secondaire, on ne peut pas faire d'alimentation double symétrique en redressement double alternance. Ce type de transfo est moins universel .

        le fait que les diodes aient à tenir une tension double n'est pas un problème dans la plupart des cas, car les tensions redressées sont très souvent bien inférieures aux tensions VR minimum des diodes disponibles dans le commerce.

        dans le montage en pont, la charge est flottante par rapport au transformateur, ce qui peut être gênant dans certains cas.

      Filtrage.
      Les montages précédents délivrent des tensions redressées mais non continues.

      Pour obtenir une tension (quasi) continue, il suffit de mettre un gros condensateur en parallèle avec la charge.

        Redressement simple alternance.
        Ici, la charge est absolument quelconque, et peut être un montage électronique complexe ayant une consommation en courant aléatoire.

        Fig. 16. Redressement simple alternance et filtrage.

        Sur le graphique du bas de la Fig. 16, on voit en pointillé la tension redressée telle qu'elle serait sans condensateur. En traits pleins épais, on voit la tension filtrée.

        Sur ce graphe, le courant de décharge du condensateur est linéaire : il correspond à l'hypothèse de décharge à courant constant.

        Le fonctionnement est simple : quand la tension aux bornes du transformateur est supérieure à la tension aux bornes du condensateur additionnée de la tension directe de la diode, la diode conduit. Le transformateur doit alors fournir le courant qui va alimenter la charge et le courant de recharge du condensateur.

        Quand la tension du transformateur devient inférieure à celle du condensateur plus la tension de coude de la diode, la diode se bloque. L'ensemble condensateur / charge forme alors une boucle isolée du transformateur.

        Le condensateur se comporte comme un générateur de tension, et il restitue l'énergie accumulée dans la phase précédente.

        A noter que la tension aux bornes du condensateur étant en permanence voisine de la tension crête positive du transformateur, lorsque celui-ci fournit la tension de crête négative, la diode doit supporter deux fois la tension crête délivrée par le transformateur : on perd le seul avantage (hormis la simplicité) du montage à redressement simple alternance.

        Calcul du condensateur : dans la littérature, on trouve classiquement le calcul du condensateur pour une charge résistive. La décharge est alors exponentielle et le calcul inutilement compliqué.

        Ce calcul est assez éloigné des besoins réels : en général, on ne fait pas des alimentations continues pour les faire débiter dans des résistances !

        Très souvent, ces alimentations redressées et filtrées sont suivies d'un régulateur de tension. La charge est fréquemment un montage complexe ayant une consommation variable au cours du temps.

        Pour faire le calcul du condensateur, on prendra donc une décharge à courant constant, le courant servant au calcul étant le maximum (moyenné sur une période du secteur) consommé par la charge.

        Le critère de choix ne sera pas un taux d'ondulation qui n'a souvent aucune utilité pratique, mais une chute de tension maxi autorisée sur le condensateur pour que le montage connecté en aval fonctionne correctement.

        Avec ces hypothèses, le calcul du condensateur devient très simple : On considère que le condensateur C se décharge à courant Imax constant pendant un temps [image] T et que la chute de sa tension est inférieure à [image] V.

        On a alors la relation :

        Le temps [image] T choisi va être approximé à la période du secteur. En pratique, le condensateur va se décharger moins longtemps (Fig. 16), on va donc le surdimensionner légèrement.

        L'erreur commise est en fait très faible comparée à la dispersion que l'on aura sur le résultat de par les tolérances des composants, et notamment des condensateurs de filtrage : on utilise des condensateurs chimiques qui ont des tolérances très larges (-20% / +80% en général) et qui n'existent souvent que dans la série E6 (1 ; 1,5 ; 2,2 ; 3,3 ; 4,7 ; 6,8). Les transformateurs sont eux aussi assez dispersés, ce qui fait qu'au final, mieux vaut prévoir large pour éviter les mauvaises surprises !

        Pour un redressement simple alternance, on aura un [image] T de 20ms, qui correspond à l'inverse de la fréquence secteur 50Hz. La valeur du condensateur est alors :

        Il faudra veiller à choisir un condensateur supportant au moins la tension crête du transformateur à vide (la tension sera plus faible en charge du fait des chutes de tensions diverses (résistance du transfo, diode ).

        Redressement double alternance.
        Les hypothèses seront les mêmes que précédemment. La seule différence viendra du temps [image] T ; vu qu'on a un redressement double alternance, la fréquence du courant redressé est double de celle du secteur. La formule de calcul du condensateur devient donc :

        Comme dans la formule [4], F est la fréquence secteur (50Hz en France).

        A chute de tension égale, le condensateur sera donc deux fois plus petit que pour le redressement simple alternance, ce qui est intéressant, vu la taille importante de ces composants.

        La diode aura à tenir deux fois la tension crête délivrée par chaque enroulement du transformateur.

        Fig. 17. Redressement double alternance et filtrage.

        Fonctionnement des diodes et transfos.
        On peut remarquer Fig. 16 et 17 que les diodes ne conduisent pas pendant toute l'alternance du secteur, mais seulement pendant un temps très court vis à vis de cette alternance. L'énergie qui est restituée par le condensateur dans la phase de roue libre doit être au préalable stockée pendant ce court temps de conduction des diodes.

        La conséquence de ceci, c'est que pour assurer un certain courant moyen dans la charge, l'ensemble transfo plus diode devra débiter un courant de crête beaucoup plus intense que le courant moyen lors des phases de conduction des diodes (environ 15 fois le courant moyen). Voir chronogramme (GIF couleur 15ko)

        La chute de tension dans les diodes sera alors importante (plus près d'1V que de 0,6V) ainsi que la chute de tension dans les résistances du transformateur.

        Il ne faudra pas perdre ces considérations de vue quand on voudra calculer l'alimentation au plus juste !

        L'autre conséquence est le démarrage de l'alimentation : lorsqu'on branche le transformateur sur le secteur, on peut se trouver au maximum de tension de l'alternance secteur. La charge du transformateur, principalement constituée du condensateur de filtrage, sera l'équivalent d'un court-circuit. Le courant d'appel sera alors uniquement limité par la résistance interne du transformateur (quelques dizièmes d'ohms à quelques ohms), et il sera très intense : les diodes devront supporter ce courant (paramètre IFSM)

      Alimentations doubles symétriques.
      Si on analyse le fonctionnement du redresseur double alternance à transformateur à point milieu, on s'aperçoit que chaque secondaire débite du courant seulement pendant une alternance. L'autre alternance serait susceptible de fournir un courant négatif.

      Partant de cette constatation, on peut imaginer facilement une alimentation double symétrique, avec 4 diodes disposée en pont : deux diodes vont conduire les alternances positives des secondaires du transformateur, et les deux autres les alternances négatives.

      Le point milieu du transformateur sera le potentiel commun des deux alimentations.

      Fig. 18. Alimentation double positive et négative.

      On peut bien évidemment mettre un condensateur aux bornes de chacune des charges pour filtrer les tensions redressées obtenues.

      Ces alimentations sont incontournables dans les montages symétriques où il est nécessaire d'amplifier des tensions continues, et notamment dans les montages à amplificateurs opérationnels

      Doubleur de tension.
      Dans certaines applications, on peut avoir besoin de tensions continues très élevées (quelques milliers de volts). On pourrait les obtenir avec un transformateur élévateur et un redressement / filtrage classique.

      Il existe une solution moins onéreuse faisable avec des diodes et des condensateurs : c'est le doubleur de tension.

      Le montage de la Fig. 19. se décompose en deux : redressement / filtrage par la cellule D1 / C1, puis détecteur de crête D2 / C2.

      Fig. 19. Doubleur de tension de Schenkel.

      Aux bornes du condensateur C1, si la charge est infinie, la tension Vc restera constante et égale à la tension crête du transformateur.

      La diode D1 verra à ses bornes la tension Vt + Vc, dont la valeur crête est égale à deux fois la tension crête du transformateur. Tout se passe comme si la tension du transformateur avait été translatée d'une fois la valeur de la tension crête.

      Il suffit alors de filtrer cette tension à sa valeur de crête avec D2 et C2 : on obtient une tension continue égale à deux fois la tension crête du transformateur.

      Il est possible de continuer ce raisonnement, et en ajoutant d'autres cellules semblables à celle du doubleur, on peut tripler, quadrupler ou plus les tensions.

      Ces montages sont utilisés entre autres pour générer les tensions d'accélération des tubes d'oscilloscopes (2 à 5 kV). On remarquera qu'ils ne peuvent pas débiter beaucoup de courant (les tensions mises en jeu ne permettent pas d'utiliser des condensateurs de forte valeur), et donc, ils sont plutôt destinés à des applications quasi statiques.

  1. DIODES À AVALANCHE CONTRÔLÉE.

    Les diodes de redressement standard ne sont pas garanties pour fonctionner au delà de la tension VR spécifiée. Si on utilise des diodes standard dans des milieux parasités, il se peut qu'on dépasse momentanément la tension inverse maxi et qu'on détruise la diode.

    Certaines applications ont besoin de diodes qui ne soient pas détruites par une entrée en avalanche.

      Caractéristiques physiques.
      Les diodes à avalanche contrôlées sont fabriquées dans du silicium de meilleure qualité que les diodes standard : meilleure homogénéité du cristal, traitement de surface poussé limitant les courants de fuite

      La résistivité du silicium est ainsi plus homogène, et lorsque le phénomène d'avalanche se produit, c'est dans tout le volume du cristal qui peut alors supporter des puissances très élevées pendant quelques dizaines de µs.

      Ces diodes sont sévèrement triées en fin de fabrication pour détecter les défauts éventuels.

      On spécifie en plus des IR et VR standards une tension inverse maxi pour un courant inverse donné.

      Protection contre les surtensions.
      Une des applications est l'utilisation dans des milieux parasités : des surtensions brèves (quelques µs) d'une amplitude très supérieure à la tension VR de la diode peuvent apparaître : la diode va partir en avalanche, et limiter la surtension parasite. Ce phénomène ne sera pas destructif car la diode est conçue pour fonctionner en avalanche sans casser.

      Il y a une double fonction d'autoprotection (la diode n'est pas détruite), et de protection de l'environnement de cette diode (écrêtage de la surtension).

      Mise en série de diodes.
      Lorsqu'on veut bloquer des fortes tensions sans faire appel à des diodes spéciales haute tension (chères et difficiles à se procurer), on peut mettre en série plusieurs diodes dont la somme des VR sera supérieure à la tension à bloquer.

      Si on met en série des diodes ordinaires, les tensions ne vont pas se répartir de façon égale pour toutes les diodes comme le montre la Fig. 20.

      Fig. 20. Caractéristiques de deux diodes.

      Si on met les deux diodes de cet exemple en série, sans autres composants en parallèle, le courant de fuite sera le même pour les deux diodes, et tel que VD1 + VD2 = U, tension totale à bloquer ; VD1 et VD2 sont les tensions aux bornes des diodes D1 et D2 pour le courant de fuite commun IR.

      La diode D1 qui fuit plus que l'autre à tension donnée va imposer un courant IR entraînant une tension aux bornes de D2 supérieure à la tension de claquage VR : D2 va être détruite par avalanche.

      Dans le cas général où on met plusieurs diodes en série, la rupture de la première entraîne la destruction en chaîne de toutes les autres diodes.

      La solution est dans les diodes à avalanche contrôlée : les courants de fuite (hors porteurs minoritaires) sont très réduits par construction, et une ou plusieurs diodes peuvent rentrer en avalanche sans problèmes. Le courant de fuite étant faible, la puissance dissipée restera dans les limites admissibles par le composant.

  2. DIODES DE REDRESSEMENT RAPIDES.

      Notions de charge recouvrée.
      Nous avons déjà mentionné le phénomène de diffusion au travers de la jonction PN : les électrons majoritaires de la zone N franchissent la jonction et tendent à neutraliser les trous de la zone P et vice versa.

      Quand la jonction est polarisée en direct, le champ électrique externe s'oppose au champ électrique interne crée par les ions dépossédés de leur électron (zone N) ou trou (zone P) libres, et permet ainsi une plus grande diffusion des porteurs majoritaires dans la région de type opposé où ils deviennent minoritaires. Ils se recombinent alors avec une charge de signe opposé.

      Ce phénomène de recombinaison n'est pas instantanné : les porteurs ont une durée de vie t égale à environ 1ms dans le silicium. Il existe donc dans le cristal des charges en excès de part et d'autre de la jonction, à la manière de charges présentes sur les armatures d'un condensateur.

      On associe d'ailleurs à cette charge, appelée charge stockée , une capacité appelée capacité de diffusion .

      Si on inverse brusquement la polarité aux bornes de la diode pour la bloquer, ces porteurs vont se comporter de la même manière que les porteurs minoritaires en régime inverse établi : ils vont être attirés de l'autre côté de la jonction par le champ électrique externe et vont former un courant intense qui va s'ajouter au courant de fuite Is, jusqu'à ce que la charge stockée disparaisse.

      Ce courant va décroître jusqu'à devenir nul pendant un temps tRR appelé temps de recouvrement inverse .

      La charge stockée est d'autant plus importante que le dopage est important. Le dopage intervenant directement dans la conductivité du cristal, il se pose le problème pour les diodes de puissance qui nécessitent une conductivité, et donc un dopage importants.

      Pour diminuer la charge stockée dans ces composants, on utilise des pièges recombinants, qui sont souvent des atomes d'or. Ils diminuent la durée de vie des porteurs, ce qui induit une charge stockée plus faible.

      Utilisation.
      Ces diodes sont utilisées en électronique de puissance partout où l'on doit commuter très rapidement des courants importants. Elles sont le complément indispensable des transistors de puissance rapides.

      Des diodes standard sont inutilisables dans ces cas là car elles sont trop lentes. Lors de la commutation des transistors, elles se comporteraient comme des court circuits (pendant le temps de recouvrement inverse), ce qui entraînerait des surcourants dans les transistors, et leur destruction plus ou moins rapide.

    DIODES DE SIGNAL.

    Les diodes précédemment étudiées font intervenir des courants et tensions non négligeables. Les diodes de signal sont utilisées dans des applications à bas niveaux de courants et tensions.

      Carctéristiques physiques.
      Les diodes de signal n'ont pas besoin de tenir des fortes tensions inverses : par construction, elles pourront avoir une capacité parasite faible, et donc fonctionner à des fréquences élevées.

      Ces caractéristiques sont obtenues grâce à une surface de jonction réduite et un faible dopage (diminution des charges stockées).

      Détecteur de crête.
      Ce dispositif permet de mémoriser la valeur crête d'un signal. Il est très utilisé en instrumentation.

      C'est en fait un redresseur simple alternance avec filtrage dont la charge est quasi nulle (aux courants de fuite près) : la constante de temps de décharge du condensateur est théoriquement infinie, (très grande en pratique).

      Il se charge donc à la valeur crête (moins la tension de seuil de la diode) et reste chargé à cette valeur.

      La résitance R sert à limiter le courant de charge du condensateur à une valeur raisonnable pour le générateur d'attaque.

      Lorsque la tension e est supérieure à la tension aux bornes du condensateur U plus la tension de coude de la diode, celle ci conduit et charge le condensateur à travers la résistance R.

      A noter que tel quel, ce montage est inexploitable pour des petits signaux : la tension mémorisée par la diode et le condensateur est inférieure à la valeur crête du signal d'entrée de la tension de seuil de la diode.

      Il existe une version améliorée avec amplificateur opérationnel qui pallie cet inconvénient. Il faut aussi adjoindre à ce montage un sytème permettant de décharger le condensateur pour faire une nouvelle mesure.

      Fig. 21. Détecteur de crête.

      Détection AM.
      En radio diffusion, on ne peut pas émettre correctement un signal audible (20Hz-20kHz) directement sous forme d'une onde radio-électrique : il faut passer par un signal haute fréquence (Fig. 22.).

      Fig. 22. Signal HF modulé en amplitude.

      Fig. 23. Détecteur grandes ondes .

      Le signal haute fréquence (quelques centaines de kHz), qu'on appelle la porteuse est modulé en amplitude par le signal audio (basse fréquence) à émettre. A l'arrivée ( le poste à transistors !), on doit séparer les deux signaux. On le fait très simplement avec une diode et un condensateur (Fig. 23.).

      Fig. 24. Signal démodulé.

      Sans la résistance R, on aurait un détecteur de crête comme précédemment. On détermine cette résistance de manière à ce que la constante de temps RC soit petite devant la période de la porteuse, et grande devant la période du signal à émettre : on arrive ainsi à reconstituer le signal basse fréquence (BF) : c'est la courbe en gras de la Fig. 24.

      Thermomètres. Compensation thermique.
      C'est une utilisation importante des diodes. La tension directe des jonctions PN en silicium est affectée d'un coefficient de température négatif (environ -2mV/°C).

      Certains montages à transistors nécéssitent une dérive minimum en température. On peut arriver à compenser cette dérive à l'aide d'une diode couplée thermiquement au transistor et placée judicieusement dans son circuit de base (voir chapitre sur les transistors).

      Cette dérive en température peut aussi être utilisée comme thermomètre sur un montage. Lorsque la diode détecte des températures trop élevées, elle peut commander un circuit qui va (par exemple) couper certaines fonctions du montage (autoprotection). Cette fonction est très utilisée dans les composants intégrés.

DIODES SPÉCIALES.

    DIODES ZENER.

      Caractéristique.

      Fig. 25. Caractéristique d'une diode zéner.

      Nous avons déjà parlé de l'effet zéner. Il concerne la caractéristique inverse de la diode.

      En direct, une diode zéner se comporte comme une mauvaise diode normale.

      En inverse, on fait en sorte que par construction l'effet zéner et / ou d'avalanche se produise à une tension bien déterminée, et ne soit pas destructif. La caractéristique inverse présente alors l'allure d'un générateur de tension à faible résistance interne.

      En général, les constructeurs spécifient :

      la tension d'avalanche Vzt pour un courant déterminé Izt. (les valeurs de tension sont normalisées).

      à ce point de fonctionnement Vzt / Izt, on donne la résistance dynamique de la diode rzt.

      le courant Izm pour lequel la puissance dissipée dans le composant sera le maximum admissible.

      on indique aussi le coefficient de variation en température de la tension Vzt.

      En dessous de Vzt = 5V, c'est l'effet zéner qui prédomine. Au dessus, c'est l'effet d'avalanche.

      L'effet zéner est affecté d'un coefficient de température négatif (Vzt diminue quand la température augmente), et l'effet d'avalanche d'un coefficient positif. Les diodes ayant une tension Vzt d'environ 5V ont un coefficient de température nul, car les deux phénomènes se produisent de manière équilibrée, et leurs effets se compensent.

      L'effet d'avalanche est plus franc que l'effet zéner, ce qui fait que le coude de tension inverse est plus arrondi pour les diodes zéner de faible tension.

      Les diodes optimales en terme d'arrondi de coude et de résistance dynamique ont des tensions zéner voisines de 6 à 7V.

    1. Schéma équivalent.

      Pour simplifier les calculs, et comme pour la diode, on va définir un schéma équivalent approchant la réalité.

      Si on utilise le composant suffisamment loin du coude, le schéma suivant modélise bien le comportement d'une diode zéner :

      Fig. 26. Schéma équivalent de la diode zéner

      On définit une tension de coude Vzo, et une résistance interne constante Rz.

      Ce schéma sera à utiliser avec beaucoup de prudence sur des zéners de faible tension (< 5V) : leur coude est très arrondi, et la résistance dynamique varie beaucoup avec le courant. Pour des tensions supérieures à 5V, il n'y aura en général pas de problèmes.

    2. Régulation de tension.

      De par leurs caractéristiques de générateur de tension, ces diodes sont idéales pour réguler des tension continues ayant une ondulation résiduelle non négligeable (cas des tensions redressées filtrées).

      Fig. 27. Régulation de tension avec diode zéner.

      Il est nécessaire d'intercaler une résistance (ou un générateur de courant) entre le générateur de tension filtrée et la zéner de régulation : ces deux éléments ayant des caractéristiques de générateurs de tension à faible résitance interne, on ne peut pas les brancher directement l'un sur l'autre sans les détruire.

      Pour que la zéner fonctionne et assure son rôle de régulateur, il faut qu'un courant Iz non nul circule en permanence dans ce composant, et ce quelles que soient les variations de la tension d'entrée Vc et de la charge Ru.

      La résistance R assure donc le rôle de polarisation de la zéner, et elle sera calculée pour que la condition énoncée ci-dessus soit remplie. Il faudra aussi veiller à ce que le courant Iz ne dépasse pas le courant Izm, sous peine de détruire le régulateur.

      Fig. 28. Schéma équivalent du régulateur

      Lorsque la polarisation est correcte, on peut faire le schéma équivalent du montage. La tension d'entrée du régulateur a été scindée en une tension continue (la tension moyenne aux bornes du condensateur), et une tension alternative (l'ondulation).

      On peut définir deux coefficients de stabilisation pour caractériser ce montage. En effet, il est loin d'être parfait, et la tension de sortie va varier lorsque la tension d'entrée et / ou la charge vont varier. On distingue deux coefficients :

      Stabilisation amont : ce coefficient est représentatif de la sensibilité du montage aux variations de la tension non régulée, et ceci à charge constante . Si on utilise les notations de la Fig. 27, c'est le rapport ( [image] Vz/ [image] Vc)Iu = cte.

      Stabilisation aval : ce coefficient est représentatif de la variation de la tension de sortie quand le courant dans la charge varie (Ru varie de ± [image] Ru), et ceci à tension d'entrée constante. C'est le rapport ( [image] Vz/ [image] Iu)Vc = cte, soit en fait, l'impédance de sortie du montage . Ce paramètre est très important dans tous les régulateurs de tension.

      Il est plus simple pour calculer ces coefficients d'utiliser le schéma équivalent alternatif petits signaux. On retire alors toutes les sources de tension continues.

      Fig. 29. Schéma équivalent petits signaux

      Pour le coefficient de stabilisation amont, on a :

      Comme en général Ru >> Rz, cette formule devient :

      On voit le dilemme : plus R est grand, plus la stabilisation amont est bonne, mais en contrepartie, quel gâchis ! Il faudrait prévoir des tensions filtrées très grandes par rapport aux tensions régulées pour avoir un bon coefficient de régulation. Cela ferait beaucoup d'énergie perdue dans R. Pour pallier cet inconvénient, on remplace R par un générateur de courant : la chute de tension à ses bornes pourra être petite, et par contre, sa résistance interne (celle qui va servir pour le calcul en remplacement de R) sera très grande : on a les deux avantages, une très bonne régulation et un bon rendement.

      Le coefficient de stabilisation aval est égal à l'impédance de sortie du montage ; c'est la résistance du générateur de Thévenin équivalent, soit :

      R étant souvent très supérieur à Rz, on obtient :

      Dans ce cas, il n'y a pas grand chose à espérer d'un artifice quelconque pour améliorer cette valeur, sauf à rajouter d'autre composants actifs comme des transistors.

      En général, on rajoute toutefois un condensateur en parallèle avec la zéner : son impédance vient diminuer celle du montage aux fréquences élevées. C'est avantageux si le montage alimenté a une consommation en courant avec des composantes à hautes fréquences. Ce condensateur diminue aussi le bruit interne de la zéner qui est assez important.

      Ce type d'alimentation est appelé régulateur shunt , car le courant de régulation Iz est dérivé à la masse.

      En pratique, ces régulateurs sont utilisés dans des montages simples nécessitant peu de puissance.

    3. Écrêtage des surtensions.

      De par leurs caractéristiques, les diodes zéner sont idéales pour écrêter des surtension (commutation de selfs ou autres) et sont donc toutes indiquées pour la protection d'autre semi-conducteurs sensibles a ces surtensions.

      Certains composants comme les transils ont des caractéristiques similaires aux zéners, mais peuvent supporter des puissances crête considérables pendant de courts instants. Ils sont utilisés pour protéger les installations coûteuse contre la foudre et les parasites d'équipements industriels (gros moteurs, relais de puissance, commutateurs statiques ).

  1. DIODES ÉLECTROLUMINESCENTES.

    1. Caractéristique.

      Ces diodes spécifiques à base d'arseniure de gallium ont la propriété d'émettre de la lumière dans une bande de fréquence déterminée par les caractéristiques du matériau employé quand elles sont traversées par un courant direct.

      Il en existe de diverses couleurs (jaune, orangé, rose, rouge, vert, infrarouges).

      Leur rendement lumineux est assz faible. On les utilise avec un courant direct d'environ 10 à 20mA.

      La tension de coude de ces composants est plus élevée que pour les diodes standard, et elle dépend de la couleur. Elle va de 1,2 à 2V environ.

    2. Utilisation.

      Les utilisations des Led sont de plus en plus nombreuses, car ces composants sont plus fiables que des lampes à incandescence, et leur rendement est un peu meilleur.

      On les rencontre partout où on a besoin de témoins lumineux, et de plus en plus, associées en matrices pour remplacer des grosses lampes (feux tricolores de circulation par exemple), ou pour faire des panneaux d'affichage électroniques (heure, température, publicités diverses ).

      Les diodes à infrarouges servent beaucoup dans les télécommandes d'appareils TV / HIFI. On les utilise alors avec des forts courants pulsés.

  2. AUTRES.

    Il existe encore beaucoup d'autres variétés de diodes. Citons entres autres :

    les diodes Schottky, à jonction métal / semi-conducteur : cette jonction hétérogène est caractérisée par l'absence de stockage des charges, elle est donc très rapide. Elle est très utilisée dans les circuits logiques rapides (TTL Schottky).

    les diodes varicap : on utilise la variation de la capacité de jonction avec la polarisation inverse dans des oscillateurs ou des circuits d'accord. On fait alors facilement varier la tension d'oscillation ou d'accord en modifiant la tension de polarisation.


COURS.HTM

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/TRANS/COURS.HTM#T02

PRÉAMBULE

Il existe une catégorie de composants (qu'ils soient électriques, mécaniques, etc ) très intéressante : c'est celle qui permet d'obtenir en sortie du dispositif une grandeur de même nature et proportionnelle au stimuli d'entrée. Les exemples foisonnent :

le levier, qui permet d'avoir en sortie un effort plus important qu'en entrée, ou bien un déplacement plus important (ou plus faible) que celui appliqué à l'entrée.

l'engrenage, qui est la même chose que le levier pour les mouvements rotatifs : il permet de multiplier ou diviser la vitesse ou bien le couple d'entrée.

le transformateur, qui permet de multiplier ou diviser la tension d'entrée.

Dans chacun de ces cas, la variable de sortie est de même nature que le stimuli à l'entrée, et il existe un coefficient de proportionnalité entre les deux, indépendant du stimuli d'entrée, donc intrinsèque au dispositif.

Il faut toutefois noter que dans tous les cas cités, il y a conservation de l'énergie : l'énergie à la sortie du composant est la même que celle à l'entrée.

Il existe d'autres dispositifs présentant les mêmes caractéristiques que ceux précédemment cités, et qui en plus, permettent de multiplier l'énergie : on trouve en sortie du dispositif une énergie supérieure à celle fournie à l'entrée. Bien entendu, il n'y a pas de génération spontanée d'énergie, il faudra donc au dispositif une entrée supplémentaire par laquelle une source sera susceptible de fournir de l'énergie.

Dans ce cas, il n'y a pas seulement transformation de la sortie proportionnellement à l'entrée, mais transfert d'énergie d'une source extérieure à la sortie du dispositif, ce transfert étant contrôlé par l'entrée.

Des exemples mécaniques bien connus sont respectivement les freins et la direction assistée.

Dans le premier cas, l'effort de freinage est proportionnel à l'effort exercé sur la pédale, mais une source d'énergie auxiliaire permet d'avoir à la pédale un effort beaucoup plus faible que ce qu'il faudrait sans l'assistance.

Dans le deuxième cas, on a la même chose : les roues tournent proportionnellement à l'angle de rotation du volant, mais la plus grosse partie de l'effort est prise en charge par un dispositif hydraulique.

Dans les deux cas, le dispositif permet d'amplifier l'effort exercé tout en le conservant proportionnel au stimuli d'entrée, ce qui facilite la commande.

Un tel dispositif est en fait un robinet de régulation d'énergie : il faut disposer d'un réservoir d'énergie, on pose le robinet dessus , et on peut disposer de l'énergie proportionnellement à une commande d'entrée.

En électronique, un tel composant est intéressant, car il va permettre d'amplifier un signal, et de commander des actionneurs requérant de la puissance (haut parleurs moteurs, etc ) avec des signaux de faible niveau issus de capteurs (microphone, sonde de température, de pression, ).

Le transistor à jonction va permettre de remplir (entre autres) cette fonction en électronique. Son domaine d'action est donc particulièrement vaste

A noter qu'avant le transistor, cette fonction était remplie par des tubes à vide (triodes entre autres).

L'avènement du transistor n'a donc pas apporté la fonction miracle en elle même, mais une commodité d'utilisation, l'encombrement réduit (les tubes à vide ont besoin d'un système d'alimentation complexe avec des tension relativement élevée, et nécessitent une adaptation d'impédance en sortie (transformateur)), et plus tard, la fiabilité, le faible coût

  • PRINCIPE ET CARACTÉRISTIQUES.

    1. INTRODUCTION À L'EFFET TRANSISTOR.

      Nous avons déjà vu à propos de la diode que si celle-ci est polarisée en inverse, les porteurs minoritaires (électrons de la zone P et trous de la zone N, créés par l'agitation thermique) traversent sans problèmes la jonction et sont accélérés par le champ extérieur.

      On a vu aussi que lorsque les porteurs majoritaires d'une zone franchissent la jonction, ils deviennent minoritaires dans l'autre zone, et qu'ils mettent un certain temps à se recombiner avec les porteurs opposés.

      Partant des deux remarques précédentes, on peut déduire que si on injecte dans la zone N d'une jonction NP polarisée en inverse beaucoup de trous (qui seront dans cette zone des porteurs minoritaires) en faisant en sorte qu'ils ne se recombinent pas avec les électrons de la zone N, ils vont traverser la jonction et créer un courant dans le circuit extérieur.

      Fig. 1. Injection de trous dans une zone N.

      La figure 1 illustre ce propos : il y aura des recombinaisons (charges + et - encerclées), mais limitées, et la plupart des trous iront dans la zone P et formeront le courant I2. A noter que les recombinaisons correspondent au courant I1-I2.

    2. LE TRANSISTOR RÉEL.

      Ce que nous venons de décrire n'est ni plus ni moins que l'effet transistor : il ne manque que le moyen d'injecter des trous dans la zone N et de faire en sorte que les recombinaisons soient faibles, pour que la majorité des trous passent dans la zone P.

      1. Principe de fonctionnement.

        Dans le transistor réel, on va apporter les trous en créant une jonction PN, que l'on va polariser en direct. On rajoute pour ce faire une zone P sur la zone N du montage Fig. 1. Cette zone P qui injecte les trous est alors l'émetteur , et la zone N, faiblement dopée est la base . Comme dans le schéma de la Fig. 1., la jonction NP est polarisée en inverse. La deuxième zone P est le collecteur (voir Fig. 2.).

        Fig. 2. Schéma de principe d'un transistor.

        Les trous injectés dans la base par l'émetteur ont une faible probabilité de se recombiner avec les électrons de la base pour deux raisons :

        la base est faiblement dopée, donc, les porteurs majoritaires (électrons) seront peu nombreux.

        la base est étroite, et donc les trous émis sont happés par le champ électrique collecteur-base avant d'avoir pu se recombiner (la largeur de la base est petite devant la longueur de diffusion des porteurs minoritaires injectés par l'émetteur, qui sont ici les trous).

        On peut observer le phénomène d'un point de vue différent : quand on injecte un électron dans la base, l'émetteur devra envoyer plusieurs trous dans la base pour qu'il y en ait un qui se recombine avec l'électron émis. Les autres trous vont passer directement dans le collecteur.

        En première approximation, le nombre de trous passant dans le collecteur est proportionnel au nombre d'électrons injectés dans la base.

        Ce rapport de proportionnalité est un paramètre intrinsèque au transistor et s'appelle le gain en courant [image] .

        Il ne dépend que des caractéristiques physiques du transistor : il ne dépend ni de la tension inverse collecteur base, ni du courant circulant dans le collecteur. (ceci n'est qu'une approximation, mais dans les hypothèses de petits signaux, c'est assez bien vérifié.)

        On a les relations suivantes :

      2. Constitution et caractéristiques physiques d'un transistor.

        Un transistor bipolaire est donc constitué de trois zones de silicium alternativement dopées N et P, formant deux jonctions PN.

        Le transistor décrit au paragraphe précédent comporte deux zones P et une zone N. C'est une des deux façons d'agencer les jonctions pour fabriquer un transistor :

        soit une zone P, une N et une P : le transistor est dit PNP.

        soit une zone N, une P et une N : le transistor est dit NPN.

        Dans les deux cas, la zone centrale (base) est très étroite vis à vis de la longueur de diffusion des porteurs minoritaires issus de la zone adjacente (l'émetteur).

        La base possède en outre la caractéristique d'être très faiblement dopée en comparaison de l'émetteur.

      3. Courants de fuite.

        La relation [1] n'est qu'imparfaitement vérifiée pour une autre raison : si on reprend le schéma Fig. 2. et qu'on coupe la connection de la base (Ib = 0), on s'aperçoit que le courant circulant dans le collecteur n'est pas nul, dû à des porteurs minoritaires qui passent de la base dans le collecteur. Ce courant est nommé ICEO. La relation [1] devient donc :

        En pratique, aux températures ordinaires, ce courant de fuite sera négligé. On verra par la suite qu'on s'arrangera pour polariser les montages de telle manière que le point de polarisation soit quasiment indépendant du courant de fuite.

      4. Symboles, tensions et courants.

        Dans le symbole du transistor (figures 3 et 4), une flèche désigne l'émetteur ainsi que le sens de circulation du courant d'émetteur ; c'est le sens de cette flèche qui va repérer le type de transistor : NPN pour un courant d'émetteur sortant du transistor, et PNP dans le cas inverse.

        La base est représentée par une barre parallèle à l'axe collecteur-émetteur. D'autres symboles existent, mais celui-ci est le plus usité.

        Les transistors sont des composants polarisés : les courants indiqués sont les seuls possibles pour un fonctionnement correct. En conséquence, il faudra choisir le type de transistor adapté au besoin (NPN ou PNP) et faire attention au sens de branchement.

        • Transistor NPN

          Fig. 3. Courants et tensions sur un NPN.

          Dans ce type de transistor, les courants de base et de collecteur sont rentrants, et le courant d'émetteur est sortant. Les tensions VBE et VCE sont ici positives.

        • Transistor PNP

          Dans ce type de transistor, les courants de base et de collecteur sont sortants, et le courant d'émetteur est rentrant. Les tensions VBE et VCE sont ici négatives.

          Fig. 4. Courants et tensions sur un PNP.

    3. CARACTÉRISTIQUES ÉLECTRIQUES.

      Pour ce paragraphe, nous allons étudier les caractéristiques des transistors NPN. Celles des transistors PNP sont les mêmes aux réserves de signes décrites au paragraphe précédent.

      Les transistors NPN sont plus répandus car ils ont de meilleures performances que les PNP (la conductibilité du silicium N est meilleure que celle du silicium P, ainsi que la tenue en tension).

      1. Montages de base.

        Quand on branche un transistor, si on s'arrange pour qu'il y ait une patte commune à l'entrée et à la sortie du montage, il y a 3 manières fondamentales de procéder :

        la patte commune est l'émetteur : on parle de montage émetteur commun . L'entrée est la base et la sortie le collecteur.

        La patte commune est la base : on parle de montage base commune . L'entrée est l'émetteur et la sortie le collecteur.

        La patte commune est le collecteur : on parle de montage collecteur commun . L'entrée est la base et la sortie l'émetteur.

        Nous reverrons ces trois montages fondamentaux dans un chapitre spécifique.

      2. Schéma de mesure des caractéristiques.

        Les caractéristiques qui suivent sont données pour un montage émetteur commun . Le schéma le plus simple est le suivant :

        Fig. 5. Montage de base émetteur commun .

        Dans ce schéma, la base est polarisée en direct par la résistance de base Rb : le potentiel de la base est alors de 0,7V environ, car l'émetteur est à la masse et la jonction base émetteur est l'équivalent d'une diode passante.

        Le collecteur est lui polarisé par la résistance de collecteur Rc de telle manière que la tension du collecteur soit supérieure à la tension de la base : la jonction base collecteur est alors polarisée en inverse.

        On polarise donc convenablement le transistor avec une simple alimentation et deux résistances. Dans ce montage, l'entrée est la base et la sortie est le collecteur.

        L'entrée est caractérisée par les deux grandeurs IB et VBE, et la sortie par les grandeurs IC et VCE, soit 4 variables.

      3. Caractéristique d'entrée.

        La caractéristique d'entrée du transistor est donnée par la relation IB = f (VBE) @ VCE = cte.

        En fait, le circuit d'entrée est la jonction base émetteur du transistor, soit une jonction diode.

        Cette caractéristique va dépendre très peu de la tension collecteur émetteur : on la donne en général pour une seule valeur de VCE. La courbe est la suivante :

        Fig. 6. Caractéristique d'entrée du transistor.

        La tension VBE est d'environ 0,7V pour une polarisation normale du transistor (courant de base inférieur au mA). Cette valeur est donc légèrement supérieure à celle d'une jonction de diode.

      4. Caractéristique de transfert.

        La caractéristique de transfert est définie par la relation IC = f (IB) @ VCE = cte.

        Nous avons déjà dit que le courant d'émetteur est proportionnel au courant de base (formule [1]).

        Fig. 7. Caractéristique de transfert du transistor.

        La caractéristique de transfert est donc une droite ; le transistor est un générateur de courant commandé par un courant.

        Si on considère le courant de fuite ICEO, la caractéristique ne passe pas par l'origine, car IC = ICEO pour IB = 0.

        Le [image] du transistor va varier grandement en fonction du type de transistor : 5 à 10 pour des transistors de grosse puissance, 30 à 80 pour des transistors de moyenne puissance, et de 100 à 500 pour des transistors de signal.

      5. Caractéristique de sortie.

        La caractéristique de sortie du transistor est définie par la relation IC = f (VCE) @ IB = cte. En pratique, on donne un réseau de caractéristiques pour plusieurs valeurs de IB.

        Fig. 8. Caractéristiques de sortie du transistor.

        Sur ces caractéristiques (Fig. 8.), on distingue deux zones :

        une zone importante où le courant IC dépend très peu de VCE à IB donné : cette caractéristique est celle d'un générateur de courant à résistance interne utilisé en récepteur. Dans le cas des transistors petits signaux, cette résistance est très grande : en première approche, on considérera que la sortie de ce montage à transistor est un générateur de courant parfait.

        La zone des faibles tensions VCE (0 à quelques volts en fonction du transistor) est différente. C'est la zone de saturation. Quand la tension collecteur-émetteur diminue pour devenir très faible, la jonction collecteur-base cesse d'être polarisée en inverse, et l'effet transistor décroît alors très rapidement. A la limite, la jonction collecteur-base devient aussi polarisée en direct : on n'a plus un transistor, mais l'équivalent de deux diodes en parallèle. On a une caractéristique ohmique déterminée principalement par la résistivité du silicium du collecteur. Les tensions de saturation sont toujours définies à un courant collecteur donné : elles varient de 50mV pour des transistors de signal à des courants d'environ 10mA, à 500mV pour les mêmes transistors utilisés au maximum de leurs possibilités (100 à 300 mA), et atteignent 1 à 3V pour des transistors de puissance à des courants de l'ordre de 10A.

      6. Limites d'utilisation.

        Le transistor pourra fonctionner sans casser à l'intérieur d'un domaine d'utilisation bien déterminé.

        Ce domaine sera limité par trois paramètres :

        le courant collecteur maxi ICMax. Le dépassement n'est pas immédiatement destructif, mais le gain en courant [image] va chuter fortement, ce qui rend le transistor peu intéressant dans cette zone.

        la tension de claquage VCEMax : au delà de cette tension, le courant de collecteur croît très rapidement s'il n'est pas limité à l'extérieur du transistor.

        la puissance maxi que peut supporter le transistor, et qui va être représentée par une hyperbole sur le graphique, car on a la relation :

        Fig. 9. Limites d'utilisation du transistor.

        Toute la zone hachurée sur la caractéristique de sortie du transistor (Fig. 9.) est donc interdite.

      7. En bref

        Ce qu'il faut retenir d'essentiel dans le transistor , c'est que c'est un amplificateur de courant : c'est un générateur de (fort) courant (en sortie) piloté par un (faible) courant (en entrée).

      8. Paramètres essentiels des transistors.

        Le choix d'un transistor (au premier ordre) se fera en considérant les paramètre suivants :

        Le VCEMax que peut supporter le transistor.

        Le courant de collecteur maxi ICMax.

        La puissance maxi que le transistor aura à dissiper (ne pas oublier le radiateur !).

        Le gain en courant [image].

        Si on utilise le transistor en commutation, la tension de saturation VCEsatmax sera un critère de choix essentiel.

  • MONTAGES DE BASE.

    1. PRELIMINAIRE.

      1. Mise en œuvre du transistor.

        On a vu que le transistor était un amplificateur de courant : on va donc l'utiliser pour amplifier des signaux issus de sources diverses.

        Il va falloir pour cela mettre en œuvre tout un montage autour du transistor pour plusieurs raisons :

        • Alimentation.

          Le transistor, tout en étant classifié dans les composants actifs, ne fournit pas d'énergie : il faudra donc que cette énergie vienne de quelque part ! C'est le rôle de l'alimentation qui va servir à apporter les tensions de polarisation et l'énergie que le montage sera susceptible de fournir en sortie.

        • Polarisation.

          Le transistor ne laisse passer le courant que dans un seul sens : il va donc falloir le polariser pour pouvoir y faire passer du courant alternatif, c'est à dire superposer au courant alternatif un courant continu suffisamment grand pour que le courant total (continu + alternatif) circule toujours dans le même sens.

          Il faudra en plus que la composante alternative du courant soit suffisamment petite devant la composante continue pour que la linéarisation faite dans le cadre de l'hypothèse des petits signaux soit justifiée.

        • Conversion courant/tension.

          Le transistor est un générateur de courant. Comme il est plus commode de manipuler des tensions, il va falloir convertir ces courants en tensions : on va le faire simplement en mettant des résistances dans des endroits judicieusement choisis du montage.

        • Liaisons.

          Une fois le transistor polarisé, il va falloir prévoir le branchement de la source alternative d'entrée sur le montage. En règle générale, ceci se fera par l'intermédiaire d'un condensateur de liaison placé entre la source et le point d'entrée du montage à transistor (base pour montages émetteur et collecteur commun, émetteur pour montage base commune).

          De la même manière, pour éviter que la charge du montage à transistor (le dispositif situé en aval et qui va utiliser le signal amplifié) ne perturbe sa polarisation, on va aussi l'isoler par un condensateur de liaison.

          Ces condensateurs vont aussi éviter qu'un courant continu ne circule dans la source et dans la charge, ce qui peut leur être dommageable.

        • Insensibilité du montage aux paramètres du transistor.

          Dans la mesure du possible, la polarisation devra rendre le montage insensible aux dérives thermiques du transistor et elle devra être indépendante de ses caractéristiques (notamment le gain), ceci pour que le montage soit universel , et ne fonctionne pas uniquement avec le transistor dont on dispose pour réaliser la maquette. Cela permet aussi de changer le transistor sur le montage sans se poser de questions en cas de panne.

      2. Méthodologie de calcul.

        Nous avons déjà vu lors d'une approche globale de l'électronique qu'il convenait pour des raisons de simplification des calculs de séparer l'étude de la polarisation de l'étude en alternatif petits signaux.

        La polarisation est calculée dans un premier temps ; on fait alors un schéma équivalent du montage pour le continu. Le calcul se fait simplement avec la loi d'Ohm et les principaux théorèmes de l'électricité.

        Pour la partie petits signaux alternatifs, on a vu qu'on va devoir linéariser les caractéristiques du transistor au point de fonctionnement défini par la polarisation. Il faut donc définir les paramètres à linéariser et en déduire un schéma équivalent du transistor.

        La solution globale (celle correspondant à ce qui est physiquement constaté et mesuré sur le montage) est la somme des deux solutions continue et alternative définies ci-dessus.

      3. Schéma équivalent alternatif petits signaux du transistor. Paramètres hybrides.

        En pratique, pour simplifier l'exposé, nous allons d'abord donner le schéma équivalent et les équations qui s'y rapportent, pour ensuite justifier ces éléments à l'aide des caractéristiques des transistors.

        Le transistor est considéré comme un quadripôle ; il a deux bornes d'entrée et deux bornes de sortie (une patte sera alors commune à l'entrée et à la sortie) et va être défini par 4 signaux : courant et tension d'entrée, courant et tension de sortie. Ces variables ont déjà été définies (Fig.5) pour le montage émetteur commun : il s'agit du courant IB et de la tension VBE pour l'entrée, du courant IC et de la tension VCE pour la sortie.

        En fait, ces signaux se décomposent en deux parties : les tensions et courants continus de polarisation notés IBo, VBEo, ICo, et VCEo, et les petites variations alternatives autour du point de repos qui sont respectivement ib, vbe, ic, et vce.

        Nous avons les équations :

        Ce sont les petites variations qui vont nous intéresser pour le schéma équivalent alternatif qui est le suivant :

        Fig. 10. Schéma équivalent du transistor NPN.

        Il convient de noter que ce schéma, bien que dérivé du montage émetteur commun (l'émetteur est bien ici la borne commune entre l'entrée et la sortie) est intrinsèque au transistor et pourra être utilisé dans tous les cas de figure : il suffira de l'intégrer tel quel au schéma équivalent du reste du montage en faisant bien attention aux connections des trois pattes du transistor E, B et C.

        L'appellation schéma équivalent du montage émetteur commun provient de la définition des variables d'entrée et de sortie qui sont celle de ce type de montage.

        Attention !!! : le schéma de la Fig. 10. correspond à un transistor NPN (courant rentrant dans le collecteur). Pour un transistor PNP, il faudra inverser les sens de ib, ic, et du générateur commandé h21e ib. Les tension vbe et vce seront alors négatives.

        Dans ce schéma, nous avons les relations suivantes :

        L'indice e sur les paramètres hije (qu'on appelle paramètres de transfert) indique qu'il s'agit des paramètres émetteur commun. On peut mettre le système [10] sous la forme matricielle suivante :

        Nous nous contenterons ici de voir que ça existe , et d'ajouter que ce formalisme matriciel permet de simplifier les calculs quand on associe plusieurs quadripôles (en série, en parallèle, en cascade ). Nous n'utiliserons pas ces caractéristiques dans ce cours.

        Si on analyse la première équation du système [10], on y voit l'expression de vbe en fonction de ib et vce. On a :

        h11e = vbe/ib @ vce = 0 . Si on se rappelle que vbe et ib sont des petites variations autour du point de repos (VBEo,IBo) et que la caractéristique d'entrée du transistor est la courbe IB = f(VBE) @ VCE = cte (donc vce = 0), alors, on voit que h11e est la résistance dynamique de la jonction base-émetteur .

        h12e = vbe/vce @ ib = 0 . Ce paramètre est en fait la réaction de la sortie sur l'entrée dans la théorie des quadripôles. Lors de l'étude du principe du transistor, il a été dit que cette réaction était négligeable . Dans toute la suite de l'exposé, il ne sera plus fait mention de ce paramètre.

        La deuxième équation nous donne :

        h21e = ic/ib @ vce = 0 . Ce paramètre est le gain en courant en fonctionnement dynamique du transistor. Il peut être légèrement différent du gain en fonctionnement statique [image] déjà mentionné, car il a été dit que la linéarité de ce paramètre n'est pas rigoureusement vérifiée.

        h21e = ic/vce @ ib = 0 . Ce paramètre a la dimension d'une admittance : c'est l'inverse de la résistance du générateur de courant de sortie du transistor. En pratique, sa valeur est faible (donc la résistance est élevée), et sauf montage un peu pointu , on le négligera, car son influence sera modérée vis à vis de l'impédance de charge du montage.

        On voit qu'en fait, les paramètres de transfert issus de la théorie des quadripôles colle bien aux caractéristiques physiques du transistor :

        une entrée résistive (la résistance différentielle de la jonction base-émetteur), la réaction de la sortie sur l'entrée étant négligeable.

        une sortie équivalente à un générateur de courant proportionnel au courant d'entrée , ce générateur étant imparfait, donc avec une résistance interne non nulle.

    2. MONTAGE ÉMETTEUR COMMUN.

      Le décor étant entièrement planté, on va pouvoir passer au montage fondamental à transistor : le montage émetteur commun . Il réalise la fonction amplification de base de l'électronique.

      1. Polarisation. Point de fonctionnement.

        • Polarisation par une résistance.

          Le montage le plus élémentaire tout en étant fonctionnel est le suivant :

          Fig. 11. Polarisation par résistance de base.

          Le fonctionnement est simple : le courant de base IBo est fixé par Rb, ce qui entraîne un courant de collecteur ICo égal à [image] IBo. Le courant collecteur étant fixé, la tension aux bornes de Rc va être égale à Rc ICo. Le montage est entièrement déterminé.

          Pour calculer les élément Rb et Rc, on va procéder à l'envers : on va partir de ce qu'on désire (le courant ICo et la tension VCEo), et remonter la chaîne :

          On se fixe un courant collecteur de repos ICo (c'est le courant de polarisation). Ce courant sera choisi en fonction de l'application, et variera entre une dizaine de µA (applications très faible bruit), et une dizaine de mA (meilleures performances en haute fréquence, soit quelques MHz).

          On se fixe une tension de collecteur VCEo, qu'on prend en général égale à E/2, pour que la tension du collecteur puisse varier autant vers le haut que vers le bas lorsqu'on appliquera le signal alternatif.

          La résistance de collecteur Rc , en plus d'assurer une polarisation correcte de la jonction base-collecteur, convertit le courant collecteur (et ses variations) en tension. Elle est déterminée par la formule :

          le courant IBo est alors imposé par les caractéristiques de gain en courant du transistor (le [image]). On note ici qu'il est impératif de le connaître (donc de le mesurer) :

          La résistance de base Rb est alors calculée à l'aide de la formule :

          Pour ce faire, on prendra VBEo = 0,7V, car un calcul plus précis (il faudrait connaître la caractéristique IB = f (VBE) pour le faire !) ne servirait à rien.

          On peut résumer toute cette étape de polarisation sur un seul graphique :

          Fig. 12. Polarisation du transistor.

          On reconnaîtra ici les trois caractéristiques du transistor (entrée, transfert, sortie) jointes sur le même graphique. Attention : il faut bien remarquer que les axes sont différents de part et d'autre du zéro !

          Ce montage assure les diverses fonction vues précédemment : il est correctement alimenté, polarisé (jonction base-émetteur en direct, jonction base collecteur en inverse, courants dans le bon sens ), et il possède des condensateurs de liaison. Il y a une ombre au tableau : bien que fonctionnel, ce montage ne garantit pas du tout la fonction de robustesse vis à vis de la dérive thermique et des caractéristiques du transistor. En effet, on peut remarquer que :

          si ICEO (le courant de fuite) augmente sous l'effet de la température, rien ne va venir compenser cette variation : VCEo va augmenter et le point de polarisation va se déplacer.

          Si on veut changer le transistor par un autre dont le gain soit très différent, vu que IBo est imposé par E et Rb, ICo = [image] IBo n'aura pas la bonne valeur, et VCEo non plus. Et il ne s'en faut pas de quelques %, car pour une même référence de transistor, le gain peut varier d'un facteur 1,5 à 5 ou plus ! On peut donc se retrouver avec un montage dont le transistor serait saturé, donc inutilisable pour l'amplification de petits signaux.

          Comme il est impensable de mesurer chaque transistor avant de l'utiliser, on ne peut pas en pratique exploiter le montage décrit Fig. 11. Ce montage n'a qu'un intérêt pédagogique, et pour des montages réels, on va lui préférer le montage à polarisation par pont de base.

        • Polarisation par pont de base.

          Ce schéma est un peu plus complexe que le précédent. Nous allons d'abord analyser les différences, et ensuite, nous suivrons pas à pas la méthode de calcul de la polarisation.

          Fig. 13. Polarisation par pont de base.

          Par rapport au schéma Fig. 11, on note que la base est polarisée à l'aide d'un pont de résistances Rb1 et Rb2. Le rôle de ces résistances sera de fixer le potentiel de base. Comme la tension VBE est voisine de 0,7V, ceci impose de mettre une résistance entre l'émetteur et la masse. Cette résistance est découplée par le condensateur CDE, qui va être l'équivalent d'un court-circuit en alternatif.

          A quoi servent ces éléments ? Pour raisonner, on va faire abstraction du condensateur CDE, qui est un circuit ouvert pour le régime continu.

          Les résistances du pont de base vont être choisies de telle manière que le courant circulant dans ce pont soit très supérieur au courant rentrant dans la base (au moins 10 fois plus grand), ceci afin que des petites variations du courant de base ne modifient pas le potentiel de la base, qui restera donc fixe.

          Le potentiel d'émetteur va être égal au potentiel de base moins environ 0,7V et sera lui aussi fixe, à courant de base donné. Dans ce cas, la tension aux bornes de RE est déterminé. Le courant d'émetteur (donc celui du collecteur, et celui de la base, via le [image]) sera alors fixé par la valeur de la résistance RE et la tension du pont de base.

          Le courant collecteur étant défini, on choisit la résistance de collecteur pour avoir VCEo au milieu de la plage de tension utilisable.

          Quel est l'avantage de ce montage ? Supposons que le courant ICEO augmente sous l'effet de la température. La tension aux bornes de RE va alors augmenter. Comme le potentiel de base est fixé par le pont Rb1/Rb2, la tension VBE va diminuer. Cette diminution va entraîner une baisse du courant de base, donc du courant de collecteur.

          Cet effet vient donc s'opposer à l'augmentation du courant collecteur dû à l'augmentation du courant de fuite ICEO. Le montage s'auto-stabilise.

          L'autre avantage, c'est que le courant de collecteur est fixé par le pont de base et par la résistance d'émetteur. Ces éléments sont connus à 5% près en général, donc, d'un montage à un autre, on aura peu de dispersions, et surtout, le courant collecteur sera indépendant du gain du transistor. On a dit à cet effet que le pont de base est calculé de manière à ce que le potentiel de base soit indépendant du courant de base : ce potentiel ne dépendra pas du transistor, et le courant de base s'ajustera automatiquement en fonction du gain du transistor sans perturber le pont de base.

          On fera les calculs dans l'ordre suivant :

          On fixe le courant collecteur de repos ICo . A noter que le courant d'émetteur sera quasiment le même car IC = IE - IB # IE.

          On fixe le potentiel d'émetteur VEo (au maximum à E/3, et en pratique, une valeur plus faible : 1 à 2V est une valeur assurant une assez bonne compensation thermique sans trop diminuer la dynamique de sortie).

          On calcule alors la résistance RE par la formule :

          On se fixe la tension collecteur émetteur VCEo : en général, on la prendra égale à la moitié de la tension disponible qui est égale non plus à E, mais à E - VEo. On en déduit la résistance Rc :

          On fixe le courant du pont de base (on prendra une valeur moyenne pour le [image] du transistor, cette valeur n'étant pas critique ici) :

          On calcule Rb2 (en règle générale, on prendra VBEo égal à 0,7V) :

          On en déduit Rb1 :

          Le point de repos du montage étant déterminé, on va passer au comportement en alternatif.

      2. Fonctionnement en petits signaux alternatifs.

        Si on applique les règles définies dans le chapitre "Outils pour l'électronique", on obtient :

        Fig. 14. Schéma équivalent en alternatif.

        On notera que la résistance d'émetteur a disparu, car elle est shuntée par le condensateur de découplage CDE.

        En quoi va consister l'étude en alternatif ?

        Tout d'abord, on va évaluer la capacité du montage à amplifier le signal d'entrée . La caractéristique représentative de cette fonction est le gain en tension Av, qui est le rapport entre les tensions de sortie et d'entrée.

        Ensuite, il faut regarder en quoi le montage peut s'interfacer avec la source d'entrée sans la perturber ; il doit rester le plus neutre possible vis à vis de cette source, surtout s'il s'agit d'un capteur de mesure ! La grandeur représentative est l'impédance d'entrée .

        Même chose vis à vis de la charge branchée en sortie du montage, qui va utiliser le signal amplifié : il va falloir regarder dans quelle mesure l'étage à transistor n'est pas perturbé par cette charge . La grandeur représentative est l'impédance de sortie .

        Nous allons calculer ces trois paramètres. On pourrait y rajouter le gain en courant Ai qui est le rapport des courants de sortie et d'entrée, et aussi le gain en puissance. En amplification petits signaux, ces paramètres sont peu utilisés, nous n'en parlerons donc pas.

        • Fonctionnement intuitif .

          Avant de faire des calculs compliqués sur un schéma abstrait, il serait bon de voir comment marche le montage de façon intuitive et qualitative.

          On considère que le potentiel d'émetteur est fixe grâce au condensateur de découplage CDE.

          Si on augmente légèrement la tension de base, le courant de base va augmenter. Le courant de collecteur va augmenter proportionnellement au courant de base, et donc, la chute de tension dans la résistance Rc va augmenter. Le potentiel du collecteur va alors baisser.

          On peut par conséquent s'attendre à un gain en tension négatif (entrée et sortie en opposition de phase).

          On peut aussi voir ce que donnerait le montage sans le condensateur CDE : si la tension de base augmente, le courant de base, donc de collecteur augmente. La tension aux bornes de la résistance d'émetteur va augmenter aussi, et donc, le potentiel de l'émetteur va remonter, ce qui va entraîner une diminution de la tension VBE, donc du courant de base, donc du courant de collecteur : il y a une contre-réaction qui s'oppose à l'amplification.

          Le gain en tension sera plus faible qu'avec le condensateur CDE. Nous aurons l'occasion de revoir ce montage (dit à charge répartie) dans un chapitre ultérieur.

        • Gain en tension.

          Le gain en tension peut être défini de deux manières :

          le gain à vide , c'est à dire sans charge connectée en sortie du montage.

          le gain en charge , avec la charge connectée.

          Dans ce paragraphe, nous allons calculer le gain de l'étage à vide. Nous verrons ensuite qu'il est simple de calculer le gain en charge à postériori.

          On va d'abord procéder à quelques simplifications dans le schéma :

          les deux résistances du pont de base sont en parallèle du point de vue alternatif. Nous allons donc les remplacer par une seule résistance Rp dont la valeur sera égale à Rb1 // Rb2.

          la résistance de sortie 1/h22e du transistor est grande (plusieurs dizaines de k [image] ). Pour une alimentation E de 12V, un courant ICo de 2mA et une tension VCEo de 5V, on aura Rc = 2500 [image], soit environ le dixième de 1/h22e. On va donc négliger ce dernier terme. On notera que lorsque la tension d'alimentation est élevée et que le courant de collecteur est faible, cette simplification est moins justifiée.

          on supprime la charge Ru (hypothèse de calcul).

          Avec ces hypothèses, le schéma devient :

          Fig. 15. Schéma équivalent simplifié.

          On a les équations suivantes :

          Si on pose h21e = [image] (le gain dynamique est égal au gain statique), on obtient l'expression du gain en tension :

          Cette expression montre que le gain de l'étage dépend de deux paramètres du transistor : le gain en courant [image] et la résistance dynamique d'entrée h11e .

          Pour augmenter ce gain, on pourrait se dire qu'il suffit d'augmenter Rc (donc de diminuer le courant ICo pour garder un VCEo constant).

          Ce serait une grave erreur : en effet, si on diminue ICo, on diminue aussi forcément IBo, et en conséquence, la résistance différentielle de la jonction base émetteur augmente : le gain risque donc de ne pas trop augmenter.

          Les paramètres de cette formule sont donc liés : ils ne sont pas indépendants, et on ne fait pas ce qu'on veut.

          Nous allons essayer de trouver une formulation mettant en œuvre des paramètres indépendants.

          Nous avons déjà dit que la jonction base-émetteur était l'équivalent d'une diode. Elle satisfait notamment aux mêmes formulations mathématiques. Dans le chapitre relatif à la diode, l'équation [2] donnait la résistance différentielle en fonction du courant dans la diode :

          Pour le transistor, on a la même chose en remplaçant Id par le courant de base IBo et rd par h11e.

          Le terme kT/q est homogène à une tension et vaut environ 26mV à température ordinaire.

          La relation simplifiée entre h11e et IBo (h11e est en [image] et IBo en A) devient alors :

          Si on réinjecte cette relation dans la formule [24] en tenant compte du fait que ICo = [image] IBo, on obtient :

          Le terme 38,5 ICo représente la pente du transistor au point de polarisation ICo. C'est le rapport IC / VBE en ce point. Il ne dépend pas du transistor : c'est un paramètre intéressant qui permet de calculer le gain d'un étage indépendamment du composant choisi pour le réaliser.

          Cette formulation du gain est beaucoup plus satisfaisante que la précédente, car elle ne dépend plus des caractéristiques du transistor, et notamment de son gain (attention toutefois au facteur 38,5 qui est le terme q/kT : il dépend de la température !). Elle montre aussi que le gain est relativement figé si on garde pour règle une tension de polarisation VCEo égale à la moitié de la tension d'alimentation (moins la tension d'émetteur). Le seul moyen de l'augmenter est d'accroître la tension d'alimentation ; on pourra alors augmenter le terme RcICo qui est la chute de tension dans la résistance de collecteur.

          A tire indicatif, pour un montage polarisé sous 12V avec une tension VEo de 2V et VCEo de 5V, on aura Rc ICo égal à 5V, et un gain en tension Av égal à 190.

        • Schéma équivalent de l'étage amplificateur.

          Le schéma équivalent du montage amplificateur émetteur commun peut être représenté sous la forme donnée figure 16 (voir chapitre I).

          En entrée, on y trouve l'impédance Ze (on néglige la réaction de la sortie sur l'entrée, donc, il n'y a pas d'autres composants)

          En sortie, on a un générateur de tension commandé (la tension de sortie est égale à la tension d'entrée multipliée par le gain Av de l'étage à vide) avec sa résistance interne qui sera la résistance de sortie de l'étage.

          On notera que la représentation de la sortie est celle du générateur de Thévenin équivalent

          Fig. 16. Schéma équivalent de l'étage amplificateur.

          On pourra voir ici une contradiction avec notre montage émetteur commun qui est doté en sortie d'un générateur de courant. Cette objection est balayée par les deux points suivants :

          on veut calculer le gain en tension de l'étage ! On considère donc notre montage comme un générateur de tension avec sa résistance interne, si grande soit-elle.

          la transformation Norton / Thévenin nous permet de passer d'une représentation à l'autre simplement.

          Ce schéma va nous permettre de définir les impédances d'entrée et de sortie de notre étage.

        • Impédance d'entrée.

          Par définition, et en se référant au schéma Fig. 16., l'impédance d'entrée est égale à :

          Ici, le schéma est simple, le générateur d'entrée débite sur deux résistances en parallèle. On a donc :

          On voit qu'on n'a pas intérêt à prendre un pont de base avec des valeurs trop faibles. Il faudra donc faire un compromis avec la condition de polarisation (Ip >> IBo). En général, h11e sera petit (1k [image] pour IBo = 26µA), donc cette impédance sera bien inférieure à Rp, et très souvent, elle sera insuffisante pour qu'on puisse interfacer des sources de tension (capteurs notamment) directement sur un étage émetteur commun.

        • Impédance de sortie.

          Fig. 17. Transformation Norton / Thévenin.

          Si on transforme la sortie du montage Fig. 15. en celle du schéma Fig. 16. (transformation Norton / Thévenin), on obtient le schéma de la figure 17.

          la résistance Rc qui était en parallèle sur le générateur de courant h21e ib devient la résistance en série avec le générateur de tension. L'impédance de sortie est donc ici très simple à identifier :

          Cette valeur est assez élevée, et souvent, on ne pourra pas connecter le montage tel quel sur une charge.

        • Gain de l'étage en charge.

          Il y a deux manières de voir la chose :

          On reprend le schéma équivalent de la Fig. 15. et on rajoute Rch en parallèle avec Rc. La formule du gain devient alors :

          On connaît l'impédance de sortie et la charge. D'après le schéma Fig. 16, ces deux résistances forment un pont diviseur qui atténue la tension de sortie à vide. Le gain devient :

          On vérifiera que si on développe Rc // Rch dans la formule [31], on tombe bien sur la formule [32].

        • Bilan. Utilisation du montage.

          Au final, le montage émetteur commun est un montage ayant :

          une bonne amplification en tension (de l'ordre de plusieurs centaines).

          une impédance d'entrée relativement faible (égale à h11e, soit de l'ordre de plusieurs k [image]), variable en fonction de la polarisation (plus ICo est faible, plus l'impédance d'entrée est élevée).

          une impédance de sortie assez élevée Rc qui va aussi dépendre du courant de polarisation ICo.

          Ce montage est l'amplificateur de base à transistor et sera donc utilisé comme sous-fonction dans des circuits plus complexes (discrets, ou intégrés comme dans l'amplificateur opérationnel). Par contre, il sera souvent inexploitable seul, et il faudra lui adjoindre des étages adaptateurs d'impédance.

    3. MONTAGE COLLECTEUR COMMUN.

      Dans ce montage, l'entrée est la base et la sortie l'émetteur. C'est le collecteur qui est le point commun entre l'entrée et la sortie. On notera que c'est faux pour la polarisation, car le collecteur est relié au +E et l'entrée se fait entre base et masse, et la sortie entre émetteur et masse. En fait, le collecteur est bien commun en alternatif, car le générateur de polarisation +E est un court circuit pour ce régime, et donc, le collecteur va se retrouver à la masse alternative : ce sera donc bien la patte commune entrée sortie.

      1. Polarisation. Point de fonctionnement.

        Comme pour le montage émetteur commun, il y a moyen de polariser le transistor avec une seule résistance de base, ce qui entraîne exactement les mêmes inconvénients. Nous passerons donc directement à la polarisation par pont de base, qui est la plus utilisée. Le schéma complet est donné sur la figure 18.

        Par rapport au montage émetteur commun, on remarque que la résistance de collecteur a disparu. Le condensateur de découplage de RE aussi, ce qui est normal, car ici, la sortie est l'émetteur : il n'est donc pas question de mettre la sortie à la masse en alternatif !

        Fig. 18. Montage collecteur commun.

        Pour la polarisation, on se reportera au paragraphe équivalent du montage émetteur commun, et on prendra en compte les différences suivantes :

        En général, on fixera le potentiel de repos de l'émetteur à E/2 pour avoir la même dynamique pour les alternances positives et négatives.

        On n'a pas à se préoccuper du potentiel de collecteur ni de sa polarisation car cette broche est à +E.

      2. Fonctionnement en petits signaux alternatifs.

        Nous avons ici fait les mêmes simplifications de schéma que pour le montage émetteur commun. On voit bien sur le schéma résultant que le collecteur est le point commun entrée / sortie.

        Fig. 19. Schéma équivalent collecteur commun.

        On pourra remarquer que (en le réarrangeant) le schéma équivalent interne du transistor est le même que pour le montage émetteur commun.

        Par rapport à ce dernier montage, on a rajouté la résistance interne du générateur d'attaque. En effet, on voit qu'ici, l'entrée et la sortie ne sont pas séparés, et donc, la charge va avoir un impact sur l'impédance d'entrée et l'impédance interne du générateur d'attaque influera sur l'impédance de sortie. Il ne faut pas oublier que cette dernière est l'impédance vue de la charge, donc englobe l'étage à transistor et le dispositif d'attaque.

        Le paramètre h21e a été remplacé par [image], les gains statique et dynamique étant sensiblement les mêmes.

        • Fonctionnement intuitif .

          Considérons le schéma de la Fig. 18. Si on augmente la tension de base, la tension VBE va augmenter, ainsi que le courant IB, donc IC, ce qui va créer une chute de tension plus grande dans RE. Le potentiel de l'émetteur va alors remonter, contrariant l'augmentation de VBE, donc du courant IC. Le potentiel de l'émetteur va ainsi suivre sagement (aux variations [image] VBE près, qui sont très faibles) le potentiel qu'on impose à la base.

          Si on regarde bien le montage, on voit en fait que la tension de sortie est toujours inférieure à la tension d'entrée de la valeur VBE. Quand on va appliquer un signal alternatif sur la base, on va le retrouver sur la résistance d'émetteur diminué de la variation de [image] VBE qui va être très faible.

          On voit donc qu'intuitivement, ce montage aura un gain positif mais inférieur à 1.

          Ce n'est pas un montage amplificateur. On va voir que ses caractéristiques d'impédance d'entrée et de sortie le destinent à l'adaptation d'impédance.

        • Gain en tension.

          Si on applique la loi des nœuds au niveau de l'émetteur (Fig. 19.), on voit que le courant circulant dans RE est égal à ( [image] +1) ib et va de l'émetteur vers le collecteur. On peut alors poser les équations suivantes :

          On remarquera au passage en analysant l'équation [33] que vu de la base, tout se passe comme si la résistance RE était multipliée par le gain en courant.

          On déduit le gain à vide des équations [33] et [34] :

          Ce gain est légèrement inférieur à 1, et c'est normal, car la tension de sortie est égale à la tension d'entrée multipliée par le pont diviseur formé par h11e et ( [image] +1)RE. En général, RE est du même ordre de grandeur que h11e, ce qui fait que le terme ( [image] +1) RE est beaucoup plus grand que h11e. A quelques centièmes près, le gain sera quasiment égal à l'unité . Pour cette raison, et aussi pour ce qui a été dit dans la rubrique fonctionnement intuitif , on appelle ce montage émetteur suiveur , car le potentiel d'émetteur suit celui imposé à la base (aux variations [image] VBE près, qui sont très faibles).

          Quand l'étage est chargé sur Rch, il convient de remplacer RE par RE // Rch dans l'équation [35], ce qui change très peu le résultat, même si Rch est égale ou même un peu inférieure à RE (dans les mêmes conditions, le gain de l'étage émetteur commun aurait chuté d'un facteur supérieur ou égal à 2 !).

          Ceci augure d'une bonne impédance de sortie : il ne faut pas oublier que ce paramètre mesure l'aptitude d'un montage à tenir la charge.

        • Impédance d'entrée.

          Le courant ie est égal à ib augmenté du courant circulant dans Rp.

          L'impédance d'entrée va donc être égale à Rp//(ve/ib). On peut tirer cette dernière valeur de l'équation [33] :

          On en déduit la valeur de l'impédance d'entrée :

          On remarque que le premier terme est une valeur très élevée (de l'ordre de [image] RE, h11e étant négligeable), et que malheureusement, la valeur du pont de base vient diminuer cette impédance d'un facteur 10 environ. C'est donc la valeur de Rp qui va déterminer l'impédance d'entrée. Cette impédance est quand même au moins 10 fois supérieure à celle de l'émetteur commun.

          On voit toutefois que là encore, la polarisation ne fait pas bon ménage avec le régime alternatif : tout sera une affaire de compromis, comme bien souvent en électronique. Il n'y aura jamais la bonne solution, mais une solution intermédiaire qui sera la mieux adaptée au fonctionnement désiré.

          Il faut aussi remarquer que vu de la base, les impédances situées dans le circuit d'émetteur sont multipliées par le gain [image] du transistor. C'est une remarque très importante qui est toujours vraie.

          L'impédance d'entrée a été ici calculée pour un montage fonctionnant à vide. Si on le charge par Rch, cette résistance vient se mettre en parallèle sur RE dans la formule [37]. Dans le cas général, l'impédance d'entrée dépend donc de la charge. Cette dépendance sera faible tant qu'on aura une polarisation par pont de base, car on a vu que Rp est le terme prépondérant. Il existe néanmoins des astuces pour éliminer l'effet du pont de base (montage bootstrap ou couplage direct de deux étages à transistor), et dans ce cas, il faudra tenir compte de la charge.

        • Impédance de sortie.

          Le calcul va être plus compliqué que pour l'émetteur commun. On remarquera qu'ici la sortie n'est pas séparée de l'entrée, ce qui fait que tout le circuit d'entrée va influer sur l'impédance de sortie, y compris la résistance interne du générateur d'attaque Rg. Comme dans le cas général cette impédance n'est pas nulle, nous l'avons faite figurer sur le schéma Fig. 19.

          Là aussi, il faut calculer les caractéristiques du générateur de Thévenin équivalent.

          On peut écrire les équations suivantes :

          Si on considère le générateur de Thévenin équivalent au générateur d'entrée plus Rp, on peut écrire :

          Si on pose :

          en injectant [40] et [41] dans [39], on obtient :

          En remplaçant ib par cette valeur dans [38], on a :

          Après un développement laborieux, on peut mettre Vs sous la forme A eg + Zsis : ce sont les caractéristiques du générateur de Thévenin de sortie de l'étage. Le terme Zs est le suivant :

          RE , Rg et h11e étant du même ordre de grandeur, le terme divisé par ( [image] +1) va être le plus petit, et RE va avoir un effet négligeable. On pourra aussi souvent négliger Rp par rapport à Rg. Zs devient :

          Cette impédance de sortie est relativement faible : le montage pourra tenir des charges plus faibles que le montage émetteur commun.

          On peut faire une remarque similaire a celle qui a été dite dans le paragraphe sur l'impédance d'entrée : vu de la sortie, l'impédance du montage est égale à tout ce qui est en amont de l'émetteur divisé par le gain en courant.

        • Bilan. Utilisation du montage.

          Un montage collecteur commun présente donc les caractéristiques suivantes :

          gain en tension quasiment égal à l'unité .

          impédance d'entrée élevée : environ [image] fois plus grande que celle de l'émetteur commun si on ne considère pas le pont de base (on verra qu'on peut l'éviter). La valeur typique est de plusieurs dizaines à plusieurs centaines de k [image] en fonction du montage.

          impédance de sortie faible (divisée par [image] environ par rapport à l'émetteur commun). Sa valeur est de l'ordre de quelques dizaines d' [image] .

          Ce montage ne sera donc pas utilisé pour amplifier un signal, mais comme adaptateur d'impédance, situé en amont ou en aval d'un montage émetteur commun, qui, nous l'avons vu, n'a pas de bonnes caractéristiques d'entrée / sortie.

          On pourra donc intercaler un tel montage entre un capteur à haute impédance de sortie et un montage émetteur commun sans que celui-ci ne perturbe le capteur.

          On pourra aussi le mettre en sortie d'un montage émetteur commun que l'on doit interfacer avec une faible charge, et ceci, sans écrouler le gain en tension de l'étage.

    4. MONTAGE BASE COMMUNE.

      1. Polarisation. Point de fonctionnement.

        Fig. 20. Montage base commune.

        Le montage commence à nous être familier : en effet, mis à part l'emplacement du générateur d'attaque et le condensateur de découplage qui est ici situé sur la base, le montage est le même que celui de l'émetteur commun.

        La procédure de calculs des éléments de polarisation est donc identique, car seuls les éléments liés au régime alternatif changent.

        La raison en est simple : l'amplification est basée sur une augmentation de IC due à une augmentation de VBE. Pour augmenter VBE, on a le choix entre deux solutions :

        soit on augmente la tension de base à potentiel d'émetteur constant : c'est le montage émetteur commun.

        soit on abaisse la tension d'émetteur à potentiel de base constant : c'est le montage base commune.

      2. Fonctionnement en petits signaux alternatifs.

        On va donc étudier ici le montage base commune. On voit tout de suite le défaut que va présenter ce montage : vu qu'on attaque côté émetteur, il faudra faire varier un courant important, donc, l'impédance d'entrée sera sûrement beaucoup plus faible que pour l'émetteur commun, qui n'était déjà pas brillant sur ce point. En fait, ce montage sera peu utilisé, sauf dans des applications hautes fréquences où il trouvera son seul avantage.

        Le schéma équivalent est le suivant :

        Fig. 21. Schéma équivalent base commune.

        Le pont Rb1 / Rb2 disparait car il est shunté en alternatif par le condensateur de découplage CDB. La base est bien le potentiel commun entrée / sortie, et le schéma du transistor est le même que pour l'émetteur commun.

        • Fonctionnement intuitif .

          Le fonctionnement intuitif a déjà été ébauché dans le paragraphe relatif à la polarisation : il est rigoureusement le même que pour l'émetteur commun sauf qu'on attaque l'émetteur pour imposer les variation VBE, avec un potentiel de base fixe.

          On aura juste une différence de signe provenant du fait que quand on augmente la tension de base à potentiel d'émetteur constant, la tension VBE augmente, et quand on augmente la tension d'émetteur à potentiel de base constant, elle diminue : une tension d'entrée positive dans les deux cas aura donc des effets contraires.

        • Gain en tension.

          Du schéma Fig. 21., on tire les équations suivantes :

          D'où l'expression du gain en tension à vide :

          Ce gain (au signe près) est le même que pour l'émetteur commun, ce qui est normal, vu que le fonctionnement est identique.

          On peut bien entendu faire les mêmes remarques que pour l'émetteur commun et mettre le gain sous la forme donnée dans l'équation [27], au signe près.

          Pour le gain en charge, rien de différent non plus, Rch vient se mettre ne parallèle sur Rc dans la formule du gain à vide.

        • Impédance d'entrée.

          Du circuit d'entrée, on tire l'équation suivante :

          Si on tire ib de l'équation [47] et qu'on le remplace par sa valeur dans [49], on obtient :

          On en tire l'impédance d'entrée :

          RE étant du même ordre de grandeur que h11e, le terme prépondérant est h11e / ( [image] +1). Cette impédance d'entrée est très faible, environ [image] fois plus faible que celle de l'émetteur commun : ce montage, sauf cas très spécial, est inexploitable tel quel, il faudra un étage adaptateur d'impédance en entrée pour l'utiliser.

          On peut remarquer que cette impédance d'entrée est quasiment la même que l'impédance de sortie du montage collecteur commun : si on se rappelle de ce qui a été dit à ce propos, l'impédance vue de l'émetteur est égale à tout ce qui est en amont divisé par le gain en courant : c'est exactement le cas ici, et on aurait donc pu prévoir facilement la valeur de l'impédance d'entrée sans calculs.

        • Impédance de sortie.

          Pour éviter de longs calculs inutiles, on ne tiendra pas compte de la résistance du générateur d'attaque Rg.

          Du circuit de sortie, on peut tirer l'équation suivante :

          L'équation [47] nous donne ib en fonction de Ve ; en le remplaçant par sa valeur dans [52], on obtient :

          C'est l'équation du générateur de Thévenin de sortie : on en déduit que Zs = Rc.

          Si on fait le calcul en tenant compte du générateur d'entrée, on démontre que le résultat reste le même, seul le terme multiplicatif de eg va changer dans l'expression de la tension de sortie du générateur de Thévenin, et le terme multiplicatif de is reste Rc.

          On a donc :

          On aurait pu prévoir ce résultat, car l'entrée est séparée de la sortie par un générateur de courant qui présente une impédance infinie (en pratique égale à 1/h22e, qui est très grand) : du point de vue des impédances, on se retrouve avec l'entrée séparée de la sortie.

        • Bilan. Utilisation du montage.

          Les caractéristiques sont donc les suivantes :

          même gain en tension que pour l'émetteur commun (plusieurs centaines).

          impédance d'entrée très faible : quelques dizaines d' [image].

          impédance de sortie moyenne : quelques k [image], la même que pour l'émetteur commun.

          En pratique, ce montage sera très peu utilisé, sauf en haute fréquence où il va présenter une bande passante supérieure à celle du montage émetteur commun.

    5. REMARQUES FONDAMENTALES.

      Il faudra garder à l'esprit ces deux remarques fondamentales , qui permettront d'évaluer grossièrement mais sans calculs les impédances des montages à transistors :

      tout ce qui est vu de la base et situé en aval de l'émetteur est multiplié par le gain en courant .

      tout ce qui est vu de l'émetteur et situé en amont de celui-ci est divisé par le gain en courant .

      Ces remarques sont fondamentales par le fait qu'on peut évaluer très rapidement les potentialités d'un montage sans faire de calculs sur le schéma alternatif petits signaux, qui, on l'a vu, sont particulièrement pénibles, et ne donnent pas beaucoup plus de précision que ce que l'on peut déterminer très simplement.

      Cette façon d'appréhender les choses permet à l'électronicien de bâtir un schéma rapidement sans se noyer dans les calculs, et aussi, permettent de mieux comprendre le fonctionnement d'un étage à transistor, autrement que par le biais d'équations.

    6. FONCTIONNEMENT EN HAUTE FRÉQUENCE

      Tout ce qui a été dit jusqu'à présent ne concerne que le fonctionnement à faible fréquence (inférieure à quelques centaines de kHz). Pour des fréquences plus élevées, on utilise un schéma équivalent du transistor différent, rendant mieux compte de ce qui se passe physiquement.

      Ce modèle introduit des capacités parasites, et donc, les paramètres du transistor deviennent complexes (au sens mathématique du terme !).

      Dans ce cours, on se contentera de présenter le schéma équivalent en HF, et on exposera le théorème de Miller, qui est très important pour la compréhension des limitations du transistor en haute fréquence.

      1. Schéma équivalent de Giacoletto.

        Fig. 22. Schéma de Giacoletto.

        Le schéma ci-dessus présente en plus des éléments du montage basse fréquence :

        une base B' virtuelle et interne au transistor. L'équivalent de h11e est rBB' + rB'C. rBB' sera faible (moins de 100 [image] en général), inférieure à rB'E.

        Une capacité base-émetteur CB'E qui viendra shunter rB'E en haute fréquence. Pour des petits transistors standards (2N2222 par exemple), elle est de l'ordre de 30pF.

        Une résistance rB'C (très grande, qui sera souvent négligée) en parallèle avec CB'C qu'on appelle capacité Miller, situées entre l'entrée et la sortie (pour un montage émetteur commun) du montage. L'ordre de grandeur pour CB'C est de 10pF (2N2222). Elle est prépondérante dans la limitation en fréquence du fonctionnement du transistor.

        la résistance rCE tient la place de 1/h22e.

        le gain en courant est remplacé par la pente gm du transistor : elle est équivalente au terme 38,5 ICo qu'on a défini dans le calcul du gain de l'émetteur commun.

        Ce schéma est plus délicat à manipuler que celui utilisé jusqu'à présent dans ce cours, donc, on ne l'utilisera que quand ce sera nécessaire, soit pour des fréquences supérieures à 100 kHz.

        Il permet de démontrer notamment la supériorité du montage base commune par rapport à l'émetteur commun en haute fréquence, ce qui était infaisable avec le schéma simplifié.

      2. Théorème de Miller.

        • Définition.

          Si on place une impédance entre l'entrée et la sortie d'un amplificateur de gain négatif -Av (inverseur, comme l'émetteur commun), alors, vue de l'entrée, cette impédance est multipliée par -(Av + 1).

          Fig. 23. Effet Miller.

        • Application au schéma de Giacoletto.

          On voit l'application immédiate au schéma de Giacoletto : la capacité CB'C située entre la base et le collecteur du transistor, donc entre l'entrée et la sortie d'un montage émetteur commun sera multipliée par le gain de l'étage : vue de l'entrée, elle vaudra plus d' 1nF !

          Elle devient alors prépondérante devant CB'E et c'est elle qui va limiter le fonctionnement en HF.

        • Autres applications.

          Une autre application importante consiste à utiliser cette propriété dans la conception de circuits intégrés. On fabrique des capacités avec deux surfaces métallisées en regard et séparées par de l'isolant. La capacité est proportionnelle à la surface, et en pratique, elle sera très petite (impératifs de coûts du silicium, donc des composants).

          On peut multiplier une capacité par effet Miller sur ces circuits, et gagner au choix de la surface de silicium ou augmenter la valeur de la capacité.


FET.HTM

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/FET/COURS.HTM#F01

INTRODUCTION.

Nous avons vu au chapitre précédent que le transistor à jonction était une source de courant commandée par un courant. Cette caractéristique permet à ce type de composants d'amplifier des signaux alternatifs.

Du point de vue théorique, on peut imaginer d'autres dispositifs similaires, mais caractérisés par un mode d'attaque différent : par exemple, une source de courant commandée par une tension. Le principe reste le même (une source commandée), seule la nature du signal de commande change.

Cet objet théorique existe : la famille des transistors à effet de champ (Field Effect Transistor en anglais, FET) répond à la définition précédente : ce sont des sources de courant commandées en tension.

De ce point de vue, on conçoit aisément que l'étude des FET va être en tous points similaires à celle des transistors à jonction, et ce, malgré un fonctionnement microscopique complètement différent.

Il ne faudra donc surtout pas se polariser sur les différences de structure et de fonctionnement prises du point de vue cristallographique, mais voir au contraire toutes les similitudes existant avec le transistor à jonction : polarisation, conversion courant / tension, amplification en régime des petits signaux

Ces similitudes sont dues aussi en grande partie au fait qu'on utilise les mêmes outils de modélisation pour les deux composants.

  • LE TRANSISTOR FET À JONCTION.

    1. PRINCIPE DE FONCTIONNEMENT.

      1. Constitution d'un FET.

        De même qu'il existe deux types de transistors bipolaires (NPN et PNP), le FET à jonction (ou JFET) est décliné en deux versions : le canal N et le canal P .

        Le FET à jonction canal N est constitué d'une mince plaquette de silicium N qui va former le canal conducteur principal. Cette plaquette est recouverte partiellement d'une couche de silicium P de manière à former une jonction PN latérale par rapport au canal (Fig. 1.).

        Fig. 1. FET à jonction à canal N (principe).

        Le courant circulera dans le canal, rentrant par une première électrode, le drain et sortant par une deuxième, la source . L'électrode connectée à la couche de silicium P sert à commander la conduction du courant dans le canal ; on l'appelle la grille , par analogie avec l'électrode du même nom présente sur les tubes à vides.

        Le transistor FET fonctionnera toujours avec la jonction grille-canal polarisée en inverse.

      2. Phénomène de pincement.

        • Tension drain-source nulle.

          Pour simplifier le raisonnement, nous allons considérer dans un premier temps un montage (Fig. 2.) où le canal est court-circuité (VDS = 0) et où la grille est à un potentiel négatif par rapport au canal (jonction polarisée en inverse).

          Nous avons vu dans le chapitre consacré à la diode que le fait de polariser la jonction en inverse créait une zone vide de porteurs, appelée zone de déplétion : les trous de la zone P se recombinent avec les électrons de la zone N, créant ainsi une zone neutre (il n'y a plus de porteurs pour assurer la conduction électrique) d'épaisseur w = k|VGS |.

          Fig. 2. Modulation de conductivité à VDS = 0.

          Il reste dans le canal N une zone conductrice d'épaisseur (h-w). La résistance entre drain et source sera alors égale à :

          où b est la largeur du canal et [image] sa résistivité. La résistance RDS varie donc avec la tension (inverse) appliquée sur la jonction grille-canal. A la limite, pour VGS = VP , appelée tension de pincement, la zone de déplétion ferme le canal : il n'y a plus de porteurs, et la résistance entre source et drain tend vers l'infini (Fig.3.) : c'est le phénomène de pincement.

          Fig. 3. Phénomène de pincement.

        • Tension drain-source non nulle.

          Si on reprend le montage précédent, et qu'en plus on applique une tension positive entre le drain et la source, le gradient de potentiel présent tout le long du barreau de silicium constituant le canal va modifier le profil de la zone de déplétion. Vers le drain, la tension grille-canal sera supérieure (en valeur absolue) à ce qu'elle est vers la source. En effet, on a la relation (attention, tous les termes sont négatifs) :

          En conséquence, la zone isolante présente une forme similaire à celle donnée sur la figure 4.

          Fig. 4. Modulation de conductivité pour VDS non nul.

          Sur cette figure, le canal n'est pas complètement bouché. Si on augmente la tension VDS , à VGS donnée, l'épaisseur isolante w2 va augmenter ; à partir d'une certaine tension VDS , correspondant à une largeur du canal très faible, le courant va tendre vers une valeur constante, car deux phénomènes contradictoires vont s'équilibrer :

          une augmentation de VDS devrait entraîner un accroissement du courant dans le canal (loi d'ohm),

          mais cette augmentation de VDS va accroître la tension VDG, qui aura pour effet d'agrandir la zone de déplétion et entraîner une diminution de la largeur du canal, donc, de sa résistivité.

          Un accroissement de la tension VDS ne va donc pas entraîner une augmentation du courant dans le canal (le courant de drain), mais une augmentation de la résistivité de ce canal. Le courant de drain va tendre vers une valeur constante.

    2. CARACTÉRISTIQUES.

      A partir de ce qui a été dit dans le paragraphe précédent, on peut déjà deviner trois choses :

      Si VGS = VP , dans tous les cas, quelle que soit la tension VDS , le courant dans le canal sera nul. En effet, une tension VDS non nulle ne fera que renforcer le phénomène de pincement.

      Le courant de drain deviendra d'autant plus vite constant que la tension |VGS | sera plus élevée.

      Le courant constant maximum sera obtenu pour une tension grille-source nulle.

      Les caractéristiques du FET s'en déduisent aisément.

      1. Caractéristique d'entrée.

        Nous avons vu que le FET sera toujours utilisé avec une polarisation grille-canal négative, soit VGS < 0. La caractéristique correspondante est donc celle d'un interrupteur ouvert : courant nul quelque soit la tension appliquée. En pratique, on aura un très léger courant de fuite caractéristique d'une jonction diode polarisée en inverse. Ce courant double tous les 6°C pour le silicium. A température ambiante, il sera inférieur au µA, et plutôt de l'ordre de quelques nA.

      2. Caractéristiques de sortie et de transfert.

        La figure 5 représente les caractéristiques de transfert IDS = f (VGS) à gauche, et de sortie IDS = f (VDS , VGS) à droite.

        Fig. 5. Caractéristiques du FET à jonction.

        La caractéristique de sortie peut être décomposée en deux grandes zones :

        la partie correspondant au fonctionnement à courant constant (zone de pincement), et qui servira à l'amplification de petits signaux de la même manière que pour le transistor bipolaire.

        la zone ohmique (en grisé sur la figure 5.) : dans cette zone, le FET est assimilable à une résistance dont la valeur est fonction de la tension VGS . On ne représente que la partie positive de la caractéristique, mais en fait, le canal conducteur peut laisser passer le courant dans les deux sens (c'est juste un barreau de silicium conducteur, ce n'est pas une jonction. Le seul défaut qui limite les valeurs négatives de VDS est le fait qu'au delà d'une certaine tension négative de drain, la tension grille-drain devient positive, la jonction grille-canal étant alors polarisée en direct ; le FET ne fonctionne plus correctement. Néanmoins, et à condition de rester dans le domaine des petits signaux (quelques dizaines à quelques centaines de mV), on peut considérer le FET comme une résistance dont la valeur est pilotée en tension.

        On notera que les caractéristiques de sortie ont une allure connue : on retrouve celles du transistor bipolaire. La principale différence provient du mode d'attaque, comme indiqué en introduction : le FET est commandé en tension, et non en courant, comme l'est le bipolaire.

        Ce réseau de courbes est borné en bas (ID = 0, VGS = VP ), et en haut (ID = IDSS , VGS = 0). IDSS est la valeur maxi de courant de drain qui pourra circuler dans le composant. Cette valeur est de l'ordre de quelques mA à quelques dizaines de mA pour les FETs courants. La tension de pincement VP est de l'ordre de quelques volts (typiquement de -2 à -8V).

        La zone ohmique est sensiblement différente de la zone de saturation du transistor bipolaire. La fonction résistance commandée est spécifique au FET et ne peut pas être réalisée de cette façon avec un transistor bipolaire.

        Pour une même référence de FET (2N3819 par exemple), la dispersion de IDSS et VP sera très importante, plus encore que la dispersion observée pour les caractéristiques des transistors bipolaires. Ceci fait que ces transistors ne pourront pas être utilisés sans précautions dans des montages pointus, ni à plus forte raison, dans des montages de précision.

        La caractéristique de transfert IDS = f (VGS) résume bien les limites du FET : courant de drain nul pour une tension VGS égale à la tension de pincement VP, et courant maxi IDSS pour une tension VGS nulle. La courbe est assez bien approximée par une parabole d'équation :

        La dérivée de cette loi va nous renseigner sur l'aptitude du transistor à amplifier : en effet, pour un courant IDS donné, la dérivée (qu'on appelle judicieusement la pente du FET) va être égale à :

        Cette pente est le rapport de la variation du paramètre de sortie (IDS ) et du paramètre d'entrée (VGS ) ; elle est bien représentative de l'amplification d'un signal d'entrée. La valeur maximum, atteinte pour VGS = 0, vaut :

        On peut alors exprimer l'équation [4] sous la forme condensée suivante :

        La pente du FET est en moyenne relativement faible, soit quelques mA/V, au mieux quelques dizaines de mA/V. Elle dépend de la tension VGS (la tension de polarisation) : comme pour le transistor bipolaire, l'amplification ne sera pas linéaire ; on fera là aussi des hypothèses de fonctionnement en petits signaux.

        On peut d'ailleurs faire un parallèle avec l'amplification du transistor bipolaire. A elle seule, la caractéristique de transfert du FET correspond à la caractéristique globale entrée + transfert du bipolaire. En effet, dans ce dernier, la vraie caractéristique de transfert est une transformation courant-courant IC =f (IB), la caractéristique d'entrée opérant la conversion tension-courant. De ce point de vue, on peut considérer le bipolaire comme un générateur de courant commandé en tension (la différence avec le FET est qu'il consomme du courant). La pente du transistor bipolaire (le rapport [image] IC / [image] VBE) vaut alors :

        Pour un courant collecteur de 1,3mA et un [image] de 150, le h11e vaut 3k [image], ce qui fait une pente d'environ 50mA/V.

        La pente du transistor bipolaire est environ 5 à 10 fois plus élevée que celle d'un FET typique. L'amplification qu'on pourra attendre d'un FET sera plus faible que celle obtenue dans les mêmes conditions avec un bipolaire.

    3. REPRÉSENTATION. SCHÉMA ÉQUIVALENT.

      1. Symboles des FETs.

        Le FET est représenté par les symboles suivants :

        Fig. 6. Symboles électriques des FETs.

        La flèche représente la jonction grille / canal, et son sens indique quel serait le sens du courant si la jonction était passante.

        Pour le FET canal N, le courant ID circulera dans le sens représenté sur la figure 6, la tension VDS sera positive et la tension VGS négative.

        Pour le FET canal P, la tension VDS sera négative et la tension VGS positive. Le courant de drain circulera de la source vers le drain.

      2. Schéma équivalent en petits signaux.

        Ce schéma, comme pour le transistor bipolaire, concerne un composant convenablement polarisé : le fonctionnement se fera dans la zone de pincement.

        On construit le schéma équivalent de la même manière que pour le transistor bipolaire.

        Fig. 7. Schéma équivalent alternatif petits signaux.

        Le schéma fig. 7. est celui relatif au FET canal N. L'entrée se fait sur la grille. On note un trou entre grille et source : l'impédance grille-source est très élevée, on la considère en première approximation comme infinie. En sortie, on retrouve les mêmes éléments que pour le transistor bipolaire : une source de courant (commandée par la tension VGS , et non par un courant), et sa résistance parallèle [image]. Comme pour le transistor bipolaire, cette résistance est très élevée (plusieurs centaines de k [image] ), et on la négligera dans toutes les applications courantes.

    4. MONTAGE SOURCE COMMUNE.

      Ce montage est le pendant du montage émetteur commun pour le bipolaire. Le fonctionnement sera donc totalement similaire. Un montage drain commun existe aussi, qui est le pendant du montage collecteur commun du bipolaire ; ce montage n'a toutefois que peu d'intérêt, car le FET est un composant à très forte impédance d'entrée, et ce, on va le voir, même lorsqu'il est utilisé en source commune.

      Nous allons voir le montage source commune pour le FET de type N. Le montage à canal P s'en déduit aisément.

      1. Polarisation.

        Il faut tout d'abord noter que la zone ohmique est relativement étendue, surtout vers les fortes valeurs de IDS . On veillera à polariser le composant pour que la tension de repos VDSo ne soit pas trop faible, de manière à ce qu'il fonctionne dans la zone générateur de courant .

        Fig. 8. Montage source commune.

        Nous avons vu lors de l'explication du principe de fonctionnement du FET que le bon fonctionnement nécessitait une alimentation positive pour polariser le canal drain-source, et une alimentation négative pour polariser la grille par rapport à la source. Ce raisonnement est valable si on place la source à la masse.

        En pratique, on va relier la grille à la masse par une résistance de forte valeur ; comme le courant qui circule dans la grille est très faible (courant de fuite), le potentiel de la grille va être pratiquement nul. Il reste à trouver une astuce pour mettre la source à un potentiel positif, ce qui fera VSG positif, donc VGS négatif. Pour ce faire, on intercale une résistance entre la source et la masse. Le courant de drain va circuler dans cette résistance et élever le potentiel de la source par rapport à la grille. Deux phénomènes vont alors se contrarier :

        Le courant de drain est maxi pour VGS = 0 ; au démarrage, on aura donc un fort courant dans la résistance de source, donc une forte tension.

        mais, au fur et à mesure que la tension va augmenter, la tension |VGS | va augmenter aussi, ce qui va avoir pour effet de limiter le courant de drain.

        Les deux phénomènes vont s'équilibrer. La valeur du courant de drain va dépendre des caractéristiques du FET (IDSS et VP ), et de la résistance de source : c'est cette dernière qui nous permettra d'ajuster le courant de drain.

        La tension de polarisation sur RS sera de l'ordre de quelques volts (typiquement 1 à 3V).

        Il ne reste plus qu'à alimenter le drain à l'aide d'une source de tension, en intercalant une résistance RD qui aura pour fonction (comme pour le montage émetteur commun du bipolaire) la conversion courant / tension permettant d'exploiter le signal de sortie.

        On choisira le courant de drain (ou la résistance RD ) de manière à ce que la chute de tension dans cette résistance soit égale à la tension de polarisation VDSo , ceci pour assurer un maximum de dynamique au signal alternatif.

        On rajoute un condensateur de découplage CD sur RS pour que la source soit effectivement à la masse en alternatif. Sans ce condensateur, on aurait un effet de contre réaction qui affaiblirait beaucoup le gain en tension.

        Vu que la grille est au même potentiel que la masse (autant dire zéro !), le générateur d'entrée, s'il délivre uniquement un signal alternatif, peut être couplé directement à la grille, sans condensateur de liaison. La sortie se faisant sur le drain, en revanche nécessite un condensateur de liaison pour ne pas perturber les étages avals.

      2. Fonctionnement en petits signaux.

        Nous avons vu que la caractéristique de transfert du FET n'est pas linéaire : nous allons donc être obligés de travailler en petits signaux pour pouvoir linéariser le montage et utiliser les lois fondamentales de l'électricité.

        • Schéma équivalent.

          Le schéma équivalent se construit de la même manière que pour les montages à transistors bipolaires. On utilise le schéma équivalent du FET de la figure 7, et on obtient :

          Fig. 9. Schéma équivalent en alternatif petits signaux.

          Ce schéma est très similaire à celui de l'émetteur commun du transistor bipolaire. La différence essentielle est que le générateur de courant est commandé par la tension VGS , et non pas par un courant ib .

        • Gain en tension.

          Les équations sont quasiment triviales. En entrée, on a :

          En sortie, si on néglige [image], dont la valeur est très élevée vis à vis de RD , on a :

          On en tire aisément le gain en tension à vide :

          Ce gain a une valeur relativement faible, due au fait que g ne dépasse guère la dizaine de mA/V : on aura des valeurs comprises entre 10 et 50 environ.

          On peut faire l'analogie avec le montage émetteur commun en bipolaire, dont le gain était égal à -38,5 ICo RC . Le terme 38,5 ICo avait été appelé la pente du transistor. RC a la même fonction que le RD du montage à FET, et pour des valeurs identiques de tension d'alimentation et de courant de drain / collecteur (par exemple 1mA), leur valeur sera la même. La différence se fera donc sur la pente, soit 38,5 mA/V pour le bipolaire contre 5 mA/V en typique pour le FET.

        • Impédance d'entrée.

          La solution est triviale :

          On veillera à ne pas choisir une valeur trop élevée tout de même pour que la chute de tension occasionnée par le courant de fuite de la grille soit négligeable. On choisira typiquement une valeur de l'ordre de quelques M [image] . L'avantage sur les montages à bipolaires est évident.

        • Impédance de sortie.

          On se retrouve exactement dans le même cas de figure que pour le montage émetteur commun du bipolaire. En opérant la même transformation norton-thévenin que pour ce dernier montage, on trouve :

          Cette valeur est moyenne, RD valant typiquement quelques k [image] . On ne pourra généralement pas utiliser ce montage sans un étage adaptateur d'impédance en aval.

    5. UTILISATION EN RÉSISTANCE COMMANDÉE.

      Si on utilise le FET dans la zone ohmique, on peut faire varier la résistance du canal en modifiant la tension VGS . Le FET est utilisé dans un montage potentiométrique (diviseur de tension) mettant en jeu la résistance RDS du canal et une résistance additionnelle R.

      Sur le schéma figure 10, on remarque un réseau r-r-C reliant le drain à la grille et à la commande. On pourrait appliquer directement la tension VC sur la grille, mais en rajoutant ce réseau, on améliore la linéarité, notamment pour des tensions VE , donc VS négatives : en effet, on a déjà vu que dans ce cas, la jonction grille-canal est polarisée en direct, et le FET ne travaille pas convenablement. En appliquant sur la grille la moitié de la tension alternative présente sur le drain, on améliore sensiblement la linéarité et la tension maxi d'utilisation du FET en résistance commandée. Cette tension maxi demeure faible (quelques dizaines à quelques centaines de mV).

      Fig. 10. Utilisation en résistance commandée.

      Cette fonction est utilisée en particulier dans des amplificateurs à commande automatique de gain (CAG), qui permettent de garantir un niveau de sortie constant avec un niveau d'entrée fluctuant (exemple : réglage automatique du niveau d'enregistrement des magnétophones à cassette audio bon marchés).

      Une autre application déduite de la fonction résistance commandée est le commutateur analogique : si on applique une tension supérieure ou égale en valeur absolue à la tension de pincement VP sur la commande, la résistance de drain va devenir très grande (quelques M [image] ). Si on choisit pour R une valeur moyenne (quelques dizaines de k [image] ), la tension VS sera quasiment égale à la tension VE : tout le signal passe.

      Si on applique maintenant une tension nulle sur la grille, la résistance du FET sera minimum (quelques centaines d'ohms), et la tension VS sera quasiment nulle.

      On a ainsi réalisé un commutateur analogique. Cette fonction est très utilisée sous forme de circuits intégrés et permet le multiplexage de signaux analogiques, une fonction indispensable pour les dispositifs d'acquisition de données.

    6. SOURCE DE COURANT.

      Fig. 11. Source de courant à deux bornes.

      On a vu lors de la polarisation du montage source commune comment procéder pour obtenir un courant de polarisation de drain constant. L'ajustage de la résistance de source définit le courant de drain. Si on retire du montage source commune la résistance de drain, on se retrouve avec un dispositif à deux bornes susceptible de garantir un courant constant dans le circuit sur lequel il sera branché.

      Des circuits intégrés existent, qui comprennent le FET et sa résistance de polarisation (la résistance de grille est ici inutile), et qui peuvent servir de sources de courant préréglées. Des restrictions limitent toutefois leur usage :

      le composant est polarisé : le courant ne peut circuler que dans un seul sens.

      ce dispositif ne génère pas de courant, il le régule (comme la zéner régule une tension).

      la tension appliquée entre les deux bornes du composant doit être au moins supérieure à la tension VGS de polarisation permettant le fonctionnement du FET dans sa zone de pincement.

    7. DOMAINE D'UTILISATION.

      De par sa constitution, le FET à jonction n'est pas adapté du tout aux forts courants. Il va rester cantonné aux applications d'amplification et de traitement des petits signaux.

      Il est utilisé dans des montages à haute impédance d'entrée et faible bruit : préamplificateurs pour signaux de faible niveau par exemple.

      La fonction résistance commandée est beaucoup utilisée. Il y a bien sûr des restrictions d'utilisation : la portion de caractéristique ohmique est linéaire pour des faibles variations de tension (guère plus de 100mV), ce qui nécessite des précautions de mise en œuvre .

      Mais, le JFET, de par la dispersion de ses caractéristiques d'un composant à l'autre reste difficile à maîtriser dans des montages à composants discrets. On a intérêt à les trier si on désire un résultat fiable et répétable.

      Dans ces conditions, l'utilisation la plus importante qui est faite de ces transistors est l'intégration dans des composants tels les amplificateurs opérationnels : la très forte impédance d'entrée des JFET leur donne un avantage décisif par rapport aux bipolaires, et aujourd'hui, la plupart des ampli-op de qualité possèdent au minimum un étage d'entrée en JFET.

      Pour ce qui est du volet puissance, il existe un autre composant très bien adapté : le MOSFET.

  • LE TRANSISTOR MOS FET.

    Les transistors à MOSFET reprennent plusieurs caractéristiques de FETs à jonction : ils se déclinent en deux versions, le canal N et le canal P, et les électrodes vont aussi s'appeler drain, source et grille, leur fonction étant la même que pour les JFETs.

    1. LE MOSFET À CANAL INDUIT.

      1. Description.

        Dans un substrat faiblement dopé P, on insère deux zones N fortement dopées. Ces deux zones seront la source et le drain du MOSFET ; elles sont distantes d'une dizaine de µm (séparées par le substrat P). La source est généralement reliée au substrat.

        La grille n'est pas directement reliée au substrat P ; elle en est isolée par l'intermédiaire d'une très fine (quelques nm) couche d'isolant (de l'oxyde de silicium). Cette caractéristique donne son nom au MOSFET : Metal Oxyde Semiconductor.

        La grille est ainsi isolée du substrat : le courant de grille sera nul en continu.

        Fig. 12. Schéma de principe d'un MOSFET canal N.

      2. Principe de fonctionnement.

        Si VGS = 0, aucun courant de drain ne passera, car le circuit source-drain est composé de deux jonctions en série, l'une PN, l'autre NP : il y en aura toujours une en inverse.

        Lorsqu'on applique une tension VGS positive, l'électrode de grille, l'isolant et le substrat P forment un condensateur.

        Fig. 13. Phénomène d'inversion.

        Les électrons (porteurs minoritaires du substrat P) sont alors attirés vers la grille. Pour une tension VGS suffisamment élevée (tension de seuil), la concentration en électrons dans le substrat est supérieure à la concentration en trous au voisinage de la grille ; on a alors une couche N dite couche d'inversion entre les zones N de la source et du drain. Les deux jonctions disparaissent, on n'a plus qu'un canal N, et le courant peut passer entre drain et source.

        Mais, pour une tension VDS supérieure à VGS , on annule la tension grille-drain, et donc l'effet condensateur : on a un phénomène de pincement du canal induit N comme pour le JFET. Le courant de drain tend alors vers une valeur constante, de la même manière que pour le JFET.

        Ce mode de fonctionnement est appelé à enrichissement , car une tension VGS positive enrichit le canal en porteurs minoritaires, permettant le passage du courant.

      3. Caractéristiques.

        Fig. 14. Caractéristique de sortie du MOS canal N.

        La caractéristique de sortie est similaire à celle d'un JFET, sauf que le courant de drain pourra atteindre plusieurs ampères pour des composants de puissance. On note la zone en fonctionnement ohmique, tout à fait similaire à celle des JFETs, et permettant les mêmes applications.

        La caractéristique de transfert a la forme suivante :

        Fig. 15. Caractéristique de transfert du MOS canal N.

        Cette caractéristique de transfert est appelée la transconductance du MOS, et est exprimée en siemens (S). Pour des MOS de puissance, elle vaut plusieurs siemens (1 à 10 typiquement), soit des valeurs beaucoup plus importantes que pour les JFETs (quelques mS).

        La tension de seuil atteint plusieurs volts (1 à 3 typique). Ce seuil varie avec la température.

    2. LE MOSFET À CANAL INITIAL.

      1. Description du principe de fonctionnement.

        Le MOSFET à canal initial a la même structure que le MOS à canal induit, avec en plus, un canal faiblement dopé N entre la source et le drain.

        Pour VGS nulle, Ce transistor fonctionne comme un JFET : un courant de drain pourra circuler ; quand VDS augmente, un phénomène de pincement se produit, qui obstrue le canal : le courant de drain devient constant.

        Si VGS est inférieure ou égale à 0, on accélère le pincement (le condensateur formé par la grille, l'isolant et le canal attire des trous dans le canal initial qui neutralisent les électrons de cette zone N) : on fonctionne en régime d'appauvrissement.

        Au contraire, pour VGS supérieure à 0, on retrouve le fonctionnement du MOS à canal induit, et le courant de drain va croître.

        Fig. 16. MOSFET N à canal initial..

      2. Caractéristiques.

        La caractéristique de transfert est la suivante :

        Fig. 17. Caractéristique de transfert d'un MOS à canal initial

    3. UTILISATION DES MOSFETs.

      De par leur constitution, les transistors MOS sont très fragiles, notamment au niveau de la grille. Les décharges électrostatiques sont à proscrire, car elles peuvent casser le composant, ou pis, l'endommager sans que ses caractéristiques ne changent : c'est la fiabilité qui est compromise.

      1. MOSFET de puissance.

        Les MOS servent beaucoup en commutation de puissance, car ils sont très rapides et commandables en tension. On notera toutefois qu'à fréquence élevée, la grille formant un condensateur avec le substrat, elle ne présente plus une impédance infinie, comme en statique !

        Quand ils sont passants, ils fonctionnent dans la zone ohmique, et leur caractéristique essentielle est, avec la tension VDS maxi, la résistance RDS , qui peut être aussi basse qu'une dizaine de m [image].

      2. Intégration dans les composants numériques.

        La technologie MOS se prête très bien à l'intégration à grande échelle : elle permet de réaliser des composants logiques consommant très peu de courant, et permet ainsi un très grand niveau d'intégration (exemple : mémoires, microprocesseurs, circuits logiques divers ) Les transistors MOS sont utilisés ici en commutation.


Amplificateur opérationnel

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/AOP/COURS.HTM#AO63

  1. INTRODUCTION.

    Comme nous avons pu le constater dans les chapitres précédents, les montages amplificateurs de base à transistors ne sont pas très commodes d'emploi :

    ils ne transmettent pas le continu ;

    ils sont tributaires des dispersions des transistors, ce qui fait que leurs caractéristiques sont imprécises et non répétables ;

    leurs performances sont moyennes, et à moins d'aligner un montage à plusieurs transistors, on ne peut pas avoir simultanément fort gain en tension, haute impédance d'entrée et faible impédance de sortie.

    Les amplificateurs opérationnels sont nés au début des années 60, quand on a commencé à intégrer plusieurs transistors et résistances sur le même substrat de silicium ; cette technologie a permis de bâtir des montages complexes, et de les faire tenir sur une petite plaquette de silicium encapsulée dans un boîtier (généralement à 8 broches) commode d'emploi.

    Avec ces composants, on a eu accès à des amplificateurs simples d'utilisation, transmettant des signaux continus, et à mise en œuvre facile à l'aide de quelques composants annexes (résistances, condensateurs...) ; les caractéristiques des montages obtenus ne dépendent quasiment plus de l'amplificateur opérationnel, mais uniquement des composants passifs qui l'accompagnent, ce qui garantit une bonne fiabilité du résultat et assure sa répétabilité.

    Les amplificateurs opérationnels ont beaucoup progressé depuis leur création, et tendent maintenant à devenir très proches de l'amplificateur idéal (l'amplificateur opérationnel parfait, AOP).

  2. L'AMPLIFICATEUR OPÉRATIONNEL PARFAIT.

    1. PRINCIPE.

      A la base, l'AOP est un amplificateur différentiel, donc muni de deux entrées , l'une dite non inverseuse (V+) et l'autre inverseuse (V-), et d'une sortie (s) :

      Fig. 1. Symbole d'un amplificateur différentiel.

      La fonction de transfert complète en continu (en pratique, Avd et Avmc dépendent de la fréquence) de cet amplificateur est donnée par la formule :

      Avd est le gain en tension différentiel de l'amplificateur, et Avmc le gain en tension de mode commun. Dans le cas d'un amplificateur parfait, on fait l'hypothèse que ces gains ne dépendent pas de la fréquence.

      Les gains, ainsi que les impédances d'entrée et de sortie d'un AOP doivent répondre à des critères précis. On peut donner un schéma équivalent de l'AOP :

      Fig. 2. Schéma équivalent d'un AOP.

    2. CARACTÉRISTIQUES.

      Pour que cet amplificateur soit parfait, les gains en tension doivent répondre aux caractéristiques suivantes :

      Avd =

      Avmc = 0

      On distingue deux types d'impédances d'entrée dans un AOP : l'impédance différentielle et celles de mode commun, qui sont définies sur le schéma de la figure 2.

      Un ampli parfait doit répondre aux critères suivants du point de vue des impédances :

      Zed =

      Zemc =

      Zs = 0

      En résumé : un amplificateur opérationnel parfait est un amplificateur de différence pur à gain différentiel infini, rejetant parfaitement le mode commun, dont les impédances d'entrées sont infinies et l'impédance de sortie est nulle. En pratique, nous verrons que l'amplificateur opérationnel réel présente des défauts par rapport à l'idéalisation que constitue l'AOP, mais le modèle de ce dernier est suffisant pour étudier la plupart des montages simples sans faire des calculs laborieux et inutiles : en effet, du point de vue impédances et gains, et sauf à utiliser les composants à leurs limites, les amplis réels sont suffisamment près des AOP pour qu'on fasse les approximations avec une erreur minime (très souvent mieux que le %). Seul le comportement fréquentiel pose vraiment problème par rapport au modèle idéal.

    3. FONCTIONNEMENT D'UN SYSTÈME BOUCLÉ.

      Tous les montages fondamentaux vont être étudiés avec les hypothèses relatives au modèle d'AOP parfait telles que décrites précédemment.

      Dans ces hypothèses, on a vu que le gain en tension différentiel tendait vers l'infini : cela implique que la tension d'entrée différentielle (V+ - V-) va devoir tendre vers 0 pour que la tension de sortie soit finie (voir équation [1]).

      Une grande conséquence de ceci est qu'on n'utilisera (quasiment) jamais un amplificateur opérationnel en boucle ouverte pour un fonctionnement linéaire ; on l'utilisera toujours avec une contre réaction, soit en boucle fermée : on réinjectera une fraction de la tension de sortie sur l'entrée inverseuse (retour du signal en opposition de phase). Nous allons maintenant étudier quelques rudiments de la théorie des systèmes bouclés pour mieux comprendre le fonctionnement des montages classiques utilisant des AOP.

      1. Schéma-bloc d'un système bouclé.
        On peut représenter un système bouclé à une entrée et une sortie de la manière suivante :

        Fig. 3. Système bouclé.

        Le signal est d'abord atténué en passant dans le bloc de fonction de transfert [image] (qui dans beaucoup de cas est égale à l'unité : on peut alors supprimer ce bloc), et arrive ensuite dans un mélangeur différentiel.

        Dans ce mélangeur, une fraction du signal de sortie est soustraite du signal d'entrée atténué. Le tout est multiplié par la fonction de transfert du bloc A. On obtient l'équation suivante :

        On peut en tirer le rapport H=s/e, qui est la fonction de transfert du système bouclé :

        Le produit AB est le gain de boucle du système ; dans un système bouclé, on cherche à ce qu'il soit le plus grand possible de manière à ce que H dépende très peu de A. En effet, si AB>>1, on peut écrire :

        Si [image] et B sont bien maîtrisés (ce sont la plupart du temps des réseaux constitués de composants passifs de précision correcte), la fonction de transfert H ne dépendra quasiment plus de la fonction de transfert A, qui pourra être assez imprécise, pourvu que sa valeur soit élevée. On réalise un asservissement de la sortie à l'entrée au facteur [image] /B près.

        Deux autres avantages (que nous ne démontrerons pas ici) concernent les impédances d'entrée et de sortie :

        l'impédance différentielle d'entrée est multipliée par le gain de boucle.

        l'impédance de sortie est divisée par le gain de boucle.

        Ces deux propriétés sont importantes, car elles vont permettre d'améliorer les performances apparentes des amplificateurs réels, et donc de justifier encore mieux le fait qu'on utilise le modèle de l'AOP pour faire les calculs.

      2. Application à l'AOP.
        Le fonctionnement en asservissement tel que décrit précédemment va convenir idéalement aux amplificateurs opérationnels : ceux-ci présentent un gain en tension très élevé, mais défini à un facteur trois ou quatre près sur un lot de composants et en fonction des conditions d'utilisation (charge, température...). Le fait de les boucler va permettre de s'affranchir de leurs imperfections.

        L'AOP est un amplificateur différentiel à grand gain. On peut reprendre le schéma de la figure 3 et l'adapter à son cas.

        Fig. 4. L'AOP bouclé.

        Ce montage appelle quelques commentaires :

        La fonction de transfert A est le gain différentiel de l'amplificateur (infini pour un AOP, très grand et dépendant de la fréquence pour un ampli réel).

        les blocs [image] et B sont des quadripôles (donc munis de deux entrées et de deux sorties) ; dans le cas des montages à AOP, ces quadripôles ont en fait une entrée et une sortie reliées à la masse : elles ne sont pas représentées sur les schémas blocs.

        si le signal d'entrée e rentre (via le bloc [image]) sur l'entrée V-, il faudra rajouter un signe - à [image] pour que les équations précédentes soient vérifiées.

        On a vu que dans le cas de l'AOP, le gain A est infini. Le gain de boucle sera donc lui aussi infini, et à la sortie du mélangeur différentiel, on va avoir un signal qui tend vers 0 pour que le signal de sortie s ait une valeur finie.

        L'amplificateur ne va pas amplifier le signal proprement dit, mais l'écart entre l'entrée et la sortie qui va donc copier fidèlement l'entrée au facteur [image] /B près. On parle alors d'amplificateur d'erreur.

      3. Calcul des montages à AOP.
        Il existe deux alternatives pour calculer les montages à amplificateurs opérationnels : utiliser la loi d'ohm, ou les traiter par la méthode des schémas-blocs.

        Pour la suite du cours, les montages (qui sont des montages de base, donc simples) seront calculés à l'aide de la loi d'ohm ; toutefois, pour illustrer au moins une fois le calcul par schéma-blocs, nous allons traiter l'amplificateur inverseur par cette méthode.

        Pour des montages un peu compliqués, la loi d'Ohm (et ses dérivés : théorème de superposition, Thévenin...) donnent assez vite des mises en équation laborieuses ; de plus, si on veut prendre en ligne de compte le comportement fréquentiel de l'amplificateur réel, les calculs deviennent trop complexes et peu intelligibles.

        On calculera alors les montages par la méthode des blocs. Cette méthode est aussi très pratique dans le cas de calcul de fonctions de transferts à l'aide d'outils informatiques : le problème est bien décomposé et donc plus facile à simuler.

  3. MONTAGES DE BASE À AOP.

    Dans "amplificateur opérationnel", il y a deux mots :

    amplificateur : c'est la fonction de base de ce composant ; on va étudier plusieurs montages amplificateurs de base.

    opérationnel : les caractéristiques de cet ampli nous donnent la possibilité de créer des fonctions mathématiques telles que dérivée, intégrale, Log... Ces fonctions ont autrefois (il y a 25 ans !) été utilisées dans des calculateurs analogiques, et permettaient notamment de résoudre des équations différentielles, et ainsi de simuler des réponses de systèmes physiques divers (mécaniques, acoustiques...). D'où le nom "opérationnel". Nous étudierons les fonctions opérationnelles de base.

    1. AMPLIFICATION

      1. Amplificateur inverseur.
        C'est le montage de base à amplificateur opérationnel. L'entrée non inverseuse est reliée à la masse ; le signal d'entrée est relié à l'entrée inverseuse par une résistance R1, et la sortie est reliée à cette entrée par une résistance R2.

        Fig. 5. Amplificateur inverseur.

        • Calcul par la loi d'ohm.
          La mise en équation est très simple, et s'appuie sur les conditions vues lors de la définition de l'AOP :

          les impédances d'entrée étant infinies, il n'y a pas de courant qui rentre dans l'entrée inverseuse (V-) ; par conséquent, tout le courant i arrivant dans R1 ira par R2 vers la sortie de l'AOP.

          Le gain Avd est infini ; dans ces conditions, (V+ - V-) va tendre vers 0.

          De cette dernière constatation, on peut tirer une équation simplissime, mais fondamentale, et toujours vraie en fonctionnement linéaire :

          Comme V+ est à la masse, V- se retrouve au même potentiel : comme ce point n'est pas relié physiquement à la masse, on parle de masse virtuelle ; pratiquement, et du point de vue calcul, tout se passe comme si V- était vraiment relié à la masse.

          Ces constatations étant faites, le calcul du gain en tension est un jeu d'enfant :

          On fera attention à l'expression [7] : la tension et le courant sont dans le même sens, d'où le signe -.

          Le gain en tension est donc négatif, et sa valeur ne dépend que des deux résistances R1 et R2, qui peuvent être très précises : contrairement aux montages à transistors, le résultat va être fiable et répétable !

          Le calcul de l'impédance d'entrée est aussi simple :

          On voit ici les limites de ce montage amplificateur : pour obtenir un fort gain en tension, il faut augmenter R2 et diminuer R1 ; or, on va de ce fait diminuer l'impédance d'entrée. Comme celle ci devra rester suffisamment grande et que d'autre part, on ne peut pas augmenter R2 au delà de quelques M [image] (problèmes de bruit, les imperfections des amplis réels deviennent sensibles...), le gain sera limité et ne pourra pas trop dépasser quelques centaines, ce qui est déjà très bon !

          L'impédance de sortie sera nulle, comme celle de l'AOP, et comme celle de tous les autres montages basés sur un AOP :

        • Calcul par la méthode des schémas-blocs.
          On a ici un réseau de deux résistances partant de l'entrée et aboutissant à la sortie, en passant par l'entrée - de l'ampli.

          Comment se ramener à un schéma équivalent à celui de la figure 4 ? D'abord, on remarque qu'aucun signal n'arrive sur l'entrée + de l'ampli : c'est un des cas où on va mettre un signe - au terme [image]. Ensuite, pour calculer [image] et B, il va falloir utiliser le théorème de superposition.

          Partant de ces deux remarques, on peut définir le quadripôle [image] (figure 6). Il devrait théoriquement arriver sur l'entrée + de l'ampli, on compensera le fait qu'il arrive sur l'entrée - par un signe -. Pour déterminer le quadripôle [image], on utilise le théorème de superposition : on considère que Vs est égal à 0, seule compte la contribution de Ve. La valeur de [image] est alors triviale (pont diviseur) :

          Fig. 6. Quadripôle [image].

          De la même manière, on va obtenir le quadripôle B : théorème de superposition, on "éteint" la source Ve, et ici, pas de signe -, car B reboucle bien sur l'entrée - de l'ampli.

          Fig. 7. Quadripôle B.

          B vaudra :

          Au final, si on applique le résultat de l'équation [4] à nos valeurs, on obtient bien :

          On note que dans ce cas, la méthode des schémas-blocs est plus longue que l'utilisation de la loi d'ohm : nous l'avons déjà dit, elle devient "rentable" quand le schéma se complique, ou pour faire des simulations sur ordinateur (logiciels de tracé de courbes travaillant en complexes, calculateurs vectoriels et matriciels...)

      2. Généralisation à des dipôles quelconques.

        Fig. 8. Amplificateur inverseur généralisé.

        On a précédemment établi un résultat pour deux résistances R1 et R2 ; on peut appliquer ce résultat à n'importe quels dipôles d'impédances Z1 et Z2. La condition que Z1 et Z2 soient des dipôles est fondamentale. Le gain en tension est le suivant :

        Ceci ouvre la voie à tout une panoplie de filtres et correcteurs en fréquence divers et variés ; le gros avantage de l'AOP par rapport à des circuits purement passifs, c'est qu'on va pouvoir amplifier le signal à certaines fréquences, et non plus seulement l'atténuer, ce qui offre des débouchés nouveaux et intéressants.

      3. Amplificateur non inverseur.
        L'amplificateur non inverseur est le deuxième amplificateur de base. Pour calculer le gain en tension, on va se servir de l'équation [5] et en déduire :

        R2 et R1 forment un pont diviseur entre Vs et V- , soit :

        On en tire :

        Fig. 9. Amplificateur non inverseur.

        Le gain est non seulement positif (ampli non inverseur), mais il est aussi toujours supérieur à 1, alors que l'ampli non inverseur autorisait un gain (en valeur absolue) inférieur à 1, soit une atténuation. Notons que pour un ampli, cette caractéristique n'est pas trop gênante...

        Pour ce qui est de l'impédance d'entrée, on attaque directement l'entrée de l'ampli : elle sera donc infinie dans le cas d'un AOP, et très grande dans tous les cas ; de plus, elle ne dépend pas du gain choisi, ce qui laisse plus de latitude dans le choix de R1 et R2 pour régler le gain que dans le cas du montage inverseur. L'impédance de sortie est nulle :

        On a donc ici un ampli qui présente des caractéristiques idéales ! En pratique, seul le comportement en fréquence de l'amplificateur opérationnel réel viendra ternir le tableau.

        On notera la simplicité de mise en œuvre du montage, comparé à un étage à transistor : impédances idéales, gain ajustable à loisir et de façon précise, voire réglable par un simple potentiomètre, transmission de signaux continus, tout ceci avec un seul amplificateur opérationnel (généralement en boîtier 8 broches) et deux résistances !

        Tout comme pour l'amplificateur inverseur, une généralisation de ce montage est faisable avec n'importe quels dipôles d'impédance Z1 et Z2 remplaçant respectivement les résistances R1 et R2. l'expression du gain devient :

      4. Montage suiveur.
        Ce montage est une extrapolation de l'ampli précédent, avec R1 = [image] et R2 = 0. On obtient un montage tout simple, de gain unité, dont la seule fonction est l'adaptation d'impédance. On le placera donc en tampon entre deux portions de circuit de façon à les isoler l'une de l'autre pour prévenir toute interaction parasite.

        Ce circuit est aussi idéal en entrée et en sortie d'un montage pour bénéficier d'impédance d'entrée infinie (ou presque) et d'impédance de sortie très basse.

        Fig. 10. Amplificateur suiveur.

    2. MONTAGES OPÉRATIONNELS.

      Après les fonctions d'amplification de base, on va voir plusieurs montages opérationnels, dans le sens où ils vont réaliser des opérations arithmétiques sur un ou plusieurs signaux.

      1. Additionneur inverseur.

        Fig. 11. Amplificateur sommateur inverseur.

        On a souvent besoin de mélanger plusieurs signaux ensemble ; la difficulté réside dans le fait qu'il faut éviter toute interaction de réglage des gains affectés aux différentes entrées, ceci pour deux raisons :

        si on doit recalculer tout l'échafaudage à chaque modification du gain d'une entrée, ou en cas de rajout d'une entrée, le montage n'est pas vraiment pratique.

        on ne peut pas faire varier le gain de chaque voie indépendamment des autres, à l'aide d'un potentiomètre, par exemple, alors que c'est une fonction souvent demandée à ce genre de montage.

        Le circuit décrit ici permet de s'affranchir de ces défauts.

        À la base de ce montage, on retrouve l'amplificateur inverseur ; on avait vu que l'entrée inverseuse était considérée comme une masse virtuelle, et qu'aucun courant n'entrait dans l'AOP. De ce fait, chaque courant ii ne dépend que de la tension d'entrée Vei et de Ri relatif à sa branche : il n'y aura donc pas d'interaction entre les différentes entrées.

        On a :

        La loi des nœuds en V- nous donne :

        En sortie, on a :

        Au global, on obtient pour Vs :

        On voit qu'on peut ajuster le gain globalement en jouant sur R, et le gain de chaque entrée en jouant sur les résistances Ri. Ce montage offre donc toutes les souplesses.

        On peut obtenir un additionneur inverseur pur en fixant toutes les résistances du montage à la même valeur.

        Aux chapitre des inconvénients, l'impédance d'entrée de chaque voie i est égale à la résistance Ri :

        La latitude de réglage citée précédemment baisse donc un peu du fait de cette contrainte, car plus le gain sera élevé, plus l'impédance d'entrée sera faible.

        Comme d'habitude, l'impédance de sortie de ce circuit est voisine de 0.

      2. Montage soustracteur (différentiel).
        Ce montage permet d'amplifier la différence de deux signaux. C'est un montage de base très important en mesures.

        Fig. 12. Amplificateur différentiel.

        Pour calculer le gain en tension de cet étage, on va faire appel à la formule du pont diviseur et au théorème de superposition. Le lien va encore être l'équation :

        La tension sur l'entrée non inverseuse est :

        La formule du pont diviseur est ici appliquée sans approximation, car l'impédance d'entrée de l'AOP est infinie.

        Le calcul de la tension sur l'entrée inverseuse se fait en deux temps, et avec l'aide du théorème de superposition :

        Des équations [29], [30] et [31], on tire :

        La formule générale de la tension de sortie de ce montage est donc :

        Tel quel, ce montage n'est pas un ampli de différence ; il faut imposer des conditions sur les résistances. Si on pose :

        en remplaçant k par sa valeur dans [33] et compte tenu de la propriété suivante :

        on obtient :

        On a bien en sortie la différence des deux signaux d'entrée multipliée par le gain k.

        Si les résistances ne sont pas bien appariées deux à deux dans le rapport de k (condition [34]), le gain ne sera plus purement différentiel ; il va apparaître un terme de mode commun. Ce défaut sera expliqué en détail dans le cours d'électronique 2 (Amplificateur d'instrumentation).

        Les impédances d'entrée Ze1 et Ze2 sont difficiles à cerner, surtout celle de l'entrée inverseuse Ze2 ; on retiendra qu'elles sont différentes, ce qui peut poser des problèmes pour certaines applications.

        On peut aussi définir une impédance d'entrée différentielle Zed et une de mode commun Zemc. Une de ces impédances est constante, c'est l'impédance d'entrée différentielle Zed :

        Cette valeur est équivalente à ce qu'on obtient avec l'amplificateur inverseur : elle est faible quand le gain devient élevé.

      3. Montage intégrateur.
        Nous attaquons ici les montages opérationnels plus sophistiqués que de simples additions ou soustractions.

        Fig. 13. Montage intégrateur.

        Le calcul de la réponse Vs à un signal d'entrée Ve se traite comme dans le cas de l'amplificateur inverseur. On a :

        En sortie, le condensateur a aux bornes de ses armatures une charge électrique q égale à :

        Cette charge électrique est l'intégrale du courant i qui traverse le condensateur ; compte tenu du sens de i, on a :

        Si on remplace dans [40] i et q par leur valeur en fonction de Ve et de Vs (équations [38] et [39]), on obtient :

        On retrouve en sortie l'intégrale du signal d'entrée. Ce montage est délicat à utiliser et devra faire l'objet de précautions : en effet, la moindre tension continue présente à l'entrée (y compris et surtout une tension parasite) sera intégrée et générera une rampe en sortie. Il faudra donc prévoir des dispositifs annexes, soit un système de stabilisation, soit un système de remise à zéro de la sortie.

      4. Montage dérivateur.
        Ce montage est similaire au précédent et se traite de la même manière.

        Fig. 14. Montage dérivateur.

        En entrée et en sortie, on a :

        Le courant i est la dérivée de la charge électrique q présente sur les électrodes du condensateur :

        Au final, on obtient :

        La sortie est proportionnelle à la dérivée de l'entrée. Comme pour le montage précédent, avec un amplificateur réel, on aura des difficultés à faire fonctionner ce circuit tel quel (système instable), et il faudra rajouter des éléments pour le rendre pleinement fonctionnel.

      5. Montage logarithmique.
        Dans ce montage, on retrouve la structure traditionnelle de l'ampli inverseur, mais avec une diode en contre-réaction. Cette diode, dont la caractéristique courant/tension est logarithmique va nous donner une fonction de transfert de ce type. En entrée, on a :

        Et en sortie :

        Lorsque le terme en exponentielle est significativement supérieur à 1 (Vd > 50mV environ), on peut écrire :

        Soit, en remplaçant i par sa valeur :

        Fig. 15. Montage logarithmique.

        En sortie, on trouve bien une fonction logarithmique du signal d'entrée. Tel quel, ce montage aurait peu d'intérêt ; mais, si on se rappelle qu'additionner des logarithmes revient à faire une multiplication, on en perçoit l'utilité !

        En pratique, et une fois de plus, ce montage (bien que fonctionnel) n'est pas utilisé tel quel : d'abord, il ne fonctionne que pour des tensions d'entrée positives, et il nécessite de sérieuses compensations thermiques pour permettre des opérations précises. De plus, on remplace souvent la diode par une jonction base-émetteur de transistor, linéaire sur une plus grande plage de courant.

      6. Montage exponentiel.
        Pour multiplier deux signaux, il ne suffit pas de prendre le Log de chacun des signaux, et d'additionner ; il faut ensuite prendre l'exponentielle du résultat. Ce circuit est fait pour ça.

        Fig. 16. Montage exponentiel.

        Par des calculs analogues aux précédents, on démontre facilement et de la même manière :

        En pratique, on trouve des circuits intégrés tout faits comprenant le montage Log, le montage exponentiel, ainsi que les compensations thermiques et diverses possibilités de réglage de gain. Ces montages sont des multiplieurs analogiques, et servent notamment, en mesures, à linéariser certains capteurs. A noter que ces composants sont délicats, coûteux, et présentent des dérives importantes. L'utilité de tels montages est devenue douteuse avec l'introduction massive du traitement numérique.

    3. FILTRAGE.

      L'amplificateur opérationnel ouvre les portes d'une kyrielle de fonctions de filtrage, qu'on dénomme filtres actifs, par opposition aux filtres passifs (fabriqués avec des composants du même nom) qui ne peuvent qu'atténuer le signal. Avec un AOP, on va pouvoir amplifier certaines fréquences autant qu'en atténuer d'autres.

      Il est hors de question d'aborder ici tous les filtres possibles (exercice qui n'a de limite que la créativité humaine !) : le lecteur désireux d'approfondir le sujet pourra consulter des ouvrages spécialisés dans le filtrage, et aussi les data books des fabricants d'amplificateurs, qui sont bien souvent une mine d'idées gratuites (qu'on retrouve d'ailleurs souvent telles quelles dans des livres chers...).

      Les filtres classiques d'ordre 1 présentent peu d'intérêt en filtrage actif, l'apport étant faible (au mieux, adaptation d'impédance) par rapport au filtrage passif.

      Nous allons voir deux filtres du deuxième ordre dont la fonction de transfert présente des racines imaginaires ; ceci n'est possible en filtrage passif que si on fait appel à des inductances, qui sont des composants encombrants, rares, imprécis et coûteux. Grâce à l'AOP, on va faire de tels filtres uniquement avec des résistances et des condensateurs.

      1. Passe bas 2e ordre.

        Fig. 17. Filtre passe bas du deuxième ordre.

        On peut remarquer qu'à la base, la structure ressemble fort à deux filtres passifs R-C passe bas concaténés. La différence vient du fait que le premier condensateur n'est pas relié à la masse, mais à la sortie du filtre qui est isolée de la deuxième cellule passe-bas par un montage suiveur.

        La réponse en fréquence de ce montage est du type :

        La fonction de transfert "générique" d'un filtre passe bas d'ordre 2 est du type :

        On identifie les deux formules pour les valeurs suivantes de [image] o et z :

        Le réseau de courbes de réponse en fréquence (amplitude et phase) de ce filtre est donné en annexe 1 en fonction du coefficient de surtension z.

      2. Passe haut 2e ordre.

        Fig. 18. Filtre passe haut du deuxième ordre.

        La topologie de ce filtre est la même que celle du précédent, sauf qu'on a permuté les résistances et les condensateurs. La fonction de transfert est :

        La pulsation de cassure et le coefficient de surtension de ce filtre sont :

        La réponse en fréquence (amplitude et phase) de ce filtre est donnée en annexe 2.

        Il est possible de concaténer les deux filtres précédents, et de les combiner avec des filtres du premier ordre pour obtenir un filtre d'ordre plus élevé. Des ouvrages traitant des filtres donnent les valeurs des fréquences de cassure et coefficients de surtension adéquats pour obtenir la réponse en fréquence désirée.

    4. MONTAGES NON LINÉAIRES.

      Les montages précédents sont qualifiés de "linéaires" car l'amplificateur fonctionne avec la condition V+ = V- , soit dans sa plage de fonctionnement en amplificateur linéaire. Il convient de noter que certains des montages étudiés (ex : montage logarithmique) ne sont pas linéaires ! Mais, l'amplificateur, lui, fonctionne en mode linéaire.

      Nous allons voir maintenant plusieurs montages (et il en existe bien d'autres) dans lesquels cette condition n'est plus vérifiée.

      Pour ce faire, on va forcer artificiellement les deux entrées à des valeurs différentes, ce qui impliquera en sortie, du fait du gain infini (très grand pour les amplis réels), que l'ampli ne pourra prendre que deux valeurs : Vsat+ et Vsat-, qui sont respectivement les tensions de saturation positive et négative de l'ampli. En effet , ce dernier est alimenté par deux sources de tension dont on ne pourra pas dépasser la valeurs en sortie.

      Vu que l'ampli ne peut prendre que les deux valeurs des tension en sortie, ces montages sont appelés montages en commutation, et peuvent être interfacés avec des circuits logiques, qui ne connaissent, eux aussi, que deux états.

      1. Comparateur de tensions.
        C'est un montage qui sert de base à de nombreux autres schémas plus élaborés.

        Le principe est simple : on compare un signal d'entrée à une tension de référence, et selon que la valeur du signal est supérieure ou inférieure à la référence, l'ampli prendra l'une ou l'autre des valeurs Vsat+ ou Vsat- en sortie.

        Il existe deux configurations : le comparateur non inverseur (signal sur l'entrée +) et le comparateur inverseur (signal sur l'entrée -). Dans le premier cas, si la référence est égale à 0, la sortie vaut Vsat+ quand le signal est positif et Vsat- sinon. Dans le deuxième cas, on a l'inverse.

        Fig. 19. Comparateur non inverseur.

        Si on met un signal sinusoïdal à l'entrée, les chronogrammes d'entrée et de sortie sont :

        Fig. 20. Comparateur : chronogrammes

        Important : ce montage est souvent fait avec des amplificateurs opérationnels, mais on remplacera avantageusement ce composant par un comparateur différentiel, qui est une sorte d'amplificateur à grand gain et deux entrées aussi, mais qui est prévu pour fonctionner en mode non linéaire (commutation) de façon bien plus rapide qu'un ampli op qui n'a pas des caractéristiques exceptionnelles dans ce domaine. De plus, ces composants sont souvent conçus pour fonctionner avec une seule alimentation 0-5V de manière à s'interfacer facilement avec des composants logiques.

      2. Trigger.
        Ce montage est très utilisé dans tout système de mesure où l'on doit détecter un seuil : il est donc fondamental.

        Il est une évolution du comparateur, destinée à améliorer les performances avec des signaux bruités.

        Il existe plusieurs schémas possibles. Le montage suivant a été choisi comme cas d'école :

        Fig. 21. Trigger.

        A première vue, ce montage ressemble à un ampli inverseur, mais, il ne faut pas se tromper : le réseau de résistances R1, R2 est relié à l'entrée +, ce qui fait que cette fois, le signal de sortie revient en phase sur l'entrée ; on a non plus une contre réaction, mais une réaction positive (effet boule de neige), ce qui entraîne la divergence de la tension de sortie vers une des valeurs Vsat+ ou Vsat- .

        Dans ce montage (et les autres montages non linéaires), l'amplificateur fonctionne en comparateur : comme le gain est infini (ou très grand), on a les relations :

        Ici, la valeur de V- est triviale :

        Et la valeur de V+ se calcule aisément à l'aide du théorème de superposition :

        Le basculement de la sortie de l'ampli se fait pour V+ = V- :

        Dans cette formule, il faut garder à l'esprit que Vs ne peut prendre que les deux valeurs Vsat+ et Vsat- .

        Dans le cas particulier où Vref = 0 et Vsat+ = |Vsat-| = Vsat, on aura :

        La figure 22 donne les signaux d'entrée, de sortie, et de l'entrée + de l'amplificateur, pour R1=10k [image] et R2=33k [image] :

        Fig. 22. Signaux sur le trigger

        En fait, tout se passe comme si on avait un comparateur de tension ayant deux seuils de basculement liés aux états de la sortie : quand la sortie est à l'état bas, le seuil a une valeur haute ; passé ce seuil, la sortie bascule à l'état haut, et le seuil prend une valeur basse. De ce fait, pour faire rebasculer la sortie à l'état bas, il faut que le signal diminue d'une quantité supérieure à la valeur l'ayant faite basculer précédemment : c'est l'hystérésis du trigger.

        Un trigger est caractérisé par son cycle d'hystérésis (la réponse est différente suivant la valeur de l'état de la sortie).

        Le cycle relatif aux signaux de la figure 22 (mêmes valeurs de composants) est le suivant :

        Fig. 23. Cycle d'hystérésis du trigger

        Ce cycle est centré autour de zéro, qui est la valeur de la tension de référence Vref. On y voit les deux seuils de basculement de la sortie ; La différence de ces deux seuils est la valeur de l'hystérésis.

        Ce cycle est ici symétrique pour deux raisons :

        Vref = 0

        Vsat+ = |Vsat-| = Vsat

        Si on modifie ces valeurs, le cycle va devenir asymétrique par rapport à la tension de référence.

        Quelle est l'utilité d'un tel montage ? Lorsqu'on doit transformer un signal analogique en signal numérique binaire (deux états définis par une valeur de seuil sur le signal analogique), si le signal d'entrée varie très lentement et/ou est bruité, on peut avoir un phénomène oscillatoire en sortie de l'amplificateur dû au bruit ou à des réactions parasites de la sortie sur l'entrée. Pour prévenir ces oscillations, on "verrouille" le signal de sortie en en réinjectant une partie sur l'entrée +. Pour qu'il y ait des oscillations parasites, il faut que la tension d'entrée varie de l'opposé de la valeur de l'hystérésis juste après le basculement. Cette dernière est ainsi ajustée en fonction du bruit présent sur le signal d'entrée.

        Comme pour le montage comparateur vu précédemment, un comparateur différentiel remplacera avantageusement l'amplificateur opérationnel.

      3. Multivibrateur astable.
        Le but de ce montage est de délivrer un signal carré en sortie : c'est un générateur de signal autonome.

        Fig. 24. Multivibrateur astable.

        Sur le schéma, on peut distinguer un trigger légèrement différent de celui de la figure 21 : l'entrée se fait sur l'entrée - de l'ampli ; l'hystérésis se fait là aussi par un réseau de résistances en réaction positive sur l'entrée +, une des extrémités de R1 étant reliée à la tension de référence (ici, la masse).

        L'entrée est connectée ici à un circuit R-C alimenté par la sortie de l'amplificateur.

        Un oscillogramme est donné en figure 25, qui permet de mieux comprendre le fonctionnement de ce montage.

        Fig. 25. Signaux sur un multivibrateur

        Nous ferons l'hypothèse que Vsat+ = |Vsat-| = Vsat.

        Supposons qu'à la mise sous tension, le condensateur soit déchargé, et que Vs=+Vsat. La tension aux bornes de V+ est donnée par la relation suivante (elle est positive) :

        La sortie alimente un circuit R-C, et C se charge selon la loi exponentielle suivante :

        Lorsque V- = V+, le trigger bascule (voir figure 25), et on applique alors une tension -Vsat sur le R-C qui devra se décharger de la valeur de l'hystérésis du trigger avant que la sortie ne bascule à nouveau, et ainsi de suite.

        Avec les hypothèses précédentes (Vsat+ = |Vsat-| = Vsat), on aura en sortie du multivibrateur un signal carré (rapport cyclique égal à 0.5), de fréquence égale à :

        En pratique, le signal aura un rapport cyclique différent de 1/2 car les tensions de saturation de l'ampli ne sont pas égales, et varient avec la température, la charge...

        Pour obtenir un signal "carré" convenable, on utilisera un ampli à fort slew rate, ou beaucoup mieux, comme pour le trigger, un comparateur différentiel.

        Ce type de montage est important du point de vue principe, mais en pratique, il existe des solutions beaucoup plus "propres" pour générer un signal carré. On n'utilisera donc ce montage qu'à titre de dépannage !

      4. Redresseur sans seuil.

        Fig. 26. Redresseur sans seuil.

        On a vu dans le cours sur les diodes que le gros problème de ce composant, pour redresser des faibles tensions, provient de son seuil élevé (>0.5V pour le silicium), qui dépend en plus de la température. Cette caractéristique interdit le redressement de faibles signaux avec une précision décente. L'amplificateur opérationnel va nous aider !

        Le montage est celui de la figure 26 : le montage ressemble à un suiveur auquel on a adjoint une diode en série avec l'amplificateur.

        Pour des tensions d'entrée négatives, la sortie de l'ampli va avoir tendance à devenir négative, mais, elle est bloquée par la diode : il n'y a pas de contre-réaction, car le signal de sortie de l'ampli ne peut pas revenir sur l'entrée -. Dans ce cas, la tension de sortie de l'amplificateur va prendre la valeur Vsat-, et la tension de sortie du montage va être nulle.

        Lorsque la tension d'entrée va devenir positive, la sortie de l'amplificateur va devenir positive aussi, et elle va augmenter jusqu'à la valeur de la tension de seuil de la diode, et la contre réaction sur l'entrée - va pouvoir se faire, la tension en sortie de l'ampli prenant la valeur Vd + Ve, de manière à ce que V+ soit égal à V- (donc à Vs).

        En bilan, pour des tensions positives, Vs = Ve , et pour des tensions négatives, Vs = 0 : on a un redresseur idéal.

      5. Détecteur de crête.

        Fig. 27. Détecteur de crête.

        Pour conserver la valeur crête d'une tension, on peut commencer par redresser celle-ci, et en adjoignant un condensateur au montage redresseur précédent, il est possible de garder en mémoire la valeur de crête.

        Le fonctionnement est le même que pour le redresseur sans seuil, sauf que le condensateur va se charger, et quand la tension d'entrée va diminuer, le condensateur va conserver sa charge (à condition que l'entrée - de l'ampli soit à très haute impédance et que la charge de sortie ait aussi une très haute impédance -montage suiveur par exemple), et la diode va se bloquer, car la tension de sortie va diminuer jusqu'à la valeur -Vsat (plus de contre réaction à cause de la diode).

        Il faut prévoir un dispositif annexe pour décharger le condensateur afin de faire une nouvelle mesure : sur le schéma, on a placé un simple transistor de façon schématique, mais celui-ci pourra être remplacé avantageusement par un commutateur analogique à base de FET ou de MOS.

        NB : dans ce montage, on peut remplacer la diode par un commutateur analogique bi-directionnel commandable en tension. On va alors pouvoir bloquer le signal à l'instant désiré et le conserver ; c'est le principe de base de l'échantillonneur-bloqueur (voir cours d'électronique 2).

  4. L'AMPLIFICATEUR OPÉRATIONNEL RÉEL.

    Avant d'attaquer tous les défauts de l'amplificateur réel, et afin de mieux les comprendre, nous allons étudier un schéma de principe de cet amplificateur.

    Ce schéma n'est évidemment pas un schéma réel, mais il contient tous les ingrédients fondamentaux d'un amplificateur ; c'est cette architecture qui est aussi utilisée dans des montages de puissance (amplificateurs HIFI et industriels), et donc, la compréhension de cette architecture est importante et permettra d'investiguer des domaines autres que celui de l'amplificateur opérationnel.

    1. SCHÉMA INTERNE DE PRINCIPE.

      Sur le schéma de la figure 28, nous avons représenté les deux alimentations Val+ (positive) et Val- (négative), les deux entrées V+ et V-, et la sortie Vs de l'amplificateur.

      L'ampli est constitué de trois étages :

      un étage d'entrée différentiel (T1 et T2), avec sa charge d'émetteurs (source de courant I1) et ses charges de collecteurs (miroir de courant T3 et T4).

      un étage de gain formé de T5 et de sa charge active I2.

      Un étage de sortie push pull constitué par les transistors T6 et T7 polarisés par les diodes D1 et D2.

      Fig. 28. Schéma de principe d'un amplificateur.

      • Étage différentiel :
        On a représenté ici un étage différentiel classique : deux transistors montés dans une configuration de type émetteur commun (entrée sur la base, sortie sur le collecteur) avec les deux émetteurs reliés à une source de courant. Cette source I1 doit être la plus proche possible de l'idéal, car la valeur de sa résistance interne détermine le taux de réjection du mode commun.

        Les charges de collecteur ne sont pas des résistances, mais des charges actives, constituées des transistors T3 et T4 montés en miroir de courant : le transistor T3 est utilisé en diode (le collecteur est relié à la base), et détermine le potentiel de base de T4, donc son courant de collecteur. Sur le circuit intégré, on peut construire T3 et T4 de manière à ce qu'ils aient les mêmes caractéristiques de gain, Vbe... (idem pour T1 et T2) : le courant dans la branche T1/T3 sera le même que celui de la branche T2/T4.

        On démontre que le miroir de courant est une astuce permettant de doubler le gain de l'étage différentiel.

        La sortie de cet étage se fait sur le collecteur de T2, et c'est la résistance dynamique de T4 (le 1/h22) qui charge T2. Le gain sera donc plus élevé que si on avait une simple résistance à la place de T4.

        Le gain de cet étage est de l'ordre de 100.

        L'impédance d'entrée différentielle de ce montage est égale à 2h11 (le h11 de T1 ou de T2). Pour que cette impédance soit grande (1M [image] pour un µA741), il faut que le courant de polarisation de base soit très faible (quelque dizaines de nA).

        Les amplificateurs plus récents font en général appel à des transistors FET en entrée (LF356 de NS, TL081 de Texas...) voire MOS (LMC660). La structure de l'étage reste similaire.

        En pratique, les montages sont un peu plus compliqués, et les transistors T1 et T2 sont souvent remplacés par 4 transistors, deux collecteurs communs qui attaquent deux bases communes. C'est une astuce technologique permettant d'améliorer la plage d'entrée différentielle de l'ampli.

      • L'étage de gain :
        Le deuxième étage est très simple, c'est un montage émetteur commun constitué de T5, chargé par une source de courant (en général, c'est encore un montage à miroir de courant) : la charge dynamique de T5 est donc la résistance parallèle de la source de courant I2 ; le gain est très élevé (environ 1000, ce qui fait un ordre de grandeur de 105 pour l'ensemble !).

        On note la capacité C entre base et collecteur du transistor T5 : c'est une capacité destinée à la compensation de l'amplificateur ; la fréquence de cassure de ce filtre est très basse (quelques dizaines d'hertz) et permet à la plupart des amplis d'être inconditionnellement stables. Cette capacité utilise l'effet miller : le filtre est constitué de l'impédance de sortie du premier étage (très élevée) et de la capacité C, le tout multipliée par le gain en tension du deuxième étage. On peut obtenir une fréquence de cassure très faible avec une capacité très petite (quelques dizaines de pF), qui peut ainsi être intégrée sur la puce.

      • L'étage de sortie :
        C'est un étage push pull constitué de deux transistors complémentaires qui fonctionnent en collecteur commun, T7 pour les alternances positives, et T8 pour les alternances négatives. Ces transistors sont polarisés par les deux diodes D1 et D2 afin de limiter la distorsion de croisement.

        Du point de vue petits signaux, cet étage de sortie (et sa charge, qui est déterminée par l'utilisation que l'on fait de l'ampli, et donc, va varier) vient se mettre en parallèle sur la charge de collecteur de T5 : le gain de l'étage intermédiaire va ainsi dépendre de la charge qu'on connectera en sortie de l'ampli.

        Dans les amplis réels, l'étage de sortie est plus complexe, et comprend notamment des étages de protection contre les courts-circuits, qui vont limiter le courant de sortie de l'ampli à des valeurs raisonnables.

    2. ALIMENTATION.

      Comme pour tout composant dit "actif", notre amplificateur ne va pas sortir du néant l'énergie qu'il fournit à l'extérieur. Il va falloir l'alimenter afin de polariser tous les transistors qui le composent.

      Sur le schéma de la figure 28, on voit deux entrées d'alimentation, Val+ et Val-. On remarque que nulle part sur ce schéma, la masse n'est présente ! En pratique, les deux alimentations sont référencées à la masse, et ce sont les tensions d'entrée qui vont fixer tous les potentiels par rapport à la masse, du fait de la contre réaction (la tension de sortie est liée aux tensions d'entrée qui sont liées à la masse).

      Cette caractéristique est intéressante, et va nous permettre d'alimenter l'amplificateur opérationnel de deux manières différentes :

      symétrique : on alimente l'ampli par deux sources égales et opposées. Tout l'ampli est ainsi polarisé symétriquement par rapport à la masse. C'est le mode d'alimentation le plus courant. Il faut noter que les deux tensions peuvent être inégales : le fonctionnement de l'ampli ne sera pas affecté, mais la plage de sortie sera limitée par l'alimentation la plus faible (signaux symétriques par rapport à la masse).

      unipolaire : Val+ est relié à une alimentation positive et Val- est relié à la masse. Ce système est pratique pour un fonctionnement sur piles ou batteries, mais il faudra alors polariser les signaux d'entrée à une valeur convenable pour que l'ampli fonctionne correctement (il n'y a pas de miracles, c'est un système à transistors qui nécessite une polarisation !). Ce mode de fonctionnement interdit l'amplification de signaux continus.

      Les tensions d'alimentation des amplificateurs opérationnels courants peuvent varier dans une large gamme, typiquement de ±2.5V à ±5V mini jusqu'à ±18V à ±22V maxi.

      Certains amplis sont spécialisés dans les basses tensions (alimentation par pile) et d'autres dans des tensions plus élevées. Pour des applications particulières, on consultera l'abondante documentation fournie par les constructeurs.

      Certains amplificateurs rapides nécessitent un découplage soigné des alimentations : on mettra un condensateur de découplage (typiquement 10 à 100nF céramique) entre chaque borne d'alimentation et la masse, ceci aux plus près des broches d'alimentation. Sans ces précautions, on pourra avoir des montages présentant des fonctionnements erratiques, voire des oscillations parasites aboutissant à la destruction de l'ampli (cas du LM318 !).

      Outre la plage de tensions d'alimentation, les amplificateurs sont caractérisés par leur courant de consommation : il faut alimenter tous les composants internes pour les polariser. Le courant de polarisation va être plus ou moins important selon la conception de l'ampli, et le compromis recherché : il existe des amplis à très faible courant de consommation, destinés principalement aux applications fonctionnant sur piles et batteries ; en corollaire, leurs performances en fréquence seront médiocres (voir cours sur les transistors : plus la polarisation est faible, plus les impédances mises en jeu sont grandes, et plus les capacités parasites des transistors prennent de l'importance, dégradant le comportement à haute fréquence). A côté de ces amplis, il en existe d'autres à courant de consommation élevé, ayant des bonnes performances en haute fréquence.

      Certains amplificateurs, dits "programmables" ont une possibilité de réglage du courant de polarisation (et donc du compromis consommation/rapidité), et peuvent ainsi s'adapter au besoin de l'utilisateur.

      Exemples de courants de consommation :

      LM4250 : réglable de 1 à 250µA

      LF441 : 200µA

      µA741 : 2mA

      LM318 : 5mA

      Ces amplis sont donnés du plus lent au plus rapide : produit gain-bande passante de 10 à 300kHz pour le LM4250, 1MHz pour le 741, et 15MHz pour le LM318.

    3. CARACTÉRISTIQUES D'ENTRÉE.

      1. Impédances d'entrée.
        On a vu que l'amplificateur différentiel présentait deux impédances d'entrée différentes : l'impédance différentielle, relative à la différence de tension entre les deux entrées, et l'impédance de mode commun. On va s'aider du schéma de la figure 28 pour interpréter ces deux impédances.

        • Impédance différentielle.
          Sur le schéma de la figure 28, l'impédance différentielle correspond à 2h11 et dépend directement du courant de polarisation choisi.

          En pratique, cette valeur sera comprise entre quelque centaines de k [image] et quelques dizaines de M [image] pour les amplis à transistors d'entrée bipolaires.

          Les amplis à transistors d'entrée JFET présenteront des impédances beaucoup plus élevées, couramment de l'ordre de 1012 [image].

          Il existe aussi des amplis en technologie MOSFET qui ont des impédances supérieurs à 1015 [image] : nous ne sommes vraiment pas loin de l'infini de l'AOP !

          Il convient de noter que la tension d'entrée différentielle sera toujours voisine de zéro (en fonctionnement linéaire) : le courant différentiel consommé sera donc extrêmement faible, même si les résistances connectées à l'ampli ont des valeurs voisines de l'impédance d'entrée de celui-ci. On pourra donc dans la majorité des cas négliger l'impédance d'entrée dans les calculs.

        • Impédance de mode commun.
          On peut voir cette impédance comme celle de deux montages collecteur commun en parallèle dont la charge commune d'émetteur est une source de courant de résistance dynamique très élevée. Vue de l'entrée, cette résistance est multipliée par le gain des transistors : elle sera très élevée dans tous les cas, et donc négligée dans les calculs.

      2. Tension de décalage d'entrée (offset).
        C'est un des principaux défauts de l'amplificateur réel, et pour des forts gains en tension et/ou des faibles tensions d'entrée, on devra en tenir compte.

        Cette tension est due au fait que les transistors d'entrée ne sont pas rigoureusement identiques (T1 et T2 sur la figure 28), et que pour obtenir une tension nulle en sortie, il faudra appliquer une tension différentielle non nulle à l'entrée, cette tension étant l'écart de Vbe de T1 et T2 à courant de collecteur donné.

        Quand on modélise un montage à amplificateur opérationnel avec une erreur d'offset, on le représente en général par le schéma suivant :

        Fig. 29. Erreur d'offset.

        Cette représentation n'est pas forcément judicieuse, car on peut obtenir des courants parasites dûs à cette source dans les composants d'entrée, alors qu'en fait, l'écart de courant ne peut venir que de la sortie qui compense la tension de décalage ; en effet, on aura la relation :

        Avec une telle relation, quand l'ampli fonctionne en mode linéaire, on n'a plus V+ = V-, mais V+ = V-+Vd. A noter que Vd est une valeur algébrique, et peut être positive ou négative.

        Pour les montages en commutation (comparateurs et triggers entre autres), le seuil de basculement sera lui aussi défini par la relation V+ = V-+Vd.

        Ordres de grandeur : Vd va valoir de quelques dizaines de µV pour des amplis de mesure (OP27 : 25µV) à une dizaine de mV pour des amplis à entrée JFET standards (TL081 par exemple).

      3. Courants de polarisation.
        Sur le schéma de la figure 28, on remarque qu'il n'y a aucun circuit de polarisation des bases des transistors d'entrée T1 et T2. Par conséquent, cette polarisation devra être assurée par les composants externes du montage à amplificateur.

        Si on reprend l'exemple du montage amplificateur inverseur de la figure 5, la polarisation des bases se fera directement par la masse pour l'entrée +, et par la masse et la sortie de l'ampli via R1 et R2 pour l'entrée -. Le courant de polarisation de la base de T1 va donc circuler dans ces deux résistances, en y créant au passage des chutes de tension parasites.

        Fig. 30. Ce qu'il ne faut pas faire !!!

        Une remarque importante qui découle de ceci est qu'il faut toujours laisser le passage du courant continu vers les deux entrées de l'ampli ; il est hors de question de couper ce chemin par un ou plusieurs condensateurs : le montage ne serait alors plus fonctionnel.

        Dans l'exemple de la figure 30, on coupe le chemin de la polarisation de l'entrée + ; T2 (cf figure 28) ne peut pas être polarisé, et l'ampli ne fonctionne plus.

        Si on voulait vraiment mettre un condensateur en série avec le signal d'entrée pour bloquer sa composante continue, il faudrait rajouter une résistance entre l'entrée + et la masse, de manière à laisser passer le courant de polarisation.

        Ordre de grandeur des courants de polarisation :

        de 30à 500nA pour un µA741, les fortes valeurs étant obtenues à chaud.

        de 3 à 20nA pour un LM627 (ampli rapide de précision)

        de 30pA à 50nA pour un LF356 (entrées JFET) : le courant devient important à chaud !

        Le courant de polarisation peut être rentrant ou sortant, selon le type de transistors utilisés en entrée (NPN ou PNP).

      4. Courants de décalage.
        Le courant de décalage est le pendant de la tension d'offset pour les courants de polarisation : comme les transistors d'entrée sont dissymétriques, les courants de base seront aussi différents. Le courant de décalage est égal à :

        Ce courant, en circulant dans les résistances connectées à l'ampli va créer une chute de tension parasite qui va s'ajouter à la tension d'offset.

        Les ordres de grandeurs de ces courants sont d'environ 1/20e à 1/5e de la valeur des courants de polarisation.

      5. Plages de tensions d'entrée.
        On a déjà largement abordé les problèmes de polarisation des amplificateurs, et la figure 28 montre le principe des montages utilisés.

        Sur cette figure, on voit qu'il ne faudra pas dépasser certaines limites pour les tensions d'entrée sous peine de dégrader le fonctionnement, voire de détruire l'amplificateur.

        En pratique, les constructeurs donnent des plages de tension à respecter :

        absolues pour chaque entrée : elles dépasseront rarement les valeurs des tensions d'alimentation. Les entrées sont souvent reliées aux tensions d'alimentation par des diodes connectées en inverse pour le fonctionnement normal, et qui deviennent passantes quand les tensions d'entrée dépassent les valeurs des tensions d'alimentation ; le courant est limité par les résistances câblées en série avec les entrées. Si on applique directement un signal trop élevé sur une des entrées (cas de l'ampli non inverseur), on détruit le composant.

        différentielles : ces valeurs peuvent être faibles (±0.7V, soit la valeur d'un Vbe , dans le cas ou on bride les deux entrées avec deux diodes connectées tête bêche).

        de mode commun (souvent les tensions d'alimentation moins quelques volts). Au delà des limites de mode commun admises, la polarisation des étages d'entrée ne se fait plus correctement.

        En bref, il ne faut pas faire n'importe quoi avec un amplificateur opérationnel, et si on a des cas de fonctionnement limites, il faudra s'assurer qu'ils sont autorisés par l'ampli choisi. Tout est ici affaire de compromis, et il existe une grande variété d'amplis sur le marché autorisant certains modes de fonctionnement au détriment d'autres : il faut choisir le bon composant en fonction du problème. Une seule chose est sûre : on n'aura jamais tout en même temps !

    4. CARACTÉRISTIQUE DE TRANSFERT.

      La caractéristique de transfert est linéaire : la sortie est proportionnelle à la différence des tensions d'entrée ; il ne faut pas non plus oublier le terme de mode commun (voir équation [1]).

      La tension de sortie est bien évidemment limitée aux deux extrémités de la plage de fonctionnement à Vsat+ et Vsat-.

    5. CARACTÉRISTIQUES DE SORTIE.

      1. Impédance de sortie.
        En pratique, l'impédance de sortie des amplificateurs réels n'est pas nulle ; elle reste néanmoins faible, de l'ordre de la centaine d'ohms pour les amplis courants. Si cette valeur paraît encore assez élevée, il faut savoir que dans un système bouclé, sa valeur sera divisée par le gain de boucle du système considéré. En pratique, l'impédance de sortie des montages sera donc couramment inférieure à l'ohm.

        Attention toutefois à la valeur de l'impédance en boucle ouverte : si on charge l'amplificateur par un condensateur (par exemple un câble coaxial assez long, ce qui peut faire plusieurs centaines de pF), la résistance de sortie couplée à ce condensateur va former un pôle supplémentaire qui peut rendre le montage oscillatoire.

      2. Vitesse de balayage (slew rate).
        En plus des problèmes de réponse en fréquence, la tension de sortie des amplificateurs ne peut pas varier instantanément d'une valeur à une autre (cas d'un échelon de tension).

        Fig. 31. Slew rate.

        La cause profonde vient de la structure des amplis (voir figure 28) : lors d'un transitoire violent, la capacité collecteur-base du deuxième étage doit se charger instantanément, ce qui n'est pas possible, car elle le sera par les sources de courant de polarisation. Comme ces courants sont très faibles, la charge sera relativement lente, et on note qu'elle sera linéaire (charge d'un condensateur à courant constant). On obtient le chronogramme donné figure 31.

        Cette montée linéaire en réponse à un échelon est appelée vitesse de balayage (ou plus communément slew rate) ; elle est exprimée en V/µs.

        L'ordre de grandeur du slew rate est de 0,5V/µs pour le 741, 10 à 15V/µs pour les amplis à FET du type TL081, LF356..., et peut monter à 50V/µs (voire 150V/µs avec une compensation particulière) pour le LM318.

        En général, les amplificateurs ne peuvent pas être bons partout : les amplis très précis (OP7 : fort gain en statique et très faible offset) sont souvent mauvais du point de vue slew rate, et vice versa un LM318 est bruyant et peu précis).

        Le slew rate va limiter les amplifications des forts signaux, et la bande passante sera plus faible que pour des petits signaux à fréquence donnée (la pente en V/µs des signaux est proportionnelle à leur amplitude : plus l'amplitude sera forte, plus le slew rate sera limitatif.

      3. Tension de saturation.
        On en a déjà parlé lors des montages fonctionnant en commutation : la tension de sortie est limitée à Vsat+ et Vsat-, qui sont respectivement les tensions de saturation haute et basse de l'ampli.

        Ces tension dépendent évidemment des tensions d'alimentation : elles sont inférieures aux tensions d'alimentation (en valeur absolue) d'environ 0.5 à 1.5V. Ces tensions de déchet dépendent de la température, de la charge de sortie de l'ampli (plus le courant de sortie est important, plus elles sont élevées), et de la structure de l'ampli : il existe des ampli à transistors MOSFET (LM660C de NS) spécialement conçus pour avoir une dynamique de sortie maximale, soit des tensions de déchet comprises entre 0.1 et 0.3V. On privilégiera ces amplis dans les application alimentées en monotension de faible valeur (0-5V par exemple).

        Les tensions de déchet haute et basse sont souvent différentes, ce qui fait qu'avec une alimentation rigoureusement symétrique, on aura Vsat+ [image] |Vsat-|.

      4. Sortance en courant.
        L'impédance de sortie est une chose, la sortance en courant en est une autre : ce n'est pas parce qu'un ampli a une impédance de sortie très faible (quand il est bouclé) qu'il va pouvoir débiter des ampères !

        En pratique, les amplificateurs opérationnels sont des composants traitant des faibles signaux, pas de la puissance : les courants de sortie seront faibles, de quelques mA à quelques dizaines de mA pour les plus vaillants.

        L'amplificateur opérationnel a un étage de sortie push pull capable de fournir ou d'absorber du courant : en général, les courants maxi absorbés (sink) et fournis (source) seront sensiblement différents : on se reportera à la notice du constructeur pour plus de précisions.

        On veillera donc à ne pas trop charger les amplis en sortie (charge mini de quelques k [image] pour des signaux de quelques volts) : on n'oubliera pas que les réseaux de contre-réaction se mettent en parallèle avec la charge de sortie ! Par conséquent, on évitera de câbler des impédances trop faibles (inférieures à une dizaine de k [image]).

        Certains amplis sont prévus pour débiter des courants "importants" sur des charges faibles : alimenté en ±18V, le NE5534 peut débiter ±26mA dans 600 [image] (±16V en sortie).

        Il existe aussi des amplificateurs opérationnels de puissance : la structure est la même, mais ils possèdent un étage de puissance capable de délivrer des centaines de mA voire des ampères (ex : LM12 de NS, capable de débiter ±10A). Ils sont principalement destinés aux applications audio grand public (autoradios, mini chaînes...).

      5. Protections de sortie.
        On vient de voir que les amplificateurs opérationnels ne supportent pas les forts courants ; dans ces conditions, le moindre court-circuit pourrait leur être fatal ! Heureusement, les fabricants ont inclus des protections en sortie de leurs amplis qui limitent le courant de quelques mA à quelques dizaines de mA.

        Les amplificateurs opérationnels sont ainsi des composants assez robustes, ne nécessitant pas trop de précautions d'emploi (tout est relatif...)

      6. Puissance dissipée.
        Quand un ampli débite du courant, les transistors qui le constituent (notamment ceux du push-pull de sortie) dissipent une puissance non négligeable. Les amplis encapsulés en boîtiers traditionnels (DIL8 ou CMS) peuvent dissiper entre 250mW et 1W (à 25°C). Les amplis de puissance pré-cités sont encapsulés en boîtiers de puissance (boîtiers isowatt, voire TO3 pour le LM12), et peuvent dissiper plusieurs watts, à condition bien sûr de les munir du radiateur adéquat !

        Dans tous les cas, on veillera à ne pas dépasser les limites admises par les amplis. Certains sont protégés thermiquement (limitation du courant de sortie au delà d'une certaine température), mais pas tous...

    6. IMPACT SUR LES MONTAGES DE BASE.

      Tous ces "défauts" font que dans la pratique, l'amplificateur opérationnel réel s'éloigne sensiblement de l'AOP. Nous allons faire un rapide tour d'horizon de l'impact de ces défauts sur les montages de base vus plus haut, ce qui nous permettra de mieux choisir le modèle d'ampli approprié à une application donnée.

      1. Tension de saturation.
        On a vu que les tensions de saturation Vsat+ et Vsat- sont différentes : ceci aura un impact sur tous les montages en commutation où les tensions de saturation rentrent en jeu dans les formules (trigger, multivibrateur...). De plus, ces tensions vont varier avec la charge de l'amplificateur, la température... Ces défauts sont en fait assez peu gênants.

      2. Impédances d'entrée.
        L'impédance d'entrée des amplificateurs réels est dans tous les cas assez grande (>1M [image], rarement moins mis à part quelques amplis spéciaux). De plus, le fait que dans tous les montages linéaires l'ampli soit bouclé est bénéfique : l'impédance d'entrée est multipliée par le gain de boucle, ce qui donne facilement plusieurs dizaines ou centaines de M [image] : on est quasiment dans les conditions de l'AOP.

        On fera tout de même attention aux montages intégrateurs, où des amplificateurs à trop faible impédance d'entrée seront rejetés, la contre réaction n'agissant pas à très basse fréquence. On préférera des amplis à entrée JFET.

      3. Offset en tension.
        C'est une des grosses tares de l'amplificateur réel. Si on doit amplifier des faibles tensions continues avec un fort gain, il faudra soit choisir un ampli à très faible offset, soit compenser un ampli standard.

        La plupart des amplificateurs possèdent deux broches destinées à régler l'offset. On se reportera à la notice du composant utilisé, les modes de branchement et les valeurs des résistances nécessaires variant d'un ampli à l'autre. Souvent, il est fait appel à un potentiomètre branché entre les deux broches d'ajustage de l'ampli et une des alimentations.

        Les amplis doubles en boîtier 8 pattes (deux amplis dans le même boîtier) ne possèdent pas de réglage d'offset. On pourra faire un montage externe, tel que celui ci-dessous :

        Fig. 32. Compensation d'offset d'un ampli inverseur.

        En plus de la valeur de l'offset en tension, les constructeurs donnent la valeur de sa dérive en température et dans le temps. Il est illusoire de compenser un ampli à fort offset pour faire des mesures précises, car la variation sera importante et le réglage devra être revu souvent !

        Pour faire des mesures de précision, on optera pour un "bon" ampli dès le départ !

        Pour les amplifications de tensions uniquement alternatives mais avec un fort gain (plusieurs centaines), on se méfiera aussi de l'offset : un ampli ayant 10mV d'offset (les séries TL07x et TL08x de Texas ne sont pas merveilleuse de ce point de vue !) et utilisé avec un gain de 500 délivrera une tension continue parasite de 5V en sortie ! Cette tension abaissera d'autant la plage de sortie, et on fera une correction (même sommaire) de l'offset pour résoudre ce problème.

        Le montage intégrateur sera lui aussi fortement affecté par l'offset : cette tension parasite en entrée va être intégrée et générer une rampe de tension en sortie : ce montage devra être réalisé de préférence avec un ampli à faible offset et/ou compensé.

        Les montages à seuil (comparateurs, triggers), sont bien entendus aussi affectés par l'offset, et on en tiendra compte pour des faibles signaux.

      4. Courants de polarisation.
        On a vu que les transistors de l'étage différentiel d'entrée étaient polarisés par l'extérieur ; le courant de polarisation va donc circuler dans les composants externes à l'ampli. La chute de tension ainsi provoquée va s'ajouter à l'offset en tension.

        Afin de minimiser les écarts entre les deux entrées, on veillera à ce que celles-ci "voient" les mêmes impédances.

        Pour le montage amplificateur inverseur, une compensation fréquente des effets des courants de polarisation est la suivante :

        Fig. 33. Compensation des courants de polarisation.

        Cet exemple montre un montage inverseur auquel on a rajouté une résistance entre l'entrée + et la masse. Cette résistance est égale à R1//R2, soit l'impédance vue par l'entrée -. Les deux entrées "voient" les mêmes impédances, les effets des courants de polarisation vont donc se compenser.

        Les amplis à entrée JFET sont peu concernés par ce type de compensation, du moins à faible température. En effet, on a vu que l'entrée d'un JFET était équivalente à une jonction diode en inverse. Le courant parasite doublant tous les 6°C, il peut devenir important à haute température, supérieur à ce qu'on obtient avec de bons amplis à transistors bipolaires. Pour les fortes température d'utilisation, on préférera ces derniers. Pour des usages à température ambiante, on utilisera des amplis à entrée JFET sans compensation.

        Les courants de polarisation perturbent aussi beaucoup les montages intégrateurs : pour des intégrateurs à grande constante de temps, on utilisera impérativement des amplis à entrée JFET, ou mieux MOSFET (LMC660 par exemple).

        Les montages détecteurs de seuils et échantillonneurs bloqueurs utiliseront aussi des amplis à très faibles courants de polarisation, afin de ne pas décharger le condensateur de mesure par des fuites parasites.

      5. Courants de décalage
        Les courants de décalage sont plus problématiques à compenser. Comme ils sont faibles, on se contentera d'utiliser des résistances de faible valeur pour que la chute de tension parasite soit négligeable.

      6. Plages de tensions.
        Dans tous les montages, on fera attention à ne pas dépasser les limites absolues préconisées par le fabricant de l'amplificateur utilisé. Pour les montages à commutation, où on utilise l'amplificateur avec la condition V+ [image] V-, on veillera à choisir des amplis tolérant une tension différentielle suffisante (entrées non bridées par des diodes).

      7. Slew rate.
        Si on doit amplifier des forts signaux à fréquence élevée, on choisira des amplificateurs à slew rate suffisant. Dans la pratique, le µA741 est trop juste (0.5Vµs) et sera délaissé au profit d'amplis à FET standards (TL081, LF356 et autres) présentant des slew rates de plus de 10V/µs.

        On choisira éventuellement des amplificateurs plus rapides pour les montages en commutation, où la sortie va devoir basculer rapidement de Vsat+ à Vsat-. On l'a déjà dit, dans ces applications, un comparateur différentiel remplacera avantageusement un amplificateur opérationnel.

        Des applications telles que les étages de sortie de convertisseurs numérique/analogique, dont la sortie varie par bonds, utiliseront aussi des amplis à fort slew rate.

  5. RÉPONSE EN FRÉQUENCE D'UN AMPLIFICATEUR OPÉRATIONNEL. STABILITÉ.

    L'amplificateur réel n'a pas un gain différentiel infini ; de plus, celui-ci varie avec la fréquence. Comme l'amplificateur est utilisé en système bouclé, sa réponse en fréquence a un impact fondamental sur la stabilité du montage, qui va aussi dépendre de la valeur de la fonction de transfert de la boucle de retour B.

    Nous allons donc étudier maintenant la fonction de transfert harmonique typique d'un amplificateur opérationnel, voir quelle est la condition de stabilité d'un ampli bouclé, et étudier l'impact de ces considérations sur quelques montages de base.

    Cette section ne constitue que l'aperçu d'un vaste problème qui sera approfondi en automatisme ; néanmoins, il était difficile de faire l'impasse sur une des plus grosses imperfections de l'amplificateur opérationnel et ses conséquences.

    1. STABILITÉ D'UN SYSTÈME BOUCLÉ.

      Nous avons vu le principe de fonctionnement d'un système bouclé (voir figure 3) et l'expression de sa fonction de transfert :

      Dans le cas général, la fonction A est complexe, et comme [image] et B sont bâtis avec des composants qui peuvent être réactifs (condensateurs notamment), ces deux fonctions vont aussi être complexes : on va pouvoir déterminer le module du gain et le déphasage entrée/sortie en fonction de la fréquence (c'est la représentation de bode : nous n'utiliserons que celle-ci, contrairement à l'automatisme dont les adeptes sont friands d'autres critères beaucoup plus complexes à appréhender et moins intuitifs à comprendre !).

      1. Ordre d'un système
        L'ordre d'un système est déterminé par le nombre de pôles de sa fonction de transfert (les valeurs de la fréquence qui annulent le dénominateur).

        Ces pôles peuvent être réels ou imaginaires, et ainsi, l'ordre du système est donné par le degré du polynôme en f (ou [image], ce qui revient au même) qui forme le dénominateur de la fonction de transfert.

        Le tracé asymptotique du gain dans le plan de bode va être fonction de l'ordre du système (voir figure 34) : un système d'ordre 1 aura une pente de -20dB/décade au delà de la fréquence de cassure déterminée par son pôle, un système d'ordre 2 une pente de -40dB/décade... Chaque pôle supplémentaire augmente la pente de -20dB/décade.

        Parallèlement au gain, la phase diminue de -90° à chaque pôle. Les -180° fatidiques sont atteints asymptotiquement pour l'ordre 2.

        La figure 34 illustre un système à deux pôles (10Hz et 10kHz), dont la fonction de transfert est la suivante :

        Sur ce graphique, on a fait un tracé asymptotique du gain, qui met bien en évidence les pôles (fréquences de cassures) et les pentes de décroissance du gain.°

        Jusqu'à 1kHz environ, la phase varie comme pour un système du premier ordre (asymptote à -90°), et ensuite, à cause du deuxième pôle, elle tombe à -180° (valeur asymptotique qui ne sera théoriquement jamais atteinte).

        Fig. 34. Système à deux pôles.

        Un système du premier ordre sera toujours stable (phase mini de -90°), et les ennuis vont commencer dès le deuxième ordre (dépassements, oscillations amorties...). Il faut un troisième pôle pour arriver aux conditions d'oscillations, mais dans les amplificateurs opérationnels, on trouve toujours ce pôle supplémentaire, soit en interne, soit dans les composants externes (câblés volontairement ou parasites).

        Ce troisième pôle, même placé assez loin du deuxième, abaissera suffisamment la phase pour que les conditions d'oscillation soient réunies.

      2. Condition de Barkhausen.
        Si on regarde l'expression [70], on voit que le produit AB peut être négatif, et notamment prendre la valeur -1 (le module du gain vaut 1 et le déphasage est de -180°).

        Dans ce cas particulier, le dénominateur s'annule : il n'y a plus besoin de signal en entrée pour qu'il existe un signal en sortie. Nous avons réalisé un oscillateur ; un exemple sera décrit plus loin.

      3. Réponse en transitoires.
        Si dans certains cas, le fonctionnement en oscillateur du système bouclé est voulu, il sera indésirable la plupart du temps.

        Un système ne passera pas ex-abrupto de l'état stable aux conditions d'oscillation de Barkhausen. Le phénomène sera progressif, et, sur des transitoires marqués (ex : échelon de tension), le signal de sortie présentera un dépassement (overshoot) de plus en plus important, accompagné d'oscillations de moins en moins amorties au fur et à mesure que l'on va se rapprocher de la condition de Barkhausen.

        Ces dépassements et oscillations vont beaucoup perturber le fonctionnement de l'amplificateur, et modifier de façon substantielle le signal à amplifier : même si le système n'est pas un oscillateur, il n'en est pas moins inutilisable.

        La figure 35 illustre ce propos : elle représente la réponse indicielle (réponse à un échelon unité de tension) de trois systèmes bouclés dont les marges de phase sont respectivement de 18, 39 et 51° (par rapport aux 180° de l'oscillateur). Plus la marge de phase diminue, plus les oscillations et les dépassements sont forts (60% de dépassement pour une marge de 18°).

        Fig. 35. Réponse indicielle de systèmes bouclés.

        On y voit aussi que même pour une marge correcte du point de vue critère de stabilité (soit >45°), on a un léger dépassement (mais très peu d'oscillations).

        Le processus d'instabilité est donc progressif, et augmente au fur et à mesure qu'on se rapproche de la limite d'oscillation.

      4. Critères de stabilité.
        En pratique, on a vu que l'étude de la stabilité va se résumer (dans notre cas : ne généralisons pas à tous les systèmes !) à l'analyse du produit AB (le gain de boucle). Deux méthodes simples vont consister à regarder la phase ou la pente de la courbe de gain pour un module du gain égal à 1.

        • Marge de phase.
          Le critère généralement retenu par les automaticiens pour que le système soit déclaré stable est que la phase ne doit pas être inférieure à -135° pour un module |AB|=1 . Il reste une marge de 45° pour atteindre les 180° fatidiques (oscillateur). On dit que la marge de phase est de 45° .

        • Pente de la courbe de gain.
          Un critère très simple de stabilité sera le suivant : le diagramme asymptotique du produit AB devra croiser l'axe 0dB avec une pente maximum de -20dB/décade . Toute pente supérieure dénotera un système instable.

        • Choix du critère de stabilité.
          Il convient de noter ici que le critère de la pente est très facile à mettre en œuvre, car le seul tracé asymptotique est nécessaire, et que ce tracé nécessite peu de calculs (uniquement les fréquences de cassure des divers pôles et zéros de la fonction de transfert).

          Dans le cas de compensation de plusieurs pôles par plusieurs réseaux de compensation, il se peut que ce critère soit insuffisamment précis : on l'utilisera pour "dégrossir" le problème et mettre en place les réseaux de compensation adéquats, et on optimisera ces réseaux en appliquant le critère de marge de phase, plus précis.

          Pour un système compliqué, le tracé précis de la phase nécessite un calcul complet, qui peut vite se révéler laborieux à la main : un logiciel de tracé de courbes travaillant en complexes est quasiment nécessaire.

    2. FONCTION DE TRANSFERT DES AMPLIFICATEURS OPÉRATIONNELS.

      Il existe deux principaux types d'amplificateurs sur le marché :

      les amplificateurs inconditionnellement stables : le montage amplificateur est stable quel que soit le gain en boucle fermée obtenu (jusqu'au gain unité). Pour un gain supérieur à 0dB, ces amplificateurs présentent une réponse en fréquence du type premier ordre (pente de -20dB/décade), d'où leur stabilité inconditionnelle.

      certains amplificateurs à hautes performances présentent un deuxième pôle dans leur fonction de transfert pour des gains supérieurs à l'unité. De ce fait, en amplification pure (le réseau de retour est constitué de résistances, d'où B est réel), le système bouclé sera stable uniquement pour un gain supérieur à une certaine valeur (typiquement 5). Leur domaine d'utilisation est donc différent : ils possèdent de meilleures performances en fréquence que les premiers au prix d'une interdiction de leur emploi (sans précautions particulières) dans certaine fonctions.

      Pratiquement, les fonctions de transfert des amplificateurs sont similaires à celles représentées en annexe 3 pour les amplis inconditionnellement stables et annexe 4 pour les amplis dits "décompensés".

      On remarque que le gain en statique (pour une fréquence nulle, soit le continu) est très élevé, mais, le premier pôle réduit ce gain à partir d'une fréquence très basse (de quelques hertz à quelques dizaines d'hertz).

      Le deuxième pôle est situé beaucoup plus loin : vers 1Mhz pour le µA741, 4Mhz pour les TL081, LF356...

      En fait, dans les amplis inconditionnellement stables, on place volontairement le premier pôle très bas en fréquence (c'est le rôle du condensateur C du schéma de la figure 28), de manière à ce que le gain ait chuté suffisamment pour couper l'axe 0dB avant la deuxième fréquence de cassure.

      De cette manière, pour des gains en boucle fermée jusqu'à 0dB, le système est du premier ordre, et ne sera donc jamais oscillatoire.

      On agit sur le premier pôle, car il est plus difficile technologiquement de reculer le deuxième (et le troisième qui n'est pas loin !) : c'est le cas des amplificateurs rapides, et ils sont chers et délicats à utiliser...

      Pour améliorer le gain aux fréquences élevées, on diminue la valeur de la capacité intégrée C : on déplace le premier pôle d'un facteur 5 sur l'axe fréquentiel, et on atteint alors le deuxième pôle pour un gain de l'ordre de 5 avec les amplis courants (LF357, qui est un LF356 décompensé, LM149, qui est un LM148 décompensé, OPA637, qui est un OPA627 décompensé...).

      L'amplificateur n'est plus inconditionnellement stable, et ne pourra pas servir dans des applications telles que les suiveurs, dérivateurs, filtres d'ordre 2, montages logarithmiques, redresseurs sans seuils... En revanche, il fera merveille pour des amplis à fort gain : la bande passante sera 5 fois plus élevée qu'avec l'ampli équivalent inconditionnellement stable.

    3. AMPLIFICATEUR BOUCLÉ. PRODUIT GAIN-BANDE.

      Lorsqu'on boucle un ampli non inverseur avec un réseau de résistances, tant que le gain de boucle AB est élevé (soit à basse fréquence), le gain du système bouclé va tendre vers 1/B (voir [4] ; [image] est égal à 1 dans ce cas) ; à haute fréquence, le gain de boucle va diminuer, pour devenir égal, puis inférieur à la valeur 1/B. Dans ces conditions, la courbe de réponse en fréquence du système bouclé va tendre asymptotiquement vers celle de l'amplificateur.

      Fig. 36 Amplificateur bouclé.

      La figure 36 donne le résultat obtenu avec un ampli du type µA741 (première cassure à 10Hz, deuxième à 1MHz, gain statique de 100dB).

      Si on observe cette figure, on remarque que le produit du gain par la bande passante à -3dB est constant, et égal ici à 1MHz, soit la fréquence pour laquelle le gain en boucle ouverte vaut 1 (0dB).

      Ce produit est une caractéristique importante de l'amplificateur pour caractériser ses performances en fréquence.

      Ex : 1MHz pour le µA741, 3MHz pour le TL081, 15MHz pour le LM318...

      On note que cette caractéristique est juste pour les amplis inconditionnellement stables. Pour les amplis décompensés, la fréquence théorique à gain unité est obtenue en prolongeant la droite à -20dB/décade située entre la première et la deuxième cassure jusqu'à l'axe 0dB.

    4. COMPENSATION EN FRÉQUENCE.

      Tout le travail de compensation en fréquence de l'amplificateur consistera à installer des réseaux de correction de telle manière que la condition de coupure à -20dB/décade soit réalisée. Cette méthode sera préférée aux autres, car elle est très simple à mettre en œuvre, et l'effet des réseaux correcteurs sur le tracé de bode est bien visible.

      1. Compensation par déplacement de la première fréquence de cassure.
        Cette méthode est extrêmement simple ; elle est un prolongement de l'astuce technique qui consiste à placer le condensateur C (voir le schéma de la figure 28) entre collecteur et base du transistor du deuxième étage de l'ampli. La figure 37 montre le diagramme de bode asymptotique permettant de comprendre la compensation qui consiste à rajouter une capacité supplémentaire en parallèle avec la capacité C de la figure 28. (deux broches sont disponibles sur les boîtiers des amplis prévoyant cette compensation). De ce fait, la première fréquence de cassure recule vers les basses fréquences.

        Ces compensations étaient nécessaires avec des amplis anciens (LM101 par exemple) qui étaient bâtis pour garantir de bonnes performances à haute fréquence, mais nécessitaient une compensation pour les applications à faible gain.

        Fig. 37. Compensation d'un ampli à gain unité.

        L'astuce est très simple, et consiste à reculer toute la partie haute du diagramme de bode pour que le produit AB coupe l'axe 0dB dans la zone à -20dB/décade (ici, on coupe juste à la limite du deuxième pôle, la marge de phase est de 45°).

        Sur le schéma, on a représenté la compensation d'un montage suiveur : B vaut 1, et le produit AB se confond avec A, gain en boucle ouverte de l'ampli : n'oublions pas que le critère de stabilité s'applique au produit AB !

        On note l'overshoot de 10dB pour le montage suiveur non compensé, garant de fortes oscillations sur les transitoires. Le suiveur compensé a une courbe quasi-plate, mais en revanche, a une bande passante plus faible.

        Ce montage présente deux gros inconvénients :

        le gain de boucle est réduit dès les plus basses fréquences, ce qui nuit à la précision.

        le slew rate est affecté : la capacité de compensation vient se mettre en parallèle sur C ; l'ensemble, de capacité supérieure à C, va se charger avec le même courant, donc plus lentement.

        Avec l'apparition d'amplis rapides inconditionnellement stables, ce type de compensation est devenu peu utilisé.

      2. Compensation par retard de phase.
        On a imaginé une autre méthode de compensation éliminant les défauts de la méthode précédente : on ne va pas reculer la première fréquence de cassure, mais on va déformer la courbe de réponse en fréquence plus loin, par adjonction d'un réseau à retard de phase dans la chaîne directe de l'asservissement (en cascade avec A).

        Le but est de faire chuter le gain rapidement (avec une pente de -40dB/décade), pour reprendre ensuite une pente de -20dB/décade un peu avant que le produit AB ne croise l'axe 0dB : même si la pente a été de -40dB/décade auparavant, le montage est stable quand même, car le point important est que l'axe 0dB soit croisé avec une pente de -20dB/décade.

        Attention : si on veut augmenter le gain en boucle fermée du montage (par exemple, montage à gain réglable), il faut garder à l'esprit qu'on va abaisser la valeur globale du produit AB, et qu'on va se retrouver à un moment donné avec un croisement de l'axe 0dB avec une pente de -40dB/décade : le montage ne sera pas stable dans toute une plage de gain !

        C'est le prix à payer d'une amélioration du gain aux basses fréquences, la compensation par recul de la première fréquence de cassure n'avait pas ce défaut...

        Fig. 38 Compensation par retard de phase.

        Comment réaliser le réseau à retard de phase susceptible de modifier le gain de la chaîne directe ? Il faut tirer parti des éléments existants du montage, y compris des éléments parasites. Dans les amplificateurs de puissance (HIFI et autres, dont on a dit que la structure est la même que celle des amplificateurs opérationnels), on utilise l'impédance de sortie en boucle ouverte pour créer le réseau suivant :

        Fig. 39 Réseau à retard de phase.

        Sa réponse en fréquence est la suivante (représentation du gain réel et du gain asymptotique du réseau utilisé dans la compensation illustrée figure 38) :

        Fig. 40. Réponse en fréquence du réseau à retard de phase.

        La fonction de transfert de ce réseau est de la forme :

        avec :

        Dans le réseau de la figure 39, la résistance R1 est en fait souvent l'impédance de sortie d'un étage amplificateur qu'on cherche à compenser. On trouve ainsi très souvent un réseau R-C série en sortie des amplificateurs HIFI : ce réseau est destiné à les stabiliser avec une compensation par retard de phase. Ce procédé n'est pas utilisé tel quel sur les amplificateurs opérationnels : le réseau R-C chargerait trop la sortie de l'amplificateur.

      3. Compensation par avance de phase.
        La compensation par retard de phase n'est pas très simple à mettre en œuvre dans les montages à amplificateurs opérationnels. On lui préférera souvent la compensation par avance de phase, qui possède les avantages suivants :

        simple à mettre en œuvre (un condensateur supplémentaire suffit souvent).

        bande passante élargie par rapport aux autres modes de compensation.

        slew rate non altéré.

        Le défaut est que cette compensation n'est possible simplement qu'avec des gains supérieurs à 2 ou 3 (montage suiveur incompensable par cette méthode).

        Jusqu'à maintenant, on n'a pas touché la deuxième fréquence de cassure du produit AB (qui est celle de A en amplification pure). C'est ce qu'on va faire ici.

        Il existe deux méthodes :

        reculer la deuxième fréquence de cassure de l'ampli (compensation feed-forward) : cette méthode est assez délicate à mettre en œuvre, et ne fonctionne pas pour tous les montages.

        augmenter la valeur de B à haute fréquence : il suffit de jouer sur le réseau de contre réaction, ce qui est beaucoup plus simple (mais nécessite un gain du système bouclé supérieur à 2 ou 3).

        La figure 41 montre la compensation par un tel réseau d'un ampli ayant un gain en boucle fermée de 10dB. On remarque qu'aux basses fréquences, B vaut -10dB (B est un atténuateur !), et qu'à partir d'une fréquence un peu supérieure à la deuxième fréquence de cassure de l'ampli, sa valeur remonte, pour tangenter ensuite l'axe 0dB (la figure montre le diagramme asymptotique de B).

        Grâce à ce réseau, la courbe du produit AB peut s'étendre vers les fréquences élevées, jusqu'à tangenter la courbe A de l'ampli en boucle ouverte, qui constitue une limite ; cette remarque explique pourquoi on ne peut pas compenser avec cette méthode un ampli de gain unité, le produit AB étant confondu dans ce cas avec A.

        Fig. 41. Compensation par avance de phase.

        Le réseau à avance de phase peut être construit de la manière suivante :

        Fig. 42. Réseau à avance de phase.

        La fonction de transfert de ce réseau est du type :

        avec :

        Le fonctionnement de ce réseau est simple : aux hautes fréquences, C vient shunter R1, et Vs tend vers la valeur de Ve : le pont diviseur passe de la valeur R2/(R1+R2) à 1.

        Sur un montage du type amplificateur non inverseur, ce réseau est extrêmement simple à mettre en œuvre : on se contentera de rajouter un condensateur C en parallèle avec la résistance R1 :

        Fig. 43. Ampli non inverseur compensé.

        L'avantage de ce montage, c'est qu'on peut le compenser très simplement sans aucun calcul, en expérimentant des valeurs de C directement sur le montage attaqué par un signal carré en entrée : la bonne valeur du condensateur est celle qui réduit l'overshoot et les oscillations parasites à une valeur convenable.

        C'est ce que faisaient beaucoup de "bidouilleurs" à la belle époque de l'électronique analogique, sans connaître en détails la justification théorique de leur expérimentation.

      4. Bilan des compensations.
        On a vu trois méthodes de compensation :

        la compensation par déplacement du premier pôle est simple à mettre en œuvre, universelle, et donne un amplificateur inconditionnellement stable une fois compensé. Les défauts sont une bande passante rétrécie, donc un gain de boucle diminué dès les plus basses fréquences, et un slew rate ralenti.

        la compensation par retard de phase dans la chaîne directe est moins simple à appliquer sur des montages à amplificateurs opérationnels, mais très utilisée sur des amplificateurs de puissance. L'amplificateur résultant n'est pas inconditionnellement stable, et cette compensation nécessite des calculs et tracés de bode pour être efficace. Elle doit être adaptée au cas par cas. Il existe divers montages de compensation ; certains n'ont pas d'effet sur le slew rate (cas décrit ci-dessus), d'autres le diminuent.

        la compensation par avance de phase dans la boucle de retour est simple à utiliser, et son côté intuitif lui permet de trouver la bonne compensation rapidement par expérimentation. Le slew rate n'est pas affecté, la bande passante est meilleure qu'avec les autres méthodes, mais, elle est inapplicable pour un gain unité.

    5. ÉTUDE DE STABILITÉ DE MONTAGES SIMPLES.

      1. Amplificateur rapide.
        Il peut paraître stupide d'utiliser un amplificateur rapide à faible coût (ampli décompensé type LF357) pour l'utiliser avec des faibles gains. En fait, il ne faut pas oublier que le slew rate de ce type d'ampli est beaucoup plus élevé que celui du même ampli inconditionnellement stable (12V/µs pour le LF356, 50V/µs pour le LF357...).

        Il peut donc valoir la peine d'utiliser un ampli rapide et de le compenser, par exemple par réseau à avance de phase dans la boucle de retour. L'annexe 5 montre un tel montage et sa réponse en fréquence et en phase, qui illustre bien la compensation.

      2. Montage dérivateur.
        Même avec un ampli inconditionnellement stable, le montage dérivateur est oscillatoire. En rajoutant simplement une résistance en série avec le condensateur, on stabilise le tout, sachant qu'on limite évidemment la plage où le montage est dérivateur : on ne peut pas tout avoir ! Le schéma et le mécanisme de compensation sont exposés en annexe 6.

    6. OSCILLATEURS.

      1. Oscillateur à pont de wien.
        On a vu que quand le dénominateur de la fonction de transfert s'annule, le système devient auto-oscillant.

        La condition de Barkhausen s'écrit :

        Le produit AB doit donc être égal à -1 : cela correspond à une phase de ±180° pour un module du gain égal à 1.

        B étant en général un réseau passif (c'est la solution la plus simple, mais il existe aussi des réseaux de retour actifs), il sera atténuateur. La valeur du module de l'amplification A devra donc être supérieure à 1 pour compenser cet te atténuation et faire en sorte que |AB|=1.

        La phase de 180° peut provenir soit de l'ampli (ampli inverseur : la phase de B doit dans ce cas être égale à 0), soit du réseau B (ampli non inverseur dans ce cas)

        Il existe plusieurs réseaux produisant un déphasage de 0° ou 180° ; un des plus utilisés est le réseau de Wien :

        Fig. 44. Pont de Wien.

        La réponse en fréquence de ce réseau est la suivante :

        Fig. 45. Réponse en fréquence du pont de Wien.

        La phase de ce réseau varie de +90° à -90° , et passe par la valeur 0° lorsque le gain atteint une valeur maxi de -9,54dB, qui correspond à une atténuation de 3.

        La fonction de transfert de ce réseau s'écrit :

        Le maximum de B est atteint pour :

        Pour satisfaire aux conditions de Barkhausen, il faut donc mettre ce réseau en contre-réaction d'un amplificateur de gain -3 ; une autre solution possible est de reboucler avec ce réseau non pas sur l'entrée - de l'ampli, mais sur l'entrée + : avec un gain de +3, les déphasages sont les mêmes. Le schéma obtenu est le suivant :

        Fig. 46. Oscillateur à pont de Wien.

        La structure est simple à comprendre : il s'agit d'un amplificateur non inverseur, avec le pont de Wien rebouclé sur l'entrée de ce type d'ampli, donc, l'entrée +.

        En pratique, on remplacera R1 ou R2 par une résistance ajustable, et on augmentera le gain progressivement jusqu'à l'apparition d'oscillations en sortie du montage. Au fur et à mesure que le gain se rapproche de +3, la fonction de transfert globale du montage va tendre vers l'infini, comme illustré sur la figure 47 :

        Fig. 47. Fonction de transfert de l'oscillateur.

        Cet oscillateur, quand il est bien réglé, donne un signal sinusoïdal avec très peu de distorsion.

        En pratique, pour limiter l'amplitude des oscillations, on devra introduire un élément non linéaire dans la chaîne : soit des diodes zéner en sortie, soit une lampe à filament spécialement prévue pour cet usage à la place de R1.

        Si le gain devient supérieur à 3, les oscillations prennent une amplitude telle qu'elles sont écrêtées par l'amplificateur. Le signal n'est plus franchement exploitable, car il présente une distorsion importante.

        Les oscillateurs sont délicats à mettre en œuvre, car il faut les régler de telle manière que le gain soit suffisant pour que l'oscillateur "accroche", mais pas trop grand, car on a alors beaucoup de distorsion. La plage de fonctionnement correcte est très étroite, et relativement instable (variations dues à la température, à la charge de l'ampli...).


PUISS

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/PUISS/COURS.HTM#P01

Préambule

Les mesures de puissance dans les montages électroniques laissent souvent les gens perplexes ne serait-ce que par le nombre de définitions qui s'y rapportent. L'objet de la première partie de ce chapitre est de clarifier les choses en donnant quelques définitions simples.

Une deuxième partie fournit des éléments de calcul des radiateurs qu'il faudra fixer sur les semi-conducteurs dès lors que la puissance dissipée excédera un watt.

Les rappels de mesure de puissance seront ici très utiles : les calculs de radiateurs nécessitent de connaître la puissance dissipée par l'élément à refroidir, et en pratique, dans un montage électronique, les signaux de courant et tension seront souvent complexes, et on ne pourra pas, pour calculer la puissance, utiliser les formules vues en électricité et applicables seulement dans le cas de signaux sinusoïdaux.

  • MESURES DE COURANT, TENSION ET PUISSANCE : DÉFINITIONS.

    1. VALEURS INSTANTANÉES.

      1. Courant et tension.

        La valeur instantanée d'un courant ou d'une tension, c'est sa valeur à un instant donné. L'ensemble de ces valeurs donnent les fonctions u(t) et i(t), respectivement tension et courant en fonction du temps. Ce sont les courbes que l'on verra affichées sur l'oscilloscope (la tension se mesure directement avec l'oscilloscope ; pour le courant, on mesure en fait soit la tension aux bornes d'un shunt, soit la tension de sortie d'une sonde de courant).

      2. Puissance.

        C'est la définition de la puissance. Toutes les autres en sont dérivées. C'est le produit de la tension instantanée par le courant instantané.

        Pour des tensions et courants continus, on retrouve bien entendu P = UI.

        Il faut noter ici que pour des composants autres que des résistances, cette formule est toujours la seule valable, et que dans les composants électroniques dits actifs , il n'y a pas que la résistance interne qui dissipe de la puissance.

        Exemple : une diode zéner. La tension dissipée dans ce composant est égale à Vz Iz, et le terme Vz comprend aussi bien le générateur de tension Vzo que la chute de tension dans la résistance rz.

    2. VALEURS MOYENNES.

      1. Courant et tension.

        La valeur moyenne d'un signal de courant ou tension est obtenue en faisant la moyenne de toutes les valeurs instantanées sur un intervalle de temps [to, t1], soit en intégrant le signal de tension ou de courant sur l'intervalle considéré et en le divisant par l'intervalle de temps :

        La formule est évidemment la même pour le courant.

      2. Puissance.

        La formule [2] est aussi valable pour la puissance en remplaçant u(t) par p(t). Si dans cette formule on remplace p(t) par sa valeur (formule [1]), on a:

        On voit ici qu'il est absolument hors de question de dire que la puissance moyenne sur un intervalle de temps donné est égale au produit de la tension moyenne par le courant moyen ! C'est justifié du point de vue mathématique par le fait que l'intégrale d'un produit de 2 fonctions n'est absolument pas égale au produit des intégrales de ces fonctions.

        On peut remarquer autre chose : l'intégrale de la puissance instantanée sur un intervalle [to, t1] est en fait l'énergie W fournie ou absorbée par un composant pendant cet intervalle de temps. La puissance moyenne est donc l'énergie fournie ou absorbée par le composant divisée par la durée de l'intervalle d'étude.

      3. Interprètation graphique.

        Les formules des valeurs moyennes sont très simples à interpréter graphiquement :

        Fig. 1. Tension moyenne sur un intervalle de temps.

        Sur la fig. 1., le schéma de gauche représente le signal instantané de la tension pendant l'intervalle de temps [to, t1]. La valeur moyenne umoy représentée sur le schéma de droite est telle que les surfaces hachurées So et S1 soient les mêmes. Ces surfaces correspondent mathématiquement à l'intégrale des fonctions sur l'intervalle [to, t1].

    3. VALEURS EFFICACES.

      1. Courant et tension.

        On a vu que pour déterminer la puissance induite par une tension alternative quelconque dans une résistance, il faut intégrer. On ne peut pas utiliser la valeur moyenne de la tension. Les valeurs efficaces ont été créées pour pallier cet inconvénient : le carré de la tension efficace est proportionnel à la puissance que cette tension va fournir à une résistance. Les valeurs efficaces sont donc par définition liées à la notion de puissance.

        Ainsi, la tension efficace d'un signal alternatif quelconque sera égale à la tension continue qui induirait les mêmes effets d'échauffement dans une résistance que ce signal alternatif.

        Pour une tension alternative quelconque appliquée à une charge résistive, on a les équations :

        On en déduit :

        La formule donnant la puissance moyenne dans cette résistance est :

        La tension continue ueff qui donnerait la même puissance dans cette résistance est donc :

        pmoy est alors simplement égal à :

        On retrouve la formule applicable en régime continu.

      2. Puissance.

        En fait, la puissance efficace n'existe pas !!! Et c'est de là que viennent malheureusement bien des confusions.

        Cette confusion est entretenue par le fait que certaines spécifications de produits (notamment amplificateurs HIFI) parlent de puissance efficace.

        En fait, les valeurs efficaces sont relatives aux courants et tensions, et on a vu que par définition, elles donnent la même puissance qu'une tension continue égale : la puissance calculée à partir d'une tension ou d'un courant efficace est donc une puissance moyenne !

    4. VALEURS CRÊTES.

      Les valeurs crêtes sont les extremums des signaux sur un intervalle de temps donné. Elles ont un intérêt en électronique (surtout les tensions) car ce sont ces valeurs qui vont déterminer le dimensionnement des semi-conducteurs (diodes, transistors ). On a vu en effet que les phénomènes de claquage des jonctions se produisaient à partir de tensions bien déterminées, et même si les dépassements sont de très courte durée, il peut y avoir destruction rapide des semi-conducteurs exposés à ces surtensions.

      Dans tout montage, on surveillera donc les tensions crêtes appliquées aux semi-conducteurs, surtout dans les montages où on commute des éléments à composante inductive (relais, selfs, haut-parleurs ).

      Pour ce qui est des puissances, les valeurs crêtes ont moins d'importance, car le composant a une inertie thermique qui permet d'absorber ces pointes sans trop de dommages : on pourra ainsi mesurer des puissances crêtes très élevées pendant des temps très courts sans que le composant ne chauffe, car dans ce cas, c'est la puissance moyenne qui compte. Il y a quand même une limite à cela, et en général, pour les composants de puissance (transistors, diodes ), le fabricant fournit des abaques qui donnent la puissance crête à ne pas dépasser en fonction du temps d'application et de la fréquence de répétition des pulses de puissance.

      Il convient de noter que les puissances maximums ne seront probablement pas enregistrées aux mêmes endroits que les courants et / ou tensions maxi : en effet, les crêtes de puissance sont obtenues quand on a simultanément un fort courant et une forte tension, et l'expérience montre que habituellement, les maxis de tension sont observés à faible courant et vice versa.

      Il ne suffira donc pas en général de localiser les pics de courant et de tension pour avoir ceux de puissance.

    5. EN PRATIQUE

      Comment mesurer toutes ces grandeurs en pratique dans un laboratoire ?

      La plupart des multimètres numériques sont dotés de convertisseurs qui intègrent les signaux pendant un temps donné : par construction, ils donnent comme indication les valeurs moyennes des tensions et courants mesurés. (les galvanomètres magnéto-électriques à cadre mobile aussi, mais on ne les voit plus beaucoup dans l'industrie )

      Il faudra se méfier de certains multimètres de compétition , très rapides et destinés à être branchés sur des ordinateurs par liaison IEEE ou GPIB (ou autre ) et qui donnent la valeur instantanée du signal (soit la valeur à l'instant précis de la mesure). Il faut alors bien maîtriser le point où se fera la mesure (trigger). Il n'est plus ici question de valeur moyenne.

      Dans tous les cas, trois règles d'or :

      essayer la mesure avec un signal connu (générateur basse fréquence).

      dans le doute, abstiens toi . Mieux vaut pas de mesure qu'une mesure complètement fausse.

      lire la documentation du matériel (eh oui !).

      On l'a vu, les oscilloscopes donnent les valeurs instantanées des courants (via un shunt ou une sonde) et tensions. Pour ce qui est de la puissance, les oscilloscopes numériques actuels (excepté les modèles d'entrée de gamme, mais l'évolution est rapide dans ce domaine) sont capables de faire le produit des signaux issus de deux voies différentes : en mettant la tension sur la voie A et le courant sur la voie B, on peut obtenir la puissance instantanée en temps réel sur l'écran de l'oscilloscope.

      Pour ce qui est des valeurs moyennes, ces oscilloscopes numériques disposent en général de fonctions donnant l'aire d'un signal (l'intégrale) : on a donc accès aux valeurs moyennes des signaux par ce biais (il faudra faire très attention au calage du zéro des courbes !). La mesure à l'oscilloscope de valeurs moyennes peut être rendue obligatoire pour des signaux rapides (les multimètre ont des bandes passantes souvent faibles : relire la documentation si ce n'est déjà fait !) ou très complexes : dans ce cas, il est préférable de voir ce qu'on fait. On pourra aussi corréler les mesures oscilloscope et multimètre : si elles sont égales, on préférera le multimètre, plus précis, tout en surveillant les opérations sur l'écran de l'oscilloscope.

      Pour ce qui est des valeurs efficaces, à de rares exceptions près, on ne les utilisera pas en électronique. Ces notions sont beaucoup plus utiles en électrotechnique, et encore, car l'avènement des composants électroniques de puissance dans ce domaine et leurs applications (hacheurs, onduleurs et convertisseurs divers ) ont fait apparaître bien d'autres contraintes dans les mesures (entre autres les phénomènes transitoires sur des composants selfiques, où les déphasages courant/tension ne sont pas aussi simples qu'en régime établi).

      On se souviendra seulement que ces valeurs efficaces sont un artifice de mesure donnant simplement la puissance (moyenne !) sans faire de calculs, mais dans des conditions de mesure bien particulières, souvent inapplicables en électronique et qu'elles étaient initialement liées à du matériel de mesure spécifique (galvanomètre ferromagnétique).

  • DISSIPATION THERMIQUE DANS LES COMPOSANTS.

    Dans un transistor, l'essentiel de la chaleur produite l'est dans la jonction collecteur-base. Si cette jonction était isolée thermiquement, sa température deviendrait vite très élevée.

    La température maxi de jonction pour le silicium est d'environ 175°C. Au delà, le semi-conducteur dopé retrouve quasiment un comportement de semi-conducteur intrinsèque, car l'élévation de température augmente beaucoup le nombre de porteurs minoritaires (création de paires électrons-trous par agitation thermique).

    On évitera de toutes façons de travailler à des températures élevées, car la fiabilité d'un composant électronique décroît très vite quand la température augmente.

    On est donc obligés d'évacuer les calories produites dans les jonctions des semi-conducteurs, en fixant ceux-ci sur des radiateurs.

    Cette évacuation va se faire par les trois échanges thermiques fondamentaux :

    par conduction d'abord : les calories produites à la jonction du silicium vont se propager à la surface extérieure du boîtier du composant, puis du radiateur, éventuellement au travers d'un élément isolant (mica ou isolation du boîtier du composant en époxy).

    par convexion ensuite : l'air chauffé au contact du radiateur s'élève et laisse la place à de l'air plus frais ; il y a une circulation naturelle de l'air autour du radiateur (attention à ne pas entraver cette libre circulation : les radiateurs doivent être bien dégagés pour remplir leur rôle efficacement).

    et enfin, par rayonnement : l'énergie est transmise sous forme d'ondes électromagnétiques au milieu ambiant.

    1. EN CONTINU : RÉSISTANCE THERMIQUE.

      1. Loi d'Ohm thermique.

        L'efficacité de ces échanges thermiques sera fonction du composant, de la fixation composant / radiateur, de la taille du radiateur (la convexion et le rayonnement sont proportionnels à sa surface), de sa forme et de sa position (convexion plus ou moins efficace), et de sa couleur (le noir mat rayonne plus que toute autre couleur).

        Il y a néanmoins une limite à la taille du radiateur : au delà d'une certaine valeur, l'efficacité n'augmente plus. C'est dû au fait que les calories doivent se propager par conduction sur toute la surface du radiateur, et cette propagation est limitée.

        La dissipation est proportionnelle à la différence de température qui existe entre le radiateur et le milieu ambiant.

        On caractérise le pouvoir de dissipation d'un montage thermique par l'élévation de sa température par rapport au milieu ambiant et ceci pour une puissance dissipée égale à 1W : c'est la résistance thermique de l'élément :

        Cette relation est connue sous le nom de loi d'Ohm thermique .

        On considère ici un semi-conducteur monté sur un radiateur : ce qui nous intéresse est l'élévation de température de la jonction par rapport à la température ambiante. Dans la formule [10], on a :

        Rth est la résistance thermique jonction-ambiante.

        Tj est la température de jonction.

        Ta est la température ambiante.

        P est la puissance dissipée dans la jonction.

        L'analogie avec la loi d'Ohm électrique est la suivante : la puissance thermique circule comme un courant, et comme le matériau conducteur s'oppose à cette circulation (résistance thermique, comme la résistance électrique s'oppose au passage du courant), on observe une différence de température entre deux points situés sur le chemin de circulation de la puissance thermique (assimilé à la différence de potentiel électrique).

        Cette loi est très utile : quand on connait la puissance dissipée et la résistance thermique totale du montage, de la jonction à l'air ambiant, on peut calculer l'échauffement de la jonction par rapport à la température ambiante, et donc la température absolue de la puce. On déterminera alors le radiateur pour que celle-ci reste raisonnable de manière à ne pas détruire le composant.

        On va voir maintenant de quoi est fait l'empilement thermique, et comment déterminer pratiquement les valeurs de ses composantes.

      2. Constitution de l'empilement thermique.

        En pratique, la résistance thermique totale de la jonction à l'air ambiant comporte plusieurs composantes, détaillées à la Fig. 2.

        Fig. 2. Sandwich thermique.

        Le transistor lui même est constitué de :

        la puce de silicium.

        une plaque de cuivre appelée lead frame qui supporte la puce, lui garantit une certaine rigidité (le silicium est fragile !), et constitue une capacité thermique.

        la puce est fixée au lead frame qui est relié électriquement de ce fait au collecteur.

        dans certains cas (et de plus en plus), le lead frame est isolé de l'extérieur par une couche d'isolant (genre époxy) qui enrobe le composant : celui-ci peut être fixé directement sur le radiateur sans qu'on ait à se soucier de l'isolation. Ces composants sont de plus en plus utilisés dans l'industrie, car ils évitent d'avoir à rajouter l'isolant dans le processus de fabrication.

        Quand les composants ne sont pas isolés, il faudra intercaler un dispositif d'isolation entre eux et le radiateur, pour des raisons de sécurité d'une part (on ne peut pas laisser un radiateur à un potentiel de 300V par exemple à l'air libre !), et de fonctionnement d'autre part : on peut être amenés à fixer plusieurs transistors non isolés sur le même radiateur ; si leurs lead frame (qui sont reliés aux collecteurs par construction) sont à des potentiels différents, on risque des courts circuits intempestifs, qui seront évités par l'isolation.

        L'isolation classique se fait en intercalant une feuille mince de mica entre le transistor et le radiateur ; on complète le montage par un joint de graisse spéciale aux silicones à bonne conductibilité thermique, dans le but d'éliminer des lamelles d'air (très mauvais conducteur de chaleur) entre le transistor, le mica et le radiateur.

        Du point de vue loi d'ohm thermique, ce sandwich est assimilable à plusieurs résistances mises en série, comme le montre la Fig. 3.

        Fig. 3. Empilage des résistances thermiques.

        La puce est à la température Tj, et le boîtier du transistor à la température Tb. Le transistor a une résistance thermique Rth j->b qui va déterminer son aptitude à évacuer les calories produites dans la jonction. On peut écrire la loi d'Ohm thermique pour ce composant :

        Ensuite, on rencontre la fixation / isolation du transistor sur le radiateur : on va la caractériser par la résistance thermique boîtier / radiateur Rth b->r :

        Enfin, il y a la liaison entre le radiateur et l'air ambiant, définie par la résistance thermique du radiateur Rth r->a :

        On remarque qu'en additionnant les 3 résistances thermiques, on obtient la résistance thermique totale Rth, et on retombe sur l'équation [10].

        Les fournisseurs de composants d'une part, et de radiateurs d'autre part fournissent des données permettant de calculer leur résistance thermique.

      3. Caractéristiques thermiques des transistors de puissance.

        En pratique, les constructeurs de transistors (et autre semi-conducteurs de puissance) donnent rarement directement la résistance thermique des composants.

        Ils donnent très souvent la puissance maxi et la température de jonction maxi, qu'il faut interpréter en général comme suit : la puissance maxi est donnée pour une température de boîtier maintenue à 25°C (radiateur infini, soit avec une résistance thermique Rth r->a nulle) et une température de jonction maximale.

        Quand on considère l'équation [11], on voit que si on augmente la température de boîtier, pour conserver une température de jonction constante, il faut diminuer la puissance dissipée par le composant. Cette loi est linéaire. On peut alors tracer le graphique de la puissance dissipée en fonction de la température de boîtier, et ceci à température de jonction maxi. On obtient la Fig. 4.

        Fig. 4. Courbe de dissipation maxi du transistor.

        On peut écrire un cas particulier de l'équation [11] :

        On voit qu'on obtient facilement à partir des données du constructeur la résistance thermique du composant.

        Le graphique Fig. 4. nous enseigne une chose essentielle : plus la température du boitier augmente, plus la puissance dissipable par le composant est faible, jusqu'à devenir nulle quand la température du boitier est égale à la température maxi admissible par la jonction .

        Une autre chose fondamentale à se rappeler est que la puissance maxi dissipable l'est pour une température de boîtier de 25°C , ce qui correspond à un radiateur infini. Le composant seul, sans radiateur, ne pourra dissiper au mieux que quelques watts !

      4. Élément d'isolation.

        Si le boîtier du transistor est isolé, il n'y a pas à s'en préoccuper, car c'est pris en compte dans la résistance thermique du composant.

        Si on met du mica et de la graisse, on prendra Rth b->r égal à 1°C/W. Il existe des isolants ayant un Rth descendant à 0,1°C/W : il faudra se reporter à la notice du fabricant pour vérifier cette valeur.

        Si la planéïté du radiateur n'est pas parfaite (tôle d'aluminium assez mince par exemple), il faudra tenir compte des éventuelles lames d'air, et ne pas prendre un Rth trop faible.

      5. Calcul pratique du radiateur.

        En pratique, le calcul de la partie thermique d'un montage électronique se fait ainsi :

        le composant de puissance est défini par des impératifs électriques ; on détermine sa résistance thermique comme indiqué au paragraphe précédent en utilisant les données du fabricant.

        on détermine la puissance moyenne dissipée par le composant de puissance par mesures et calculs.

        on fait des hypothèses sur la température ambiante maxi où sera situé le montage.

        on se fixe une température de jonction maxi en accord avec les impératifs de fiabilité donnés dans le cahier des charges. En pratique, et sauf utilisation extrême de composants spéciaux, cette température sera bien en deçà de la température maxi de jonction admissible (entre 60 et 100°C environ).

        Il ne reste donc que la résistance thermique du radiateur à déterminer de manière à ne pas dépasser la température de jonction maxi qu'on s'est fixée.

        Si on additionne membre à membre les équations [11], [12] et [13], on obtient :

        On en déduit facilement la résistance thermique radiateur / ambiant qui nous permettra de choisir le bon radiateur dans un catalogue :

        Dans le cas où le radiateur serait trop volumineux, ou pire, que le Rth r->a obtenu ne corresponde à aucun radiateur du catalogue, il faut passer à des solutions plus sophistiquées, à savoir convexion forcée par ventilateur (le Rth r->a diminue alors considérablement), ou dans les cas extrêmes, à un refroidissement par circulation de liquide dans le support du composant de puissance.

    2. EN TRANSITOIRE : CAPACITÉ THERMIQUE.

      Tous les calculs faits précédemment sont relatifs au régime établi, qui correspond en théorie à un temps de stabilisation infini (en pratique, les temps de stabilisation de température des radiateurs peuvent être élevés (plus d'une heure), surtout si les radiateurs sont gros : il faudra en tenir compte si on est amené à faire des mesures de température sur des composants de puissance).

      En pratique, il est rare qu'un boîtier électronique ait à dissiper en permanence la puissance maxi. Il y aura des pointes de puissance pendant des durées limitées suivies de moments de repos relatif, où la puissance dissipée sera beaucoup plus faible.

      Dans ce cas, afin de ne pas surdimensionner les éléments de refroidissement (qui prennent beaucoup de place en comparaison des circuits électroniques, de plus en plus miniaturisés), il faudra tenir compte du fait que les composantes thermiques ne prennent pas instantanément la température maxi.

      Ceci provient du fait que le composant a une capacité thermique, qui est en fait sa capacité calorifique :

      m est la masse du composant (ou du radiateur), et C sa chaleur spécifique. Le produit mC représente la capacité calorifique du composant.

      Cette capacité est caractérisée par l'augmentation de température T2 - T1 du composant quand on lui fournit adiabatiquement une quantité d'énergie Q.

      Plus la capacité thermique (ou calorifique) du composant est élevée, plus la quantité d'énergie à fournir pour augmenter sa température est élevée.

      On peut remarquer dans l'équation [17] le sens du terme capacité , et l'analogie avec la loi d'Ohm thermique. La quantité d'énergie Q, intégrale de la puissance dissipée est l'équivalent thermique d'une quantité d'électricité, qui est l'intégrale d'un courant électrique.

      En électricité, on a la relation Q = C (V2 - V1) : si on remplace la différence de potentiel par la différence de température, la capacité électrique par la capacité thermique, et la quantité d'électricité par la quantité d'énergie, on retombe sur la formule [17] de la capacité thermique. Cette formule dédiée au régime transitoire complète donc la loi d'Ohm thermique classique du régime continu.

      1. Rôle du lead frame.

        En pratique, le lead frame va servir de capacité thermique, et va permettre à la puce d'encaisser des puissances instantanées bien supérieures à ce que le calcul de résistance thermique donnerait.

        Pour un gros transistor de puissance, on a une capacité thermique de l'ordre de 1 à 3 J/K.

        Si un tel transistor dissipe 200W pendant 100µs, l'énergie qu'il devra absorber sera de seulement 20mJ : l'échauffement correspondant sera dérisoire (0,02°C) !

        Ce pulse d'énergie peut être supporté par le transistor nu, c'est à dire non muni de radiateur. Par contre, il est hors de question de faire dissiper en continu une telle puissance à un transistor qui ne serait pas muni d'un radiateur à circulation de liquide !

        On voit tout l'intérêt de la notion de capacité thermique dans le cas où le transistor aurait à dissiper des fortes puissances pendant des temps très brefs. Il serait absurde d'utiliser dans ce cas les calculs de résistance thermique.

      2. Puissance maxi.

        Ce processus a une limite : il ne faut pas perdre de vue que le paramètre critique est la température de jonction, et que la liaison silicium / lead frame (soudure) a une résistance thermique non nulle (environ 0,5°C/W) : il faudra veiller à ce que le produit de cette résistance thermique par la puissance instantanée (échauffement) ajouté à la température du lead frame ne dépasse pas le maximum de la température de puce autorisé par le constructeur.

        Pour des pulses d'énergie très courtes, la puce elle même a une capacité thermique non nulle, mais il faut faire attention aux transistors bipolaires : l'application d'une forte puissance instantanée créé des points chauds localisés à la surface de la puce qui vont drainer de plus en plus de courant, ce qui va entraîner un effet d'emballement local et aboutir à la destruction de la puce (phénomène de second claquage).

        Ce phénomène est complexe, et si on doit utiliser des transistors à la limite , on se reportera aux ouvrages adéquats avant toute manipulation (qui pourrait dans ce cas coûter fort cher !).

      3. Généralisation

        Le processus décrit précédemment l'a été pour le transistor seul. On peut généraliser à tout l'empilement thermique. Cet empilement serait alors une succession de résistances et de capacités thermiques :

        Fig. 5. Schéma thermique équivalent.

        On parle alors dans ce cas d'impédance thermique, et l'analogie avec l'électricité est immédiate. La Fig. 5. donne tous les éléments du schéma équivalent que l'on traite avec les équations et le formalisme de l'électricité.

        On notera les deux composants qui forment le début et la fin du schéma : l'énergie électrique est schématisée par un générateur de courant, et l'air ambiant comme une source de température. Cette dernière approximation est fausse si le montage est confiné dans un boîtier mal aéré ou si la convection est forcée (ventilateur).

        Dans tous les cas, une bonne expérimentation est nécessaire après les calculs et simulations pour vérifier le bien fondé des hypothèses et la validité du modèle.


Perturbation dans les mesures

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/PERTU/COURS.HTM#P01

INTRODUCTION.

Les plus gros soucis que devra affronter le spécialiste en mesures lors de la mise au point de manips ou de bancs de mesures viendront des nombreuses perturbations extérieures qui affecteront le résultat.

L'objet de ce cours est de répertorier les principaux modes de perturbations électriques ; pour chacun de ces modes, on donnera une définition théorique (donc assez large), et pour ne pas rester dans le flou, on passera tout de suite à un exemple concret, représentatif de ce qu'on trouve fréquemment dans la pratique de la mesure.

Il ne faudra bien entendu pas se borner à cet exemple, et garder à l'esprit qu'il est seulement représentatif d'une famille de perturbations.

Ce cours est très simplifié. En effet, on rentre dans le domaine plutôt complexe de la Compatibilité ÉlectroMagnétique (CEM) des équipements électriques. Ce domaine est assez mal maîtrisé, car jusqu'à présent, il est resté confiné dans des domaines pointus (spatial, militaire, radiodiffusion...).

L'émergence de nouvelles normes en matière de CEM visant à réduire les parasites émis par les équipements électriques augmente actuellement de façon considérable le champ d'action de cette discipline.

Il n'est pas question dans ce cours de rentrer dans le détail des notions complexes de ce domaine ; le but est juste de sensibiliser de futurs spécialistes en mesure aux plus gros problèmes qu'ils devront affronter, et leur permettre :

d'éviter les pièges les plus grossiers.

de " flairer " les pièges plus subtils ; il feront alors appel à un spécialiste de la CEM qui les aidera à mettre le montage de mesure au point. Quelquefois, des conseils simples suffiront.

  • NOTIONS DE COUPLAGE ÉLECTRIQUE.

    Pour qu'il y ait couplage, il faut au moins deux équipements en présence : un qui va générer des signaux parasites (le coupable ), et un autre qui va subir la perturbation (la victime ).

    Dans notre cas, le coupable pourra être quelconque (alimentation, ventilateur, ordinateur, câble véhiculant des forts courants pulsés...), et la victime sera l'ensemble composé du système à mesurer, de l'équipement de mesure, et bien sûr, encore et toujours des câbles.

    A noter que dans le cas d'un banc de mesure complexe, certaines parties de ce banc peuvent devenir des coupables pour d'autres parties qui en seront victimes...

    Le couplage est la liaison physique (au sens de phénomène physique) qui va permettre au coupable de polluer la victime.

    Les six modes de couplage recensés sont les suivants :

    couplage par impédance commune

    couplage par diaphonie inductive

    couplage par diaphonie capacitive

    couplage carte à châssis

    couplage de champ à fil

    couplage de champ à boucle

    Les quatre premiers sont des couplages par conduction (à travers une résistance, une inductance, une mutuelle inductance, un condensateur, ces éléments étant parasites), et les deux derniers, des couplages par rayonnement de champs électromagnétique.

    Nous allons voir ces six couplages en détail et étudier des exemples concrets pour chacun d'eux.

  • COUPLAGE PAR IMPÉDANCE COMMUNE.

    Quand on rencontre des problèmes de parasitage des mesures, on va souvent chercher des explications compliquées mettant en cause des champs électromagnétiques ou pis, des démons inconnus...

    Très souvent, nous sommes seulement ( ! ) victimes de couplage par impédance commune.

    1. DÉFINITION.

      Dans une boucle de mesure, on a un couplage par impédance commune lorsqu'une impédance parasite faisant partie de la boucle est parcourue par un courant étranger à la boucle de mesure. La chute de tension créée par ce courant dans l'impédance parasite va s'ajouter à la tension à mesurer et la fausser.

      En général, l'impédance parasite sera résistive (99% des cas), et parfois inductive. Les inductances parasites des câbles étant faibles, le phénomène sera gênant en HF et lors de commutation rapide de courants importants.

      Le couplage par inductance est plus problématique pour le concepteur de circuits électroniques rapides que pour le spécialiste en mesures.

    2. EXEMPLES.

      Les cas les plus critiques seront toujours les mesures de signaux de faible niveau : le niveau relatif des perturbations devient alors gênant pour qu'on puisse garantir la précision. Nous allons donc insister sur ces cas.

      1. Cas d'école.

        Dans la littérature, ce mode de couplage est présenté de la façon théorique suivante :

        Fig. 1. Couplage par impédance commune.

        Considérons une impédance Zm aux bornes de laquelle on désire mesurer une tension Vr.

        Cet élément à mesurer est relié à un amplificateur de mesure de gain Av par 2 fils, dont l'un présente une impédance parasite Zp.

        La boucle de mesure, schématisée figure 1 comprend l'impédance aux bornes de laquelle on mesure une tension, l'entrée de l'ampli d'instrumentation, et les fils aller (point chaud) et retour (masse) du câble.

        Dans le cas où l'impédance Zm est interconnectée avec d'autres éléments (circuit électronique), ainsi que l'ampli de mesure (par exemple à un oscilloscope), il peut exister un courant parasite Ip indépendant de la mesure et circulant dans le fil d'impédance Zp liant l'élément à mesurer à l'amplificateur.

        Le courant de mesure proprement dit est conditionné par l'impédance d'entrée de l'ampli, qui est (sauf en HF) en général très élevée (> 1M [image]) pour ne justement pas perturber l'élément à mesurer. Ce courant étant infime, on va le négliger.

        Nous étudierons dans les exemples suivants d'où peut provenir le courant Ip. Pour l'instant, on va admettre qu'il existe et analyser les perturbations induites.

        Si on applique la loi d'ohm dans la boucle de mesure, on trouve une tension à l'entrée de l'ampli égale à :

        En effet, l'entrée de l'ampli " voit " tout ce qui compose la boucle de mesure, à savoir la tension à mesurer plus la chute de tension dans l'impédance parasite Zp.

        • Application numérique.

          Si le signal Vr est de l'ordre de 100mV (ce qui est déjà, en mesure, une valeur " importante "), Ip = 1A et Zp = Rp = 10m [image], le signal d'erreur représentera 10% du signal à mesurer... et le résultat sera inexploitable !

        • Cause fondamentale.

          Le point de départ de toutes ces perturbations est une remise en cause d'un postulat de l'électronique théorique : la masse n'est pas une véritable équipotentielle , surtout lorsqu'on a plusieurs équipements interconnectés. C'est le problème de base de la CEM, et c'est dû à un phénomène non pris en compte dans les cours d'électronique de base : tout conducteur, quel qu'il soit, présente une impédance à ses bornes. C'est donc vrai pour toutes les liaisons, et en particulier celles entre masses.

        • Dépasser la mise en équation.

          Ces éléments théoriques ne sont pas suffisants pour permettre au néophyte de les mettre en évidence sur une manip, et de voir les branchements et mécanismes concrets qui ramènent à ce cas d'école.

          Passons donc au concret : nous allons voir sur 3 cas extrêmement répandus en mesure le mécanisme de couplage par impédance commune.

      2. Exemple de mesure de courant à l'aide d'un shunt.

        L'illustration la plus proche du cas théorique précédent est la mesure d'un courant à l'aide d'un shunt sur un équipement électronique.

        • Description du montage.

          Le montage est composé des éléments suivants :

          un montage électronique comprenant le shunt de mesure d'un courant, un des pôles du shunt étant relié à la masse du montage électronique.

          une alimentation stabilisée fournissant l'énergie au montage électronique.

          un oscilloscope permettant de visualiser et mesurer le courant du montage électronique.

          un câble coaxial liant le montage à l'oscilloscope.

          Le montage réel sera le suivant :

          Fig. 2. Mesure sur shunt.

          Il est très important de noter que chaque appareil possède sa masse électrique, que ces masses sont reliées entre elles par les câbles de liaison, et que les masses de l'alimentation et de l'oscilloscope sont reliées à la terre.

          A ce titre, dans tous les laboratoires, les prises de courant sont toutes équipées de terre, et tous les appareils électriques et électroniques d'alimentation, de génération et transformation de signaux, et ceux de mesure sont équipés de prises de terre, ceci afin de mettre ces appareils à un potentiel très voisin de celui des humains qui les utilisent : on évite ainsi les chocs électriques et on assure la sécurité des personnes qui manipulent.

          Le respect de ces règles est obligatoire, et les circuits de mise à la terre sont régulièrement contrôlés.

        • Schéma équivalent.

          Fig. 3. Schéma de câblage équivalent.

          A partir du schéma de branchement, on va bâtir le schéma électrique équivalent en tenant compte des impédances parasites des câbles (Fig. 3.).

          Dans ce schéma, nous n'avons mentionné que les résistances parasites. Le raisonnement serait strictement le même si on incluait les selfs parasites.

          Si dans un premier temps on supprime l'oscilloscope, le fonctionnement est le suivant : tout le courant Is circulant dans le shunt est fourni par le pôle + de l'alimentation et revient par le pôle - de cette alimentation, ainsi que les autres courants circulant dans le module électronique.

          La prise de terre sert uniquement à mettre le montage au potentiel de la terre : aucun courant ne circule dans cette connexion (sauf gros problème !).

          Si maintenant on rajoute l'oscilloscope avec sa prise de terre, et le câble de liaison avec le montage électronique, la règle précédente reste valable : aucun courant ne " disparaît " dans la terre. Par contre, le courant Is circulant dans le shunt a maintenant 2 circuits possibles pour retourner vers l'alimentation :

          le circuit direct prévu à cet effet, à savoir le câble de masse reliant l'alimentation au montage (courant I1).

          un circuit parasite, composé du fil de masse du câble de mesure, du fil de terre reliant l'oscilloscope au secteur, et du fil de terre reliant le secteur à l'alimentation (courant I2).

          Les courants I1 et I2 peuvent être aisément calculés par la loi du diviseur de courant :

          On retrouve ici le cas d'école, avec l'impédance parasite qui est Rcbl et le courant parasite I2 circulant dans la boucle de mesure. On en déduit alors facilement la valeur du signal d'erreur Verr :

          Ces équations sont données à titre indicatif : dans la pratique, on ne connait pas les impédances parasites avec précision, ni surtout les résistances de contact des câbles aux borniers. On ne saura donc pas faire un calcul précis. On se bornera à estimer un ordre de grandeur de l'erreur qu'on corrèlera à l'aide de la mesure d'une pièce étalon pour voir si on ne fait pas fausse route dans le diagnostic des sources d'erreur de la mesure.

        • Discussion.

          Ce cas typique (et surtout ses variantes) se présente assez souvent ; il permet de faire le lien avec le cas d'école, et surtout, de voir le mécanisme de bouclage des courants par des circuits dérivés, et donc d'interpréter la présence d'un courant parasite dans la boucle de mesure (le diagnostic étant fait, il sera plus facile d'éliminer ce courant ou ses conséquences).

          Il faut noter un aspect extrêmement vicieux du phénomène de " parasitage " de la mesure dans ce cas particulier : le signal d'erreur a exactement la même forme que le signal utile ; il ne va affecter que son amplitude, et le résultat de mesure paraîtra " propre ". Il sera alors difficile de détecter l'erreur si on ne connaît pas exactement le résultat attendu (on a intérêt dans ce cas à mesurer une pièce étalon pour valider la mesure).

          Le piège est plus grossier et facilement détectable quand le courant parasite n'est pas celui qu'on désire mesurer : l'oscilloscope montre alors un " vrai " bruit.

          La principale parade existant pour contrer la circulation de ces courants parasites consiste à faire une mesure différentielle : ceci fera l'objet d'un cours spécifique.

          Remarque : ce type de perturbation se rencontre plus généralement pour toute mesure faite en mode commun (mesure d'un point chaud par rapport à la masse).

          Il est clair que si dans l'exemple précédent le shunt était flottant (aucun pôle à la masse), il serait hors de question de faire une mesure de mode commun en mettant un des pôles du shunt directement à la masse de l'oscilloscope par exemple : on court-circuiterait une partie du montage électronique, avec tous les dégâts que cela peut engendrer. Dans ce cas, la mesure en différentiel est impérative .

        • Extension à d'autres cas.

          En pratique, les mesures sur shunt sont (presque) toujours faites en mode différentiel : il n'y aura donc pas de problème dans ce cas.

          Par contre, il est plus fréquent qu'on ait à mesurer une faible tension par rapport à la masse sur une carte électronique où circulent des forts courants. Les perturbations seront strictement les mêmes : les forts courants auront souvent (au moins) deux chemins possibles pour retourner au pôle - de l'alimentation, et un de ces chemins est en général le fil de masse du câble de mesure.

          Si les courants sont pulsés (présence d'une alimentation à découpage par exemple), il faudra prendre en compte les inductances parasites pour expliquer des surtensions brèves mais parfois de forte amplitude au moment des commutations du courant parasite. Ces surtensions peuvent être dangereuses pour certains équipements de mesure fragiles.

      3. Mesure simultanée d'une tension et d'un courant par sonde.

        Cet exemple particulier va nous montrer que même si la sonde de mesure est " isolée " du montage à mesurer, on peut avoir des couplages parasites venant fausser les résultats.

        • Description du montage.

          On se propose de mesurer un courant sur un montage électronique par l'intermédiaire d'une sonde de courant, ainsi qu'une tension (sonde reliée à l'oscilloscope).

          Pour ce faire, on dispose :

          d'un montage électronique.

          d'une alimentation stabilisée fournissant l'énergie au montage.

          d'un oscilloscope.

          d'une sonde d'oscilloscope standard.

          d'une sonde de courant et de son amplificateur, celui-ci délivrant une tension proportionnelle au courant mesuré. Cette tension doit être analysée à l'oscilloscope positionné sur le calibre 10mV/div (faible signal).

          Fig. 4. Mesure de courant par sonde.

          Le principe de la sonde de courant est basé sur des phénomènes de couplage par mutuelle induction (transformateur de courant) ou sur l'effet hall, celui-ci permettant de mesurer des courants continus. Dans tous les cas, il n'y a pas besoin de couper le circuit pour mesurer le courant comme dans le cas d'un shunt. La sonde de courant se présente sous forme d'une pince entourant le câble où circule le courant à mesurer : il y a donc isolation parfaite entre la sonde et le circuit à mesurer.

        • Schéma équivalent

          Fig. 5. Schéma équivalent

          Si on fait le schéma équivalent du montage comme dans l'exemple précédent, on pourra constater les choses suivantes : si on mesure uniquement le courant, la sonde de tension étant débranchée, il n'y a aucun problème. Dès que l'on rajoute la sonde de tension, et surtout, sa connection de masse sur le montage, on ouvre la voie à deux chemins parasites pour le courant de retour du montage électronique : un va transiter par le câble de masse de la sonde de tension, l'autre par le câble de masse liant l'ampli de sonde de courant à l'oscilloscope. On pollue d'un seul coup deux signaux !

      4. Application à la mesure de faibles résistances : mesure 4 points.

        Une mesure de résistance est faite selon le principe suivant : on injecte un courant calibré dans la résistance à mesurer, et on mesure la chute de tension induite aux bornes de cette résistance.

        Dans ce cas, l'instrument de mesure (un multimètre) va comporter à la fois le générateur de courant et le voltmètre (qui est, rappelons le, l'instrument de mesure de base).

        Dans les multimètre à bon marché, il n'y a que deux bornes de sortie permettant de faire cette mesure : les cordons de mesure vont donc servir à véhiculer le courant et recueillir la tension.

        Fig. 6. Principe de mesure d'une résistance.

        Or, ces câbles, ainsi que leur contact avec le composant à mesurer sont résistifs. Le courant de mesure va donc provoquer des chutes de tension parasites dans ces résistances, et au lieu de mesurer Rtest, on va mesurer Rtest + Rcord1 + Rcord2 :

        Fig. 7. Perturbation de la mesure de résistance.

        Le phénomène sera plus gênant pour les mesures de faibles résistances, car les résistances parasites ont une valeur sensiblement constante : plus la résistance mesurée a une valeur élevée, plus l'erreur sera faible.

        Là encore, on est en présence de couplage par impédance commune. D'aucun objecteront que le courant " parasite " est le courant de mesure. En fait, on peut considérer que l'instrument de mesure est le voltmètre, et qu'il est perturbé par le courant I qui est pour lui un courant parasite !

        La parade à cet inconvénient consiste à faire une mesure dite " 4 points " : on amène le courant de mesure et on lit la tension avec deux jeux de câbles différents. On lit alors vraiment la valeur de la résistance à mesurer :

        Fig. 8. Mesure de résistance " 4 points "

        Les multimètres de précision possèdent 4 bornes de sortie pour la mesure 4 fils :

        2 bornes notées " force " qui injectent le courant.

        2 bornes notées " sense " qui mesurent la tension.

        Attention à la précision ! 1k [image] n'est pas une faible valeur, certes, mais si on veut mesurer une telle résistance avec une précision de 1 pour 10000, il faudra passer par une mesure 4 points, alors que ce ne sera pas nécessaire pour mesurer 100 [image] à 1%. Tout est relatif !

      5. Conclusions.

        Ces petits exemples de tous les jours ont permis de mettre en évidence les mécanismes de couplage par impédance commune. Les éléments essentiels à retenir sont :

        les " équipotentielles " ne sont jamais parfaites.

        il convient de bien faire le schéma équivalent de tout le montage, en prenant en compte tous les chemins possibles (mises à la terre, mises à la masse multiples...) pour arriver à détecter les problèmes et y remédier.

        on aura d'autant plus de problèmes qu'un des appareils consommera ou générera des forts courants.

        il faut se rappeler qu'un câble de masse supplémentaire mal placé sur un montage de mesure peut fausser toutes les mesures : il faut réfléchir à deux fois avant de modifier quelque chose qui marche !

        ces exemples illustrent l'ampleur des problèmes potentiels qui se posent lors de la conception d'un banc de mesure automatisé, réalisant la commande, la mesure et le traitement d'un grand nombre de paramètres, et comprenant plusieurs appareils interconnectés !

    3. REMÈDES.

      Il n'y a pas de remède miracle universel et possédant toutes les qualités. Très souvent, un simple toilettage du montage suffira (câblage rationnel des appareils, pas de câbles superflus, câbles courts...).

      Ensuite, en fonction des résultats désirés et des moyens disponibles, on pourra piocher dans les méthodes proposées ci dessous.

      1. " Flottement " d'un appareil.

        Nous avons vu que la source de tous nos problèmes venait souvent de couplages dûs aux liaisons à la terre des divers appareils interconnectés.

        Pour éviter ces problèmes à peu de frais, on peut être tentés de couper ces liaisons avec la terre.

        Mais alors, attention ! ! ! Ce genre de manipulation peut être extrêmement dangereux, et ne devra pas être fait à la légère. Dans tous les cas, il faudra qu'il subsiste au moins un appareil à la terre pour assurer la sécurité des personnes qui vont manipuler les appareils.

        Il faudra que toutes les liaisons entre appareils restent en place (et notamment les masses).

        De plus, on risque de se retrouver avec des couplages autres (carte à châssis par exemple) qui ruineront les gains obtenus, surtout s'il existe des courants ou tensions HF dans le montage. Cette méthode est donc fortement déconseillée dans la plupart des cas.

        Tout au plus, dans certaines manips, on pourra désolidariser l'alimentation stabilisée de la terre. Certaines alimentations possèdent d'ailleurs des bornes de masse et de terre séparées en face avant. On pourra ou non les relier en fonction des besoins. On constatera alors le résultat sur l'oscilloscope : si le flottement donne de bons résultats, on laissera tel quel, sinon, on remettra la connexion de terre.

        Cette méthode peut être efficace dans les exemples de mesure sur shunt ou avec la sonde de courant cités plus haut. A proscrire si les tensions mises en jeu sont élevées !

        Il est très déconseillé de flotter des oscilloscopes : certains sont alors dangereux. De plus, les potentiels atteints par le châssis peuvent l'endommager.

      2. Mesure en différentiel.

        C'est une méthode quasi universelle pour la résolution de ce genre de problème. Nous allons l'étudier en détail au chapitre suivant : " L'amplificateur d'instrumentation ".

        Elle n'est pas utilisée systématiquement, car elle est plus complexe à mettre en œuvre et plus chère qu'une mesure simple par rapport à la masse.

        De plus, les amplificateurs différentiels ont aussi des limitations qui empêchent leur utilisation partout.

      3. Amplification " à la source ".

        Si on conçoit soi-même la carte électronique dont on veut mesurer un faible signal, il est possible d'amplifier ce signal sur la carte même. Dans ce cas, la réjection du signal d'erreur sera multipliée par le gain de l'amplificateur.

        Par exemple, si on a un signal utile de 100mV et un signal d'erreur de 10mV dû au câblage, un ampli de gain 10 va permettre de monter la tension utile à 1V, et le signal d'erreur ne fera plus que 1% du signal utile au lieu de 10%. L'ampli " local " étant référencé à la masse du montage, il n'y a pas de problème local de couplage par impédance commune (à condition que le routage du montage électronique soit fait convenablement !).

        Le câble de mesure va alors véhiculer un signal de fort niveau et à basse impédance, donc " robuste ".

        Cette méthode peut être très bon marché et efficace. Elle évite une mesure en différentiel, plus lourde à mettre en œuvre et plus chère.

  • COUPLAGE PAR DIAPHONIE INDUCTIVE.

    1. DÉFINITION.

      Tout courant variable circulant dans un conducteur va créer un champ magnétique autour de lui. La variation de flux ainsi produite va créer des tensions induites parasites dans les boucles formées par les câbles conducteurs contigus au câble perturbateur.

      En pratique, cela revient à considérer la mutuelle inductance entre le câble perturbateur et le câble victime.

      Parmi les perturbateurs, on fera attention aux câbles d'alimentation des convertisseurs statiques, des moteurs électriques, des relais, et aussi aux câbles véhiculant des signaux logiques à front raide.

      En mesure, on aura des problèmes avec les convertisseurs statiques, et aussi avec des câbles en nappe dans le cas de bancs informatisés : ces câbles sont pratiques pour véhiculer beaucoup de signaux sans avoir une forêt de fils, mais ils posent des gros problèmes de diaphonie.

    2. REMÈDES.

      Les remèdes peuvent être simples :

      dans la mesure du possible, on éloignera les câbles à courants pulsés (dI/dt élevés) des câbles véhiculant des signaux faible niveau à mesurer.

      surtout, il faudra se garder de faire courir le câble source et le câble victime parallèlement sur une grande distance.

      Si le câble source et le câble victime doivent se croiser, il faudra le faire à angle droit (couplage nul, même si les deux câbles se touchent).

      on évitera de faire circuler dans un câble en nappe des signaux logiques (fort dI/dt) et des signaux analogiques bas niveau.

      afin de réduire la boucle formée par les conducteurs aller et retour d'un signal bas niveau, on rapprochera ces deux fils au maximum.

      dans la mesure du possible, on torsadera ces deux câbles : le champ perturbateur va créer des effets qui vont s'annuler grâce à l'inversion des câbles induite par le torsadage.

  • COUPLAGE PAR DIAPHONIE CAPACITIVE

    Ce phénomène est dû au fait que deux conducteurs en regard et séparés par un diélectrique (l'air, ou un isolant quelconque) forment une capacité qui va les relier.

    1. DÉFINITION.

      Le couplage par diaphonie capacitive est créé par variation de tension entre deux conducteurs en regard. La capacité parasite formée par les deux conducteurs va présenter une impédance faible en HF à cette variation de ddp et permettre le passage d'un courant parasite.

      Remarque : la différence essentielle qu'il y a avec la diaphonie inductive est que la diaphonie capacitive est provoquée par une variation de tension (champ électrique), alors que la diaphonie inductive est provoquée par une variation de courant (champ magnétique).

    2. EXEMPLES.

      1. Isolation galvanique.

        Une méthode a été beaucoup utilisée pendant l'âge d'or de l'électronique analogique pour résoudre les problèmes de couplage par impédance commune : c'est l'isolation galvanique, réalisée notamment à l'aide de transformateurs d'isolement, et plus récemment, par des isolateurs opto-électroniques.

        Les différents éléments d'un système électronique étant isolés, il n'y a plus de chemin pour les courants parasites.

        Fig. 9. Isolation galvanique en HF.

        Ce remède était valable à une certaine époque, lorsqu'on travaillait principalement avec des fréquences relativement faibles, et que la commutation en était à ses balbutiements.

        Aujourd'hui, les choses ont changé : les fréquences de travail sont très élevées, on a de plus en plus de signaux logiques très rapides (on dépasse le GHz pour les processeurs), et la commutation est entrée en force dans l'électronique de puissance.

        Il y a donc de plus en plus de signaux HF dans les circuits électroniques actuels, qui vont mettre en défaut les composants d'isolation galvanique. En effet, ceux-ci présentent entre les deux parties isolées des capacités parasites non négligeables : de quelques pF pour les composants optiques à quelques dizaines de pF pour les transformateurs.

        Si le secondaire du transformateur d'isolement est soumis à des variations rapides de tension de mode commun, les capacités parasites vont réinjecter ces signaux au primaire, et pourront perturber par conduction tout le circuit électronique qui y est relié.

        La figure 9 est une illustration d'isolation galvanique par transformateur. On y remarque deux masses : ces deux masses sont bien évidemment séparées, sinon, l'isolation galvanique n'aurait pas de sens ! Ce sont des masses locales. Si une ddp apparaît entre ces deux masses (tension de mode commun [image] Vmc), les capacités parasites Cp2 et Cp2 laisseront passer les composantes HF de cette tension, introduisant une tension de mode commun sur le circuit amont qui peut perturber ce circuit et les appareils qui y sont reliés.

        Il faut noter que les capacités parasites Cp1 et Cp2 n'existent pas physiquement telles quelles : la capacité parasite est en fait répartie uniformément sur tout le bobinage. Les deux capacités discrètes indiquées sur le schéma sont des capacités équivalentes permettant de raisonner et de faire des calculs simples.

      2. Routage des circuits imprimés.

        Dans les interfaces de mesure, on trouve presque toujours des signaux analogiques, souvent bas niveau et/ou à haute impédance voisinant avec des signaux logiques rapides.

        Fig. 10. Câblage d'une carte mixte.

        Il ne faudra jamais perdre de vue que si deux de ces pistes sur un tel circuit imprimé sont routées parallèlement et à faible distance l'une de l'autre, elles vont être reliées par une capacité parasite non négligeable. Le signal analogique pourra alors être pollué par les variations rapides de potentiel inhérentes aux signaux logiques.

        Prenons l'exemple de la figure 10 : un capteur est relié à une carte électronique ; il est équivalent à un générateur de tension Ec en série avec une résistance Rc. Sur la carte électronique, le signal est conditionné par un amplificateur à haute impédance d'entrée (amplificateur opérationnel ou d'instrumentation par exemple).

        L'entrée du capteur est voisine d'une entrée logique, et les pistes cheminent parallèlement sur quelques centimètres : il en résulte une capacité parasite Cp reliant ces deux pistes.

        Pour la suite, on va supposer que le signal logique est délivré par un générateur de tension à impédance interne faible qu'on va donc négliger.

        On va considérer aussi que ce signal logique de tension Vl est périodique : il est alors possible de le décomposer en une série de Fourier :

        La pulsation du fondamental est [image], et correspond à une fréquence fo. En théorie, la série est infinie ; en pratique, au delà d'une certaine fréquence, les composantes Vil sont négligeables.

        Le schéma équivalent de ce montage électronique est le suivant :

        Fig. 11. Schéma équivalent.

        La tension à l'entrée de l'amplificateur est égale à :

        Dans cette équation, ZCp représente l'impédance complexe de la capacité Cp, et est égale à :

        La pulsation [image] i, égale à i [image], est celle de l'harmonique i des composantes de Fourier du signal logique (les harmoniques d'ordre élevé sont les plus perturbantes), et la pulsation [image] c celle du signal délivré par le capteur.

        On voit clairement (deuxième terme de l'équation [7]) que le terme perturbateur est proportionnel au pont diviseur formé par la capacité parasite d'une part, et l'impédance équivalente de Thévenin vue du point perturbé de la piste sensible.

        Ici, cette impédance équivalente est égale à l'impédance interne du capteur en parallèle avec l'impédance d'entrée de l'ampli, qui est en général très grande.

        Plus l'impédance de la capacité sera faible, plus grande sera la perturbation. C'est aux fréquences élevées qu'on aura le plus de problèmes (c'est le cas des harmoniques des signaux logiques).

        On pourra noter au passage que la capacité parasite diminue l'impédance sous laquelle le capteur " voit " le circuit d'entrée (premier terme de l'équation [7]). Il faudra prendre ce phénomène en compte si le capteur délivre des composantes à haute fréquence ( [image] c élevée).

        On peut tirer deux conclusions de ce rapide calcul :

        On a intérêt à diminuer autant que faire se peut les capacités de couplages en évitant de faire cheminer des pistes sensibles en parallèle avec des pistes perturbantes. Il convient de noter ici que si l'impédance de la source perturbatrice est non nulle, elle se rajoute à l'impédance de la capacité parasite, ce qui a un effet bénéfique. En pratique, il ne faut pas rêver, les impédances de source des perturbateurs sont souvent faibles...

        Les circuits à haute impédance d'entrée sont particulièrement sensibles aux couplages capacitifs. On sera en permanence pris entre deux impératifs : avoir un ampli à forte impédance d'entrée pour ne pas perturber le capteur, et limiter au maximum l'effet des couplages capacitifs parasites, donc, avoir une faible impédance d'entrée...

        Il y aura donc toujours un compromis à faire. En pratique, on choisira l'impédance d'entrée la plus basse possible qui soit compatible avec les impératifs de précision de mesure qu'on s'est fixés.

        Si les signaux délivrés par le capteur sont à basse fréquence, un filtre passe bas disposé à l'entrée de l'amplificateur permettra de résoudre à bon compte certains problèmes de diaphonie avec des signaux logiques.

      3. Câble en nappe.

        Comme dans le cas de la diaphonie inductive, les signaux fragiles circulant dans un câble en nappe vont être pollués par les variations relatives de potentiel qui existent sur les câbles contigus, et ceci via les capacités parasites existant fatalement entre ces câbles.

        Même remède : ne pas faire circuler des signaux " fragiles " à côté de signaux à fort dV/dt.

    3. CONCLUSION.

      Le couplage capacitif sera perturbant uniquement lorsque le montage de mesure sera entouré de matériel fonctionnant à haute fréquence.

      Ce cas sera malheureusement courant, car la logique est présente quasiment partout, et les fronts raides des signaux logiques sont générateurs de parasites HF.

      Les principaux remèdes sont la séparation des câbles perturbateurs et perturbés, faire des circuits d'interface à la plus basse impédance possible, et en dernier recours, filtrer.

      Une autre conclusion remarquable est qu'un isolement galvanique ne protège pas des perturbations de mode commun HF.

  • COUPLAGE CARTE À CHÂSSIS.

    Ce mode de couplage va affecter prioritairement des équipements isolés de leur châssis (le boîtier protégeant l'équipement considéré) soumis à des tensions de mode commun HF élevées. Il est finalement un cas particulier de la diaphonie capacitive.

    1. DÉFINITION.

      Le couplage carte à châssis a lieu lorsqu'une carte électronique est isolée du boîtier qui l'enveloppe, et qu'il existe une différence de potentiel variable entre la masse de cette carte et le châssis (variation de tension de mode commun).

      Il existe des capacités parasites entre la carte et le châssis. Si le potentiel entre la carte et le châssis est variable, ces capacités vont former un chemin de passage pour des courants parasites.

    2. EFFETS PRODUITS ET REMÈDES.

      Il est nécessaire ici de parler de ce mode de couplage, car, comme il a été dit précédemment, on peut être tentés de " flotter " certains équipements pour couper des chemins conducteurs parasites et éviter ainsi les couplages par impédance commune.

      Il faut savoir que quand on fait cela, on s'expose à un autre couplage parasite qui est le couplage carte à châssis.

      Ce type de couplage sera évidemment important si les équipements concernés sont le siège de courants ou tensions HF.

      Sur des équipements uniquement BF, on pourra flotter des cartes électroniques sans problèmes.

      Si on a des composantes HF, il faudra empêcher le flottement des potentiels en reliant la masse de la carte à son châssis. On évitera alors les couplages par impédance commune en utilisant des liaisons différentielles entre les différentes cartes ou appareils.

  • COUPLAGE CHAMP À FIL.

    1. DÉFINITION.

      Tout câble conducteur plongé dans un champ électrique variable va être le siège d'un courant de conduction induit par le champ électrique. Ce phénomène sera significatif uniquement en HF.

    2. EXEMPLES.

      L'exemple le plus simple, bien que n'ayant rien à voir avec la mesure, est celui de l'antenne de voiture pour autoradio. Cette antenne n'est qu'un vulgaire bout de ferraille qui va collecter les champs électriques HF émis par les stations de radiodiffusion, et transformer ces champs en courant conduit qui va être acheminé vers l'entrée de l'autoradio pour y être traité.

      En pratique, l'espace qui nous entoure est entièrement baigné d'ondes radioélectriques : émetteurs radio, TV, talkies walkies, téléphones portables, ainsi que des parasites d'origine industrielle véhiculés par les lignes électriques du secteur qui se comportent alors comme des émetteurs.

      Il ne faut pas oublier non plus les montages électroniques générant des composantes HF rayonnées : ordinateurs, variateurs à triacs, alimentations à découpage...

      Ces champs sont inévitables, et il va falloir s'en protéger !

    3. REMÈDES

      • Des manips propres !

        Première règle simple : pas de fils qui traînent ! C'est facile à dire, c'est peu souvent bien réalisé.

        Sur une manip, on enlèvera tous les cordons non branchés aux deux extrémités. Un cordon qui pend, connecté à une de ses extrémités à un montage de mesure se comporte de la même manière qu'une antenne d'autoradio, et va capter tous les champs parasites qui traînent, les transformer en courant et les injecter par conduction dans le montage.

        Dès qu'on a des signaux bruités lors d'une mesure, la première chose à faire avant d'investiguer plus loin est de rationaliser le câblage, mettre les câbles les plus courts possibles, et éviter les fils inutiles qui traînent.

      • Éviter les sources de perturbation.

        Il n'est évidemment pas question de saboter les émetteurs de radiodiffusion pour faire une manip tranquille, mais bien d'éviter, à l'intérieur du labo toutes les sources rayonnantes qu'on maîtrise et dont on peut se passer.

        Exemples :

        une lampe halogène munie de son variateur à triac est à proscrire.

        on éteindra les équipements informatiques inutiles à la manip.

        on évitera (si possible) de faire dans un même labo une manip perturbante (électronique de puissance, convertisseur à découpage de gros calibre) et une manip sensible.

        on blindera (si possible) les équipements perturbants, et on évitera là aussi les fils qui pendent (ils forment de beaux émetteurs). A titre indicatif, les ordinateurs d'aujourd'hui sont blindés, et sont donc moins perturbants qu'à l'âge d'or de l'informatique familiale (1985) où ils étaient simplement habillés de plastique non métallisé. Il était tout bonnement impossible d'écouter la radio (même en FM) à côté.

      • Blindage des câbles.

        Une des principales parades au couplage champ à fil consiste à blinder les fils véhiculant des signaux sensibles.

        C'est pour cette raison que les câbles de liaison des appareils de mesure sont blindés : le fil " chaud " est gainé par une tresse de cuivre qui l'enveloppe complètement. Cette tresse est reliée à la masse des appareils, et donc, est (presque !) une équipotentielle. Cette tresse reliée à un potentiel fixe sert ainsi d'écran électrostatique vis à vis du fil " chaud ", et empêche les champs électriques rayonnés de l'atteindre.

  • COUPLAGE CHAMP À BOUCLE.

    1. DÉFINITION.

      Tout champ magnétique variable créé une ddp induite dans une boucle conductrice. Il en résulte un courant parasite circulant dans cette boucle.

      Les boucles sont nombreuses dans les circuits électroniques. On appelle boucle de masse toute boucle conductrice formée par les conducteurs aller et retour d'un signal, à savoir le fil " chaud " et le fil de masse. La figure 12 représente par exemple un capteur relié à une carte amplificatrice.

      La boucle sensible comprendra les câbles aller et retour allant du capteur à la carte, ainsi que les pistes et impédances présentes sur la carte.

      Fig. 12. Boucle de masse perturbée.

    2. REMÈDES.

      Les boucles de masse étant par définition inévitables, il faudra limiter au maximum les perturbations. On pourra entres autres :

      réduire le plus possible la surface de ces boucles en faisant en sorte que les fils aller et retour d'une boucle soient câblés au plus près l'un de l'autre.

      Pour des câbles non blindés, le torsadage est efficace.

  • DÉMODULATION DE COURANTS HF.

    Nous allons terminer ce chapitre sur les perturbations par un phénomène fréquemment rencontré et dénommé familièrement " ronflette " par les professionnels.

    Ce phénomène est caractérisé par la présence d'un signal vaguement sinusoïdal de fréquence 50Hz se superposant aux signaux à mesurer.

    Le premier réflexe consiste donc à accuser le secteur. C'est vrai, mais indirectement.

    Il est en fait issu des couplages précédemment cités. Mais, nous avons vu que ces couplages étaient surtout gênants avec des perturbations HF. Hors, le secteur est à très basse fréquence, et il est hors de question de penser une seconde qu'il puisse traverser de façon significative les quelques picofarads d'un isolement galvanique par exemple.

    En réalité, les champs électromagnétiques créés par le secteur modulent les champs HF issus de diverses sources.

    Ces champs HF polluent facilement le montage à mesurer (même basse fréquence) par tous les modes de couplage vus précédemment.

    Ils vont alors toujours trouver un démodulateur parasite complaisant : il suffit d'une diode (ou la jonction d'un transistor) et d'un condensateur pour démoduler les signaux HF et en retirer la composante BF (le secteur) qui les modulait.

    On se retrouve ainsi indirectement avec des tension parasites à la fréquence secteur dans les montages.

    Un exemple bien connu est le cas des amplificateurs Hifi qui captent la radio sans tuner ! C'est économique, mais gênant quand ces signaux se superposent à un signal musical différent.

    Ce dernier exemple montre que même avec des montages " normalement " BF, on peut avoir des problèmes secondaires induits par des composantes HF !

    Même pour ces montages, on prendra donc des précautions pour limiter l'influence des courants et tension HF, et restreindre au maximum tous les modes de couplage.


L'amplificateur d'instrumentation

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/AINST/COURS.HTM#AI01

LES MESURES DIFFÉRENTIELLES.

On peut se poser la question de ce qui fait la spécificité d'une " mesure différentielle ", car toute mesure de tension est par définition différentielle : il ne faut pas oublier qu'un potentiel absolu n'existe pas, et qu'on a toujours affaire à une différence de potentiel.

Les définitions suivantes vont éclairer la notion de mesure différentielle.

  1. DÉFINITIONS

    On appellera mesure simple une mesure de tension entre deux points dont l'un est la masse du montage de mesure.

    C'est là qu'il faut se rappeler de la définition de la masse : c'est une équipotentielle du montage (théorique, voir chapitre " perturbations dans les mesures " !) qui sert de référence de tension à ce montage et dont le potentiel absolu est fixé arbitrairement à 0V (un potentiel est toujours défini à une constante près).

    Ce potentiel étant fixé arbitrairement, on ne parlera plus de différence de potentiel pour les autres points du montage, mais simplement de potentiel, sous entendu, différence de potentiel par rapport à la masse, le potentiel de cette dernière étant fixé astucieusement à 0V.

    Une mesure de tension simple est donc en réalité une mesure différentielle dont un des points est la masse. Seul nous intéresse le potentiel de l'autre point, que l'on nomme couramment " point chaud ".

    On appellera mesure différentielle une mesure de tension entre deux points quelconques d'un circuit, aucun d'entre eux n'étant la masse du montage.

  2. MODE COMMUN ET MODE DIFFÉRENTIEL.

    1. Définitions.

      Fig. 1. Montage amplificateur quelconque.

      Considérons le montage de la figure 1, à savoir un amplificateur à deux entrées et une sortie. Dans le cas général, sa fonction de transfert sera de la forme :

      Par définition, on va appeler tension différentielle d'entrée la valeur :

      De la même manière, on définit une tension de mode commun :

      On peut voir intuitivement la signification ces définitions : la tension différentielle est simplement la différence des deux signaux ; la tension de mode commun est la moyenne arithmétique des deux signaux.

      Tout se passe comme si on remplaçait les deux signaux e1 et e2 par un signal commun (la moyenne) additionné des variations autour de ce signal commun (la différence).

    2. Fonction de transfert d'un ampli différentiel.

      Reprenons l'équation [1], donnant la fonction de transfert de l'ampli de la figure 1. Nous allons mettre cette équation sous la forme suivante :

      Pour ce faire, il suffit de procéder à un changement de variables ; on groupe dans l'équation [4] les termes en e1 et e2, et comme les équations [1] et [4] doivent être équivalentes pour toutes les valeurs de e1 et e2, on identifie leurs coefficients entre les 2 équations :

      La résolution du système donne le résultat suivant :

      Au final, on retrouve :

      La formulation [4] est particulièrement intéressante, car elle met en évidence deux termes, l'un proportionnel à la tension différentielle (le gain différentiel du montage AVd), et l'autre proportionnel à la tension de mode commun (le gain de mode commun AVMc).

      On peut formuler plus simplement cette équation, qui est la fonction de transfert générale d'un amplificateur de différence :

  3. NÉCESSITÉ D'UNE MESURE DIFFÉRENTIELLE.

    Si certaines mesures différentielles servent uniquement à améliorer la précision d'une mesure (notamment en évitant des couplages par impédance commune), d'autres présentent un caractère obligatoire, car dans ces cas là, une mesure simple est impossible. Nous allons étudier ces deux cas de figure.

    1. Remède à un couplage par impédance commune.

      Fig. 2. Mesure simple sur shunt.

      Nous avons vu au chapitre " perturbations dans les mesures " l'effet d'une mesure simple sur un shunt traversé par un fort courant. Nous supposerons ici que l'amplificateur représenté sur les figures 2 et 3 est une partie d'un appareil de mesure dont la masse est reliée à la terre.

      Sur la figure 2, les masses Mm du montage et Ma de l'amplificateur ne sont pas au même potentiel, car le courant parasite circulant dans Rcbl créé une chute de tension qui va s'additionner à la tension à mesurer et la fausser.

      Il est possible de résoudre ce problème par une mesure différentielle :

      Fig. 3. Mesure différentielle sur shunt.

      La figure 3 diffère de la figure 2 par la structure de l'amplificateur : il est ici monté en différentiel, et va mesurer la différence de potentiel présente aux bornes du shunt. La tension parasite aux bornes de Rcbl ne gêne en rien la mesure (dans le cas d'un amplificateur parfait !), car elle augmente (légèrement) uniquement la tension de mode commun vue par l'amplificateur, elle ne change en rien la tension différentielle qui reste celle aux bornes du shunt, quoiqu'il arrive.

      Nous avons donc résolu ici le problème de perturbation par impédance commune sans rendre flottant quelque appareil que ce soit. Le montage est ainsi précis et sûr.

    2. Mesure de tension entre deux points flottants.

      Il existe un autre type de mesures nécessitant obligatoirement une mesure différentielle : c'est lorsqu'on veut mesurer une tension entre deux points dont aucun n'est la masse. Il est évidemment hors de question de brancher un de ces deux points à la masse d'un instrument de mesure (à l'exception notable des multimètres alimentés par piles ou accus) sous peine de créer des courts circuits fâcheux !

      Fig. 4. Mesure sur shunt flottant.

      L'exemple de la figure 4 montre quasiment la même chose que celui de la figure 3 mis à part le fait que le shunt n'est plus relié à la masse.

      La mise à la masse d'une des bornes du shunt entraînerait la mise en court-circuit d'une partie du montage électronique, ce qui entraînerait des dysfonctionnements, voire sa destruction, et pourrait détériorer l'instrument de mesure.

      En instrumentation, une catégorie très répandue de mesures " flottantes " est celle du déséquilibre d'un pont de jauges (voir figure 5). Celui-ci est composé de 4 résistances identiques qui vont légèrement varier sous l'effet d'un paramètre physique à mesurer (pression, contrainte...). Il apparaît une tension entre les bornes du pont qu'il va falloir amplifier.

      Une des caractéristiques importantes de ce montage est la tension de mode commun : elle est égale à la moitié de la tension d'alimentation, soit quelques volts. Cette tension de mode commun est beaucoup plus grande que le signal utile (quelques mV et parfois moins), et va perturber notablement la mesure.

      Fig. 5. Mesure en pont.

  4. L'AMPLI DIFFÉRENTIEL SIMPLE ET SES DÉFAUTS.

    1. Réjection du mode commun.

      • Amplificateur parfait.

        Reprenons l'exemple précédent de la mesure en pont (Fig. 5.), et calculons la tension de sortie Vs en fonction de e1 et e2 qui sont les tensions d'entrée du montage différentiel (par rapport à la masse), et des paramètres de ce montage.

        Nous allons considérer que l'amplificateur opérationnel est parfait, et aura les caractéristiques suivantes :

        gain en tension différentiel infini.

        gain de mode commun nul.

        impédances d'entrée infinies.

        Si on tient compte de ces hypothèses, les tensions v+ et v- à l'entrée de l'ampli sont égales à :

        Cette dernière équation est obtenue à l'aide du théorème de superposition.

        L'ampli étant parfait, on a v+ = v- (gain infini). On en déduit facilement la valeur de la tension de sortie :

        Si on pose :

        en substituant AVdo à sa valeur dans [12] et compte tenu de la propriété suivante :

        on obtient :

        C'est le résultat classique d'un amplificateur opérationnel monté en différentiel. Il est obtenu en considérant que l'ampli est parfait, et que les résistances sont rigoureusement appariées (équation [13]).

        Nous allons voir maintenant, toujours en considérant que l'amplificateur opérationnel est parfait, quel est l'impact de résistances mal appariées sur le résultat.

        Nous supposerons que toutes les résistances R1 à R4 sont définies à une tolérance près. On a :

        où Rin est la valeur nominale de la résistance et e la tolérance autour de cette valeur nominale (ex : ±5%).

        On admettra que l'erreur maximale a lieu pour :

        On peut définir les deux coefficients suivants :

        On remarquera que les dernières formulations de k1 et k2 sont des approximations valables uniquement si e est petit. En pratique, e ne dépassera pas 5%, donc, cette hypothèse est justifiée. L'équation [12] devient alors :

        Cette formulation est un cas particulier de l'équation [1]. Ce qui nous intéresse, ce sont les valeurs de AVd et AVMC (équation [6]) correspondantes en fonction de k1 et k2 :

        qu'on peut mettre sous la forme condensée :

        On peut encore expliciter ces expressions en reprenant les valeurs de k1 et k2 des équations [18] et [19]. Le gain différentiel devient :

        Le terme 4e2 est un terme du deuxième ordre : on va le négliger devant les termes en e, d'où :

        Si on divise tout par (1+AVdo), et qu'on tient compte du fait que e << 1, on arrive au résultat suivant :

        Si dans ce résultat, on fait e = 0, on retrouve AVd = AVdo. Dans le cas général, l'erreur relative commise sur le gain différentiel variera de e pour un gain AVdo = 1 à 2e pour un gain très élevé. Il faut se rappeler que cette erreur est l'erreur maxi, obtenue avec les résistances agencées de la pire façon.

        Le gain de mode commun est plus simple à évaluer :

        On retrouve un gain de mode commun nul pour une erreur e nulle. Ce gain varie dans le cas général de 2e pour un gain différentiel nominal AVdo égal à 1, à 4e pour un gain différentiel élevé. Il reste faible, de l'ordre de grandeur de e, mais si on se réfère à ce qui a été dit plus haut, il va amplifier la tension de mode commun, qui peut être, elle, beaucoup plus grande que la tension différentielle.

        La tension de sortie est donnée par l'équation [8] qui fait intervenir les gains et tensions différentiels et de mode commun. On peut introduire ici la notion de taux de réjection de mode commun (TRMC, CMRR en Anglais, pour Common Mode Rejection Ratio) :

        A l'aide de ce terme, on peut expliciter l'équation [8] de la façon suivante :

        Cette formulation est très intéressante, car elle donne la tension de sortie en fonction du gain différentiel et de la tension différentielle augmentée d'un signal d'erreur. Ce signal est égal à la tension de mode commun divisé par le taux de réjection de mode commun, qui sont deux données connues ou aisément calculables.

        Si on reprend les équations [28] et [31], la valeur du TRMC devient :

        On constate que le TRMC va augmenter quand la tolérance sur les résistances va se resserrer, et de plus, il va augmenter avec le gain différentiel AVdo de l'étage. Ce résultat est important, car il montre que le plus mauvais cas sera celui du gain unité.

        Application numérique : reprenons l'exemple de la figure 5 avec les données suivantes :

        AVd = 1000

        e1 - e2 = 2 mV

        E = 10V

        résistances R1 à R4 à 1%

        On peut calculer le TRMC à l'aide de l'équation[36] : TRMC = 25025, soit 88dB.

        La tension de mode commun est égale à la moitié de la tension d'alimentation, soit 5V, ce qui nous fait un signal d'erreur ramené à la tension différentielle égal à 0,2mV, soit 10% du signal utile !

        On peut améliorer le montage en augmentant la précision des résistances, mais cela va devenir difficile avec des composants discrets. De plus, l'amplificateur n'est pas parfait : il possède son propre TRMC, qui va perturber la mesure même si les résistances sont parfaitement appariées.

      • Amplificateur réel.

        Les constructeurs de circuits intégrés donnent la valeur du TRMC pour leurs amplificateurs opérationnels, et fournissent aussi généralement une courbe de Bode qui représente ce taux de réjection en fonction de la fréquence (fig. 6 et 7).

        Fig. 6. TRMC amplis LF 155/6/7. (Doc. NS).

        Fig. 7. TRMC amplis LM 118. (Doc. NS).

        Il est possible de calculer le TRMC global d'un montage différentiel en tenant compte de la tolérance des résistances et du TRMC propre de l'ampli. Il faut pour cela reprendre les équations [9] et [10] et prendre pour Vs une formulation telle que celle donnée en [8]. Après une série de calculs laborieux, on arrive au résultat suivant :

        Attention ! Le TRMC de l'ampli est généralement donné en dB. Il faut le convertir (ex : 80dB = 10 000) avant de l'injecter dans l'équation [37] !

        Discussion

        Si on fait e = 0 dans cette équation, on obtient pour le TRMC global du montage le TRMC intrinsèque de l'ampli.

        Si on fait tendre le TRMC de l'ampli vers l'infini, on retrouve logiquement le résultat obtenu avec un ampli parfait (équation [36]).

        Le TRMC du montage sera de toutes façons inférieur au plus petit des 2 TRMC pris séparément, à savoir celui de l'ampli et celui dû au mauvais appariement des résistances.

        Si on reprend l'application numérique précédente, et qu'on considère que l'ampli utilisé a un TRMC intrinsèque de 90dB, l'équation [37] nous donne un TRMC global de 14000, ou 83dB (-5dB dus à l'ampli), ce qui fait une erreur de 0,36mV, soit 18% du signal utile à amplifier !

    2. Impédance d'entrée.

      De ce point de vue, le montage différentiel simple est fortement dissymétrique ; les impédances des entrées + et - ne sont pas égales, ce qui va nuire à une bonne précision, et surtout, risque de perturber le capteur : en effet, les courants qui vont sortir des deux bornes de sortie du capteur (dans le cas où celui-ci n'est pas un dipôle, ce qui est vrai pour un pont de jauges) vont être différents ; comme les impédances des deux sorties du capteur sont égales, il va en résulter des chutes de tension différentes, ce qui va générer un signal d'erreur supplémentaire.

    3. Ajustage du gain.

      Ce montage possède un troisième inconvénient : même si on réussit à apparier convenablement les résistances pour obtenir un bon TRMC, si on veut modifier le gain de l'ampli, tout est à refaire : il faut changer deux résistances à la fois et les apparier... Il serait plus commode de n'avoir qu'un composant à changer.

    4. Conclusion.

      Ce montage différentiel classique va donc être handicapé par la qualité de l'ampli utilisé (son TRMC), et la dispersion inévitable des résistances qui l'entourent.

      Les impédances des deux entrées sont dissymétriques, ce qui va créer un déséquilibre fâcheux au niveau du capteur en pont de jauges. Ce montage est difficilement ajustable.

      Pour des mesures délicates, il va donc falloir trouver un montage ayant une meilleure réjection de mode commun, des impédances d'entrée égales et élevées, et si possible, des possibilités d'ajustage simplifié.

    5. Le montage à éviter...

      Pour les forts gains, le plus gros problème qu'on va rencontrer sur un montage différentiel simple est la faiblesse des impédances d'entrée.

      Il existe un montage dit " potentiomètrique " qui permet de résoudre ce problème, et de plus, autorise l'ajustage du gain avec une seule résistance !

      Le gain est obtenu en câblant la contre réaction d'un ampli différentiel simple non pas directement sur la sortie, mais sur un pont diviseur R1/R2 placé sur la sortie, ce qui aura pour effet de multiplier le gain par le rapport des résistances du pont diviseur.

      Le montage différentiel simple peut donc avoir un gain de 1, et les résistances R pourront être de forte valeur (quelques M [image]), ce qui donnera une forte impédance d'entrée au montage. Le gain s'ajustera simplement en faisant varier R2.

      Fig. 8. Montage potentiométrique.

      Mais attention !!! Ce montage n'est pas adapté à l'instrumentation, car les variations des composants (tolérance initiale, dérive thermique, vieillissement...) sont multipliées par le gain : il est donc particulièrement instable.

      Il ne faut toutefois pas jeter ce schéma aux orties : pour des applications ne nécessitant pas trop de précision, il peut donner une réponse simple, efficace et à faible coût.

  • L'AMPLI D'INSTRUMENTATION.

    1. DÉFINITION.

      Les amplificateurs d'instrumentation ne sont pas des amplificateurs opérationnels. Ce sont des circuits complets associant plusieurs amplificateurs opérationnels et les composants nécessaires à leur bon fonctionnement : résistances, capacités de compensation...

      Ces amplificateurs peuvent être fabriqués à l'aide d'éléments discrets, mais la plupart du temps, on leur préférera des amplis intégrés, se présentant sous la même forme que des amplificateurs opérationnels.

      Ces composants intégrés auront plusieurs avantages sur les montages à éléments discrets :

      simplicité de mise en œuvre.

      nombre de composants limité.

      très grande précision, due notamment à un ajustage par laser des résistances sur la puce. Ce procédé va permettre d'apparier les composants de bien meilleure façon qu'avec des composants discrets, et autorisera des TRMC beaucoup plus élevés.

      fonctions annexes : réglage simple du gain, circuit de garde, conversion tension/courant en sortie...

      Les amplis d'instrumentation se distinguent notamment des amplificateurs opérationnels par le fait qu'ils ont un gain " faible " comparé à ces derniers (de 1 à 1000 contre 106 et plus), et qu'ils s'utilisent sans contre réaction.

      Il existe aujourd'hui des amplificateurs opérationnels de très grande précision, présentant des caractéristiques proches de celles des amplis d'instrumentation (tensions et courants de décalage d'entrée, TRMC, impédance d'entrée...).

      Quand on choisira un ampli d'instrumentation dans un catalogue de fabricant de silicium, on veillera à ne pas confondre les deux types de composants.

      On pourra être tentés de fabriquer un ampli d'instrumentation avec ces amplificateurs opérationnels spéciaux ; dans certains cas (besoin de rapidité, TRMC élevé à haute fréquence...), on pourra y gagner, mais il ne faudra pas oublier qu'il sera nécessaire d'apparier les résistances de façon très " serrée ".

    2. SCHÉMA À DEUX AMPLIFICATEURS.

      Fig. 9. Montage différentiel à deux amplis.

      1. Impédance d'entrée.

        Par rapport à l'amplificateur différentiel simple, ce montage est très amélioré du point de vue des impédances d'entrée : elles sont égales et de grande valeur (impédance d'entrée des amplis-op, soit >106 [image]).

      2. Gain en tension. Ajustage.

        Pour simplifier le raisonnement, on peut considérer le montage comme étant la concaténation de deux amplis :

        le premier (1) est un montage non inverseur qui va amplifier la tension e2.

        le deuxième (2) est un montage soustracteur qui va amplifier la différence entre la tension e1 et la tension de sortie Vs1 de l'ampli 1.

        On a :

        En remplaçant Vs1 par sa valeur (équation [38]) dans [39], et en posant AVdo = k+1 on obtient :

        Du point de vue du réglage, ce montage n'apporte rien de plus que le montage différentiel simple : il faut toujours changer deux composants pour le faire varier.

      3. Réjection de mode commun.

        On peut refaire un calcul strictement analogue à celui fait pour le montage différentiel simple. On va retrouver un résultat similaire (quoique très légèrement différent) : le TRMC sera égal à :

        Le résultat est légèrement différent de celui trouvé pour le montage différentiel simple (équation [36]), mais l'ordre de grandeur reste le même.

        Ce montage est encore plus défavorable dans le cas du gain unité : le TRMC sera égal à 1/4e contre 1/2e dans le montage différentiel simple.

      4. Conclusion.

        Ce montage est intéressant du point de vue des impédances d'entrée, mais il n'apporte rien par rapport au montage précédent pour ce qui est du mode commun et de la faculté d'ajustage : il faut apparier les composants de la même manière pour obtenir un bon TRMC, et il faut changer deux composants pour ajuster le gain.

        Toutefois, si on désire un étage à gain fixe et élevé, et qu'on soit capable d'apparier les résistances avec une précision suffisante, on peut obtenir un montage correct, ayant une impédance d'entrée élevée, et un TRMC de l'ordre de 90dB, ce qui est suffisant pour bon nombre d'applications en instrumentation.

    3. SCHÉMA À TROIS AMPLIFICATEURS.

      1. Premier étage

        Fig. 10. 1er étage différentiel à deux amplis.

        La mise en équation est très simple ; on va encore utiliser le fait que les entrées v+ et v- des amplis sont égales, et que les impédances d'entrées sont infinies.

        Le courant circulant dans r et dans les deux résistances R sera donc le même, ce qui permet d'écrire :

        La tension de mode commun à l'entrée du montage est :

        D'autre part, le mode commun en sortie vaut :

        On peut calculer les valeurs de Vs1 et Vs2 facilement :

        On en déduit la valeur de la tension de mode commun en sortie VMCs :

        Pour mieux voir le phénomène, on peut aussi raisonner sur une " échelle des potentiels croissants " :

        Fig. 11. Échelle des potentiels.

        L'axe des x n'est pas vraiment un axe ; il représente la référence de potentiel du montage. Le mode commun étant égal à (e1+e2)/2, il va arriver au niveau de " la moitié " de la résistance r. Les deux sorties des amplis vont voir leur potentiel augmenter (Vs1, ampli 1) et diminuer (Vs2, ampli 2) symétriquement par rapport à ce potentiel (si les deux résistances R sont égales), car le courant circulant dans les trois résistances est le même.

        Il faut noter ici que si les amplis sont alimentés symétriquement par rapport à la masse, rien n'empêche Vs2 d'être négatif, et ceci sans que le raisonnement ne change.

        Sur ce graphique, il apparaît donc clairement que le potentiel de mode commun est le même à l'entrée et à la sortie du montage. On peut se poser la question de l'utilité de ce dernier...

        En fait, il faut remarquer que si la tension de mode commun n'a pas bougé, la tension différentielle (le signal utile) a été amplifiée du facteur (2R+r)/r, qui peut être très élevé. Tout se passe comme si la tension de mode commun avait été divisée (relativement au signal utile) par le gain de l'étage.

        Pour rendre ce montage utilisable, il va falloir se débarrasser du mode commun, et référencer le signal de sortie Vsd à la masse. On va le faire très simplement en ajoutant un montage différentiel classique en sortie du premier étage.

      2. Montage complet

        Fig. 12. Montage différentiel à trois amplis.

        Attention au câblage de l'ampli différentiel de sortie !!! Il est tel qu'on va amplifier la différence e1 - e2 .

      3. Impédance d'entrée.

        Le capteur voit deux entrées d'amplificateurs opérationnels (qui seront de préférence appariés : on choisira un boîtier contenant deux ou quatre amplificateurs), soit une impédance élevée et constante.

        Le deuxième est attaqué par les sorties des amplis du premier étage, qui sont très faibles (<1 [image]) : même si les impédances des deux entrées sont faibles et de valeurs différentes, cela n'aura pas d'incidence sur le résultat.

        Du point de vue des impédances d'entrée, notre montage est (presque) idéal !

      4. Gain en tension. Ajustage.

        Si AVd2 est le gain différentiel du deuxième étage, on va avoir, pour le montage global :

        On remarque qu'il est très simple de faire varier ce gain en modifiant uniquement la résistance r. Ce montage est donc meilleur que les deux premiers pour ce critère.

      5. Réjection de mode commun.

        Nous avons vu que le premier étage laissait intacte la tension de mode commun (équation [49]).

        Regardons ce qui se passe au niveau du deuxième étage. Nous avons affaire à un étage différentiel simple : on va utiliser les résultats obtenus plus haut.

        En transposant l'équation [33] à notre montage, on obtient :

        où AVd2 est le gain du deuxième étage et TRMC2 son taux de réjection de mode commun global (ampli et tolérance des composants).

        Si on remplace (Vs1 - Vs2) = Vsd par sa valeur (équation [44]), et en posant :

        on trouve :

        On retrouve ici par le calcul le résultat qui avait été énoncé intuitivement lors de l'étude du premier étage : tout se passe comme si le signal d'erreur généré par la tension de mode commun était divisé par le gain du premier étage.

        Cela revient à dire qu'on multiplie le TRMC2 du deuxième étage par le gain Avd1 du premier étage.

        Le TRMC du montage global vaut :

        En pratique, dans un tel montage, le premier étage donnera tout le gain, et le deuxième étage aura un gain unité. Le TRMC global aura alors une valeur élevée, d'autant plus que lorsque ce schéma sera intégré sur une puce de silicium, un ajustage par laser des résistances de l'étage de sortie lui donnera un bon TRMC.

      6. Comparaison avec l'ampli différentiel simple.

        On peut voir l'impact de l'appariement des résistances du deuxième étage. Si on reprend les données relatives à ce montage, on a :

        Nous avons dit que le gain AVd2 du deuxième étage était en général égal à 1. Compte tenu de l'équation [54], on aura un TRMC total de :

        Ce résultat est à rapprocher de celui de l'équation [36]. La valeur est la même pour les deux montages dans le cas où le gain différentiel total est égal à 1, et on tendra vers un TRMC total égal au double (+6dB) de celui de l'ampli différentiel simple pour les fortes valeurs de gain.

      7. Conclusion.

        Il faut donc relativiser le résultat trouvé au premier abord, qui consiste à dire qu'on multiplie le TRMC du deuxième étage par le gain du premier étage : en effet, le TRMC du montage différentiel est proportionnel au gain différentiel, et dans le cas de l'amplificateur d'instrumentation, le deuxième étage a un gain unité, ce qui est défavorable au TRMC.

        On note qu'on gagne tout de même 6dB pour les forts gains (erreur divisée par 2), et surtout, on a des impédances d'entrée élevées, indépendantes du gain, et ce gain est réglable par une seule résistance.

        Le TRMC restera moyen pour un gain global de 1. En pratique, ce cas se rencontre rarement. Les amplificateurs d'instrumentation répondent à un besoin d'amplifier de façon précise et stable de très faibles tensions continues ou quasi-continues superposées à une tension de mode commun élevée. Les signaux à amplifier nécessitent souvent un fort gain, qui va générer un TRMC important.

        Si un gain faible est requis, il est probable que le signal utile ne sera pas petit devant la tension de mode commun, ce qui rend moins gênante la " faiblesse " du TRMC.

    4. PLAGE DE MODE COMMUN.

      Dans tous les montages différentiels, il faudra prendre garde à un paramètre : la plage de mode commun admissible par les composants.

      Un ampli d'instrumentation est composé d'amplificateurs opérationnels alimentés par des tensions continues. La tension d'entrée va en général être limitée par les tensions positive et négative d'alimentation.

      C'est surtout vrai pour les amplis d'instrumentation dont les entrées sont des entrées d' amplis opérationnels, avec toutes les restrictions que cela impose. Par exemple, il sera hors de question de faire rentrer un signal ayant une tension de mode commun de 20V sur un ampli d'instrumentation alimenté en ±15V.

      Pour ces montages, on fera aussi attention aux limites imposées par les tensions de sorties maxi des amplis. Si on reprend l'échelle des potentiels de la figure 11, il faudra veiller à ce que les tensions S1 et S2 restent dans des limites acceptables pour l'ampli : cela implique que la somme des tensions de mode commun et du signal amplifié soit inférieure à la limite de saturation des amplis.

  • UTILISATION DES DIFFÉRENTS MONTAGES.

    Aucun des montages cités dans ce chapitre n'est mieux ni moins bien qu'un autre. Ils représentent tous des compromis, et certains seront meilleurs sur un paramètre et moins bon sur un autre...

    La solution idéale n'existe donc pas ! Il faudra jauger au cas par cas et utiliser le montage le mieux adapté.

    Nous allons faire ici le tour de groupes d'applications et donner des indications entraînant le choix le plus judicieux. Tous les cas cités ci-dessous concernent uniquement la mesure différentielle.

    • Faible signal quasi-statique avec forte tension continue de mode commun.

      L'ampli d'instrumentation à 2 ou 3 amplis opérationnels est ici de mise. Si le montage doit être adaptable (gain ajustable), on choisira le montage à 3 amplis.

      Dans le commerce, on trouve ces composants tout intégrés, avec même certains qui incluent plusieurs résistances permettant de programmer différents gains (souvent 1, 10, 100 et 1000).

    • Fort signal avec forte tension continue de mode commun.

      Ici, un montage différentiel simple de faible gain fera probablement l'affaire, car son impédance d'entrée pourra être suffisante, et le TRMC ne sera pas moins bon qu'un ampli d'instrumentation. Pour des forts TRMC requis, on pourra choisir des amplis différentiels de gain unité intégrés (ex : INA 105 de Burr-Brown). Les résistances ajustées au laser permettent d'obtenir des TRMC supérieurs à 80dB.

    • Mesure différentielle permettant d'éviter le couplage par impédance commune.

      Dans ce cas, la tension de mode commun est relativement faible. Par contre, les fréquences mises en jeu peuvent être élevées, autant pour le signal utile que pour le signal de mode commun.

      Il faudra plutôt utiliser un montage différentiel simple bâti autour d'un ampli-opérationnel rapide, ayant une bande passante étendue et une réjection de mode commun élevée en fréquence (un LM118 suffira pour des applications ordinaires et on se tournera vers un OPA627/637 par exemple pour des applications exigeantes : l'OPA637 a un TRMC supérieur à 100dB à 100kHz, un produit gain bande passante supérieur à 45MHz, ceci avec une tension d'offset de l'ordre de 100 V !)

      Ces amplis sont des standards de l'industrie, et on les retrouvera chez de nombreux fabricants (sous des appellations parfois différentes : LM627 chez NS et OPA627 chez Burr-Brown par exemple).

    • Faible signal rapide avec forte tension de mode commun à composantes haute fréquence.

      Les amplis d'instrumentation du commerce sont en général relativement lents (coût de la précision en statique), car les capteurs délivrent souvent des signaux variant lentement. Par conséquent, si on doit amplifier des signaux rapides entachés de tensions de mode commun haute fréquence, il faudra " bricoler " (très proprement quand même) avec des amplificateurs opérationnels haute performance (tel celui pré-cité), et apparier les résistances du mieux qu'on peut.

      Il ne faudra surtout pas oublier les capacités parasites (voir chapitre précédent) qui vont diminuer la réjection de mode commun en haute fréquence. Le circuit devra être câblé de façon symétrique pour que les capacités parasites soient égales, et il faudra peut-être rajouter des capacités de compensation... La mesure devient ici de l'art !


Diversité de la mesure

Vu dans ... http://meteosat.pessac.free.fr/Cd_elect/courelectr.free.fr/MESU/COURS.HTM#M01

DIVERSITÉ DE LA MESURE.

  • TYPES DE MESURES.

    Les mesures à effectuer en milieu industriel ou dans des laboratoires de recherche universitaire sont extrêmement variées. On peut en distinguer plusieurs catégories :

    mesures simples , exécutées à la main avec un appareil transportable : elles se font sur le site de l'élément ou du paramètre à mesurer. Exemple : mesure de tension à l'aide d'un multimètre.

    mesures complexes , nécessitant un appareillage lourd : on les fait (quand on le peut !) dans un local aménagé pour recevoir ce matériel spécifique. Exemple : mesure de consommation spécifique d'un moteur à combustion interne sur un banc moteur. Plus généralement, c'est le cas de nombre de mesures faites dans des labos de recherche fondamentale.

    mesures multiples , nécessitant l'acquisition simultanée de plusieurs paramètres : on fait appel à une centrale d'acquisition portable pour des mesures sur site, ou à des appareils indépendants fédérés par un micro-ordinateur (pilotage des appareils et traitement des mesures) en labo. Exemple : mesure de plusieurs paramètres de fonctionnement d'un véhicule (vitesse, régime moteur, consommation instantanée...) à l'aide d'une centrale de mesure embarquée.

  • DOMAINES D'APPLICATION.

    La finalité de ces mesures peut être très variée. On retiendra notamment :

    mesures en laboratoire : indispensable à tout organisme de recherche (fondamentale ou appliquée), à tout service d'étude..., ceci afin de pouvoir élaborer des théories et les vérifier, de concevoir et tester des nouveaux matériaux, composants, produits...

    mesures de qualification de produits de grande consommation : avant de lancer un produit en production et sur le marché (automobile, électroménager, Hi-Fi, vidéo...), on doit s'assurer qu'il va bien fonctionner sans problèmes pendant une durée de vie minimum, dans divers environnement (chaud, froid, humidité...), et qu'il respecte les normes en vigueur. On fait alors fonctionner un échantillon de ces produits (quelques dizaines d'unités dans les cas courants) dans des laboratoires avec du matériel susceptible de les piloter (marche/arrêt, plus vite/moins vite...), de générer des ambiances climatiques extrêmes (froid, chaud, humidité...), et de mesurer divers paramètres. Les mesures sont parfois faites dans un autre laboratoire après un nombre déterminé d'heures de fonctionnement. Les bancs de mesure sont alors complexes à mettre au point, du fait des ambiances extrêmes, et des parasitages induits par les appareils environnants (enceintes climatiques chaud/ froid, compresseurs, ventilateurs, alimentations électriques de forte puissance...).

    mesures de tests en production : à toutes les étapes de la fabrication d'un produit, les divers éléments le constituant sont testés, c'est à dire mesurés et comparés à des valeurs mini et maxi (les tolérances). Le problème est le même que précédemment : les mesures sont faites dans une ambiance très perturbée. Il faut aussi faire face au stockage d'un très grand nombre de données et à leur exploitation, en direct ou en différé.

    contrôle de processus industriels : beaucoup de processus de fabrication industriels sont asservis, c'est à dire contrôlés par une ou plusieurs variables, et ce, en temps réel. Il est alors nécessaire de mesurer et de traiter au fur et à mesure de leur acquisition plusieurs paramètres répartis tout au long du processus pour pouvoir agir en conséquence et garantir la qualité et la conformité du produit final.

  • GRANDEURS À MESURER.

    Toutes ces mesures sont de plus applicables à un très grand nombre de paramètres physiques, qui peuvent être :

    mécaniques : longueur, vitesse, débit, pression, viscosité, état de surface, puissance, couple...

    électriques : tension, intensité, puissances...

    thermiques : température, résistance thermique...

    chimiques : Ph, concentration, salinité...

    La liste est très longue ! Mais, toutefois, beaucoup de ces mesures présentent des points communs :

    d'une part, l'élément servant à mesurer les grandeurs désirées (capteur, palpeur, sonde...) délivre très souvent (de plus en plus) un signal électrique qu'il faudra récupérer, amplifier et adapter sans déformation (ou alors avec une déformation maîtrisée : linéarisation par exemple). On se ramène donc quasiment tout le temps à des mesures de tension.

    d'autre part, il faudra transmettre ce signal à un dispositif de mesure électrique ou à une centrale d'acquisition. C'est une des raison pour laquelle on utilise de plus en plus des capteurs délivrant des signaux électriques : il est facile ensuite de stocker les signaux, de les traiter et de les restituer à l'aide d'un ordinateur.

  • MESURES MANUELLES ET AUTOMATIQUES.

    Nous allons maintenant donner une autre classification des mesures, qui va nous permettre de distinguer deux méthodologies de travail différentes :

    les mesures faites au coup par coup, avec du matériel piloté manuellement.

    les mesures à grande échelle, fortement répétitives, obligatoirement faites à l'aide de bancs de mesure informatisés permettant l'acquisition, le traitement et le stockage d'un grand nombre de données.

    En fait, nous allons voir que ces deux catégories ont une bonne partie de leur mode opératoire en commun, et que la mise au point d'un banc de mesure automatique passe par un déverminage en mode manuel.

  • QU'ES-CE QU'UNE CHAÎNE DE MESURE ?

    La chaîne de mesure est l'ensemble des éléments nécessaires pour connaître la valeur ou l'évolution de paramètres d'un système physique.

    En pratique, et dans le cas des capteurs délivrant un signal électrique, une chaîne de mesure sera constituée des éléments suivants :

    le capteur.

    un câble de liaison.

    une interface servant d'adaptateur d'impédance entre le capteur et l'étage amplificateur.

    un étage amplificateur (faible bruit) destiné à amplifier les signaux généralement très faibles issus du capteur. Cet étage amplificateur aura aussi une fonction de conversion de mode (mode différentiel à mode commun) dans le cas d'une mesure en mode différentiel.

    on peut trouver un étage conditionneur (ex : linéarisateur) si le capteur ne délivre pas une tension proportionnelle à la grandeur à mesurer. Il y aura aussi très souvent un système de compensation des dérives thermiques du capteur.

    ensuite, on trouve quelquefois des filtres destinés à supprimer les signaux parasites issus du couple capteur/câble.

    dans certaines chaînes, une interface réalise l'isolation galvanique entre le capteur et l'élément de mesure.

    dans tous la plupart des cas, on mesure une tension : on trouve donc un voltmètre derrière l'amplificateur ou les conditionneurs.

    enfin, il faut un système d'affichage pour donner la valeur de la mesure.

    dans le cas d'un banc de mesures automatique, on trouvera en plus un micro-ordinateur servant à piloter les instruments, à faire l'acquisition des paramètres et leur traitement.

    Il va de soi que tous ces éléments troubleront le moins possible la mesure : ils devront être précis, fidèles, le plus linéaire possible (faible distorsion), ne pas apporter de signal parasite (faible bruit), et avoir une dérive minimum en température, en hygrométrie...

    Un instrument de mesure est un appareil qui va réunir tout ou partie de la chaîne de mesure. Souvent, il comprend toute la chaîne à l'exception du capteur et des câbles.

    Il existe tous les degrés de modularité entre l'instrument monobloc (toute la chaîne y compris le capteur) et le système complètement éclaté.

    Par exemple, le système d'affichage ne sera peut-être pas inclus : on aura juste une sortie en tension haut niveau (quelques volts ou centaines de mV) qu'il faudra brancher sur un voltmètre ou bien un oscilloscope.

    On trouve maintenant sur le marché de plus en plus de capteurs "intelligents" : ce sont généralement des capteurs dont l'élément sensible est en silicium (exemple : capteur de pression piezo-résistif, constitué d'un pont de résistances diffusées dans du silicium micro-usiné), ce qui permet d'intégrer sur ce cristal de silicium, et juste à côté de l'élément sensible, les fonctions d'adaptation d'impédance, amplification, compensation thermique, linéarisation... Le capteur délivre alors directement un signal de tension haut niveau proportionnel au paramètre à mesurer. L'intégration permet en plus de diminuer les coûts et augmenter la miniaturisation, ce qui est intéressant pour les systèmes de mesure embarqués (aviation, spatial, automobile...)

    Pour une même mesure, on va trouver sur le marché divers appareils qui seront soit monoblocs, soit modulaires : il faudra choisir celui qui convient le mieux, et le critère principal ne sera pas forcément la qualité de mesure, mais aussi la modularité, l'ouverture (veut-on accéder à des paramètres intermédiaires, sous quelle forme...), la compacité, le coût...

    La modularité peut être un avantage si la chaîne n'est pas utilisée en permanence par une expérimentation particulière : on peut alors réutiliser des éléments pour plusieurs types de mesures.

    Bien choisir un appareil de mesure n'est pas une tâche aisée, et nécessite une bonne réflexion préliminaire !

  • MESURES MANUELLES.

    Nous allons traiter la chaîne de mesure suivante :

    Ce cas est relativement répandu, et ce qui va être dit ci-après est facilement transposable aux autres cas de figure.

    Lors de mesures électriques directes (tensions), il n'y a pas de capteur.

    Tous ces éléments (y compris les câbles, souvent négligés !) devront être choisis avec soin pour répondre convenablement au besoin : gamme de mesure, précision, rapidité...

    Par exemple, si on propose de mesurer la température ambiante dans une pièce avec un thermocouple de type K ayant une plage de mesure de -270 à 1250°C et une précision de ±3°C, on va faire beaucoup rire, surtout si on donne toutes ces indications.

    Pourtant, dans le milieu industriel, et derrière des baies de mesures impressionnantes de professionnalisme, il n'est pas rare de trouver ce genre de choses ! Et puis, qui oserait remettre en cause la valeur indiquée au 1/10ème de °C sur un afficheur de marque réputée ?

    Dans tous les choix de matériel et toutes les mesures, une règle d'or s'impose : ne pas se laisser impressionner par une débauche de matériel. Il faut toujours être critique, et bien vérifier que toute la chaîne de mesure est homogène.

    Il est tout à fait possible, avec de l'expérience, des idées et le sens du travail bien fait, de faire des mesures de bien meilleure qualité et pour beaucoup moins cher que si on se laisse happer par les sirènes du matériel "hi-tech".

    1. CHOIX DU MATÉRIEL

      Bien souvent, en mesure, on fait ce qu'on peut, et non toujours ce qu'on veut ! Ceci pour une excellente raison : le matériel de mesure coûte cher, très cher...

      On essayera alors de faire un compromis acceptable entre performances et coût.

      1. Choix du capteur.

        Autant que possible, il faudra adapter le capteur à la mesure, en termes de :

        sensibilité

        plage d'utilisation

        répétabilité, hystérésis, fidélité

        dérive en température, pression, humidité...

        Dans la pratique, on disposera peut-être d'un capteur moins performant que ce qu'on avait spécifié à priori dans le cahier des charges, mais qui peut faire l'affaire tout de même. Cela évitera l'achat d'un nouveau capteur, et va dans le sens d'une plus grande standardisation de l'instrumentation disponible dans le laboratoire.

        Par contre , il faudra faire la mesure en connaissance de cause, et tenir compte de la dégradation des performances dans les conclusions à tirer de l'expérimentation.

        Pour reprendre l'exemple précédent, on peut mesurer la température d'une pièce avec un thermocouple de type K si une précision de ± 3°C suffit. Il sera alors inutile de mettre un afficheur ayant une résolution de 0,1°C, et surtout de consigner dans le rapport des valeurs de température avec des décimales...

      2. Choix de l'instrument.

        Nous avons déjà parlé des différents types d'instruments existants. On verra donc ce qui est déjà disponible dans le labo et si un compromis est réalisable sans acheter trop de matériel.

        Il faudra néanmoins faire usage d'un instrument compatible avec le capteur :

        sensibilité, gamme d'utilisation.

        mode de câblage : capteur isolé, avec une borne reliée à la masse du montage, sortie en 1 fil + blindage, 2 fils, 2 fils plus blindage, montage en pont...

        type d'entrée (sensible à la tension, au courant, à la charge électrique, à la résistance...), impédance.

      3. Choix du câble.

        Le câble est un maillon de la chaîne qui est souvent négligé, à tort, car un câble mal adapté peut apporter beaucoup de perturbations dans les mesures, les principales étant :

        impédances parasites chargeant le capteur (capacité parasite d'un câble coaxial par exemple). Ces impédances parasites forment un diviseur de tension avec l'impédance de sortie du capteur et modifient la sensibilité annoncée par le constructeur : la chaîne ne sera plus étalonnée convenablement. En plus, pour compliquer, ce défaut variera souvent avec la fréquence du signal...

        bande passante inadaptée : pour des signaux rapides, il faut prévoir un câble permettant de transmettre des fréquences bien supérieures à celles constituant le signal afin de ne pas le déformer.

        génération de bruit : la mesure d'un signal très faible dans une ambiance bruitée avec un câble non ou mal blindé peut être complètement faussée par des signaux parasites.

        couplages : si on a plusieurs capteurs sur un équipement à mesurer reliés à une seule centrale de mesure, il faudra veiller à éviter des couplages parasites et minimiser les effets des boucles de masse.

        Parfois, le fabricant de certains capteurs (par exemple des accéléromètre piézoélectriques) fournit un câble spécifique (souvent fort cher !) destiné à les relier à un conditionneur spécifique lui aussi. Il est impératif de respecter l'homogénéité de la chaîne, et ne pas faire de mesquines économies sous peine de déboires sévères. Lors de l'achat, il faudra considérer la chaîne de mesure dans sa globalité, c'est à dire câble compris : on pourra ou non se l'acheter, mais dans tous les cas, il faut proscrire le bricolage.

      4. Attention au vocabulaire...

        Une erreur courante consiste à confondre résolution et précision.

        La résolution est la variation mini du paramètre à mesurer qui introduira une modification dans l'affichage. Sur un afficheur numérique, ce sera un digit.

        La précision va quantifier l'erreur maxi de mesure, à savoir la différence maximum entre ce qu'indique l'affichage et la valeur vraie du paramètre mesuré.

        Pour reprendre l'exemple de mesure de température ambiante avec un thermocouple, on pourra avoir une résolution de 0,1°C et une précision de ±3°C : l'afficheur donne le 1/10ème de degré, mais l'affichage pourra être différent de ±3°C par rapport à la vraie température de la pièce.

        L'afficheur peut par exemple indiquer 23,6°C pour une température vraie de 26,1°C.

        Les afficheurs numériques actuels ont un effet intimidant dû au nombre impressionnant de digits affichés. Il ne faut jamais perdre de vue que souvent, les derniers digits sont complètement faux. Il est alors inutile de les consigner dans un rapport, et pis, il est aberrant de tirer des conclusions sur l'évolution d'un paramètre si les variations enregistrées sont inférieures à la précision de la chaîne de mesure.

        Là encore, ce propos risque de faire sourire ; et pourtant...

      5. Attention au matériel...

        Grâce à l'électronique, il est tout à fait possible de protéger des équipements de mesure contre des fausses manœuvres : par exemple, il faut être vraiment très maladroit pour endommager un oscilloscope !

        Par contre, pour du matériel à très grande sensibilité, ces protections ne sont pas faisables, car elles introduiraient des perturbations trop grandes vis à vis des signaux à mesurer (courants de fuite, tension parasites...).

        Ce matériel sensible est donc très fragile. Et en général, il est aussi très cher... Il faut donc se poser toutes les bonnes questions avant de brancher !

    2. MODE OPÉRATOIRE.

      On pourrait se demander quelle est l'utilité d'un tel paragraphe : pour mesurer un paramètre d'un système donné, il suffit de mettre le capteur en place, de le relier à l'instrument de mesure, on branche le tout, on relève la valeur, et c'est fini...

      Hé bien non ! C'est pourtant ce qu'on voit très souvent.

      En mesure, il existe un principe de base : il faut rester critique vis à vis de son montage et des résultats observés.

      Souvent, plutôt que de se contenter d'une seule mesure, il faudra la répéter dans diverses conditions pour se faire une idée de l'influence de chaque maillon (capteur, câble, instrument...), de l'environnement (parasitage, température, hygrométrie...), et essayer de déterminer la configuration donnant les résultats les plus vraisemblables.

      On peut tomber sur deux cas de figure :

      soit on "connaît" le résultat qu'on doit obtenir, et alors, il sera aisé d'éliminer les configurations donnant des résultats fantaisistes. Ce cas se présente en général quand on a déjà fait des mesures similaires. Sinon, il ne faudra pas hésiter à aller consulter un collègue ayant de l'expérience dans le domaine considéré. La confrontation des idées et des résultats peut ainsi être bénéfique à tout le monde.

      le deuxième cas est beaucoup plus critique : on ne sait pas du tout où on va. Le mode opératoire indiqué ci-après est alors très fortement conseillé !

      • Essayer plusieurs combinaisons de matériel.

        Lorsque c'est possible et que cela n'entraîne pas des dépenses prohibitives (penser au prêt ou à la location de matériel), on peut faire des mesures avec des capteurs différents, associés à des câbles différents et des instruments différents. La technique des plans d'expériences pourra ici apporter un plus, notamment pour ce qui est des interactions entre les maillons de la chaîne : en effet, un câble pourra donner d'excellents résultats avec un capteur donné et perturber complètement un autre capteur. Ce n'est pas la valeur intrinsèque du câble qui est à mettre en cause, mais son association avec le capteur.

        Pour les capteurs sensibles au positionnement (capteurs de température, accéléromètres...), il faudra tester l'influence de l'emplacement et de la fixation de ces capteurs.

        Certains appareils possèdent des réglages concernant la bande passante du signal : on pourra tester ici leur effet : réduction de bruit et stabilisation de la mesure, ou alors modification importante du signal (amplitude, phase, forme...)

        Si tous les résultats convergent, c'est très bien : on retiendra les outils qu'on maîtrise le mieux, ou bien les moins chers...

        Si les résultats sont différents, il faudra étudier tous les cas un par un, essayer d'expliquer les résultats obtenus, et détecter les sources d'erreurs.

        Cette phase d'analyse ne représente que trois lignes dans ce cours ; mais il ne faut pas se leurrer : sur une "manip" un peu pointue, cela peut prendre des semaines...

        Le fait de tester plusieurs configurations différentes aide beaucoup dans cette phase de recherche. Par exemple, si une cause d'erreur est la capacité parasite d'un câble, on peut la cerner en faisant un test avec un câble beaucoup moins capacitif. On essayera avec des calculs simples et d'après les spécifications du matériel testé de quantifier (au premier ordre) les erreurs et de voir si ce calcul corrèle avec les mesures.

        On pourra ainsi petit à petit trouver toutes (soyons optimistes !) les sources d'erreur, et surtout, se faire une expérience des problèmes rencontrés qui sera bien utile à la prochaine expérimentation.

      • Tester la répétabilité des mesures.

        Cette deuxième phase se fera en fait en même temps que la précédente, car tout est lié.

        Pour chaque configuration testée, on va s'assurer que la mesure est reproductible.

        Le premier point trivial à vérifier est la stabilité de la mesure : si l'afficheur varie en permanence, ou si la courbe d'un signal tangue sur l'oscilloscope, il faut tout de suite en chercher les raisons avant d'aller plus loin. Il faudra vérifier notamment la bonne mise à la masse des capteurs, des câbles et des instruments.

        Ensuite, on devra répéter la mesure un certain nombre de fois sur une pièce témoin et juger de sa dispersion à l'aide d'outils statistiques simples comme la moyenne, le mini, le maxi, l'écart type, et éventuellement tracer la courbe de distribution des valeurs obtenues.

        Il ne faudra bien entendu pas oublier de faire des test dans des conditions climatiques différentes : par exemple, mesurer précisément des résistances ayant un coefficient de température important nécessite des précautions. Le labo peut être froid le matin, mais bien ensoleillé l'après midi. Quelques degrés d'écart peuvent rendre caduques bien des digits d'afficheur...

        De même, sur des montages à très haute impédance (mesure d'isolation par exemple), une humidité non contrôlée peut avoir une incidence importante : il faut y penser... et y remédier si possible.

        On pourra (si les conclusions ne sont pas à rendre pour la veille, comme on le voit fréquemment dans l'industrie !) tester la répétabilité dans le temps et quantifier les éventuelles dérives.

        A ce titre, quand on fait régulièrement des mesure avec le même matériel, le premier test à faire est de remesurer l'élément qui a été passé sur le banc lors de la campagne précédente. Normalement , le résultat doit être le même... Si ce n'est pas le cas, il faut passer tout le banc de mesure au peigne fin jusqu'à ce qu'on trouve les sources de divergence.

      • En conclusion

        Ne jamais se fier aveuglément aux indications d'un appareillage sophistiqué . Dans la mesure (si on peut dire !) du possible, on devra essayer plusieurs types de manipulations permettant de corréler les résultats, et comparer autant que possible ces résultats ainsi que les protocoles d'expérimentation avec des collègues ayant une expérience similaire.

        Et surtout, si nos essais nous amènent à des conclusions "bizarres", révisons notre copie avant de la publier.

        Par exemple, si nos résultats nous entraînent à remettre en cause le principe d'attraction universelle, pensons d'abord à l'erreur de mesure, et ensuite au prix Nobel...

        J'en voit qui sourient... La fusion froide, ça vous dit quelque chose ?

        P.S : il ne pas se sous-estimer quand même, ni laisser de côté sa créativité. Parfois, c'est vraiment le prix Nobel qui attend au bout des mesures...

  • BANCS DE MESURE.

    Lorsqu'on doit faire toute une série de mesures sur un échantillon de grande taille, il est nécessaire de passer au banc automatique pour plusieurs raisons :

    gain de temps.

    on évite l'ennui de refaire plusieurs fois la même chose.

    une fois que le banc est au point, l'automatisation garantit une bonne répétabilité dans les mesures, et évite les erreurs de manipulation.

    Par contre, la mise au point de ce banc devra être faite avec le plus grand soin, et on fera en parallèle avec le banc des mesures manuelles dans diverses conditions pour vérifier la fiabilité des résultats obtenus.

    1. MATÉRIEL NÉCESSAIRE

      Le matériel de base sera le même que pour les mesures manuelles, auquel on va rajouter :

      des instruments de mesure télécommandables par un ordinateur, via une liaison série ou un port GPIB (ou autre...).

      un ordinateur qui servira à commander les instruments et à récupérer les données mesurées. Il servira ensuite soit à faire du traitement des données en différé (traitement mathématique, affichage de courbes...), soit à les traiter en temps réel dans le cas d'un contrôle de processus. Dans ce dernier cas, l'ordinateur va aussi servir à piloter le processus industriel.

      souvent, on remplace l'instrument de mesure traditionnel par une carte d'acquisition de données qu'on fixe dans l'ordinateur. Ces cartes sont très utilisées quand on a beaucoup de mesures à faire en parallèle, car elles possèdent un grand nombre d'entrées configurables par logiciel depuis l'ordinateur (réglage de la sensibilité, du type de mesure simple ou différentielle...). Quelquefois, ces cartes incluent des conditionneurs de capteurs à l'entrée (notamment pour les thermocouples).

      certains bancs de mesure (pour la qualification de produits notamment) comportent des machines climatiques (chaleur, froid, humidité...) qu'on choisira de préférence pilotables par l'ordinateur.

    2. MISE EN GARDE !

      De plus en plus, on trouve dans les labos des bancs de mesures avec un ordinateur de pilotage. C'est très pratique, mais il faut faire très attention :

      Le problème de ces bancs, c'est que rien n'est accessible simplement ; s'ils ont été mis au point par une tierce personne, la documentation est généralement déficiente (quand elle existe), et en particulier, on ne connaît pas trop les limites de validité des mesures.

      On donne donc quelque chose à mesurer en pâture à la machine qui recrache un résultat aseptisé et emballé à l'autre bout. Et on ne sait rien de ce qui s'est passé dans les entrailles de la machine.

      Là encore, il ne faut surtout pas se laisser impressionner par une machine haut de gamme fournissant à la vitesse de l'éclair des résultats avec 18 décimales et des courbes en 3D et en couleur !

      Derrière ces résultats rutilants se cachent parfois des erreurs de mesure grossières. De plus, les gens mettant au point ces bancs sont plus souvent informaticiens qu'électroniciens ou spécialistes en mesure. Ils privilégient souvent l'interface au détriment de la partie instrumentation ou traitement des résultats (du point de vue mathématique ou statistique). La plus grande prudence s'impose donc !

    3. MISE AU POINT D'UN BANC.

      Mettre au point soi-même un banc de mesure est par contre quelque chose de passionnant. Il faudra s'armer de patience et de ténacité, mais le résultat en vaut la chandelle.

      Si ce banc doit servir à d'autres utilisateurs, on soignera particulièrement la documentation, et notamment la description des traitements effectués, et les limites de validité de la précision annoncée.

      1. Choix du matériel.

        Pour toute la partie instrumentation, revoir ci-dessus. La seule différence proviendra de l'aptitude des instruments à être pilotés par ordinateur.

        On choisira le type de pilotage en fonction des ressources disponibles sur l'ordinateur (carte GPIB, liaison série disponible, autre carte...) et du flux de données qu'on aura à gérer (temps réel ou pas, fréquence d'acquisition élevée ou faible, un ou plusieurs paramètres à mesurer simultanément...).

      2. Méthodologie.

        • Attention aux couplages.

          Le plus gros problème qu'on rencontrera lors de la mise au point du banc sera dû aux phénomènes de couplage par impédance commune. En effet, tous les appareils composant la chaîne de mesure et de traitement sont reliés à la même masse qui est généralement la terre (ce sont des normes de sécurité imposées aux fabricants de matériel de mesure). On sera parfois obligés d'isoler certaines parties de la chaîne à l'aide d'amplis d'isolation ou de travailler en différentiel.

        • Cartes d'acquisition.

          Si on utilise des cartes d'acquisition à mettre dans l'ordinateur, on se rappellera que celui-ci est un milieu extrêmement perturbant : fréquences de fonctionnement élevées, commutation, alimentation à découpage, ventilateur...

          Bref, il vaudra mieux pré-conditionner les faibles signaux (les amplifier, filtrer et délivrer sous faible impédance) avant de les envoyer sur ces cartes d'acquisition.

        • Mesures chaud/froid.

          Si ce banc doit utiliser un équipement climatique (enceinte thermique chaud/froid par exemple), on fera très attention aux phénomènes de condensation et de givre. Si on doit faire des mesures à chaud et à froid, il faut commencer par le chaud : le matériel testé va sécher convenablement ; ensuite, on fera le test à froid : pas de problème de givre. Ne jamais ouvrir l'enceinte climatique à froid : givrage instantané garanti dû à l'humidité de l'air ambiant ! Lors d'un retour à température ambiante, ce givre va fondre et "noyer" le montage, provocant des courants de fuite importants, et pouvant endommager certains équipements sous test.

          Il faudra aussi tenir compte de l'hystérésis en température du matériel testé, et donc faire un cycle thermique complet avant toute mesure de façon à toujours se trouver dans les mêmes conditions de mesure. On évitera ainsi des écarts difficiles à interpréter.

        • Répétabilité du banc.

          C'est un des aspects essentiels de la mise au point du banc : il est évident que lorsqu'on mesure deux fois la même pièce sur un banc, le résultat doit être le même. Eh bien une fois de plus, ce n'est pas toujours le cas !

          L'ordinateur de pilotage va nous être ici d'un grand secours : il va pouvoir faire seul un grand nombre d'acquisitions du même paramètre, et nous aider à traiter statistiquement les données.

          Dans la majorité des cas, la distribution des résultats obtenus aura la forme suivante (exemple de mesures d'une résistance) :

          Fig. 1. Distribution des mesures d'une résistance

          C'est la loi normale ou loi de Gauss. Elle est entièrement caractérisée par deux paramètres :

          la moyenne, qui est égale à l'abscisse de l'axe de symétrie de la courbe : sur l'exemple, c'est 420 [image].

          l'écart type, qui est représentatif de la dispersion des valeurs. Dans l'exemple donné, il est de 5 [image].

          Ces deux paramètres se calculent à l'aide de toutes les valeurs obtenues par la mesure.

          On remarque qu'on a très peu de mesures en dessous de 405 [image] (valeur de la moyenne moins 3 écarts type) et au dessus de 435 [image] (moyenne plus 3 écarts type).

          La théorie de la loi normale nous dit que la probabilité de trouver des valeurs hors de cet intervalle de ±3 écarts type est inférieure à 3‰.

          Dans la pratique, il faudra faire en sorte que la dispersion des mesures (à ± 3 écarts type) soit inférieure au dixième de la précision désirée pour faire la mesure.

          Par exemple, si on veut mesurer des résistances à ±3%, il faudra que l'écart type de la mesure soit inférieur ou égal à 0,1% de la valeur de la résistance mesurée.

          Si on reprend l'exemple de la figure 1, la répétabilité du banc est de ±3,5%. Il serait illusoire de prétendre faire des mesures de précision avec une telle dispersion !

          Cette notion de répétabilité est importante surtout pour les équipements de test en production : il ne faut pas que l'incertitude de mesure du banc soit importante vis à vis des tolérances des produits mesurés. Si tel est le cas, une pièce testée plusieurs fois pourra être tantôt bonne, tantôt mauvaise. C'est ce que l'on nomme les DNR (défauts non reproductibles). Plus la distribution des mesures est étroite, moins on aura de DNR.

          Attention : il ne faut pas confondre répétabilité et précision. Une mesure peut être imprécise mais très répétable : la mesure d'une résistance de 420 [image] sur un banc peut être comprise entre 440 et 440,4 [image]. La précision est de +5%, mais la répétabilité est de 1‰.

          En règle générale, la précision va être déterminée par les caractéristiques du capteur et de l'instrument de mesure.

          La répétabilité dépendra de paramètres tels que l'hystérésis des appareils constituant la chaîne, du câblage (bruit issu de sources de perturbation extérieures), et encore des tensions de mode commun mal maîtrisées, des résistances de contact fluctuantes et non prises en compte dans la mesure...

          Il vaut mieux avoir une mesure imprécise mais très répétable que l'inverse. Les causes d'imprécision sont plus faciles à identifier, et éventuellement pourront faire l'objet de compensations par l'informatique de traitement du banc : auto-zéro, auto-calibration de la chaîne de mesure...

          Une non répétabilité dénote un ou plusieurs paramètres très mal maîtrisés. Se lancer dans des mesures à grande échelle dans ces conditions est hasardeux, car des dérives supplémentaires sont prévisibles.

        • En conclusion :

          On procédera de la même manière que pour les mesures en mode manuel pour ce qui est du choix des instruments.

          On se rappellera que l'ordinateur de traitement est perturbant : on ne lui confiera pas de signaux "fragiles" (bas niveau et/ou haute impédance).

          On apportera un soin particulier à la répétabilité des résultats en s'aidant d'outils statistiques. Une mauvaise répétabilité n'est pas bon signe : la chaîne de mesure est mal maîtrisée, et tôt ou tard, on va le payer.

          On soignera d'abord la qualité de la mesure, et ensuite, on peaufinera l'aspect informatique (ergonomie, présentation...). On ne peut faire du bon travail qu'avec des données saines !

    4. EN PRATIQUE...

      Toute cette énumération protocolaire et toutes ces mises en garde vont peut-être paraître superflues, voire rebutantes.

      Il est clair qu'il s'agit là d'un exposé un peu académique, et que dans la pratique, on n'aura peut-être pas le temps ni les moyens de le mettre en œuvre.

      Il faudra aussi faire le tri en fonction de la difficulté de la mesure à faire, et cette aptitude à savoir faire l'impasse ou non sur telle procédure viendra avec l'expérience ; on ne traitera pas de la même manière la mesure d'une résistance de 1k [image] et celle d'un courant de fuite voisin du nA à -30°C...

      Toutefois, la prudence reste un excellent conseiller du spécialiste en mesure, et il faudra se garder de sous-estimer la difficulté : des manips paraissant simples à priori à un débutant pourront en fait être très délicates.

      On ne le répétera jamais assez : dans tous les cas, on aura intérêt à aller consulter les personnes ayant une expérience dans le domaine qu'on va aborder !

    Note :Technique qui consiste à faire une matrice d'essais spécifique permettant de voir toutes les influences possibles (y compris les interactions entre les différents constituants de la chaîne) avec un nombre réduit d'essai


Convertisseurs A/N et N/A

INTRODUCTION.

  • Exemple de chaîne de traitement.

NOTIONS GÉNÉRALES.

  1. CONVERSION ANALOGIQUE/NUMÉRIQUE.
    1. Principe de fonctionnement.
    2. Définitions.
      • Plage de conversion.
      • Résolution.
      • Dynamique.
      • Mise en relation.
    3. Exemple : CAN 3 bits
    4. Erreur de quantification. Amélioration.
  2. CONVERSION NUMÉRIQUE/ANALOGIQUE.
    1. Principe de fonctionnement.
    2. Définitions.
      • Résolution.
      • Plage de conversion.
      • Dynamique.
      • Mise en relation.
    3. Exemple : CNA 3 bits.
  3. ERREURS DE CONVERSION.
    1. Erreur de gain.
    2. Erreur d'offset.
    3. Erreurs de linéarité.
    4. Monotonicité (CNA).
    5. Codes manquants (CAN).
    6. Temps d'établissement (CNA).
    7. Temps de conversion (CAN).
    8. Précision du convertisseur.

CONVERSION NUMÉRIQUE / ANALOGIQUE.

  1. ARCHITECTURE GÉNÉRIQUE.
  2. CNA À RÉSISTANCES PONDÉRÉES.
    1. Principe.
    2. Précision.
    3. Avantages / inconvénients.
  3. CNA À RÉSEAU R/2R.
    1. Principe
    2. Précision.
  4. UTILISATION DES CNA.
    • Utilisation " classique "
    • Amplificateurs à gain programmable.
    • Filtres programmable
    • Multiplieur.
    • Attention !!!

CONVERSION ANALOGIQUE / NUMÉRIQUE.

  1. ARCHITECTURE GÉNÉRIQUE.
  2. CAN PARALLÈLE.
    1. Principe.
    2. Précision.
    3. Utilisation.
  3. CAN À APPROXIMATIONS SUCCESSIVES.
    1. Principe.
    2. Précision.
    3. Utilisation.
  4. CAN À COMPTAGE D'IMPULSIONS.
    1. Convertisseur simple rampe.
    2. Convertisseur double rampe.
    3. Résolution. Précision.

  1. INTRODUCTION.

    L'électronique est divisée en deux domaines distincts :

    - le domaine analogique , où les variables peuvent prendre une infinité de valeurs différentes ; les signaux varient continûment. Tous les signaux issus des capteurs sont analogiques, et traduisent des phénomènes physiques qui varient continûment.

    - le domaine numérique , où les variables prennent uniquement deux états, un état haut et un état bas.

    Le domaine numérique est maintenant prédominant. Il s'est beaucoup développé grâce aux progrès faits par les microprocesseurs. Beaucoup de signaux naguère traités de façon analogiques le sont aujourd'hui par programmation de microprocesseurs.

    Le gros avantage apporté par la numérisation des signaux est la possibilité de stockage, de transformation et de restitution des données sans qu'elles ne soient altérées. On peut par exemple faire transiter un signal sonore de qualité HI-FI par une ligne téléphonique sans que la bande passante réduite ni le bruit de cette ligne ne soient gênants, ce qui aurait été impensable avec le signal analogique de départ !

    Le traitement des données par programmation introduit aussi une souplesse dans la conception de produits à base d'électronique : un même circuit électronique à base de P pourra traiter des signaux différents ; seul le programme va changer. Cela permet de réduire les coûts par standardisation, la même carte étant utilisée pour plusieurs fonctions différentes. L'électronique analogique nécessitait au mieux un changement des composants, au pire, la conception d'une nouvelle carte.

    Mais, à la base, les signaux ont toujours une nature analogique ! Il faut donc les amplifier et éventuellement les extraire de signaux parasites (tension de mode commun par exemple). Le domaine analogique va donc toujours exister au moins en amont de toute chaîne de traitement. Parfois, on a aussi besoin d'un signal analogique en sortie de cette chaîne de traitement : il faudra alors reconvertir les données numériques en signal analogique.

    Le passage d'un type de donnée à l'autre se fera par des convertisseurs, composants " mixtes " qui vont manipuler des tensions analogiques en entrée et des signaux logiques en sortie ou vice versa.

    Il existe deux catégories de convertisseurs :

    - les Convertisseurs Analogique Numérique (CAN, ADC en anglais, pour analog to digital converter), qui vont transformer les tensions analogiques en signaux logiques aptes à être traités par microprocesseur (numérisation des signaux).

    - les Convertisseurs Numérique Analogique (CNA, DAC en anglais, pour digital to analog converter) qui vont convertir les signaux logiques en tension analogique.

    Plusieurs types de convertisseurs sont disponibles dans chaque catégorie, qui se différencient par leur précision, leur vitesse de traitement de l'information, leur prix...

    Il n'y a pas " le " convertisseur à tout faire qui soit bon partout : on devra faire un choix en fonction de ses besoins.

    • Exemple de chaîne de traitement.

      Un exemple très répandu de conversion et traitement de données est la chaîne de transformation du son, de l'enregistrement de la musique à sa restitution par les enceintes acoustiques.

      Le son est capté par des micros, dont la très faible tension de sortie est amplifiée. Le signal peut être numérisé directement à ce niveau, et sera alors traité de façon entièrement numérique (mixage...). Il peut aussi être stocké de façon analogique sur bande magnétique, mixé, et ensuite numérisé. L'avantage du traitement numérique réside dans le fait que les données sont inaltérables, contrairement aux données analogiques stockées sur bande magnétique : celle-ci se dégrade lors des passages répétés sur les têtes de lecture.

      Le stockage est maintenant presque toujours numérique (compact disc). Le lecteur de CD contient des convertisseurs numérique analogique qui vont retransformer les informations numériques en signal analogique qui sera amplifié avant d'être envoyé aux enceintes.

  2. NOTIONS GÉNÉRALES.

    1. CONVERSION ANALOGIQUE/NUMÉRIQUE.

      1. Principe de fonctionnement.

        On a vu dans l'introduction que les signaux numériques ne varient pas de façon continue. En fait, quand on voudra numériser un signal analogique (donc continu), il va falloir le discrétiser sur deux dimensions : le temps et l'amplitude.

        Il est impensable de décrire un signal avec une infinité de valeurs ; on va le mesurer à des instants bien déterminés : c'est ce qu'on appelle l'échantillonnage .

        Pour ce qui est de l'amplitude, à un intervalle de tension du signal d'entrée on fera correspondre une valeur unique : c'est la quantification (voir figure 1). Cette valeur sera ensuite codée (binaire, binaire signé...) et restituée sous forme binaire en sortie du convertisseur pour être traitée par de l'électronique numérique.

        Fig. 1. Fonction de transfert d'un CAN.

        La figure 1 représente la fonction de transfert d'un CAN, à savoir le code numérique de sortie en fonction de la tension d'entrée. On y voit clairement les plages de tension associées à un état numérique de sortie :

        Vlog = 0 pour 0 [image] Ve < 0,1V

        V log = 1 pour 0,1 [image] Ve < 0,2V

        V log = 6 pour 0,6 [image] Ve < 0,7V ...

        L'étape de quantification de la conversion analogique numérique entraîne une perte d'information.

        Un résumé graphique de tout ceci est exprimé sur la figure 2 : on y voit un signal analogique en entrée (une sinusoïde), et les échantillons issus de la conversion analogique numérique, avec la double discrétisation mentionnée.

        Fig. 2. Signal analogique et numérisé

      2. Définitions.

        Nous allons donner ci-dessous plusieurs définitions théoriques ; afin de bien comprendre à quoi elles correspondent dans la réalité, un exemple de convertisseur 3 bits est exposé plus loin. Le lecteur est invité à consulter les deux paragraphes en parallèle.

        Toutes ces définitions sont données pour des convertisseurs parfaits ; en pratique, on est loin du compte, car ces composants intègrent des comparateurs différentiels, amplificateurs opérationnels et autres réseaux de résistances qui sont imparfaits. Nous allons lister ensuite les principaux défauts des convertisseurs.

        • Plage de conversion.

          Le convertisseur délivrera en sortie un nombre fini de codes numériques, correspondant à une gamme de tension analogique d'entrée bornée : c'est la plage de conversion (ou tension de pleine échelle) du convertisseur. Cette plage de conversion sera couramment de 0-5V, 0-10V, ou encore ±5V ou ±10V. Il existe aussi d'autres plages de conversion moins usitées.

        • Résolution.

          Le signal numérisé sera d'autant plus riche en information que l'intervalle de tension qui sera codé par le même nombre binaire sera petit, et ceci à plage de conversion donnée.

          La résolution du CAN sera l'intervalle de tension d'entrée à laquelle correspondra un même nombre binaire.

          En théorie, cet intervalle de tension est le même pour tous les codes binaires ; en pratique, ça ne sera pas toujours le cas (voir les erreurs de conversion). La résolution correspondra à la valeur théorique.

        • Dynamique.

          La dynamique d'un signal est le rapport entre la tension maxi et la tension mini que pourra prendre ce signal.

          Pour un CAN, ce sera le nombre binaire le plus élevé divisé par le plus faible qui est 1 (et pas 0 qui correspond à un signal nul), donc, le nombre de codes binaires différents que peut fournir le convertisseur moins un (le zéro !).

          Si on prend l'exemple d'un convertisseur 8 bits, la dynamique vaut en toute rigueur 28 - 1 = 255.

          En pratique, on arrondira ce nombre à une puissance de 2, qui sera le nombre de bits du convertisseur. Notre convertisseur aura donc une dynamique de 256, qu'on exprimera plutôt sous la forme " 8 bits ", ou encore 48db = 20log(256).

        • Mise en relation.

          Il est possible de relier la dynamique, la résolution et la plage de conversion d'un convertisseur.

          La résolution correspond à la variation d'une unité du code binaire ; cette unité est égale à la variation du bit de poids le plus faible (LSB = least significant bit en Anglais). Si on désigne par [image] VMAX la plage de conversion et N le nombre de bits du convertisseur, on a la relation :

          L'exemple suivant clarifiera cette relation.

      3. Exemple : CAN 3 bits

        Fig. 3. Fonction de transfert d'un CAN 3 bits

        Sur la figure 3, on a représenté la fonction de transfert d'un CAN à 3 bits ayant une plage de conversion de 8V. Il y a 8 états logiques, la plage de conversion est donc partagée en 8 portions égales correspondant chacune à un état logique de sortie.

        On remarquera que la dernière transition du CAN se fait pour une tension d'entrée de 7V, correspondant au dernier état logique de sortie (égal à 7).

        Passée cette valeur de 7V, le convertisseur ne changera donc plus d'état. Toutefois, on considère que la plage de conversion s'étend jusqu'à 8V, la dernière portion, de 7 à 8V correspondant à l'état logique " 7 ".

        Dans ces conditions, la plage de conversion est de 8V, divisée en 23 = 8 portions correspondant chacune à un LSB valant 8V/8=1V. On retrouve le résultat de l'équation [1].

      4. Erreur de quantification. Amélioration.

        On a déjà dit que la double quantification, dans le temps et en amplitude consistait en une perte d'information du signal. Ceci nous conduit à la notion d'erreur de quantification, qui est inhérente à la conversion analogique/numérique (et inverse), et sera présente même si les convertisseurs sont considérés comme parfaits. Cette erreur systématique s'ajoute donc aux erreurs décrites plus loin.

        Si on numérise une rampe de tension, l'erreur entre la tension d'entrée et la tension de sortie " reconstituée " (reconvertie en analogique par passage dans un CNA) aura la forme suivante :

        Fig. 4. Erreur de quantification d'un CAN.

        L'erreur est toujours négative (valeur par défaut), et oscille entre 0 et -1 LSB (0 à -1V ici).

        Il serait souhaitable d'avoir plutôt une erreur centrée autour de 0, de manière à quantifier tantôt par excès, tantôt par défaut ; en effet, en quantifiant systématiquement par défaut, on introduit un offset dans le signal numérisé.

        Pour pallier cet inconvénient, on introduit un décalage au niveau du premier LSB du convertisseur, comme indiqué sur la figure 5 : la première transition n'a pas lieu pour 1 LSB, mais pour 1/2 LSB seulement, ce qui fait que jusqu'à une valeur d'entrée inférieure à 1/2 LSB, on quantifie par défaut, et entre 1/2 et 1 LSB, on quantifie par excès.

        Fig. 5. Fonction de transfert d'un CAN 3 bits corrigé.

        L'erreur obtenue devient celle de la figure 6 : elle est symétrique par rapport à 0 et égale à ±1/2 LSB.

        Fig. 6. Erreur de quantification symétrique

        Il y a juste une exception : le 1/2 LSB tronqué au début va se retrouver en bout d'échelle (voir figure 5) : le dernier état numérique correspondra à une plage d'entrée analogique valant 1 1/2 LSB. L'erreur de quantification sera plus grande sur cette plage, ce qui n'est d'ailleurs pas très grave !

        En pratique, la majorité des CAN ont une fonction de transfert décalée pour assurer une erreur de quantification symétrique. Il faudra toutefois s'en assurer en lisant la spécification du constructeur.

        Ce détail pourra être important si on fait de la mesure précise avec une carte d'acquisition de donnée (comprenant un CAN). Pour régler le gain et l'offset de la chaîne de conversion, il faudra observer la première et la dernière transition, et la calibration sera différente si le convertisseur est décalé ou pas ; un biais d'1/2 LSB pourra fausser les mesures si on se trompe !

    2. CONVERSION NUMÉRIQUE/ANALOGIQUE.

      1. Principe de fonctionnement.

        Si on fait l'opération inverse (conversion numérique analogique), à chaque valeur numérique, on fera correspondre une valeur analogique (et une seule) ; la tension analogique de sortie variera par " bonds ", et non plus continûment comme dans le signal d'origine. La fonction de transfert sera la même que celle de la figure 1 mais inversée. La tension de sortie aura une forme d'escalier. En pratique, on va filtrer cette tension pour lisser ces discontinuités et essayer de se rapprocher au mieux du signal d'origine (Figure 7).

        Fig. 7. Conversion numérique analogique.

      2. Définitions.

        • Résolution.

          La résolution du CNA sera la variation de tension de sortie correspondant à la variation d'une unité du nombre binaire en entrée. La définition est équivalente à celle du CAN.

        • Plage de conversion.

          Il y a ici une petite différence avec le CAN (voir figure 8) : la plage de conversion numérique va de 0 à 2N-1, N étant le nombre de bits du convertisseur, et à chaque valeur numérique correspond une valeur analogique de sortie et une seule. Par rapport à celle du CAN, la plage de conversion s'arrêtera donc un LSB plus tôt (sur l'échelle analogique du CAN, ceci correspond à la dernière transition numérique).

          Nous sommes ramenés ici au vieux problème des poteaux et des intervalles !

        • Dynamique.

          La définition est équivalente à celle du CAN.

        • Mise en relation.

          Vu ce qui a été dit sur la plage de conversion, la relation entre le pas de quantification (1 LSB), la plage de conversion [image] VMAX , et le nombre de bits du convertisseur sera légèrement différente de l'équation [1]. La figure 8 du paragraphe suivant va éclairer cette équation :

          En pratique, pour un nombre de bits supérieur à 8, l'écart entre les deux formules reste très faible !

          Il n'empêche que dans le cas de mesures précises, ce genre de détail a son importance pour expliquer un biais inattendu.

      3. Exemple : CNA 3 bits.

        Fig. 8. Fonction de transfert d'un CNA 3 bits.

        La figure 8 montre la fonction de transfert d'un CNA 3 bits ayant une résolution de 1V, comme l'exemple de CAN donné précédemment.

        On voit clairement ici ce qui a été dit pour la plage de conversion : la plage s'étend de 0 à 7V, et non pas 8V comme pour le CAN, car le dernier état numérique est " 7 ".

    3. ERREURS DE CONVERSION.

      Les erreurs décrites dans les paragraphes 1 à 3 sont valables pour les CAN comme pour les CNA. Les illustrations sont faites pour ces derniers, mais sont facilement transposables.

      1. Erreur de gain.

        La tension de pleine échelle est toujours légèrement différente de ce qui est prévu en théorie. L'écart entre les valeurs théorique et pratique est l'erreur de gain (figure 9).

        Pratiquement, le fabricant de convertisseurs Analog Devices définit cette erreur ainsi : c'est l'écart entre la valeur théorique et la valeur réelle mesurée sur la dernière transition du convertisseur et exprimé en LSB. Cette mesure suppose que l'ajustage du zéro soit parfait.

        Fig. 9. Erreur de gain.

      2. Erreur d'offset.

        De même, le code binaire 0 ne correspond pas forcément à une tension rigoureusement nulle en sortie. Cette tension est la tension de décalage, ou d'offset .

        Fig. 10. Erreur d'offset.

        En pratique, Analog Devices définit cette erreur comme étant l'écart entre la valeur théorique et la valeur réelle mesurée sur la première transition du convertisseur et exprimé en LSB. En pratique, pour ajuster un convertisseur, on réglera d'abord l'offset, et ensuite le gain.

      3. Erreurs de linéarité.

        L'erreur de linéarité est due au fait que la résolution des convertisseurs n'est pas constante.

        On distingue deux formes de non linéarité :

        - la non linéarité intégrale

        - la non linéarité différentielle

        la non linéarité intégrale , exprimée en LSB, est la différence maximum constatée sur toute la plage de conversion entre les valeurs théoriques et les valeurs mesurées.

        Cette mesure n'a évidemment de sens que si le zéro et le gain sont correctement réglés.

        La fonction de transfert est représentée figure 11.

        Fig. 11. Erreur de linéarité intégrale.

        La non linéarité différentielle concerne la différence de tension obtenue lors du passage au code numérique immédiatement supérieur ou inférieur ; théoriquement, cette valeur vaut 1 LSB. La non linéarité différentielle sera la différence entre l'écart mesuré et le LSB théorique. L'illustration est donnée en figure 12.

        Fig. 12. Erreur de linéarité différentielle.

        La valeur donnée dans les spécifications des constructeurs est la plus grande valeur constatée sur toute la plage de conversion.

        La non linéarité différentielle est plus gênante que la non linéarité intégrale, surtout dans le cas de mesures comparatives effectuées sur une faible partie de la plage de conversion.

        En général, et pour des causes technologiques bien identifiées, le maximum de non linéarité différentielle se trouve à la moitié de la pleine échelle (passage du MSB de 0 à 1), et ensuite à moindre degré à 1/4 et 3/4 de la pleine échelle.

        On sera donc vigilant quand on fera des mesures comparatives dans ces zones là.

      4. Monotonicité (CNA).

        Ce phénomène est le même que le précédent, mais poussé à l'extrême : il peut arriver que la pente de la courbe de conversion change de signe. Pour une tension analogique de sortie, il ne sera pas possible d'attribuer un nombre binaire correspondant : il y aura plusieurs solutions possibles.

        Fig. 13. Monotonicité.

      5. Codes manquants (CAN).

        Cette erreur pour le CAN est le pendant de la monotonicité pour le CNA.

        Fig. 14. Codes manquants

        Lors de la conversion, la courbe donnée binaire = f(tension analogique) n'étant pas une fonction (plusieurs codes binaires possibles pour une même tension d'entrée), le convertisseur choisira la plus faible valeur binaire parmi celles possibles. Les autres ne seront jamais utilisées, et formeront des " trous " dans le code binaire : ce sont les codes manquants.

      6. Temps d'établissement (CNA).

        Les étages de sortie des CNA sont généralement des amplificateurs opérationnels. On a vu que la tension de sortie va varier " par bonds " quand le code binaire d'entrée va changer. De ce fait, l'ampli de sortie va fonctionner en mode impulsionnel. La stabilisation de la tension de sortie n'est pas immédiate : elle peut être du type premier ordre ou oscillatoire amortie (deuxième ordre et plus).

        On appellera temps d'établissement (settling time en Anglais) le temps mis par la sortie pour atteindre un certain pourcentage de la tension finale stabilisée lorsque l'entrée va varier.

        Fig. 15. Temps d'établissement.

      7. Temps de conversion (CAN).

        Lorsqu'on numérise un signal, on envoie au CAN un ordre de conversion, et on récupère la valeur binaire en sortie au terme d'un délai appelé temps de conversion .

      8. Précision du convertisseur.

        Pour obtenir la précision globale du convertisseur, on cumulera toutes les erreurs précédemment citées.

        En général, ces erreurs sont données soit en % de la pleine échelle (% FS pour full scale), soit en fraction de quantum (± 1/2 LSB par exemple).

  3. CONVERSION NUMÉRIQUE / ANALOGIQUE.

    Il existe principalement deux types de convertisseurs numérique / analogique sur le marché : les convertisseurs à résistances pondérées, et les convertisseurs à réseau R/2R. Ces derniers sont prédominants.

    Il existe aussi des convertisseurs à réseaux de condensateurs fonctionnant sur le même principe de base que les réseaux à résistances.

    Nous n'exposerons pas ici les convertisseurs [image] / [image], qui traitent non plus le code binaire absolu, mais la différence avec l'échantillon précédent. Ces convertisseurs sont très répandus dans l'audio-numérique (lecteurs de disques compacts), car ils sont précis et meilleur marché que les convertisseurs traditionnels. Pour l'instant, ils sont peu utilisés en mesure.

    1. ARCHITECTURE GÉNÉRIQUE.

      Quel que soit le type de convertisseur étudié, on retrouvera toujours peu ou prou la même structure, constituée des même éléments de base ; seule la réalisation technologique des blocs de base différera d'un convertisseur à l'autre et en fera sa spécificité.

      Il est donc intéressant d'étudier l'architecture générique mettant en évidence les points communs à tous les convertisseurs.

      Fig. 16. Architecture des CNA.

      Sur la figure 16, on distingue 5 blocs :

      - un buffer numérique d'entrée : celui-ci est chargé de garder en mémoire la donnée numérique pendant le temps de conversion ; il sert aussi d'interface entre les parties numérique et analogique du convertisseur.

      - une référence de tension : son importance est capitale pour la précision de l'ensemble ; c'est elle qui donne le signal de référence servant à la détermination des tensions de sortie.

      - l'arbre de commutation (switching tree en anglais) : il est commandé par le buffer d'entrée et va déterminer les résistances qui seront alimentées par la référence de tension.

      - le réseau de résistances : c'est un ensemble de résistances, qui, alimentées par la référence de tension via l'arbre de commutation vont générer des courants très précis fonction du code binaire d'entrée.

      - le convertisseur courant/tension est un ampli servant à transformer les courants générés par le réseau de résistances en tension de sortie. Il est optionnel, certains CNA ne l'incluent pas, d'autres l'incluent, mais laissent le choix de l'utiliser ou non.

      On retrouvera donc toujours ces éléments de base, la distinction entre les convertisseurs se faisant généralement dans le réseau de résistances (et par voie de conséquences dans l'arbre de commutation).

    2. CNA À RÉSISTANCES PONDÉRÉES.

      1. Principe.

        Le principe de fonctionnement de ce montage est extrêmement simple : il est basé sur un amplificateur opérationnel monté en sommateur inverseur.

        Fig. 17. Schéma de principe d'un CNA à résistances pondérées (4 bits).

        Les principaux constituants sont :

        - un amplificateur opérationnel.

        - une référence de tension qui va définir la pleine échelle du convertisseur.

        - une série de résistances dans un rapport des puissances successives de 2 (1, 2, 4, 8, 16...).

        - une série de registres numériques contenant le code binaire d'entrée.

        - des commutateurs analogiques (interrupteurs commandés électriquement par les signaux logiques) reliant les résistances à la référence de tension.

        Le schéma de la figure 17 montre un CNA 4 bits. Par extension, on peut construire un CNA ayant un nombre de bits quelconque en augmentant les entrées logiques et en y affectant des résistances de valeur convenable (toujours dans le rapport des puissances de deux).

        On remarque que le LSB est affecté à la résistance de plus grande valeur, et le MSB à celle de plus faible valeur.

        Nous appellerons a0 le MSB, a1 le bit suivant, ..., et aN-1 le LSB d'un convertisseur à N bits.

        Si on applique le résultat de l'ampli sommateur inverseur à ce montage, on trouve :

        soit :

        Dans le cas de notre convertisseur 4 bits, la solution est :

        Le MSB est affecté du coefficient le plus fort, et les bits successifs voient leur coefficient divisé par deux par rapport au bit précédent.

        On peut calculer la résolution (LSB) de ce convertisseur : c'est la variation de la tension de sortie lorsque l'entrée numérique varie d'une unité, soit :

        Dans le cas général d'un convertisseur à N bits, on aurait :

        L'équation [2] va nous permettre de calculer la plage de conversion. Si on injecte le résultat de [7] dans l'équation [2], on obtient :

        où [image] VMAX représente la plage de conversion, ou pleine échelle du convertisseur. Pour notre convertisseur 4 bits, cette pleine échelle vaut donc 15/8ème de Eref. Ceci est dû au fait que le convertisseur de N bits comporte 2N états différents, dont zéro , ce qui fait que le dernier état est égal à 2N-1, et pas 2N.

      2. Précision.

        Le schéma de ce convertisseur nous permet de mieux comprendre les erreurs citées au paragraphe précédent :

        - L'erreur de gain sera directement proportionnelle à l'imprécision de la référence de tension et de la résistance de contre-réaction.

        - L'erreur d'offset sera due à l'offset de l'amplificateur.

        - L'erreur de linéarité et la monotonicité seront dues au mauvais appairage des résistances dans le rapport des puissances de 2.

        - Le temps d'établissement sera donné par la réponse de l'amplificateur à un échelon de tension.

        Pour revenir aux erreurs de linéarité, il faut noter que la précision relative sur chaque résistance aura un impact sur le résultat global qui va doubler tous les bits en allant du LSB vers le MSB.

        En effet, une erreur de 10% de la résistance du LSB ne va fausser le résultat que de 1,1 fois le LSB.

        Par contre, 10% d'erreur sur la résistance du MSB va induire une erreur égale à 1,1 fois le MSB, soit 2(N-1) fois plus que celle faite sur le LSB dans les mêmes conditions... Cette erreur peut facilement être supérieure au LSB et entraîner des non monotonicités dans la réponse (voir annexe).

      3. Avantages / inconvénients.

        L'avantage d'un tel montage est la simplicité. C'est un bon outil pédagogique.

        Malheureusement, la réalisation pratique est difficile du fait de la dynamique des résistances utilisées (2N pour un convertisseur à N bits), et, on l'a vu, une tolérance nécessaire sur les résistance divisée par 2 à chaque bit supplémentaire. Pour un convertisseur à 8 bits, la précision de la résistance du MSB devra être meilleure que 1% pour être en limite de non monotonicité, et en pratique, on prendra une résistance à 2‰ au minimum.

        Le principal problème provient de l'intégration de ces résistances : dans les circuits intégrés, on sait tenir une telle précision, mais la proportionnalité des résistances est obtenues en leur donnant des dimensions proportionnelles à leur valeur. La dynamique élevée requise ici est vite prohibitive.

        Ces défauts font que ce convertisseur n'est pas viable économiquement, surtout si on le compare au CNA à réseau R/2R, plus facile à intégrer.

    3. CNA À RÉSEAU R/2R.

      1. Principe

        Ce type de convertisseur prend en compte les défauts du précédent : il est bâti autour d'un réseau de résistances composé de seulement deux valeurs, R et 2R. Il n'y a donc plus le défaut inhérent à la grande dynamique de valeurs des résistances.

        Fig. 18. Schéma de principe d'un CNA à réseau R/2R (4 bits).

        Les composants sont sensiblement les mêmes que pour le CNA à résistances pondérées :

        - un amplificateur opérationnel.

        - une référence de tension qui va définir la pleine échelle du convertisseur.

        - un réseau de résistances R/2R.

        - une série de registres numériques contenant le code binaire d'entrée.

        - des commutateurs analogiques (interrupteurs commandés électriquement par les signaux logiques) reliant les résistances soit à la masse, soit à l'entrée - de l'ampli.

        L'amplificateur va fonctionner ici en convertisseur courant/tension : en fonction du positionnement des commutateurs, le courant total IT sera plus ou moins élevé, et sera transformé en tension par l'ampli et la résistance de contre-réaction. Certains CNA offrent d'ailleurs simplement une sortie en courant, et c'est à l'utilisateur de l'utiliser tel quel, ou de le convertir en tension.

        Avant d'attaquer la mise en équation, nous allons faire un constat, et partant de là, étudier certaines propriétés du réseau R/2R.

        L'entrée + de l'ampli est à la masse ; si on considère que cet ampli est parfait, l'entrée - est au même potentiel, soit 0 masse virtuelle). La position du commutateur n'influe donc nullement sur le fonctionnement du réseau : les courants I0 à I3 sont dirigés soit vers le convertisseur courant/tension, soit dérivés à la masse, mais le potentiel à la borne commune des commutateurs reste le même, à savoir 0.

        Pour simplifier le raisonnement, nous allons donc étudier le réseau suivant :

        Fig. 19. Réseau R/2R.

        Les courants I3 et ID sont égaux (diviseur de courant avec deux résistances égales).

        On a donc :

        Les branches où circulent I3 et ID sont en fait deux résistances égales (2R) en parallèle, soit l'équivalent d'une résistance moitié, donc R. Cette résistance équivalente est en série avec celle où circule IC. Le courant IC circule donc dans une résistance équivalent à 2R. Le circuit devient :

        Fig. 20. Réseau réduit équivalent.

        On retombe strictement sur le même type de réseau que précédemment. On en déduit facilement :

        L'étape finale du raisonnement donne le réseau suivant :

        Fig. 21. Réseau final.

        On en déduit la valeur des courants :

        Le réseau R/2R nous fournit des courant en progression géométrique de raison 2 : on retombe sur la même chose que le convertisseur à résistances pondérées.

        La tension de sortie Vs du convertisseur sera égale à :

        Le résultat est donc du même genre que pour le CNA à résistances pondérées. On note un facteur 1/4, mais on peut remarquer qu'il suffit de mettre une résistance égale à 4R en contre-réaction pour retomber sur le même résultat.

      2. Précision.

        Pour ce qui est de la précision requise sur les résistances, on retrouve les mêmes défauts que pour le CNA précédent :

        - la référence de tension et la résistance de contre-réaction vont engendrer la même erreur de pleine échelle.

        - une erreur sur la résistance du MSB aura 2(N-1) fois plus d'influence que la même erreur sur le LSB.

        Par contre, l'intégration sera plus aisée, et on sera capables de faire des convertisseurs précis et à plus grand nombre de bits que le CNA à résistances pondérées.

        En instrumentation, on rencontrera fréquemment des CNA à 12bits de ce type, notamment sur des cartes d'acquisition de données pour micro-ordinateurs.

        La structure du réseau et des commutateurs autorise une vitesse de conversion assez grande, car lors du basculement du commutateur, les résistances restent au même potentiel : il n'y a donc pas d'influence des inévitables capacités parasites qui mettraient du temps à se charger et à se décharger à travers les résistances. Ceci autorise l'utilisation de résistances d'assez grande valeur, ce qui limite l'erreur due aux résistances à l'état passant des commutateurs (quelques dizaines à quelques centaines d'ohms).

    4. UTILISATION DES CNA.

      • Utilisation " classique "

        Les CNA sont bien entendu utilisables tels quels pour faire de la conversion numérique/analogique.

        On les retrouvera en sortie de chaîne de traitement numérique lorsqu'un signal analogique est requis (commande d'un transducteur, contrôle de processus...

        Ils seront suivis d'un filtre plus ou moins sophistiqué destiné à supprimer les " marches d'escalier " inhérentes à la numérisation. Dans le cas de l'audio numérique, le filtrage est d'une importance fondamentale, et c'est lui qui conditionne grandement la qualité du son. Cet aspect n'est donc pas à sous estimer.

        Il faudra faire attention au filtrage dans le cas où ces convertisseurs sont inclus dans une boucle d'asservissement : les escaliers peuvent être néfaste à la stabilité du système.

      • Amplificateurs à gain programmable.

        Les montages étudiés peuvent se résumer tous les deux à une chose : ce sont des amplificateurs d'une tension continue (Eref) dont le gain est ajustable par une entrée numérique (les codes binaires).

        On peut donc penser à une autre utilisation des CNA : si on remplace Eref par une tension alternative quelconque, on peut utiliser l'entrée numérique pour faire varier le gain de l'ampli, et donc le signal en sortie.

        Cette application ouvre la porte aux VCA (voltage controlled amplifier), atténuateurs à commande numérique (donc télécommandables à distance)...

      • Filtres programmable

        De la même manière, on peut intégrer ces réseaux dans certains schémas de filtres, et obtenir ainsi des filtres à fréquence de coupure variable et commandée par un signal numérique.

      • Multiplieur.

        Une autre application importante est la multiplication de signaux : l'un sera analogique (en remplacement de Eref), et l'autre numérique. Ce signal numérique pourra être un signal préalablement numérisé. La sortie va donner le produit des deux signaux.

      • Attention !!!

        Toutes ces applications " spéciales " ne peuvent marcher que s'il est possible d'appliquer des tensions bipolaires sur l'entrée Eref. Il faut donc pouvoir alimenter symétriquement le montage, et les commutateurs analogiques doivent être bidirectionnels, ce qui n'est pas toujours le cas. On peut toujours polariser le signal pour qu'il soit globalement unipolaire, mais ces applications perdent de leur intérêt : la tension de polarisation étant traitée comme le signal, il sera difficile de l'extraire en sortie du convertisseur.

        Les fabricants de convertisseurs indiquent si leurs produits sont conçus pour fonctionner dans ces applications " dérivées ". Il faudra donc se reporter à leur documentation.

  4. CONVERSION ANALOGIQUE / NUMÉRIQUE.

    Parmi les principes de conversion analogique / numérique disponibles, nous en avons choisis trois particulièrement représentatifs, et qui se différencient très nettement en terme de compromis vitesse / précision :

    - les convertisseurs parallèles (ou flash en Anglais), très rapides, mais limités en précision. Leur rapidité les destine en particulier aux oscilloscopes numériques, qui se contentent de convertisseurs à 6 ou 8 bits.

    - les convertisseurs à approximations successives , moins rapides que les précédents, mais avec des possibilités en résolution bien supérieures (8 à 16 bits). Ils couvrent un vaste champ d'applications en mesure, de la carte d'acquisition de données pour micro ordinateur aux CAN intégrés dans des micro contrôleurs qui servent à piloter les applications les plus variées...

    - les convertisseurs à comptage d'impulsion sont très précis, et par construction, sont aptes à filtrer des bruits importants. En contrepartie, ils sont très lents, donc destinés à faire des mesures de signaux stabilisés.

    1. ARCHITECTURE GÉNÉRIQUE.

      Comme pour le CNA, il peut être intéressant de voir les points communs aux CAN de technologies différentes (hors convertisseurs à rampe).

      Fig. 22. Architecture d'un CAN

      La pièce centrale du schéma de la figure 22 est... un CNA !

      En pratique, un séquenceur logique va balayer les codes binaires (de façon plus ou moins astucieuse), ces codes vont être convertis en une tension analogique par le CNA, tension qui va être comparée à celle d'entrée. Le basculement du comparateur arrête le processus, et la donnée est basculée et mémorisée dans le buffer de sortie.

      Il ne faut pas oublier ce que cache ce schéma, à savoir la composition du CNA, et en particulier la référence de tension. Cette référence peut d'ailleurs être intégrée ou non dans le CAN ; dans ce dernier cas, il faudra en mettre une à l'extérieur (la remarque est valable pour les CNA).

    2. CAN PARALLÈLE.

      1. Principe.

        La tension à mesurer est comparée simultanément à 2N-1 tensions de référence, N étant le nombre de bits du convertisseur. Le nombre 2N-1 s'explique par la notion de pleine échelle vue précédemment : 0 est l'état logique supplémentaire qui fait 2N états au total pour un convertisseur à N bits.

        Ce convertisseur est composé des éléments suivants :

        - une tension de référence Eref.

        - un réseau de 2N résistances montées en série. Elles ont la même valeur R à l'exception notable de la première et de la dernière qui ont la valeur 3R/2 et R/2 : c'est l'astuce qui permet de faire basculer le premier comparateur non pas lorsque la tension d'entrée est égale à 1 LSB, mais 1/2 LSB. Au lieu d'avoir une erreur maxi de 1LSB (toujours par défaut), on aura une erreur de ±1/2 LSB (par excès ou par défaut) : voir plus haut. La dernière résistance vaut 3R/2 pour équilibrer le réseau, et pour que le LSB soit conforme à sa valeur donnée dans l'équation [1].

        - 2N-1 comparateurs comparent en permanence la tension à mesurer à une des tensions de référence délivrée par le pont de résistances.

        - un décodeur logique permet de traduire l'état des comparateurs en code binaire de sortie.

        Fig. 23. CAN parallèle à 3 bits.

      2. Précision.

        Dans le principe, ce CAN pourrait être relativement précis. En pratique, on butte sur un inconvénient de taille : il faut 2N-1 comparateurs pour un convertisseur à N bits, soit 63 comparateurs pour un 6 bits et 255 pour un 8 bits ! Le procédé devient donc vite limitatif.

        La principale source d'erreur provient de l'offset des comparateurs qui va introduire de la non linéarité différentielle.

        La rapidité va être conditionnée par la vitesse des comparateurs et du décodeur logique. La cadence de conversion est nettement supérieure au MHz, et peut atteindre des centaines de MHz pour les oscilloscopes numériques.

      3. Utilisation.

        De par leur principe, ces CAN sont limités à 6 ou 8 bits, ce qui est insuffisant pour de l'instrumentation.

        Ce handicap est négligeable en oscilloscopie numérique : certains constructeurs utilisent des convertisseurs 6 bits, ce qui est suffisant pour décrire l'axe vertical de l'écran avec une résolution supérieure à 2%.

        Pour les applications requérant des vitesses élevées mais non extrêmes, on utilise des convertisseurs semi-parallèles, qui utilisent beaucoup moins de comparateurs et conservent une vitesse de conversion intéressante, ceci avec une résolution pouvant atteindre 12 bits.

    3. CAN À APPROXIMATIONS SUCCESSIVES.

      Ces convertisseurs sont très répandus car performants et bon marché (tout est relatif quand même !).

      1. Principe.

        Un schéma de principe est donné figure 24. On y trouve principalement une référence de tension, un CNA, un comparateur et un séquenceur logique piloté par horloge.

        Le séquenceur logique délivre un code binaire à l'entrée du CNA. La tension de sortie de ce CNA est comparée à la tension à mesurer, et en fonction du résultat, le code binaire est modifié de manière à approcher la valeur à trouver.

        L'exemple le plus simple de séquenceur logique est un compteur binaire qui s'incrémente d'une unité à chaque coup d'horloge (montage vu en TP). Tous les codes binaires sont successivement comparés à la tension d'entrée. Quand le signal de sortie du comparateur s'inverse, la tension de référence vient juste de dépasser la valeur à mesurer : la conversion est terminée, il ne reste qu'à lire la valeur binaire (donnée ici par excès).

        Fig. 24. CAN à approximations successives.

        Ce séquenceur ne présente en pratique aucun intérêt, si ce n'est l'aspect pédagogique. Pour un convertisseur 12bits, il faudrait entre 0 et 4095 coups d'horloge : le temps de conversion ne serait pas constant, et surtout, serait beaucoup trop long pour les fortes valeurs de tension d'entrée.

        Les décodeurs fonctionnent en fait sur le principe de la dichotomie (figure 25) :

        - on compare d'abord la tension à mesurer Ex à une tension de référence correspondant à tous les bits à 0 sauf le MSB à 1 (étape 1). Si cette tension de référence est inférieure à Ex, on laisse le MSB à 1, sinon, on le positionne à 0.

        - tout en laissant le MSB dans l'état déterminé précédemment, on fixe le bit suivant à 1 et on applique le mode opératoire précédent (étape 2).

        - on procède ainsi de bit en bit, N fois pour un convertisseur à N bits

        La conversion est faite rapidement, et le temps de conversion est le même quelle que soit la tension d'entrée.

        Fig. 25. Approximations par dichotomie.

        Un exemple plus concret est donné à la figure 26 (principe de base réduit à 3 bits des ADC 800 et dérivés de chez National Semi-conducteurs).

        Fig. 26. Exemple de CAN à approximations successives.

        On retrouve le réseau de résistances du convertisseur parallèle de la figure 23, mais chaque nœud de ce réseau est connecté non pas à un comparateur, mais à un réseau de commutateurs de connection (switching tree) dont le point final est relié à l'entrée d'un comparateur ; l'autre entrée de ce comparateur est reliée à la tension à mesurer Ex.

        Chaque sortie logique du séquenceur actionne simultanément tous les commutateurs de même niveau (situés sur la même verticale sur le schéma).

        Sur le schéma, a2a1a0 est égal à la valeur binaire 101, soit 5. Si on suit le chemin des commutateurs fermés, on tombe bien sur la référence de tension correspondant à la valeur logique 5, soit 101 en binaire.

        En appliquant la règle de séquencement précédente, on trouve le code logique en 3 approximations (CAN à 3 bits).

        N.B : l'ensemble composé du réseau de résistances et des commutateurs est bien un CNA : il suffit de relier le point de sortie du réseau de connexion à un ampli suiveur pour avoir un type de CNA non étudié dans le paragraphe précédent mais parfaitement viable ! Il est seulement coûteux en résistances et en commutateurs si on le compare aux CNA à réseau R/2R ou à résistances pondérées.

      2. Précision.

        Ces convertisseurs sont précis : il suffit d'un bon comparateur associé à un CNA de la résolution voulue pour obtenir la précision désirée.

        La rapidité sera limitée par le temps d'établissement du CNA, la vitesse de réaction du comparateur, et la complexité de la logique.

        Les convertisseurs 12 bits courants (qui sont beaucoup utilisés en instrumentation) ont un temps de conversion de l'ordre de 10 à 200µs, ce qui fait des cadences d'échantillonnage comprises entre 5 et 100kHz environ.

        Important : la conversion prend un certain temps ; de plus, vu le principe utilisé, la comparaison ne se fait pas avec des codes binaires successifs. Il est impératif dans ce cas de figer la tension d'entrée pendant la conversion .

        Cette fonction va être réalisée par un échantillonneur / bloqueur (E/B) : lorsque l'ordre de conversion est donné par le séquenceur logique, la sortie de l'E/B prend la valeur courante du signal et se fige à cette valeur (effet mémoire).

        L'E/B est nécessaire pour éviter des codes manquants et/ou des erreurs de conversion. Il est parfois intégré dans le CAN. Si ce n'est pas le cas, on le placera entre le signal à mesurer et le CAN.

        Il faudra veiller à ce que sa précision (offset, erreur de gain) soit compatible avec le CAN placé en aval : inutile de mettre un CAN 16 bits ultra précis derrière un E/B de deuxième catégorie...

        De même, on fera attention au temps d'établissement de ce composant.

      3. Utilisation.

        On retrouve ces composants un peu partout, de l'audio numérique aux cartes d'acquisition de données en passant par l'intégration dans des micro contrôleurs.

        Comme les convertisseurs parallèles, ils mesurent des valeurs instantanées d'un signal ; il faudra donc s'assurer que celui-ci est exempt de bruit (du moins dans la limite de la résolution du CAN).

        Cette fonction sera assurée par un câblage correct de la chaîne de mesure, et un filtrage avant acquisition (attention à la fréquence de cassure du filtre qui servira par la même occasion de filtre anti-repliement --loi de Shannon).

    4. CAN À COMPTAGE D'IMPULSIONS.

      Cette catégorie de convertisseur est très répandue : tous les multimètres " de poche " fonctionnent sur ce principe. Ils offrent une grande précision pour un faible coût, mais de par leur principe, ils ne peuvent mesurer que des tensions statiques ou faire des moyennes, contrairement aux convertisseurs précédents qui échantillonnent le signal instantané.

      On trouve 4 types de convertisseurs à rampe (de simple à quadruple rampe : le principe reste globalement le même, les rampes supplémentaires venant compenser diverses erreurs), ainsi que des convertisseurs tension-fréquence.

      Tous ces convertisseurs sont basés sur une opération de chronométrage (comptage d'impulsions) pendant un temps proportionnel à la tension d'entrée.

      1. Convertisseur simple rampe.

        Fig. 27. Convertisseur simple rampe.

        Le schéma de principe d'un tel convertisseur est donné figure 27. Les principaux éléments le constituant sont :

        - un générateur de rampe (intégration d'une tension de référence).

        - deux comparateurs comparant la rampe l'un au zéro, l'autre à la tension à mesurer.

        - divers éléments de logique, dont un générateur de porte, une horloge, un compteur et un système d'affichage.

        Lorsque la logique commande le démarrage d'une mesure, il y a remise à zéro de l'intégrateur (rampe) et des compteurs ; ensuite, la tension de rampe croît linéairement avec le temps (figure 28).

        Quand le premier comparateur bascule à t0, la porte autorise le comptage des impulsions délivrées par l'horloge.

        Quand le deuxième comparateur bascule, il ferme cette porte, et la valeur contenue dans les compteurs est verrouillée et transmise aux afficheurs.

        Fig. 28. Tension en sortie d'intégrateur et porte.

        On a donc fait un chronométrage des impulsions de l'horloge pendant un temps proportionnel à la tension à mesurer.

        Cette tension est égale à :

        Si N est le nombre d'impulsions comptées et F la fréquence de l'horloge, on a :

        La pleine échelle sera donnée en nombre de points Nmax, c'est à dire le comptage maximum autorisé par la dynamique des compteurs. Dans ce cas, la résolution sera l'inverse de Nmax, et elle sera d'autant meilleure que Nmax sera grand.

        Le résultat montre qu'on aura intérêt à avoir une fréquence d'horloge élevée à rampe donnée pour avoir une bonne résolution.

        Il indique aussi le plus gros défaut de ce convertisseur : la mesure dépend de la fréquence d'horloge, de la tension de référence, et des composants R et C de l'intégrateur.

        Si on sait faire des horloges à quartz stables et des références de tension de précision, il en est tout autrement avec les capacités servant dans l'intégrateur : la précision initiale est moyenne (sauf tri), et les dérives (vieillissement, température...) difficiles à maîtriser.

        L'autre gros défaut est une grande sensibilité au bruit : si la tension d'entrée varie sous l'effet d'une perturbation quelconque, le deuxième comparateur peut fermer la porte et arrêter le processus de comptage : la valeur lue sera fausse.

        Il faut noter ici que la tension d'entrée doit impérativement être fixe , sinon, on mesure n'importe quoi !

        Comme le comptage dure un certain temps, on voit que toutes ces conditions sont difficiles à réunir.

      2. Convertisseur double rampe.

        Ce type de convertisseur va pallier les défauts du simple rampe. Le schéma de principe est le suivant :

        Fig. 29. Schéma de principe du convertisseur double rampe.

        Fig. 30. Tension en sortie d'intégrateur.

        La mesure se fait en deux temps :

        - l'intégrateur ayant été remis à zéro, on commute son entrée sur la tension à mesurer. Le comptage démarre.

        - quand il atteint un nombre N1 déterminé, on commute l'entrée de l'intégrateur sur une tension de référence Eref de polarité opposée à Ex. On compte les impulsions d'horloge jusqu'à ce que la tension de sortie de l'intégrateur s'annule, soit N2.

        Si F est la fréquence de l'horloge, on peut écrire :

        La valeur affichée est directement proportionnelle au comptage, et elle est indépendante des composants R et C, et aussi de la fréquence de l'horloge. On pourrait comparer cette méthode à la double pesée avec une balance...

        L'autre gros avantage du montage double rampe est son immunité au bruit : le signal étant intégré, seule la valeur moyenne du bruit sera prise en compte, soit une valeur nulle dans la plupart des cas. Si un parasite perturbe le signal lors de la mesure, seule son intégrale sera prise en compte ; s'il est bref, elle sera négligeable, et le résultat très peu modifié.

      3. Résolution. Précision.

        Pour ce type de convertisseurs, la dynamique n'est plus exprimée en bits, mais en points, qui correspondent à la capacité maximum du compteur.

        Les multimètres de poche font 2000 ou 3000 points, les plus évolués en font 20 000 ou 30 000, et les multimètres de laboratoire dépassent allégrement les 100 000 points.

        Il ne faut toutefois pas se leurrer quand à leur précision réelle, qui est souvent bien en deçà de la résolution.

        Par exemple, un multimètre 2000 points (11 bits équivalent à 2048 points) ne dépasse guère une précision de 0,5% de pleine échelle, soit l'équivalent de 8bits ! Et encore, ceci est valable pour des mesures de tensions continues ; pour les mesures de courant ou de résistances, la précision peut tomber à 1 ou 2%. En fait, ce sont les composants externes au convertisseur (ampli, atténuateur) qui déterminent la précision.

        Il faudra donc bien se garder de prendre pour argent comptant la valeur de l'affichage, et se rappeler que (au moins) le digit le moins significatif est faux. Dans tous les cas, il faut consulter la spécification de l'appareil pour connaître sa précision réelle, et ne pas se laisser impressionner par l'affichage...

[ Table des matières ]


Bienvenue

Bienvenue dans ce cours d'instrumentation !

    Vous allez trouver sur ce site un cours relatif aux techniques de mesure, découpé en 4 chapitres, accessibles chacun par un bouton :

Diversité de la mesure, conseils pour faire une bonne mesure, mode opératoire de mise au point d'une manip, anecdotes...

Perturbations dans les mesures : les couplages et leurs effets, étude de cas concrets, remèdes.

L'amplificateur d'instrumentation. Notion de mode commun, calculs.

Les convertisseurs analogiques/numériques et numériques/analogiques

Retour sur ces pages d'aide

    Un clic sur le bouton de chapitre (en haut à gauche) fait apparaître le sommaire dans le cadre situé en dessous : il ne reste plus qu'à cliquer dans le paragraphe désiré pour que son contenu s'affiche dans le cadre de droite (le temps de chargement peut être un peu long, le chapitre se charge en un seul bloc).

    Ce cours est celui que j'enseigne à l'IUT de Toulouse aux étudiants de deuxième année en mesures physiques (cours du soir). Les deux premiers chapitres sont assez originaux, ils sont le fruit de mon expérience industrielle, et sortent du cadre académique traditionnel.


Sommaire de l'aide

Menu Général

URL: http://courelectr.free.fr/default.htm

Présentation / contenu

Liens vers d'autres sites

Bibliographie

Logithèque

Contact / Merci qui ?

Restrictions d'usage

Quoi de neuf ?

Revoir les bases de l'électronique...
Diode | Puissance
Transistor | Électricité
FET | Conduction
Amplificateur opérationnel